JBoss.orgCommunity Documentation

Teiid Designer User Guide


Legal Notice

1. Introduction
1.1. What is Teiid Designer?
1.2. Metadata Overview
1.2.1. What is Metadata
1.2.2. Business and Technical Metadata
1.2.3. Design-Time and Runtime Metadata
1.2.4. Source and View Metadata
1.3. It's all in the Modeling...
1.3.1. What Are Models?
1.3.2. How is a Model Defined?
1.3.3. Guiding through the process
1.3.4. Targeting the Right Teiid Server
1.3.5. Model Classes and Types
1.3.6. The Virtual Database
1.3.7. Model Validation
1.3.8. Testing Your Models
1.3.9. Model Object Extensions
2. Dive Right In!
2.1. Targeting the Teiid Server
2.1.1. Server Version Preference
2.1.2. Defining a Teiid Server
2.1.3. Server Version Status Panel
2.2. Guide Example
2.2.1. Model a JDBC Source
2.3. Cheat Sheet Example
2.3.1. Consume a SOAP Web Service
3. Server Management
3.1. Setting up a Server
3.1.1. Teiid Version Support
4. New Model Wizards
4.1. Creating New Relational Source Model
4.1.1. Generate File Translator Procedures
4.1.2. Generate Web Service Translator Procedures
4.1.3. Copy From Existing Model
4.2. Creating New Relational View Model
4.2.1. Copy From Existing Model
4.2.2. Transform From Existing Model
4.3. Creating XML Document View Model
4.3.1. Copy From Existing Model
4.3.2. Build XML Documents From XML Schema
4.4. Creating XML Schema Model
4.4.1. Copy From Existing Model
4.5. Creating Web Service View Model
4.5.1. Copy From Existing Model
4.5.2. Build From Existing WSDL File(s) or URL
4.5.3. Build From Relational Models
4.5.4. Build From XML Document View Models
5. Importers
5.1. Import DDL
5.2. Import From JDBC Database
5.3. Import From Teiid Data Source Connection
5.4. Import From Flat File Source
5.5. Import From XML Data File Source
5.6. Import From Salesforce
5.7. Import Metadata From Text File
5.7.1. Import Relational Model (XML Format)
5.7.2. Import Relational Tables (CSV Format)
5.7.3. Import Relational View Tables (CSV Format)
5.8. Import WSDL into Relational Models
5.8.1. Circular References in WSDL Schemas
5.9. Import WSDL Into Web Service
5.9.1. Import WSDL From Workspace Location
5.9.2. Import WSDL From File System Location
5.9.3. Import WSDL From URL
5.10. XSD Schema File
6. Creating and Editing Model Objects
6.1. Creating New Model Objects
6.1.1. New Child Action
6.1.2. New Sibling Action
6.1.3. New Association Action
6.2. New Model Object Wizards
6.2.1. Create Relational Table Wizard
6.2.2. Create Relational Procedure Wizard
6.2.3. Create Relational Index Wizard
6.2.4. Create View Model Objects Wizards
6.3. Model Object Editors
6.3.1. Transformation Editor
6.3.2. Input Set Editor (XML)
6.3.3. Choice Editor (XML)
6.3.4. Recursion Editor (XML)
6.3.5. Operation Editor
6.4. Managing Model Object Extensions
6.4.1. Create New MED
6.4.2. Edit MED
6.4.3. Extending Models With MEDs
6.4.4. Setting Extended Property Values
7. Metadata-specific Modeling
7.1. Relational Source Modeling
7.1.1. Source Function
7.1.2. Create Relational Table Wizard
7.2. Relational View Modeling
7.2.1. Create Materialized Views
7.2.2. Create Relational View Table Wizard
7.3. XML Document Modeling
7.3.1. Create XML View Documents from schema
7.4. Web Services Modeling
7.4.1. Create Web Service Action
7.4.2. Web Services War Generation
8. Editing Models and Projects
8.1. Rename A Model
8.2. Move Model
8.3. Save Copy of Model
8.4. Clone Project
9. Managing VDBs
9.1. Creating a VDB
9.2. Editing a VDB
9.3. Test a VDB
9.4. Multi-source Binding Support
9.5. UDF support
9.6. Reusing VDBs
9.7. Security and Data Access
10. Testing Your Models
10.1. Manage Connection Profiles
10.1.1. Set Connection Profile for Source Model
10.1.2. View Connection Profile for Source Model
10.1.3. Remove Connection Profile from Source Model
10.2. Previewing Data For a Model
10.2.1. Preview Relational Table or View
10.2.2. Preview Relational Table With Access Pattern
10.2.3. Preview Relational Procedure
10.2.4. Preview Web Service Operation
10.2.5. Sample SQL Results for Preview Data
10.2.6. Execution Plans
10.3. Testing With Your VDB
10.3.1. Creating Data Sources
10.3.2. Execute VDB from Model Explorer
10.3.3. Deploy VDB from Model Explorer
10.3.4. Executing a Deployed VDB
11. Searching
11.1. Finding Model Objects
11.2. Search Transformation SQL
11.3. Search Models Via Metadata Properties
A. Supported Data Sources
B. Designer Metadata Usage Requirements In Teiid Runtime
C. User Preferences
C.1. Teiid Designer Preferences
C.1.1. Diagram Preferences
C.1.2. Diagram Printing Preferences
C.1.3. Editor Preferences
C.1.4. Validation Preferences
D. Teiid Designer Ui Reference
D.1. Teiid Designer Perspectives
D.1.1. Teiid Designer Perspective
D.1.2. Opening a Perspective
D.1.3. Further information
D.2. Teiid Designer Views
D.2.1. Model Explorer View
D.2.2. Outline View
D.2.3. Server View
D.2.4. Properties View
D.2.5. Description View
D.2.6. Problems View
D.2.7. Search Results View
D.2.8. Datatype Hierarchy View
D.2.9. Teiid Model Classes View
D.2.10. System Catalog View
D.2.11. SQL Reserved Words View
D.2.12. Model Extension Definition Registry View (MED Registry View)
D.2.13. Guides View
D.2.14. Status View
D.2.15. Cheat Sheets View
D.3. Editors
D.3.1. Model Editor
D.3.2. VDB Editor
D.3.3. Model Extension Definition Editor
D.4. Teiid Designer Main Menu
D.4.1. File Menu
D.4.2. Edit Menu
D.4.3. Refactor Menu
D.4.4. Navigate Menu
D.4.5. Search Menu
D.4.6. Project Menu
D.4.7. Metadata Menu
D.4.8. Run Menu
D.4.9. Window Menu
D.4.10. Help Menu