Skip to end of metadata
Go to start of metadata

Overview

The Eclipse-based tooling for SwitchYard is organized in the following feature groups:

  • SwitchYard Tools : core SwitchYard tooling support including the visual editor
  • SwitchYard BPEL Support : optional add-on to implement services using BPEL and integrates with the Eclipse BPEL editor
  • SwitchYard BPM Support : optional add-on to implement services using jBPM 6 and integrates with the Eclipse BPMN 2 modeler

The following sections cover how to install SwitchYard tooling into JBoss Developer Studio (JBDS) and Eclipse.

JBoss Developer Studio

SwitchYard tooling is compatible with JBoss Developer Studio 6. If you don't have JBDS installed already, download and install it from the JBDS site (https://devstudio.jboss.com/download/).

  1. Download a release version of the offline update site ZIP (switchyard-site-assembly) from the SwitchYard Downloads page. 
  2. Open JBDS 6.
  3. Select Window→Preferences from the main menu bar, go to Install/Update→Available Software Sites, and Add... the following sites:
    http://download.jboss.org/jbosstools/updates/integration/kepler/integration-stack/aggregate/4.1.3.Beta5/
  4. Select Help-->Install New Software... from the main menu bar.
  5. Press the Add... button to add the SwitchYard tooling software site zip. Click the Archive... button and specify the location of the downloaded zip.
  6. Once the software site has been configured, SwitchYard Tools should be displayed in the list of available software.  Check the box, press Next and proceed through the rest of the wizard. (Refer to the Eclipse documentation for more information on software installation.)

Eclipse Kepler

In addition to JBDS, SwitchYard Tooling is also compatible with Eclipse JEE Kepler release. If you don't already have a Kepler JEE install, download and install from the Eclipse Download site.

  1. Download a release version of the offline update site ZIP (switchyard-site-assembly) from the SwitchYard Downloads page. 
  2. Open Eclipse Kepler
  3. Select Window→Preferences from the main menu bar, go to Install/Update→Available Software Sites, and Add... the following sites:
    http://download.jboss.org/jbosstools/updates/development/kepler/integration-stack/aggregate/4.1.3.Beta5/
  4. Select Help-->Install New Software... from the main menu bar.
  5. Press the Add... button to add the SwitchYard tooling software site zip. Click the Archive... button and specify the location of the downloaded zip.
  6. Once the software site has been configured, SwitchYard Tools should be displayed in the list of available software.  Check the box, press Next and proceed through the rest of the wizard. (Refer to the Eclipse documentation for more information on software installation.)
Labels:
None
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.