Hibernate ORM within WildFly

The WildFly application server includes Hibernate ORM as the default Jakarta Persistence provider out of the box.

In previous versions of Hibernate ORM, we offered a "feature pack" to enable anyone to use the very latest version in WildFly as soon as a new release of Hibernate ORM was published.

Unfortunately, since version 5.5 is upgrading to Jakarta Persistence 3.0 and targets integration with components of the Jakarta EE 9 stack, such feature had to be disabled.

As soon as WildFly releases a Jakarta EE 9 compatible server it might be possible to re-introduce such a feature, but we can’t guarantee that we will do this as the server changed the tooling to define such packs.

As usual, please let us know how important this is for you, and while we’ll gladly help to make this happen we might need to rely on volunteers to help by contributing patches, testing it out and providing feedback.