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Chapter 1.

Introduction

1.1. What is Seam?

This introduction will help you to understand what is Seam.

Seam is a fully featured application framework on top of Java EE 5. It is also one of the most
popular enterprise Java framework today. Seam deeply integrates many other standard-based
or open source frameworks (e.g., JSF, EJB3, JMS, Web Services, jBPM, JBoss Rules, Ajax4jsf,
RichFaces, Facelets, Spring, iText, Quartz, TestNG, etc.), and provides a single programming
model for developers to "drive" those underlying frameworks via simple annotated POJOs (Plain
Old Java Objects). It makes life easier for developers to tackle complex enterprise applications
with many component frameworks.

1.2. Installation into Eclipse

Here, we are going to explain how to install Seam plugin into Eclipse.

Seam is a one module of JBoss Tools project. Since Seam has a dependence on other
JBoss Tools modules we recommend you to install a bundle of all JBoss Tools plug-ins [http://
labs.jboss.com/tools/download/index.html]. Installation instruction you can find on JBoss Wiki in
InstallingJBossTools [http:/labs.jboss.com/wiki/InstallingJBossTools] section.

1.3. Other relevant resources on the topic

The Seam Framework [http://seamframework.org/] - Next generation enterprise Java
development.

All latest release versions of JBoss Developer Studio/JBoss Tools documentation you can find
here [http://docs.jboss.org/tools/2.1.0.GA/].

The latest documentation builds are available here [http://download.jboss.org/jbosstools/nightly-
docs/].
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Chapter 2.

Creating a New Seam Project via the
New Seam Project wizard

In this chapter we provide you with the necessary steps to start working with Seam Framework.

At first, we suggest setting the specific Seam perspective that combines a humber of different
views and editors needed for work with resources concerned. For that select Window > Open
Perspective > Other > Seam or you can also access it through the button in the right top corner.

Seam - Eclipse Platform
File Edit Source Refactor MNavigate Search Project Run Window Help

ro- H- O Q- | EHE @ s @982 bR ([ seam)
4 Pack 3'3 :’_‘;Proje' =7 = B || # jBoss To 53 =5

2 & 7 X b <
.................... |- |Boss Ajaxdjsf

|= |Boss RichFaces

L=+ |Boss Seam

L= JSF HTML
o= Outline &2 =0
An outline is not
available.
0 [ D
[ Properties =8
= e e
- o
Property | Value [£! Problems 2 ¥ Tasks ' Seam Components 73 |Boss Server View T =0

0 errors, 0 wamings. 0 infos

Description Resource Path Location

Figure 2.1. Seam Perspective

2.1. Create standalone Seam Web Project

The best way to get started with Seam is to organise a simple Seam Project and experiment with
it by creating variations.

Thus, you should select File > New > Seam Web Project to run the New Seam Project wizard.
The wizard form allows you to create runtime and server instances in order to get started creating,
running, and debugging J2EE (only) applications.
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Seam Web Project wizard has an option for selecting the actual Server (not just WTP runtime)
that will be used for the project. This allows the wizard to identify correctly where the required
datasource and driver libraries need to go.

Let's get through the wizard step-by-step. First, you should enter a name and a location directory
for your new project.

Mew Seam Project

Seam Web Project r@_\

Create standalone Seam Web Project

Project name: |seamProject ]

Projact contents:

& Use default

Target Runtirme

!JBoss 4.2 Runtime = [Ngw

Dynamic Web Module version

L]

25

Target Server

|. Mew... .

| |Boss 4.2 Server -
Configuration
| Dynamic web Project with Seam 1.2 2| .Madii}r...

Configures a Dynamic Web application to use Seam v1.2

( I f
2 [ Back Mext = r Cancel

Figure 2.2. New Seam Project Wizard

Clicking on New... button in the

<proeprty>Target Runtime</proeprty>

section will bring you to another dialog. Here, you can specify a new installed Runtime environment
or the other type of runtime appropriate for configuring your project. Let's create a JBoss 4.2
Runtime. For that after choosing it click on Next button.




Create standalone Seam Web Project

£ New Server Runtime x
MNew Server Runtime
Define a new installed server nuntime environment E
Runtimes are used at build time to compile projects.
C ticnal

Select the puntime type:
|type filter text

[+]

‘ P (= |Boss
7 = |Boss, a division of Red Hat
“J |Boss 3.2 Runtime

74 |Boss 4.0 Runtime

i |Boss 4.2 Runtime

‘3 |Boss Deploy-only

(4]

|Boss Application Server 4.2

[] also create new local server

Figure 2.3. Specifying Target Runtime

All what you need here is to name runtime, type the path to its install directory or locate it by using
Browse button, select a Java Runtime Environment, and select which configuration you want.
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£ Mew Server Runtime *®
]
[ ]
|Boss Runtime Wizard - BU 5 5
ogp 4.2

A |Boss Server runtime references a |Boss installation directory.
It can be used to set up classpaths for projects which depend on this runtime,
as well as by a "server” which will be able to start and stop instances of

JBoss.
Marme

|JBoss 4.2 Runtime 1 |

Home Directory

[.fupmmrh']buss -4 2 0.GA I Browse...

JRE
|jdk15.0_12 2|
Cenfiguration
[ minimal

@ ) I Einish || Cancel f

Figure 2.4. Specifying Target Runtime Configurations

Clicking on Finish returns you to the previous dialog. The next step is to define an installed server
that you can do by clicking on New... button in the Target Server section. In appeared Server

Dialog it's possible to select a server version.

If the chosen server has already got an installed runtime, there appears a combo box with all
declared runtimes under the servers view. Here, you can indicate a server runtime that you need.
Use Installed Runtimes... button to see or edit which runtimes are installed. If there is no any
declared runtime for chosen server, click on Next to specify it on the next preferences page.




Create standalone Seam Web Project

£ New Server
Define a New Server

Choose the type of server to create

Server's host name: |localhost

Select the server type:

(type filter text

L == L]

I = JBoss

= [ |Boss. a division of Red Hat
J |Boss AS 3.2
73 |Boss AS 4.0

2 |Boss AS 4.2

#d |Boss System Copy Server
P = Macromedia

B e ke Fhm.

|Boss Application Server 4.2

[¢]

(4]

Server puntime: | |[Boss 4.2 Runtime

- l llnstalleu Runtimes.

® - | tex> ||

Einish |[ Cancel ]

Figure 2.5. Specifying Target Server

Next dialog allows you to verify the information for chosen server, set login credentials to authorize
an access to the server and specify a directory for deploying. Leave everything as it is and click

on Next.
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¢ New Server X
L .9
Create a new |Boss Server :
* JBoss
&9 4.2

A |Boss Server manages starting and stopping instances of |Boss.
It manages command line arguments and keeps track of which modules have been deployed.

MName

|JBoss 4.2 Server

Runtime Information

If the runtime information below is incomrect, please press back., Installed Runtimes. ...
and then Add to create a new runtime froam a different location.

Home Directory foptiworkijboss-4.2.0.GA

JRE fusrfjavafjdkl 5.0_12 (jdkl.5.0_12)
Configuration  default

Login Credentials

JMX Console Access

User Name [ ]

Password [ ]

Deployment

Deploy Directory I.I'DPWDI'H]DDSS-J-.E.D.GNEQWErfﬂefauWﬁEplﬁy| |BI‘I3W5E... |

@ I = Back ][E--H-E-Ii;'-“’ I Einish ] [ Cancel l

Figure 2.6. Specifying Server Configurations

On the last wizard step you can modify your project to configure it on server.




Create standalone Seam Web Project

Add and Remove Projects

Madify the projects that are configured on the server

Move projects to the right to configure them on the server

Available projects: Configured projects:

B |SFKickStart

Add > |

Add Al == ]

@ < Back fext = | Einish ” Cancel

Figure 2.7. Project Modification for Configuring on the Server

Once you have the Target Server defined click on Finish button to return to the first page of the
New Seam Project wizard.

Tip:
@

We suggest that you look through our AS manager guide [../../as/html_single/
index.html] to find out more about runtimes and servers.
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£ Mew Seam Project
Seam Web Project t\fg—
Create standalone Seam Web Project "I. )
5

Project name: |seamPrcliect

Project contents:
Use default

Target Runtirme

| |Boss 4.2 Runtime & | | New...

Dynamic Web Module version

|25

¥

Target Server

ST F || New...

Default Configuration for |Boss 4.2 Runtime
oo e et seam 12
Dynaric Web Project with Seam 2.0 Modify...
JBoss |SF Portlet Project w1.0
|Boss |SF Portlet Project w2.0
JBoss Seam Portlet Project v1.0
|Boss Seam Portlet Project v2.0
JavaServer Faces v1.1 Project
JavaServer Faces v1.2 Project
Minimal Configuration
Portlet Project v1.0
Portlet Project v2.0

my
o = DdaLn M e = T CIns T Cancel

Figure 2.8. Completion of Runtime and Server Configuration

The last section on this wizard step is Configuration. Here, you can select one of the pre-defined
project configurations either associated with Seam 1.2 or with Seam 2.0. Furthermore, you can
create your own configuration by pressing the Modify... button. It will open the dialog which allows
to configure your own set of facets for adding extra functionality to your project.

Pass to the next section to find out more details on this dialog.

2.2. Select the Project Facets

The Project Facets wizard allows you to enable or disable specific facets which define necessary
characteristics for the project. In time you switch to this wizard form, all critical facets are already

checked for the chosen Configuration.
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Select the Project Facets

Notice that this page of the wizard also allows you to set the necessary version for any facet.

rﬂ Project Facets [E]-'
Project Facets
Select the facets that should be enabled for this project. \1‘?
Configurations: | Dynamic Web Project with Seam 1.2 ] ] [ Save As... 1 [ Delete I
Project Facet ersion Details |R.|1t|mas|
B 0 Awis2 Web Services B seam 1.2
& Dynarmic Web Module 235 Enables the project to work with |Bo
ava 5.0
&) ) Requires all of the following facets:
[] b Java Persistence 1.0 N .
[ [ JavaScript Toolkit 1.0 I Dynamic Web Module 2.5 or nes
N [4] Java 5.0
(£ JavaServer Faces 12 || JavaServer Faces 1.2 or newer
[ [ Jpess ESB 4.3

b [ [ JBoss Partlets

b [ ) JBoss Web Services
B Seam
[ [ webDoclet (¥Doclet)

Figure 2.9. Project Facets Selection

Moreover, here you can specify your own preset of selected facets by checking needed ones in
project facets window and clicking on Save button.
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rﬂ Project Facets E]
Project Facets
Select the facets that should be enabled for this project. Q?
Configurations: | <custom= 2 ] [ Save As... I
Project Facet Version Details | Runtimes |
p’ [:I : Axis2 Web Servces I-_| Seam 2.0
& Dynamic Web Module 25 Enables the project to work with |Boss Se
ava 5.0
&) ) Requires all of the following facets:
[] b Java Persistence 1.0 N _
(7 B JavaScript Toolkit 10 & Dynamic web Madule 2.5 ar newer
N [ Java 5.0
| JavaServer Faces 1.2 || JavaServer Faces 1.2 ar newer
O & jBoss EsB 43 £ Save Preset *
¥ 2 Portl
b [Z] |Boss Portlets Fr—
B[] 5 JBoss Web Services
[custnrn Facets Preset
B seam 2.0 Daserpt
escription:
[ &) webDoclet (xDoclet) 1.23 E
oK I [ Cancel ]
|
(<] I [0
(] ] ] l=-]|
(i) I oK l [ Cancel ]I

Figure 2.10. Specifying Custom Facet Preset

To see all available Server runtimes click on Runtimes tab on the left. You can create a new one
using the New button. If more than one runtimes are checked here, the Make Primary button
won't be dimmed yet. So you can make use of it to mark primary runtime.
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How to Configure Web Module Settings

Project Facets

Project Facets
Select the facets that should be enabled for this project. \\\?
Configurations: | Dynamic Web Project with Seam 1.2 2 ] [ Save As... | Delete |
Project Facet \ersion Dataitg|§ﬁ._|_r_1_t_i_r1'jlg_§§-|
+ B B Axis2 web Services .IE |3 |Beoss 4.2 Puntime
¥ 52 Dynamic Web Module 25
¥ 1] Java 5.0
[] 4+ Java Persistence 1.0
[ [ Javascript Toolkit 1.0
[Z] JavasServer Faces 1.2
[ [ Jposs EsB 4.3

> OB |Boss Portlets

b [ [ JBoss web Services
[ seam 1.2
[ [ webDaclet (xDoclet) 123

[[] Show all runtimes

(i) oK I | Cancel

Figure 2.11. Runtime Manipulations

Next button will bring you to the Web Module wizard form.

2.3. How to Configure Web Module Settings

As we deal with a Dynamic Web Application we should first specify the top level directory of our
application for deploying it to a server afterwards. You know, this kind of application contains both
Web and Java code resources. Thus, it's also important to indicate the content directory as well
as Java source directory. The wizard will put all those values itself. So you can leave everything
asitis.

13
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£

New Seam Project x
Web Module _ o
Configure web module settings. E ,.-'
Context Root:
\SeamProject |

Content Directory:

\WebContent |

Java Seurce Directory:

src |

Generate Deployment Descriptor

® [ <gack |[ mewt> | [ Cancar |

Figure 2.12. Web Module Settings

Choose Next to switch to the next wizard form.

2.4. Adding JSF Capabilities

This wizard helps you to add JSF capabilities into your project for representing appropriate
behaviours associated with JSF.

Checking Server Supplied JSF Implementation means that you will have a default JSF
implementation given by server.

14



Adding JSF Capabilities

3 Mew Seam Project

|SF Capabilities
Add |SF capabilities to this Web Project

(o]

Il o @ Server Supplied JSF Implementation

O . Mew...

Component Libraries

Deploy Library Mame

JSF Configuration File: | WEB-INF/faces-config xmi |

JSF Serviet Narme: lFaces Serviet |

JSF Serviet Classname: [ja\rax.rac es webapp FacesServiet ]

URL Mapping Patterns: | « cagm

® [ <gack |[ mewts | [ cancer |

Figure 2.13. Adding JSF Capabilities to Web Project

In case when you want to use your custom JSF implementation check a lower radio button. You
are able to create a library of jars by clicking on New button.

Here, it's necessary to type a Library Name, select a Version Supported and add proper Library
jars. Then click on Finish to complete the choice.

15
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r Create |SF Implementation Library x

|SF Library
Create a library of jars that make up a |5F implementation library.

Library Name: Custom)SFimplementation |

Version Supported: (v1_1
Library |ars

i) jsf-api jar - jrooyDesktop/rhds/eclipse/plugins
) jsf-impl jar - froot/Desktop/frhds/eclipse/pluging

(il I Findsh H Cancel I

Figure 2.14. Create JSF Implementation Library

In the Component Libraries section of the wizard you can also add Component Libraries (e.g.
Richfaces [http://www.jboss.org/jbossrichfaces]). Just click on New button. Appeared dialog will
ask you to type the Library name, supported version and add necessary jar's. Press Finish to
complete the choice.

f Create |SF Implementation Library X
|SF Library
Create a library of jars that make up a |5F implementation library.
Library Name: Rich Faces |
Version Supported: UNKNOWN IL.
Library )ars
i_-"'l nichfaces-ul-3.1.2 GA-bin_zip - frootfDesktop : Add...
il
\?_‘ [ Einish | | Cancel

Figure 2.15. Create JSF Implementation Component Library
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Configure Seam Facet Settings

The last wizard options allows to edit a path for JSF Configuration File, a name for JSF Servlet,
JSF Servlet Classname and change URL Mapping Patterns.

£ New Seam Project x

|SF Capabllities
Add |SF capabiliies to this Web Project :

|SF Libraries: ) Server Supplied JSF Implementation

3 | Customn)SFimplementation :] Deplay

Component Libraries

Deploy  Library Mame

Richfaces

Fl ) B

1 W (D))

JSF Configuration File: | WEB-INF/faces-config xmi |

JSF Serviet Name: [Faces Serviet

S

J5F Serviet Classname: [Jauax.r‘ac es webapp FacesSarviet ]

URL Mapping Pattermns:

* faces
Remowve

7 < Back |: MNext = 3 | Cancel I

Figure 2.16. JSF Capabilities Wizard

Finally, as we are arranging the Seam Web project, the last step we should do is to adjust project
configurations associated with the Seam.

2.5. Configure Seam Facet Settings

The last wizard step is related to Seam facet and allows you to do the following:

17
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r MNew Seam Project x

Seam Facet

Configure Seam Facet Settings "n, —
General

Seam Runtime: | Seam 1.2 AP = F [Aﬂu_..]
Deploy as: @ WAR () EAR

Database

Database Type: [ HSQL . ]
Connection profile: |§Del’aultD-5 ¢| |Edit...] [New_..]

Database Schema Name: |

Database Catalog Name: ]

DB Tables already exists in database: J

Recreate database tables and data on deploy: [

Code Generation

Session Bean Package Mame: éorg.dumain.test.sessinn ]

Entity Bean Package Name: | org.domain test.entity |

Test Package Mame: |org .domain test test ]

o

N Einish H Cancel f

o
[

Figure 2.17. Seam Facet Settings

¢ Create Seam runtime and define Seam home folder.

For that click on Add button in the General section. Notice that in this wizard presented below
you can create a Seam runtime only for that version which was selected in the Project Facets
wizard (version 1.2 in our case).

18



Configure Seam Facet Settings

¢ MNew Seam Runtime
Seam Runtime

Create a Seam Runtime

Name: lSeam_n.lnu'me |
Version: (1.2 s
Home Folder: |.Fuptmur1qi]b055vseamv1.2.1.GA ] [Eruwse]
@ | mnisn || cancer |

Figure 2.18. Seam Runtime Creation

» Select EAR or WAR deployment by checking a necessary radio button.

» Select a Database Type

19
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¢ New Seam Project x
Seam Facet

Configure Seam Facet Settings

DB2
General

DB2/390
Seam Rurtime | Seam 1.2 AP DB2/400
Deploy as: @ WAR ) EAR Derty

Firebird
Database FrontBase
Database Tpe

Informmix
Connection profile: nrorm

Ingres
Database Schema Name: Interbase
Database Catalog Name: Mckol SOL

MysQL

DB Tables already exists in database:
MySOL (InnoDB)

MySGL (MylSAM)
Code Generation MySQL S

Session Bean Package Mame: !nrg.dumaln.sea My3SQL S (nnoDiE)
Oracle 10g

Entity Bean Package Name: iorg.dnmainEea Oracle 8i
Test Package MName: 1org.dnmaln.5e~a Qracle 9i

Pointhase
PastgreSQL

Recreate database tables and data on deploy:

Progress
SAP DB
SQL Server
Sybase
Sybase 11

Sybase Anywhere ]

=3

Figure 2.19. Seam Runtime Creation

 and then specify a Connection profile appropriate for your database.

20
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r Mew Seam Project x
Seam Facet

Configure Seam Facet Settings III. —

General

Seam Runtime: | Seam 1.2 AP H F [Aﬂu_..]

Deploy as: @ WAR () EAR

Database

Database Type: [ HSQL . ]

Connection profile: |§Del’aultD-5 ¢| |Edit...] [New_..]

Database Schema Name: |

Database Catalog Name: ]

DB Tables already exists in database: J
Recreate database tables and data on deploy: [

Code Generation

Session Bean Package Mame: éorg.dumain.test.sessinn ]

Entity Bean Package Name: | org.domain test.entity |

Test Package Mame: |org .domain test test ]

@ hy Einish H Cancel f

Figure 2.20. Connection Profile Options

You can edit chosen profile by using Edit button or organise a new one by clicking on New
button and selecting necessary for you type of connection profile.

21



Chapter 2. Creating a New Sea...

¢ New Connection Profile x

Wizard Selection Page p—

Please select the connection profile type:

Ed Derby Embedded Database

? Generic |DBC Connection

Ed HSQLDE Connection Profile
Ed PostgreSQL |DBC Connection
Ed sybase ASA

(i3] | Cancel ;

Figure 2.21. Connection Profile Selecting

On the other dialog you'll be asked to enter its name and description. And then you should select
a proper driver and adjust connection details. Press Next to preview all the adjusted settings and
complete the creation of the new profile.

22



Configure Seam Facet Settings

r HSQLDE Database
Specify a Driver and Connection Detalis

Select a driver from the drop-down and provide login details for
the connection,

Select a driver from the drop-down:

Hypersanic DB

[[] Save Password

Optional properties:

Database: | SAMPLE |
Database location: [MyDB § [Bmwse.._|
User namea: [ ]
Password: | |
URL:

| Test Connection |

@ | <gack || mext> || ginish

] | Cancel

Figure 2.22. Connection Details

The next block of settings in the Seam Facet wizard are describing a Database and a connection

to it.

In the Code Generation section the wizard have already put the names for your Session Bean,
Entity Bean and Test packages. Of course, you can change them into the others which you like.

23
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Code Generation

Session Bean Package Mame: [org.dnmain.seampmiect.sessinh ]

Entity Bean Package Name: |-Drg.dumaln.seampmiect.enﬁw ]

Test Package Name:

|or|; .domain.seamproject test

C] [ coee |

Figure 2.23. Code Generation Section

Click on Finish to generate a project.
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Directory Structure of the Generated
Project

In this chapter we describe where the Seam wizard puts the generated files for both EAR and
WAR deployments.

The Seam Project wizard generates projects like Eclipse WTP style in order to utilize Eclipse WTP
features and to have a correct classpath. To be more precise it generates one project per artifact.

3.1. WAR Deployment

The project layout for WAR projects is:

£ Package Explorer &3 =0
- &= v
. ESeamPruject

b 1=} SeamProject-test

Figure 3.1. Project Layout for WAR projects

A WAR project can only use Seam JavaBean and JPA Entity bean components; it cannot use
EJB3 Session beans etc.

WAR projects are generated to enable Seam 1.2.1 war hotdeploy feature. Classes put into src/
action will be deployed to WEB-INF/dev from which Seam 1.2.1 automatically will perform
hotdeploy of new components.

E:] Note:
Because of Eclipse WTP limits the hot deployed classes also existed in WEB-INF/
classes, but since Seam gives WEB-INF/dev precedence it will work.

Furthermore the Seam Project wizard generates a test project that is setup to run TestNG directly
against the proper libraries and server runtime libraries. When the TestNG plugin is installed you
can just run your tests via Run As > TestNG Test.

In order to deploy WAR project on server, right-click on the project and select Run As > Run on
Server. Studio will deploy WAR project into one web application on server to deploy folder.

3.2. EAR Deployment

The project layout for EAR projects is:
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Chapter 3. Directory Structur...

% Package Explorer 23 =0

, = T

v % seamProject

b ¥ SeamProject-ear
b & seamProject-ejb
b 1= SeamProject-test
ol I []

Figure 3.2. Project Layout for WAR projects
An EAR project can use the whole range of Seam components, including EJB3 Session beans.

In order to deploy EAR project on server, right-click on the project with -ear postfix and select
Run As > Run on Server. Studio will take care about all modules and deploy EAR project into one
enterprise application on server to deploy folder. EAR application keeps ejb and war modules of
the EAR project.

3.3. Renaming the Projects and Folders

If you need to rename one of the Seam Project artifacts (<project_name>, <project name>-
test, <project_name>-test or <project_name>-ejb) or any entire folder like <project_name>/
WebContent, <project_name>/ejbModule, <project name>-test/test-src, or project name in
packages org.domain.<project_name>.session, org.domain.<project_name>.entity, you can do
this by brining the context menu and navigating Refactor > Rename... or just pressing Shift +
Alt + R under the chosen resource.

Use Refactor > Move... (or Shift + Alt + V), if you need to move <project_name>/WebContent
folder, <project_name>/ejbModule folder or <project_name>/test-src folder in the other place
within the Project structure.
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Seam Menus and Actions

In this chapter we provide a description of Seam actions that are available from

* Menu bar
* Toolbar

» Context menus in views
4.1. File Menu Actions
In a Seam perspective, by default there are the following actions in File > New submenu

Table 4.1. Seam Actions in the New Submenu

Seam Web Runs New Seam Project wizard for creating a new Seam project

Project

Seam Action Runs New Seam Action wizard for creating a new Seam action

Seam Form Runs New Seam Form wizard for creating a new Seam form

Seam Entity Runs New Seam Entity wizard for creating a new Seam entity

Seam Runs New Seam Conversation wizard for creating a new Seam conversation
Conversation

Seam Generate  Runs Generate Seam Entities wizard

Entities

4.2. Navigate Menu Actions

In the next sections we are going to describe Seam actions which can help you to easily navigate
through the source code.

4.2.1. Find Seam References/Declarations

To find EL expretions both in .java and .xhtml files use Find Seam References/Declarations
actions. For that, in the main menu bar click on Search > Find Seam References or Find Seam
Declarations.

Look at the description of the actions in the table below.

Table 4.2. Find Seam References/Declarations actions

Function Keyboard Shortcut

Ctrl+G
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Name

Function

Find Seam Find all references and declarations to the selected

References element. It's available for EL expressions in both .java
and .xhtml files. Differs from normal Eclipse Find

Find Seam D%@E?BR@@S/Declarations by showing an EL or Seam
references in the Search View.

Keyboard Shortcut

Ctrl+Shift+G

also Ctrl + 1 for .java files

On the screenshot example below you could see that the search results are listed in the Search

view.

Gz loginxhemt B

<ful:define>

</h:panelGrid>

< div=
</ rich:panel=

=iy class="actionButtons® >

</ui;composition=>

value="#{identity. rememberMe}” /=

: <h:commandButton value="Login* actim="#{.‘|.ugin}‘..f=-
=fdive
=/h; form=

(o]

Visual/Source Visual '

Source | Preview

4 Search &

= % seamProject

OO X% BB F

* identity - fopt/work/workspace_jbds/seamProject/WebContent/WEB-INF/lib/jboss-seam jar

Figure 4.1. Find Seam Declaration for "ldentity"

You can also use Ctrl + 1 in .java files to activate the actions:
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Open Seam Component

[+

@Logger Log log;

@In Tdentity identity;

public boolean authenticate()
{

log. info("authenticating #0°, identity.getlUsername());

f/Write your authentication 1op, paname in file (Ctri42 A direct access)
/ireturn true if the authentid]

/fisuccessful, Talse otherwise |Ei Copy to Criteria Editor

ddentity. addRole("admin®}; [t Find Seam declarations for ‘identity”

return true;
} s Find Seam references for ‘identity’

¥

['J
4 Search E;':.’

= 3% seamProject
= 2 WebContent - seamProject
= = layout - seamProjectWeb Content

t leginout xhtmil - seamProject/WebCon

@i menu.xhtml - seamProjectWebContentdayout (5 matches)
2% login.page. xml - seamProjectWebContent (2 matches)

Figure 4.2. Find Seam References for "ldentity"

4.2.2. Open Seam Component

To open Seam Components click on Navigate > Open Seam Component in the main menu bar.
This dialog is also available from toolbar icon.

ERIO

Figure 4.3. Open Seam Components icon

In the table below read a description about the dialog.

Table 4.3. Open Seam Components Dialog

Name Function Keyboard Shortcut

Open Brings up the Open Seam Component dialog | Ctrl+Shift+Z

Seam Compoteendpen a component in the editor. The Open
Seam Component selection dialog shows all Seam
components existing in the workspace. You can
search the components via their short, imported or full
name.
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Enter a name in the text field and see the results as it shown on screenshot:

Enter seam component name prefix or pattemn (? = any character, * = any string):
|capt I

Matching items:

@' org jboss seam captcha captcha - testSeam-ejb

@) org jboss seam capteha captcha - seamProject

@ org jboss seam captcha captchalmage - testSeam

@) org jboss seam captcha captehalmage - testSeam-ajb

@ org jboss seam captcha captchalmage - seamProject

&) org jboss.seam captcha.captcha - testSeam

[ira) [ OK I[ Cancel I

Figure 4.4. Open Seam Components Dialog




Chapter 5.

Seam Wizards

This chapter introduces you with Seam Components.

All the Seam component generations options known from Seam-gen are available as wizards
(with sensible auto-defaulting) for creating various common Seam components:

e Seam Action

* Seam Form

¢ Seam Entity

» Seam Conversation

Go to File > New and select the component wizard.

mﬁdlt Source Refactor Navigate Search Project Bun Window Help

Mew S{e e % Searn Web Project

Open File,.. % Project...
# Package
& Class
¥ Interface
&7 Source Folder
% Folder
| ¥ File
Mowe .. © Seam Form
Rename... F2 | =2 Seam Entity
Refresh F5 Seam Conversation
Convert Line Delimiters To ¥ | o0 Seam Generate Entities
% Example...
Switch Warkspace ¥ | [ Qther...
f=3 Import...,
3 Export...
Properties Alt+Enter
Exit

Figure 5.1. Seam Component Wizards

The wizards create multiple resources and place it in the appropriate folders depending on your
project structure (WAR or EAR).
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Let's create a WAR project using the New Seam Project wizard.

= seam_war

[>
B
[>
B
[>

® grcfaction
B srefmodel
Bl JRE System Library [jok1.5.0_12]
B4 All JBoss Libraries [JBoss 4.2 Runtime]
Bl Web App Libraries
= build
P = resources
= sre
I = WebContent
M8 hibernate-console properties
|7] seam_warlaunch
= 2% seam_war-test
[+ (% test-src
b (% embedded-ejb
I B JRE Systemn Library [jokl.5.0_12]
I =i Referenced Libraries

=]

Figure 5.2. Seam Project WAR Deployment

After the project is created you need deploy it on server.

5.1. New Seam Action

In this and following sections you can see example creating Seam Components.

To create a New Seam Action you should select a necessary project, type a name for Seam
component, POJO class, Method, Page and select a Package using Browse button.
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New Seam Action

K New Seam Action »
Seam Action ['—""_
Create a new Seam action '-;;'g_'ju_;' —
Seam Project: [seaumject ] [Bmwse]
Seam component name: |Action |
POJO class name: [Aj:ljnnPOID ]
Method narme: [acuann‘lemnd ]
Page name: [actionPage ]
Package name: [nrg_domain.seampm]e::t.sessmn ] Browse

|| Finish I[ Cancel I

Figure 5.3. New Seam Action Wizard

You can see the action page in WebContent folder. Click on it to open in JBoss Tools HTML Editor.

[ Package Explorer m\ =0 =0
B~ i B
— IR "http://www.w3. org/TR/xhtml1/0TD/xhtmll- transitional. dtd™>
= ¥ seam_war - <ui:composition xmins="http://www.w3.org/ 1999,/ xhtml" A
- . xmlns:s="http://jboss. com/products/seam/taglib” 3
r n
P & sreiactio xmins:ui="http://java. sun.com/jsf/facelets”
b ™ srefmodel xmins: f="http://java. sun.com/jst/cora” i
P = JRE System Library [jdk15.0_12] xmlns:h="http://java.sun.com/jsf/html"
- xmLns: rieh="http: //richTaces. ajaxdjsr.org/rich”
b= Al JBoss Libraries [JBoss 4.2 Runtime’ xmlns:a="https://ajax4jsf.dev. java.net/ajax"
P =k Web App Libraries template="layout/template. xhtml">
& build <ui:define name="body">
b & resources o N ) ~ -]
& sre L Gl L L)
¥ = WebContent - = cle 7 uw| 7 A
P =img -4 -
#lprojeciName):  Home Welcome, #{identity.username]  Login  Logoul ||
B = layout @
I (= META-INF 2
D E>sty|esheet Error Messages
P = WEB-INF 1
v actionPage xhtmi
o error.xhtml
o home xhtmil ] L
o index html =
X login page xmi | | ®
et lrumins vl =l
GI m D] Visual/Source Visual Source|PrevIew

Figure 5.4. Action Page in JBoss Tools HTML Editor.
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Action component was hot-deployed. Forms and Conversations will work the same way.

RELE L oLl

oo W Ehup:Mncahust:EﬂEﬂ:‘s&am_warfa:HmPag&.Eaam |'] =3 .
seam_war:  Home foga
actionPage
| actionietnod: |

Powsend by Searn, Gonarated by SO3M-06

Figure 5.5. Action Component

5.2. New Seam Form

Click on actionMethod in the internal browser and add a form in your project using the New Seam
Form wizard File > New > Seam Form.

Select a necessary project, type a name for Seam component, POJO class, Method, Page and
select a Package using Browse button.
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New Seam Form

[ MNew Seam Form x
Seam Form F“
Create a new Seam form | ‘_u_:' —
Seam Project: [seam_war ] [Bmwse...]
Seam component name: |Form |
POJO class name: [FarmPD]G ]
Method narme: [Tum’ihlemnd ]
Page name: [furmPag-e ]
Package name: [nrg_uomain.seam_war.sesr.lnn ] Browse...

(il | Enish | [ Cancel I

Figure 5.6. New Seam Form Wizard

The Form Page was created in WebContent folder.

"y

[# Package Explor 32 ({5 Project Explorer = B || @ seam_war |m FormPOJO java  x formPage xhim =8|
- =!DOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.0 Transitional//EN" (<]
o — “http: //www. w3, org/TR/=html1/DTD/xhtmll- transitional. dtd"= A
b =\ web App Libraries = <uli:composition Xmlns="http://www.w3.org/1999/xhtmL"
& build =mlns:s="http://jboss.com/products/seam/taglib® ™
xmlns:ui="http://java. sun.com/jsf/facelets”
P & resources xmlns: f="http://java. sun.com/}sf/core”
& sre “mlns:h="http://java. sun.com/jsf/html"
| | *mins: rich="http://richfaces.ajax4jsr.org/rich”
= = WebContent *mlns: a="https://ajax4]sf.dev. java.net/ajax"
b E&img template="layout/template. xhtml™=
B layout Gl . |,]_'
[ META-INF
d - = = sl B s A
b & stylesheet &
b = WEB-INF #{projecthamel:  Home ‘Welcome, #{identity.username}  Login  Logout | |
o actionPage xhtmi @
o error.xhtrl = &y Error Messages |
— |
o home xhimi
HE Index. htmi Value*
4 login page xmi L
o login.xhuri [ crmivetnos |
[ hibernate-consale properties : =
| searn_warlaunch L ®
b =¥ seam war-test L=
1 i I+ VisuaHSour\:e|vlsua1|Source Preview

Figure 5.7. Form Page in JBoss Tools HTML Editor.

Deploy the form on server. Right click on Form Page, select Run As > Run On Server.
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(o5 E, TR - C

fi=] o [hn:p:mucalhnst:auawseam_warﬁunﬂmge.seam |"| =3 n
seam_war: Home Login
formPage
Value *
| formMethod |

Powsrod by Seamn. Gonoratod by sosm-gon

Figure 5.8. Form Component

Form component was hot-deployed.

5.3. New Seam Conversation

Enter some value in the text field (e.g. valuel) and click on formMethod.
Add a conversation using the New Seam Conversation wizard File > New > Seam Form.

You should select a necessary project, type a name for Seam component, POJO class, Method,
Page and select a Package using Browse button.
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Seam Conversation

Create a new Seam conversation

Create New Conversation x

Seam Project: seam_war | |Browse...|
Seam component name: ltalh: ]
POJO class name: | Talk |
Method name: [talk: J
Page name: |talk |
Package name: |org.domain.seam_war.session | |Browse...|

Finish I[ Cancel I

Figure 5.9. New Seam Conversation Wizard

Conversation page was created in WebContent folder.

POOEOAN JOUSS LIUNGiES [JOUSS 52 MUnianmieey
P m4 Web App Libraries
= build
P (& resources
& src
= = WebContent
P =img
I = layout
I (= META-INF
P (= stylesheet
P = WEB-INF
o actionPage xhtrmil
o error.xhtmi
o formPage xhtrmi
o home xhimil
o index_html
41X login.page_xmi
o login.xhtrmi
[ hibernate.console properties
|1 seam_warlaunch
b &) seam_war-test

Ll I D)

(12 Package Explor x:\l&, Project Explorer = o
8% v

<IDOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.0 Transitional//EN®
“hitp: /ffwew. w3, org/TR/xhtmL1/DTD/xhtml1- transitional. dtd">
<ui:composition Xmlns="http://www.w3.org/1999/xhtmL"

<h:messages

xmlns:s="http://jboss.com/products/seam/taglib”
*mlns:ui="http://java. sun.com/jsf/facelets”
xmlns: f="http://java.sun.com/)st"
=mlns:h="http://java. sun.com/jsf/html"

xmlns: rich="http://richfaces.ajaxdjst.org/rich”
template="layout/template. xhtml* =

=ul:define name="body">

globalOnly="true" styleClass="message" /=

= = = B I u SN
#projectHame):  Home Welcome, #(identity.usemame]  Login  Logout | |
Error Messages
talk =
Value #itak vale}
= E3
x

Visual/Source | Visual | Source| Prevlew|

Figure 5.10. Conversation Page in JBoss Tools HTML Editor.

37




Chapter 5. Seam Wizards

Right click on Conversation page, select Run As > Run On Server.

@ searn_war

=08

e o |htrp:.fﬂ::ucalhuﬁt:BDSWseam_warﬂalk Seam

"iﬁ*ﬂ

SeamWar: Home

Value !

[ sogin [ icremenc [ Ens

=

Pevriod by Soam. Genimied by soam-gon

Figure 5.11. Conversation Component

Conversation component was hot-deployed.

Click on Begin and Increment buttons to check the conversation functionality.

5.4. New Seam Entity

Entities cannot be hot-deployed, so we need to stop the server.

Create an Entity using the New Entity wizard File > New > Seam Entity.

Lagin

You should select a necessary project, type a hame for Entity class, select a Package using

Browse button, type a name for Master Page and Page.
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New Seam Entity

I Mew Seam Entity x

Seam Entity
Create a new Entity

Seam Project:

[SEEITI_'IH-EF

Seam entity class name: | Customer

Package name: [nrg.dumain_seam_war_entity
Mastar page name: [cusmmerust
Page name: [custnmerPage

| Ensn || cance |

Figure 5.12. New Seam Entity Wizard

The Master Page and the Entity were created in WebContent folder.

I & resources
12 src
= = WebContent
B = img
b 5= layout
I (= META-INF
B = stylesheet
b = WEB-INF
i actionPage xhtrmil
o customerPage xhtmi
i error.xhtmi
o formPage . xhtmi
i home xhtml
i index html
24 login page xmi
e lagin. xhtmi
o talk xhtml
[ hibernate-console properties
[ seam_warlaunch

L ey

Ll I

[T+

xmlns: s="http: //jboss. com/productss/seam/taglib®
wmlns:ui="http://java. sun. com/jsf/facelets”
xmlns: f="http:s/java. sun.com/jsf/core”
amlns:h="http: //java. sun.com/jsf/html"

x*mlns: rich="http://richfaces.ajax4)sf.org/rich”
. template="layout/template. xhtml" =

[% Package Explorer x;'\ = =0
= :‘5 - =!DOCTYPE compesitien PUBLIC *-//fW3C//DTD XHTML 1.6 Transitional//EN" [=]
—— — | *http: //wew. w3 org/TR/xhtml1/DTD/xhtml]l- transitional.dtd" = I
& build el <ui:composition XmLns="hTtp://we. w3.org/1999/xhtmL"

#projectName}:  Home

& R«

Errer Messages

customerl ist
Mo customer exists

#customer.id) #customer name]

[E1N

Welcome, #{identity.username]}  Login  Logout

X [

Visual/Source \ﬂsuall Source Frevlew|

Figure 5.13. Master Page in JBoss Tools HTML Editor.

39




Chapter 5. Seam Wizards

The Entity page is:

[Z Package Explorer = \ . :@ custormnerList.xhtmi i =g]
= =!DOCTYPE compesitien PUBLIC *-//W3C//DTD XHTML 1.8 Transitional//EN® (]
- - “http: /fwww. w3, org/TR/xhtml1/DTD/xhtmll- transitional . dtd">
T iZ seam_war <ui:composition xmlns="Rttp://www. w3.org/1999/xhtmL"
P §# srefaction xmlns: s="http: //jboss. com/productss/seam/taglib® ||
N wmlns:ui="http: //java. sun.com/jsf/Tacelets”
b & srcjmodel xmlns: f="http:s/java. sun.com/jsf/core”
P =4 JRE System Library [jdk1.5.0_12) zmlns:h="http://java. sun.com/jsf/html"
xmlns: rich="http://richfaces.ajax4jst.org/rich”
P =i All JBoss Libraries [JBoss 4.2 Runtims template="layout/template. xhtml*>
I m Web App Libraries
(= build <ui:define name="body">
P & resources <h:messages globalOnly="true® styleClass="message"/=
i sre =)
= {= WebContent .- : =
b &img - = I u| 4 A
[ -
B i layout ﬁ | #lprojectName}:  Home ‘Welcome, #{ldentity.username}  Login  Logout ||
P (= META-INF @
b e lesheet
(& styleshee & Error Messages
P 5= WEB-INF L 3
o actionPage xhtml
o customerList. xhtml B Name Error Messages
or error.xhtmil B
i formPage xhtmi | m m 1|
o home xhtmil =
o index htmi = *
@l m 0 Visual/source ‘\.ﬂsuallSnurce Freview|
Figure 5.14. Entity Page in JBoss Tools HTML Editor.
Run the Entity page on server. This is what you get:
r =
(9 seamwar B -
B & [hltp:.f.ﬂnc alhost: 8080/seam_warfcustomerPage seam | = I =3 ‘
seam_war: Home Login

Povwersd by Seam. Gonoratod by seam-gon.

Figure 5.15. Customer Page

Let's create two customers c1 and c2. Enter the name in the text field and press the Save button.
Customer should be successfully created. Press Done. Do the same for c2 customer. The result

should be:
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o

9 seamwar 3 “E

oo B [http:Mucalhust:a‘-uBO!saam_war.i‘custumerUst.EEam?cid=‘.-'&clr=uue&cunuersaljunﬁ'opa;l'] [ -

seam_war: Home Login

customerList

Id Name
121
22

Povinid by Soam Goriealad by Soarr-jn.

Figure 5.16. Two Customers Are Created
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Chapter 6.

Seam Generate Entities

The main purpose of this chapter is to tell you about Seam Generate Entities.

Generate Entities is available directly from within Eclipse using Hibernate Tools plugin for the
standard seam-gen generation.

Generate Entities generates a set of CRUD Seam components and web pages based on existing
tables in a database or on existing entities in your application.

[ Generate Seam Entities x
Generate Seam Entities T
A=
Seam Project |SeamPruj-et:t lBrnwse.. I
Hibernate Console Configuration: | SeamProject S |
Generation Mode
@ :Reverse engineer from database
) Use existing entities
@ [ Einish 1 | Cancel

Figure 6.1. Generate Seam Entities Wizard

In the Generate Seam Entities wizard there are two generation modes: Reverse Engineer from
database and Use existing entities.

The Reverse Engineer from database mode can be described in four steps:

1. The wizard gets in database, extracts the tables and their connections

2. On basis of this metainfomation the Entity classes are generated into org.domain.project.entity
package

3. For the entities from step 2 the classes EntityList and EntityHome are generated into
org.domain.project.session package
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4. The xhtml pages are generated.

Checking the Use existing entities mode the wizard executes only 3 and 4 steps. It generates
missing classes and xhtml pages.

Read the Generate a CRUD Database Application chapter in order to see how the Generate Seam
Entities wizard can be used.
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Seam Editors Features

7.1. Content Assist

In this chapter you know what Seam Editors Features are and how to work with them.

Content Assist (ctrl + space) is available when using expression language in:

* JSP
« XHTML
« XML

JAVA

The Seam components are available in content assist.

<rich:toolBar =
xmlns="http:// www. w3.0rg/1999/xhtml*
xmlns:uil="http://java. sun.com/]sf/facelets”
=mlns:h="http://java.sun, com/jsf/html"
xmlns: T="http: //java. sun. com/jsT/core”
xmlns: s="http://jboss.com/products/seam/taglib®
wmlns: rich="http://richfaces. ajaxdjsf. org/rich"=
=rich:toolBarGroups>
<h:outputText value="#{projectName}: =/ /=
<s:link view="/home.xhtml" value="Home" />
</ rich:teolBarGroup=>
<rich:toolBarGroup location="right"=
<h:outputText value="Welcome, #{identity.usermame}" rendered="#{identity.loggedIn}"/=>
. =5:link view="/Llogin.xhtml® value="Login® rendered="#{not ident lty.l Wi
=s:link view="/home.xhtml” action="#{identity.logout}" value=[@ ientityaddRole -
=/ rich:toolBarGroup>
</rich: toolBar> @ identity addRole{argo)
y.authenticate
(@ identity. authenticate()
® identity authenticate({loginC ontesxt)

(@ identity. authenticateMethod

@ igentity.checkEntityPermission

(@ identity.checkEntityPermission{argd, argl)
@ identity.checkPermission

K I @ Iidentity.checkPermission(name, action, arg)
LB} identitv checkRestriction

Figure 7.1. Content Assist

Preferences
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7.2. OpenOn

OpenOn let's you easily navigate through your project without using the Package Explorer or
Project Explorer. After pressing ctrl + left click (or just F3) you will see a corresponding method
or class.

<rich: toolBar -
xmlns="http: /S wew. w3, org/ 1999/ xhtml"
xmlns:ui="http: //java. sun. com/jsT/Tacelets”
xmlns:h="http://java,. sun.com/jsf htmL”
xmlns: f="http://java. sun.com/jsf/core”
¥mlns: s="http:/f/)boss. com/products/seam/taglib”
xmlns: rich="http: f/richfaces.ajaxd4jsf.org/rich”=
<rich: toolBarGroups
<h:outputText value="#{projectName}:" /=
=5:1link view="/home.xhtml®” value="Home" /=
<f rich: toolBarG roups
<rich: toolBarGroup location="right">
toutputText values"Welcome, #{identity.username}” rendered="#{identity.loggedIn}”/=
=5:1link view="/login.xhtml® value="Login® rendered="#{not identity.}"/= -
=5:link view="/home. xhtml® action="#{identity.logout}" wvalue="Logout® rendered="#{ident
<frich:toolBarGroups
<frich:toolBar=

Figure 7.2. OpenOn

7.3. Seam Validation

Validation of various possible problematic definitions is implemented for Seam applications.

If an issue is found it will be showed in the standard Problems View.

[ Package Explorer [;\_-,Pro]ect Explorer % = .% ¥ =8 Wﬁ] DifferentAuthentic ator java =g

import org.jboss.seam.annotations. Logger; |=|m
b orgposs.seam.core import org.jboss.seam.annotations.MHame;
B & org jboss.seam.drools import org. jboss. seam.log. Log;

import org.jboss. seam. security.Identity;
P org jboss.seam.security P rg.] ¥ Vi

P ) seam-demo (sss)

= %% |ava Resources: src

[ @Name(*authenticator®)
. public class Authenticator] m
= ¢ org.domain 555 session

3 @ Authenticator = @In Identity identity;
- (] DifferentAuthenticatorjava : ] : =
b @ DifferentAuthenticator
[ @ org.domain.sss test
I (= META-INF

-?“, Online Help |E;_ Problems 5 @ Tasks?

2 errors. 2 warnings, 0 infos

bR || Description Resource Path
import.sql
pari=q = & Errors (2 iterns)
P [E messages_en properties ) ) i :
£ Duplicate component name: authenticator Authenticaterjava seam-.
I [E seam properties ) ) ) ) _
& Duplicate component name: authenticator DifferentAuthenticator java seam-c

b 2 security.dr

. | b & Warnings (2 items)
I i sss-ds xmi L=/|

Figure 7.3. Seam Validation
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Seam Validation

In the preferences page for Seam Validator you can see and modify the validator behavior. Go
to Window > Preferences > JBoss Tools > Web > Seam > Validator and select the severity level
for the optional Seam Validator problem.

[type fiter text ] Validator
b General -] Configure Project Specific
I+ Ant Select the severity level for the following
b Conneciivity optional Seam Validator problems:
) ~ Components
FreeMarker Editor )
b Help Duplicate component name: | Error —
HOL editor Stateful component does not contain @Remove method:
b InstallUpdate Stateful component does not contain @Destroy method: Error e
I+ Internet
Stateful component has wrong scope: Error H
I Java
I+ |Boss jBPM Component class name cannot be resolved to a type:
= |Boss Tools Component class does not contain setter for property: | Error &
I JBoss Servers
J ¢ Entitles
Packaging Archives
Lk ¢ Component life-cycle methods:
- Web
¢ Factories
b Edit
rors » Bijections
[+ |SF
J ¢ Context variables
= Seam
¢ Expression language
Validator
B Struts
Verific ation
b KDoclet
|FA E
I Plug-in Development
I+ Run/Debug
b server
I+ Spring
B SQL Development = ; :
I — Restore Defaults | [ Apply
@ ok || cancel

Figure 7.4. Seam Validator Preferences

On WTP projects validation are enabled by default and thus executed automatically, but on normal
Java projects you will have to go and add the Validation builder to your project . It is available in
the properties of your project under Validation. The validations can be run manually by clicking
Validate via the context menu on your project which will execute all the active WTP validations.
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Chapter 7. Seam Editors Features

7.4. Structured components.xml Editor

When editing components.xml a structured tree editor is available in addition to pure source
editing. It has a graphical view (Tree tab) and source (Source tab).

3 componentsxmi 5

Seam Components 1.2 Editor

* components ~ Seam Components 1.2 Flle

- B2 components xm

3
@

W org jposs seam,

Edit..

&% Factory...
@) orgjbossseam.  Properties... —_— | |
M | class Add...
I+ &) entityManager Framework , |
T semnnetosey e
© persistence unit properties spring N —
% org jboss.seam.core gjb Ramoting , -
b &) securityRules per '
% org jposs seam security identity Core C @
= b org jboss seam notLoggedin Drools C
&l #{redirect captureCurrentView} Security »
b @b org jboss seam postAuthenticate Mail d o
L3 e
& org jboss seam mail mailSession Jas -—
= '

I+

11'ee] Source |

Figure 7.5. component.xml Editor

48



Structured components.xml Editor

[ Project Explorer ES\ B %S <0

= ;= WEB-INF =
P (= classes
b = dev
b &b

= ¥ components xmil

% org jboss seam.core.init
W org jooss seam.core manager
[ & entityManager
[ &) seamEntityManagerfactory
% org jboss seam.core. ejb

[ &) securityRules

'] org. |boss. seam. security.ldentity

[+ ﬁ org jboss seam.notLoggedin
[+ ﬁ org jboss seam postAuthenticate

& org jooss seam.mail. mailsession

B () Fmmnr el caeeld

KDI____II___,__I_.__ E‘E\ - =

1 items selected
|

Advanced Froperty Value
authenticate-methe # {authenticator authenticate}
auto-create Talse
class

installed

jaas-config-name

name

precedence
remember-me true
scope

security-rules #{securityRules}

Figure 7.6. component.xml Editor

49



50



Chapter 8.

Seam Views

8.1. Seam Components View

This chapter introduces you with Seam Components View.

The Seam Components View is available from Seam perspective. It provides a list of seam
components found in a project.

{1 Problems < Tasks . Searn Components & < |Boss Server View | 4t Servers =R =

= & SeamProject =
= Ly Application
b HE (default package)
[ & orgjboss seam captcha
= H org jboss seam core
b &) applicationContext
b & businessProcessContext
b &) conversationContext
= @ ejb
¥ components xmil
| jposs-seam jarforg jboss seam.core Ejb
B @ eventContext

b & exceptions

b &) expressions

|4

Figure 8.1. Seam Components View

The Seam Components View can show a components default scope in two ways:

* as labels on each component (click on the triangular symbol at the top of the Seam Components
View page and select Scope Presentation > Label)
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Chapter 8. Seam Views

zI},’_L Problems & Tasks ME |Boss Server \I"il!'-ll'] i Servers

| 8%~ =0

= L SeamProject

Ir & {default package)
H org jboss.seam.captcha
i org jhoss seam core
& org jooss.seam.debug
H# org jboss seam frameweork
& org jooss.seam.ioc spring
t# org jboss seam jms
H# org jboss.seam.mail
# org jboss seam pdf
& org jooss.seam.persistence
i org jboss seam remoting
& org jooss.seam.remoting.messaging

v T T T T T T T T T T v

& org jboss seam security

Seam Packages L

d

QLabel

CiNode
| v Customize View ...

Scope Presentation

[] Link Editor

Al

Figure 8.2. As label

* as a node per scope where the components are grouped under a node representing its default

scope.

[ Problems & Tasks WJ |Boss Server \new] il Servers

[e& =9

= L% SeamProject
I L Application
I+ L Business Process
I+ L Conversation
I+ L Event
I % Method
b L Page
I+ L Session
b Ef stateless
I L Unspecified
b % seamProject-test

Seam Packages

CiLabel Scope Presentation

' T Customize View. ..

[] Link Editor

Figure 8.3. As node

The Seam Packages can be presented in two ways:

* Flat
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Seam Components View

-lf{.z Problems +| Tasks WE |Boss Server wgw] i Servers - G 7= 8|
= L% SeamProject Seam Packages

= L Application | OHierarchical  Scope Presentation

b 8 (default package) o Customize View ..

H# org jboss seam captcha
H org.jboss.seam.core L L1 Link Editor
8 org jboss seam debug

# org jboss seam ioc.spring

# org jboss.seam jms

H# org jboss seam remating
# org jboss seam remating messaging
H# org jboss seam security

# org jboss seam serviet

P
b
P
b
P
b B org jboss seam mail
P
b
P
b
P

H# org jboss seam uigraphicimage

Al

Figure 8.4. Flat Presentation of Seam Packages

» Hierarchical

z[L- Problems & Tasks W_E |Boss Server \new] 4 EII'U'II'IE B & =0

= % SeamPraject CIFlat Seam Packages

= L Application | QHierarchical Scope Presentation  *

= 8 (default package)
b & pdrKeyStore

o Customize View ...

b % SeamProjectEntityManagerFactory L [ Link Editor

b &) securityRules =
= 8 org
= t jboss
P & seam

[+ L Business Process
b Lh Conversation —
I+ L Event
b L Method
b 5 Page

A

Figure 8.5. Hierarchical Presentation of Seam Packages

The Seam Component View can be filtered by choosing Customize View.
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Chapter 8. Seam Views

SRE-S il =
Seam Packages r

Scope Presentation *

—+ Customize View. .

] Link Editor

Figure 8.6. Customize View

Select the Seam Components from Libraries under the Filters tab. This will make the view ignore
components defined in jars. This will hide the many built-in Seam components and leave only
those that are actually defined in the project or have been actively configured via components.xml.
Therefore, deselecting the filter will show you all available components.

Selecting the Seam Components from Referenced Projects will hide the components that
dependent on other project.

£ Avallable Customizations x|

& Alters % Content
Select the filters to apply (matching iterms will be hidden):

[enter name of filter

Seam Componeants from Libranes

Seam Components from Referenced Projects

:

[ oK | | Cancel

Figure 8.7. Available Custimozations

8.2. Project Explorer integration

If you don't like to have a view for every piece of information in Eclipse, the content of the
Seam Components view is also available as a node in the built-in Project Explorer (not Package
Explorer!) view in Eclipse.
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Project Explorer integration

e, 7 77"
+ 12 seamProject
+ [ Seam Components
b L application
b [ Business Process
b i Conversation
I s Event
b Ei Method
L Page
b [ Session
I [ Stateless
b L Unspecified
b7 Web Resources
b §% Java Resources
b = build
b = resources
b = sre
b [ hibernate-console properties
b 2 SeamProject.launch
b 1= SeamProject-test

Figure 8.8. Seam Components in Project Explorer
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Chapter 9.

Seam Preferences

In this chapter you get to know how Seam preferences can be modified during the development
process.

9.1. General Preferences

Seam preferences can be set using the Seam preference page. Click on Window > Preferences
> JBoss Tools > Web > Seam.

On this page you can manage the Seam Runtime. Use the appropriate buttons to Add more
runtimes or to Remove those that are not needed.

r Preferences x

|type filter text | Seam

[+]

I+ General

boAnt

b Connectivity Seam 1.2AP 12 foptiwork/jbds/jboss-eap

Name Varsio Path

FreeMarker Editor

£
4

b Help Bemove

HOL editor
InstallUpdate
Internet

Java

|Boss jBPM

4 v = - v

|Boss Tools
I |Boss Servers
Packaging Archive
= Web
I Editors
b sk
Label Decoratic
|- seam |
Walidator
b struts
Verification
P xDeclet
|Pa.
(4] [ I+

(4]

(i) oK ” Cancel I

Figure 9.1. Seam Preferences Page
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Chapter 9. Seam Preferences

Clicking on Edit button you get the form where you can change the path of Seam runtime home
folder, modify name and version. Press Finish to apply the changes.

£ Edit Seam Runtime x
Edit Seam Runtime @—E
Input | \ \—
nput new values .“_,,:)
Home Folder: | joptiwork/bds/jboss-eap/seam lBruwse... I
Mame: Seam 1.2 AF ]
Wersion: 12 =

Figure 9.2. Edit Seam Runtime

9.1.1. Validator Preferences

Seam preference page includes a subsection Validator. See Window > Preferences > JBoss Tools
> Web > Seam > Validator.

On this page you can choose a severity level for the various Seam validator problems. For
example, if you want to ignore the case when component name is duplicated expand the
Components node and select Ignore next to Duplicate component name. After that you won't see
the error.
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Validator Preferences

¢ Preferences x
[type filter text | Valldator =1
b General = Configure Project Specific
b Ant Select the severity level for the following
b Connectivity optional Seam Validator problems:
= Components
FreeMarker Editor
I Help Duplicate component name: Error
HOL editor Stateful component does not contaln @Remove method: wamﬂ
Ignore
P Instal/Update Stateful component does not contain @Destroy method: Error 5
I Internet ;
Stateful component has wrong scope: | Errar %
b Java T
I JBoss [BPM Component class name cannot be resolved to a bype: Error =
= |Boss Tools Component class does not contain setter for property:
I |Boss Servers
¢k Entities
Packaging Archives
¥ Component life-cycle methods:
= Web
» Factories
I Editors
» Bljections
b JsF
b Context variables
Label Decorations
¢ Expression language
= Seam
I
b Struts
Verification
B ¥Doclet
JP&A
B Plug-in Development
P Run/Debu H '
| g v = [Fl.esture Qefaulls] [ Apply
‘ ¥
@ [ oK l | Cancel

Figure 9.3. Seam Validator Preference Page

In the upper right corner of the page there is a Configure Project Specific link. Clicking on it you
get the form where you can choose a project for specific setting. Project specific configuration
allows you to have different validator settings for each project. Check the Show only projects with
project specific settings if you want to see the projects that have been already set. Click on Ok.
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Chapter 9. Seam Preferences

Project Specific Configuration

Select the project to configune:

& seamProject

= seamProject-ejb
= seamProject-test

[] Show only projects with project specific settings

7 I oK ” Cancel I

Figure 9.4. Project Specific Configuration

You get the validator properties page for chosen project. Check the Enable project specific settings
to be able to change the settings.
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Project Preferences

i Properties for seamProject (Filtered)

|-t5.rpe filter text ] 'y Seam Valldator

Seam Validator Enable project specific settings

Select the severity level for the following
optional Seam Validator problems:

~ Components

Duplicate component name: | Efror H
Stateful compeonent does not contain @Remove method: Error H
Stateful compenent does not contain @Destroy method: Error =

Stateful cormponent has wrong scope: Erro

Component class name cannot be resolved to a type:

e

En'ar -

.

Component class does not contain setter for property:

» Entities

¢ Component life-cycle methods:
» Factories

¢ Bljections

¢ Context varlables

¢ Expression language

Restore Qeraults] [ Apply

@ E oK '] | Cancel

Figure 9.5. Validator Properties Page for Chosen Project

9.2. Project Preferences

Once Seam project is created you can modify its settings. Right click on Seam project in Project
Explorer and select Properties > Seam Settings.

This project properties page allows you to have a flexible project layout. It means that you are
not restricted with a specific project structure. You can use the Seam wizards (New Action, Form,
Entity, etc.) on Maven, command line seam-gen or your own project structure.

Moreover you are not required to use the Seam New Project wizard to benefit from Seam artifact
wizards. You can just enable Seam on your existing project and configure the folders as you want.
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Chapter 9. Seam Preferences

f Properties for seamProject

[l:ype filter text ] Seam Settings o .
AResource
Searn support:
Beaninfo Path PpRo o
auilders Seam Runtime: | Seam 1.2.AP 3] | Adu...|
FreeMarker Context Main Seam Project: [seammiect ]
Hibernate Settings
Connection profile: [ :] [Edrt...l [Hew...]
J2EE Module Dependen
Java Build Path Deployment
P Java Code Style Deploy as: ) WAR (3 EAR
P Jova Compller Seam EJB Project: |seamProject-ejb | [Emwse...]
b Java Editor
Javadoc Location View
|SP Fragment View Folder: [fseamﬁ'ujecwu'ehCuntent ] [Brcrw*se...]
Packaging Archives Model
Profile C li d
e i Source Folder: [ﬂseamﬁuject-ejbfe]brﬂn-dule ] [Emwse...]
Project Facets
Project References Package: | org.domain seamProject entity | [ Browse...]
Run/Debug Settings Source Folder: |.f5&amP‘rnject-ejhfeibMudule ] [Bn:msa...]
Seam Settings
Saarm Vaildator Package: |n-rg.dumaln.sean‘ﬂ’m{ect.sessmn l [En:mse...]
Server Test
Targeted Runtimes Create Test:
Task Tags Test Project: |seamF’ro]ect-test ] [Bmwse...]
TestNG
valldation Source Folder: [ﬂseamPrn]ect-tes.t.mest-sn: ] [Emwse...]
Wb Content Settings Package: |urg.dumain.5ean'd’miect.test I [Eruwse,,.]
Web Project Settings
b HMDoclet
XDoclet Configurations
lltesmre Qeraulls] [ Apply
(4] I I [*)
[ira) || OK I [ Cancel ]

Figure 9.6. Properties for Seam Project

Tip:

The wizard doesn't allow the renaming of the artifacts listed in the Seam Settings.
It's possible to do in the . See Renaming the Projects and
Folders.
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Project Preferences

In Seam Wizards (New Action, Form, Entity, Conversation, Generate Entities) you can get a quick
access to project settings using the Settings link in the upper right corner of each wizard.

F

Seam Actlion

Seam Project:

Local interface:
Bean name:
Method name:
Fage name:

Package name:

®@

Create a new Seam action

Seam Cl.'.ll'l'lpﬂl‘!lEl'It narme: lﬁ.ctian

New Seam Action

[seamh‘u]ect ] [Bruwse... ]

[An:ljnn

[Acﬁunﬂean

[ECTJGF‘I

[acti-un

fLL sl

[urg_domain.seamﬁu]ect.sesslan ] Browse...

o] [ coce |

Figure 9.7. Settings Link
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Chapter 10.

Generate a CRUD Database
Application

10.1. What is CRUD?

CRUD is an acronym for the four basic types of SQL commands: Create , Read , Update ,
Delete . Most applications have some kind of CRUD functionality, and we can assume that every
programmer had to deal with CRUD at some point. A CRUD application is one that uses forms
to get data into and out of a database.

In the next section we will create Seam Web application, connect it to the HSQL [http://
www.hsqgldb.org/] database and add CRUD support.

10.2. How to create the CRUD Database Application
with Seam

« First, you should download [http://docs.jboss.org/tools/resources/] a database and start it by
running ./runDBServer.sh or runDBServer.bat from the database directory.

« Create a new Seam Web Project using New Seam Project wizard or main menu File > New
> Seam Web Project.
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Chapter 10. Generate a CRUD D...

£ New =
Select a wizard p—
Create a Seam Web Project r

Wizards:

(type fiter text |

[v]

< Seam Components File
< Seam Conversation

< Seam Entity

< Seam Form

<~ Seam Generate Entities

5% Seam Page Flow

£ Seam Web Froject
I = Server

Figure 10.1. Seam Web Project Creation

« Name your project as crudapp, specify Target Runtime, Server and Seam Runtime
configuration. Then press Next and follow the next wizard steps keeping default settings.
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How to create the CRUD Database Application
with Seam

[ MNew Seam Froject x

Seam Web Project

o
Create standalone Seam Web Project @

Project name: [:rudapp |

Project contents:

Use default

' [ homefochikvinafjavajeclipse-toalsfeclipsefworkspace3/cr

‘Target Runtime

| |Boss 4.2 Runtime ¢ | [New..|

Dynamic Web Module version

(25 ]
Target Server

[JEuss 4.2 Server e ] [Nw]
~Configuration
[Dynamtmhpm;actthamzt)G.l 1Mn-d'rly...]

Configures a Dynamic Web application to use Seam v2.0

@ ' < Back ]I Mext = I Einis | Cancel

Figure 10.2. New Seam Project Wizard

Tip:
\

Please have a look here how to create Target Runtime and Seam Runtime in order
to get started creating, running, and debugging J2EE applications.

On Seam Facet page click New... next to the Connection profile section to create a new
Connection profile.
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New Seam Project

Seam Facet u'*
Connection profile is not selected \’

General

Seam Runtime: | jbass-seam-2.0.2.GA

Deploy as: ® WAR O EAR

Database

Databasze Type: [ HSGL o]

Connection profile: | o | Edit...| [New.,.]

Database Schema Mame: [ ]

Database Catalog Name: | ]

DE Tables already exists in database: O
Recreate database tables and data on depley: [

Code Generation

Session Bean Package Mame: [arg.domain.:rudapp.ses:.ion |
Entity Bean Package Narme: [nrg.dnmain.:mdapp.entit}r ]
Test Package Mame: [wg.damain.:rudapp.test ]

rT—————————— T —
(] < Back l I Cancel

Figure 10.3. Seam Facet page

» On New Connection Profile dialog select the HSQLDB connection profile type, name it cruddb
and click Next.
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How to create the CRUD Database Application
with Seam

8 MNew Connection Profile 1

Connection Profile p—

Create an HSQLDE connection profile. f_

Connection Profile Types:

[type filter text ]

E DB2 for Linux, UMX, and Windows
& D82 for isfos
Ed oB2 for z/0s
ES Derby

Ed Generic JDBC
Ed Informix

Ed maxDB

& MysaL

Ed Oracle

ES PostgresqL
Ed SOL Server
ES Sybasze asa
Ed Sybase ASE

Mame:
| cruddb |
Description (opticnal):

@ I [ext = ] Eir | cancel |

Figure 10.4. New JDBC Connection Profile

« On the next page click the round icon next to the Drivers field to select a database driver.
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Mew Connection Profile

Specify a Driver and Connection Details £

Select a driver from the drop-down and provide login details for
the connection. T U

Drivers: | =

Properties

Connect when the wizard completes

[] Connect every time the workbench is started

|’-\.
C

Cancel

Figure 10.5. New JDBC Connection Profile Database Driver

« Now you should see the New Driver Definition dialog. On the first tab select the HSQLDB JBDC
Driver. Underneath in the Driver name field you can change its name if you need.
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MNew Driver Definition

Specify a Driver Template and Definition Name

& Unable to locate |AR/zip in file system as specified by the driver definition:
hsqldb jar.

Name/Type q Jar List | Properties |
Svailable driver templates:

Mame Vendor Version

= Database

HSQLDB |DBC Driver HSQLDB

Driver name:
|HSQLDB |DBC Driver ]

Driver type:
[HEQLDE JDEC Driver ]

7 : Il Cancel |

Figure 10.6. Database Driver Type

with Seam

* You may notice the note on the previous figure. It prompts that you should specify the driver
of the type you pointed. Set the location of the driver by switching to the next tab and press

Add JAR/Zip button.
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MNew Driver Definition

Specify a Driver Template and Definition Name

Specify a drver template, then modify details in the fields below to provide a
unigue narme, a list of required jars, and set any available and applicable

Driver files:

fhomefochikvina/javaihsgldb jar

_Bernwe JARfZip |
| Clear all

(il oK ” cancel ]

Figure 10.7. Driver Definition

« On the Properties tab set the Connection URL, Database Name and User ID and click OK.

72



How to create the CRUD Database Application

MNew Driver Definition

Name/Type :i'Jar Lis':. Properties

Broperties:

Specify a Driver Template and Definition Name

Specify a drver template, then modify details in the fields below to provide a
unigue narme, a list of required jars, and set any available and applicable

Property

Walue

= General
Connection LURL
Database Mame

User ID

jdbe hsgldb:hsglydocalhost: 1701

amplayes

[ oK ” Cancel ]

Figure 10.8. Driver Definitions Properties

with Seam

« After clicking OK to submit the newly created driver you can observe and if you need edit all

specified connection details.
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Mew Connection Profile

Specify a Driver and Connection Details p—
Select a driver from the drop-down and provide login details for
the connection. T
Drivers: | HSQLDB JDBC Driver | & A
Propertias
Database: |emplnyee |
Database location: [hsql:}ﬂucalhnst:l?ﬂl | ~ _! [Emws&..._!
User name [55 |
Password: [ ]
Save Password
URAL [tdbc:hsqldh:hsql;ﬁduc alhost:1701 |
Connect when the wizard completes -Iest conne:tiun]
[] Connect every time the workbench is started
il [ < Back lf Mext = | Einish I [ Cancel

Figure 10.9. Driver and Connection Details

* Now click Test Connection to be sure that connection can be established.

Success

@ Ping succeeded!

Figure 10.10. JDBC Connection is OK

» Validate JDBC Connection profile settings and press Finish or Back if something is wrong.
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with Seam

Mew Connection Profile

Summanry —

Information gathered from previous pages.

| Property value
MName cruddb
| Description |

Auto connect at startup  false
| Auto connect on finish  true |

Driver name HSQLDE |DBEC Driver

| Database employee |
Database location hsql:flecalhost:1701

| User name ] |
URL jdbchsgldb:hsgliflecalhest: 1701

| Save password true |

Connection properties

Figure 10.11. Validate JDBC Connection settings

 After clicking Finish two projects crudapp and crudapp-test will be created.
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MRSl = oot 7 O
2% 7
+ & crudapp
I (8 srefaction
b & srefmodel
b @i JRE Systern Library [java-15.0-5
b =i )Boss 4.2 Runtime [|Boss 4.2 Rur
b=l Web App Libraries
= build
I (= resources
& src
= [=WebContent
b =img
b= layout
b META-INF
b stylesheet
b (= WEB-INF
o error.xhtml
o home xhtml
e indeshtml
iz login.page.xml
e legin.xhtml
[ erudapp launch
M hibernate-conscle. properties
b 1= crudapp-test

[<] | | [>]

Figure 10.12. CRUDAPP Seam Project

* Have a look at the created projects. You can expand WEB_CONTENT folder and open
home.xhtml or login.xhtml with JBoss Visual Editor.
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How to create the CRUD Database Application

with Seam

"y

=0

IC

Error Messages

Login

Please Bgn uSing any usermame and password

Usemame #{identity, username}

Remember me F

1]

Visual/Source }ﬂsuai Source | Preview

Figure 10.13. CRUDAPP Seam Project

« Switch to Database Development perspective with Window->Open Perspective->Other... and

connect to the cruddb database.
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Database Development - fopt/work/workspace/crudapp/WebContent/login.xhtml - Eclipse SDK

File Edit MNawigate Search Project Fun Window Help
| £3~ B |$-0 Q| ¥ 9|8 |2 » o %7 [(hDatabasen_| »
v 2w _-\:3' - |
= B[ home.xhtmi |'}w‘n login xhtml &1 =n
= B I U 7 A
=% [E 0% il K| spoecnane:  Hone Welcome, #{dentityusemame)  Login  kogout
= (= Databases @
b (= ODA Data Sources - [
Bing... .
fogin using any usermame and password
smame # {identity usemname)
Repame E2 laword FITTT T
g:::m Delete Inembor me F
Refgesh Fs g
Froperties Alt+Enter
Posaired by Sl G-ineraid by Siem-Dann
X
1] I T»] Visual/Source Visual Source |Preview|
7% 2§ cruddb (Disconnected) , O

Figure 10.14. Connecting to the CRUDDB database

e Expand cruddb nodes to view its Schemas, Tables, Columns etc.
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with Seam

¢ Database Development - fopt/work/workspace/crudapp/WebContent/login.xhtml - Eclipse SDK
Fle Edit Navigate Search Project Run Window Help

i B | 0-Q- | # |9 |8 |2~ R © & |({yDatabaseD.| *
- - .\::" -
or 53 = O dz home xhtml :..w loginxhiml 53 =
IO I N : 2 iz) 8 r u| 2z A
v Datapases ] &
< &9 cruddb (PostgresQLv. 8.25) — | Mprojecthame):  Home Welcome, #(dentity.usemame)  Loain  Leaout
< [J employee @
@ [ Catalogs % Error Messages
= [J employee Login

= ) Schemas

i . Fiease login using any username and pas sword
b &% information_schema

b 57 pg_catalog v o _ :
= 57 public semame identity usermame
u Depeﬂdendes w ArEsAREIsRR R ERR RN
) Stored Procedures Remember me =
= ) Tables

= [ customers
= ) Columns
b B addresslinel [VARCHAR(
b 8 addressline2 [VARCHAR( e e ot e
U Dependencies
b B contactfirstname [VARCH

b B contactlastname [VARCH
P B country [VARCHARISO)]
b B creditiimit [FLOATS Nullal X

1] ] [v] | Visual/Source Visual| Source Preview|

Figure 10.15. CRUDDB Database

« Switch back to the Seam perspective. From the toolbar select New->Seam Generate Entities
to create a set of CRUD Seam components and web pages based on existing tables in the
database. In the Generate Seam Entities dialog keep everything by default and press Finish .
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r Generate Seam Entities x

Generate Seam Entities

Seam Project: [cn.ldapp ] IBraw:‘-e... I

Hibernate Console Configuration: [ crudapp = |

Generation Mode

@ :H.everse engineer from database

() Use existing entities

Finish ” Cancel I

&

Figure 10.16. Generate Seam Entities

* Under WebContent folder you can find a lot of generated xhtml files:
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Seam - fopt/werk/workspace/crudapp/WebContent/CustomersEdit.xhtml - Eclipse SDK
Ele Edit Navigate Search Project Fun Window Help

o3 L @ [$-0-Q- @ [ B EG | ®2 |9 B |3 0o G & | seam =
| 4
|81 51 © & o
:' 12 Package Ex Ez'\[ﬁﬂ'ﬂiict&pl “u“m Customers. xhtmi W CustomersList.xhtm| =pn| :
o B® Y| ~ : ] ) 12l 2 w| 2 A @
b layout | X customemame* (¥ {customersHome instance customername) 1 | —
b & METAINF @ 5
b & stylesheat Y g
b (= WEB-INF I phone*
X Customers page.xml Error Messages
% Customers xhtml N
¥ CustomersEditpagexml
i CustomersEditxhtml state”
X| CustomersList page xml Error Messages
fn CustomersList xhtml * fequired feids i
 enployees psgn.on xS o

i Employees xhtml

¥ EmployeesEdit page xml emplyess | orderses | paymentses

i EmployeesEdit xhtml No employees
% EmployeesList page.xmi empioyeenumber emal extension fratname
i EmployeesList xhtml #employees employ ber)  &#{employees.emal) #{employees.extension)  #{employees firstnam
did error.xhtmi |
i) home xhtmi 8
o index html Ie] T DN
| login page. xml 14 o
it Levevin whiten| bt . B ~

1 i | DIl Visual/Source | Visual | Source Preview

| o° witable  Smartinsert | 1:1 | lem a2

Figure 10.17. Entities Web Pages

e And under src folder java classes are created.
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Seam - crudapp/src/action/org/domain/crudapp/entity/CustomersList.java - Eclipse SDK

File Edit Source Refactor Navigate Search Project Run Window Help

= ™ srcfaction
= |8 org.domain.crudapp.entity
P[] CustomersHome java
= ) CustomersListjava

@Name("customersList®)

" "lower{customers

¥ {3 Customerstist "lower{customers
¥ RESTRICTIONS “lower{customers.

o customers “lower{customers.
"lower{customers.

@ getCustomers() *lower{customers

& getEjbql() "lower{customers.

& getMaxResuhs() “lower(customers.

e - “lower({customers.

@ getRestrictions() "lower(customers.

| 3~ (B~ 0- Q- Q- (B HG ™| OB o | Seam
EL AN " S
l : ) oy :
- p “mﬁ [ project Expl = B | [§] CustomersHomejava | [i) CustomersListjava 2!
o Bg " I package org.domain.crudapp.entity;
= 3 crudapp ~|  #import org.jboss.seam.annotations.Name; '

4 public class CustomersList extends EntityQuery {

= private static final String(] RESTRICTIONS = {
.addresslinel) like concat(lower(#{custo
.addressline2) like concat(lower(#{custo

city) like concat(lower(#{customersList
contactfirstname) like concat(lower(#{c
contactlastname) like concat(lower(#{cu

.country) like concat(lower(#{customersL

customername) like concat(lower(#{custo
phone) like concat(lower(#{customersLis
postalcode) like concat(lower(#{custome
5tate) like concat(lower(#{customersLis

b 1) EmployeesHome java
b [} EmployeesListjava private Customers customers = new Customers();
b {0 officesHome java - @override
b [i) OfficesListjava - public String getEjbgl() {
n . return "select customers from Customers customers®;
b [ OrderdetailsHome java )
b [J) orderdetailsList java
b [1] OrdersHome java - @override
b I o a public Integer getMaxResults() {
1) OrdersListjava ] return 25;
b [ paumanteHama isva L= 1
1] ] D | (o1 [ [+)
e org.domain.crudapp.entityCu...stjava - crudappisrc/action | | e BB @ &

(a]

o

n| K e

7

Figure 10.18. Entities Java Classes

« Switch to Hibernate perspective with Window->Open Perspective->Other... . On Hibernate
Configurations view expand the crudapp configuration. Right click on Customers and select

Open Mapping Diagram from the popup menu.

82




f

How to create the CRUD Database Application
with Seam

Hibernate - Eclipse SDK

File Edt MNawigate Search Project Pun Window Help

3 $-0-Q- @ 4|95 % »moo

. -

2 Pbcka:gé =0

B W W T

= [ erudapp
= [&}, Configuration

* € Customers :
i i HQL Editor

i Hibemate Criteria Editor

b @ Employees
b @ offices

b @ Orderdewils B Add Configuration...
b © orders

b @ pPayments

b © productlines

b O Products Refresh

b W Session Factory
b [ Database Open Mapping Diagram
Open Source File
Open Mapping File

X

1| ]
[ Properties 52 =

-+, -
"

Property Value

-

o
o
a

o x

Figure 10.19. Hibernate Configurations View

« Observe that Mapping Diagram is opened in the editor. Here you can see the relations between
models and database tables. Select Customers entity model, right click and select Open Source

File .
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Hibernate - - Eclipse SDK

Ele Edit Navigate Search Project Fun Window Help
e L @[30 | % |4 |9 |8 B s RO Dy |8 o [t Hibemate]
|61- 3iv v o
P = = ~ ! :
% Hibernat 52 . [2 Package = O & =i,
8 W W Y| : - - s  p
— |, © org.domain.crudapp.entity.Customers -> public.customers o Source e
= [6 crudapp ||| 8 customernumber : int St o
= [& Configuration ||| ® addresslinel : javalang String Open Mapping File | custome
v € Customers 8 addressline2 : java.lang String rputMethods b | » [ address
b © Employees ||| ® city : javalangString ) T el address
b O ¥ contactfirstname : java lang.String » b city
Offices ¥ contactlastname : java lang.String + [ contactf
b @ orderdetails || ® country : javalang String # By contactl
b O orders ||| ® creditiimit : javalang Double » b country
b @ Payments || ® customername : java lang String » [ creditin
b @ Productines Ji=iemployess : org domeincradppeniiySmployess 3 T " & custome
||t=) orderses - Set<org.domain.crudapp entityOrderss S 1l salesre
b @ Products B key » B phone |-
b % Session Factory | 1 #alement - » [ postalec
b £ Database |12} paymentses : Set<org domain.crudapp.entityPayments=> & » b state
| ¥ key
(I veelement
] ] I+] || ® phone : javalang String 2
- .|| ® postalcode : javalang String .
&5 Properties ss\__ = E 1 state - javalang String !
¥ = 7
Property  Value  @public.orders 2
H@ orderumber -+ 3 org.doi
'+ By comments B, employ
b 90 customernumber -« ‘lﬂ] customi
‘1 & orderdate B key |-
M4l | I D]
| o |e ¥ u oD

Figure 10.20. Mapping Diagram

 This will open the Customers.java file in the java editor.
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Hibernate - crudapp/src/modeliorg/domain/crudapp/entity/Customers.java - Eclipse SDK

File Edit Source Refactor Navigate Search Project Run Window Help
[res L @ |- 0- Q- @~ |2 |[F] 0 | B o [t vibernate]  »
P b o® oo | g Biv = v o~
%) Hibernat £2 I Package| = O | ® Diagram for org.domain.crudapp.entityCustomers | =8|,
BT @ package org.domain.crudapp.entity; [+]m P
=[5 crudapp // Generated Nowv 21, 2007 3:23:36 PM by Hibernate Tools 3.2.0.CR1 8=
< (&} Configuration
®import java.util.HashSet; |
b @ Employees AL
b @ Offices * Customers generated by hbm2java
. v/
b (C Orderdetails @Entity
b @ orders @Table(name = "customers®, schema = “public”)
b G'Faymen'ls & public class Customers implements java.io.Serializable {
b @ froductiines private int customernumber;
b @ products private Employees employees;
. . private String addresslinel;
i F
b ESessuon achory private String addressline2;
b [T Database private String city;
private String contactfirstname;
private String contactlastname;
private String country;
; = : private Double creditlimit;
[ Properties 52 = private String customername;
- | private String phone;
E: 2 private String postalcode;
private String state;
lPrope:ty Value | private Set<Orders> orderses = new HashSet<Orders>(0);
Name org.domain crudapp.e private Set<Payments> paymentses = new HashSet<Payments=>(0);
public Customers() {
} -
| [«] [+
oo Writable Smartinsert 1:1 | f 95 6 B

Figure 10.21. Entity class from Mapping Diagram

After that you are ready to deploy your application to J2EE application server. This is described
in the next chapter.
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Chapter 11.

The CRUD Application Walkthrough

After you familiarized oneself with example of creating the CRUD Database Application with Seam,
you can read this charter.

11.1. Using CRUD Application

To run your CRUD Application you should do the following steps:

« Start JBoss Application Server if it was not started before.

On JBossServer View right click on the JBoss Application Server and select Start

Seam - fopt/work/workspace_jbds/crudapp/WebContent/login.xhtml - Eclipse Platform
File Edit Mavigate Search Project Bun Window Help

i BrO-Q Q- | BHFG | &S ® | QT2 »n b £ | seam|
12 Pack 2 . - Proje | = B || loginxntmi % =5|
BE® ~ =<!DOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.0 Transitional//EN" 5]
- - "http: /S e w3, org/TR/XhtmLL/DTD/xhtmll-transitional. dtd” >
= 72 crudapp =ui:composition xmins="http: //www.w3.orgs1999/xhtml*
b (® sre/action xmlns: s="http: //jboss. com/products/seam/taglib”
xmlns:ul="http://java.sun.com/)sf/facelets”
P (# srefmodel xmlns: f="http://java.sun,com/jsf/core”

b =\ JRE System Library [jc XMLASIN="NTLP: //java. sun. comjsT/ntm”
#mlns: rich="http: //richfaces.ajax4jsf.org/rich”
I =\ All JBoss Libraries [JBe template="layout/template. xhtml" =
P =4 Web App Libraries Gl [+)
(= build S

- - , —
& resources VisualfSource Visual Source Preview

B crudapp-ds.xmi  [f —

Wer Vi X 4
& src » 0 5
P = WebContent
[ crudapp launch =Y |Boss Application §- Stopped Republish

I
hibernate-censole pre. ' New Server

b & crudapp-test

b [ Modules | ¥ Delete
! Eventlog
[ 1 XML Configuration 5 Debug
. File Filters. t
'ﬂ] Inactive Categories - Publish
il JM¥ Console Clean...

& Twiddle Server
4 Edit Launch Configuration
[t Add and Remove Projects...

Figure 11.1. Start the Server

* Run a project on the Server.

On Package Explorer View right click on the crudapp project, select Run As > Run on Server.
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Seam - /optfwork/workspace_|jbds/crudapp/WebContent/login.xhtm| - Eclipse Flatform
File Edit Source Refactor Navigate Search Project Run Window Help

=i [#-0- Q- | & B EE | &S| @8 |2 8o 0
P - . - s )
o login xntmi 33\ =8
<!DOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.0 Transitional//EN" E|_
"http: /v w3, org/TR/XATMLL/DTD/ xhtmll-transitional. dtd" > H

» (KPS St w3 0 gy 1999/ xh tmlL®
http://jboss, com/products/seam/taglib”
F“http://java. sun.com/)sf/Tacelets”

b & srcfa Go Into

b (2 srepm ) http://java. sun,com/jsf/core®
b m\JRE S Open in Hew Window http://java. sun.com/jsT/hEml”
Open Type Hierarchy F4 h="http://richfaces.ajax4jsf.org/rich”
b m Al B e Shiftealswy » | L2YOUt/template xhtal®> 5
b =\ Web | il 1]
(& build| {2 Copy Ctri+C "
= (= resoL ¥y Q d Narr e
[ en @ Paste culy
x| ¥ m eSO
o sre | % Detete Delete | # 0 £ .
D 4> WebC  Build Path » || Steus
hiber  Refactor SRift+AR+T »

b & crudape ;. Import...
w5 Expart...

un XDoclet Shift+Corl+F1
<" Refresh F5
Close Project
Assign Working Sets...

Debug As »| B 2 Java Applet ShiftARREX A |
Profile As » [11 3 Java Application Shift+Alt+X |
Validate i 4 TestNG Test Shift+Alt+X N

| Run on Server Shift+Alt+X R

(= |
3
[a]

Figure 11.2. Run Project on Server

Select a Server and click Finish
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r Run On Server »

Define a New Server
Choose the type of server to create
How do you want to select the server?

@ Choosa an existing server

) Manually define a new server

Select the server that You want to use:

type filter text

= = localhost

;'_;'f- JBoss Application Server 4.2

JBoss Application Server 4.2

[ Always use this server when running this project

@ < B; | mext> || mnisn || cance |

Figure 11.3. Select a Server

Home page of the crudapp project should appear in Web Browser.
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Seam - http://localhost:B080/crudapp/ - Eclipse SDK
file Edit Navigate Search Project Fun Window Help

| r3- [$- 0~ Q- @ (B # G- &+ |9 | B & | seam =

P b O B N - - =1 -

| RN LG - - =] =
a B~ .S [hnp Jfocalhost-8080/crudapp/ome seam [L] > B #
crodapp:  Home Productinesiist Emplovesslist Officeslist Customerslist Paymentslist Progustsiif
b ™ srcfaction -
P i® srcimodel Welcome! o
b A JRE System Library [jdk
b =\ All JBoss Libraries [jBo This empty shed application includes:
ibrari « Ant buld seript
bom wgb App Ubranes : T Boe s
& build « Integration lesting using TestNG and JBoss Embeddable EJBY
. o EJB 3.0 Seam components
= = resources » Templaled Facelets views
3 <t R e e
£ sre o Internationalzation Support
P 5= WebContent
L crudapp launch
[ hibernate-console prog Prosrered by Seam Generatod by seamgen
b & crudapp-test
« | D
|2 problems | &) Tasks ' Seam Components ¥ JBoss Server View 2 . [ Console =D
* 0 y L] &
Server State Status

= |Boss 4.2 Server ¥ Started Synchronized

< () Modules
_i ferudappiresources/crudapp-ds xml
s crudapp

P i EventLog

(] 1 D]

-

Figure 11.4. Home page
After that you can use CRUD application with "employee" database.

You can use internal JBDS Web Browser or your external Web Browser with the same link (http:/
/localhost:8080/crudapp/home.seam).

Click on the Employees List link and observe that data from employee database is displayed.
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http://localhost:8080/crudapp/home.seam

Using CRUD Application

crudapp - Mozilla Firefox

File Edit View History Bookmarks Tools Help

@ - - @ 0 3 L nupanocalhost:8080/crudapp/EmplayeesList.seam -[»] [G-

crudapp: Home ProductlinesList Employeeslist Officeslist Customerslist PaymentsList Productslist OrderdetailsList Orders List Lu!nz

(4]

Employees search parameters «
emall
extension
firstname
Jobtitie
lastname
officecode
Employees search results
emoioveenumber omad gignsicn | fisiname it bstname | officecods | reporisio | action
1002 dmurphy Bk s Smoseic ars. Lom *5800 Diane Presigent Maxrphy 1 Salect
1056 mpatierso@ciassicmodelcars.com x4611 Mary VP Sales. Patterson 1 1002 Select
1076 frreb@chssicmodeicars com 9273 Jetw VP Marketing Firreli 1 1002 Select
1088 ‘wpatterson@classicmodelcars com x4871 Wilkam Sales Manager (APAC), Patierson 6 1056 Select
1102 ghendur@clssicmodelcars.com %5408 Gerard Sale Manager (EMEA); Bondur 4 1056 Satoct
& 1143 abow@cla delcars.com x5428 Anthony  Sales Manager (NA): Bow 1 1056 Select ]
G Find: | | @next @ prev [ Match case
' Done

Figure 11.5. Employees List
Use Employees search parameters fields to filter the selected list.

Press Select opposite one of employees.
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! crudapp - Mozilla Firefox -'ax

Eile Edit View History Bookmarks Tools Help %)
¢ -~ i - @ K ﬁ: | L] http:/fecalhost:8080/crudapp/Employees.seam?employeesEmployeenumber | = D-] Qv| b |
crudapp: Home Productlineslist Emploveeslist Officeslist Customerslist Paymentslist Productslist Orderdetallslist Orders List Login [4]
Employees
employeenumber 1166
emall Ehompsonciassicmodeicars com
extension x4065
firstname Lesie
Jobtitie Sales Rep
lastname Thompson
officecode 1
reportsto 1143
| £ait il Done |
cuslomenses
cusfomernumber  addressinel 2 ity ame  country ithmit phone  postalcode stale action
3675 Furth West Coast
478 o Burbank | Steve Thompson usa 5800 o co. 3105553722 94019  CA | Select
218 ‘“c v v, Glendale | Mary Young USA | 110000 Boards &Toys Co. | 3105852373 92961 CA | Select
208 :’::’Dr Pasadena Juse Young USA 007000 ToysdGrownlps.com 6265557265 90003 | CA  Seiect
361 Furth San Coliectabie Mo
29 o o Valacie Thomgson usa 1050000 GO 7605558146 91217 CA | Select
12 g‘”""""" Lo Jean Kig USA | 718000  Signal G Sives 7025551838 83030 NV | Selec
6047 Los Men R US Retalers, H
u7 0 A, Bean Chandier usa | s7rooo 2155554369 91003 | CA  Seiect
| Add customers | o
[4] D
| Done

Figure 11.6. Employee details
Press Edit to edit employee fields.

Enter Login and Password to login. (Use "crudapp-user"/"secret" for example)
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] crudapp - Mozilla Firefox - 0%
Eile Edit View History Bookmarks Tools Help 8
@~ - ¢ o @ 0 nupnocanost:s08oici [+ | B [IC-] =y

crudapp: Home Productlines List Emplovees List OfficesList CustomersList Paymen

« Pieasa log in first

Legin

Figage login using any username and password

Username Crudapp-user
Password s
Remember me F
P owwered by :}m Goneraled by Learm-gen
A I I+
Done

Figure 11.7. Login page
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¥ crudapp - Mozilla Firefox

Eile Edit View History Bookmarks Tools Help

@ - @ &I fh} |1 http:iocalhost:8080/crudapp/EmployeesEdit.seam?employeesEmployeen: | = | | Q'

« Walcome, crudapp-usar
[Edit Employees

emplayeenumber " 1166

W:MWMMMWMMMWT

Ithampson@classicmodelcars.com
4065
Ledlie
Sales Rep
Themgsen
1
1143
customernumber  addressinel city counry credifimi  customername phone | postalcode state acton
6047 Los Men R US Retalers, =
M7 b A A " Brian Chandier usa STT00.0 Lid. 2155554369 91003 CA  Saiact
205 mbr Pasadena Julie Young USA  90TO00 Toys4GrownUps.com 6265557265 | 90003 CA | Select
361 Furth San Colectable Mird
Fz] Circk o Valadie Thompson uUsA 1050000 o Co. Te05558148 91217 CA | Select
4087
219 Dougk Glendale i usa 110000  Boards & Toys Co. 105552373 92561 Ch —
Av. Mary oung oys Select ]
(] I Dl

Figure 11.8. Edit Employee
Fill in firstname and press Update.

Database will be updated.
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Chapter 12.

Using TestNG project
With the help this chapter you will get to know with TestNG.

12.1. What is TestNG?

TestNG ("Testing, the Next Generation") is a Java unit testing framework that aims to overcome
many limitations of JUnit. TestNG introduces some new functionalities that make it more powerful
and easier to use, such as:

« JDK 5 Annotations (JDK 1.4 is also supported with JavaDoc annotations)
» Flexible test configuration

» Support for data-driven testing (with @DataProvider)

* Support for parameters

« Allows distribution of tests on slave machines

» Powerful execution model (no more TestSuite)

» Supported by a variety of tools and plug-ins (Eclipse, IDEA, Maven, etc...)
« Embeds BeanShell for further flexibility

 Default JDK functions for runtime and logging (no dependencies)

» Dependent methods for application server testing

More information can be found on home page: www.testng.org [http://testng.org]

12.2. Other relevant resources on the topic

Next-Generation Testing with TestNG (An Interview with Cedric Beust) [http://www.artima.com/
lejava/articles/testng.html]

TestNG: The next generation of unit testing [http://www.javaworld.com/javaworld/jw-04-2005/jw-
0404-testng.html]

Test Categorization Techniques with TestNG [http://dev2dev.bea.com/pub/a/2006/09/testng-
categorization.html]

TestNG makes Java unit testing a breeze [http://www-128.ibm.com/developerworks/java/library/
j-testng/]
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Chapter 12. Using TestNG project

In pursuit of code quality: JUnit 4 vs. TestNG [http://www-128.ibm.com/developerworks/java/
library/j-cq08296/index.html]

12.3. How to use the generated Seam-test project to run
Seam tests?

» Create a new Seam Web Project with EAR deployment using the New Seam Project wizard.

« After a project is created you will have the generated Seam-test project that is setup to run
TestNG directly against the proper libraries and server runtime libraries.

li Package Explorer Z3

&

b 3= seamProject

b & seamProject-ear
b & seamProject-ejb
b (8 test-src

b 0™ embedded-ejb

b+ =l JRE System Library [jdk1.5.0_12]
P A Referenced Libraries

= lib

Figure 12.1. Seam-test Project

» Add Seam Action to your project via File > New > Seam Action.
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How to use the generated Seam-test project to

run Seam tests?

- 1 seamProject
P E®osre
I+ =i JRE System Librar
I+ = ANl JBoss Libraries
I+ = EAR Libraries
I+ = Web App Libraries

(= build

= WebContent

b B seamProject-ear

b & seamProject-gjb

b 1= seamProject-test

Cpen in New Window
Open Type Hierarchy

Shaw In

5 Copy

5 Paste
¥ Delete

Build Path
Source
Reractor

a3 Import...
L3 Export...

27 Refresh
Close Project

Assign Working Sets...

Figure 12.2. Seam Action Creation

i Package
F4 & Class
Shift+AILEW  * F Interface
&% Source Folder
Cri+C
% Folder
. [ Fle
i FAY)
Delete
- Seam Form
¥ Seam Entity
Shift+Alt+5 * - Seam Conversation
Shift4+Alt+T * - Seam Generate Entities

I Example...

% Other.

FS

« Fill out the wizard fields. New Seam Action wizard will create resources and place them in the
appropriate folders dependent on EAR project structure.
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£ New Seam Action ]

Seam Action —
Create a new Seam action ,_g!-,'_':,
Seam Project: [seaumject ] [Bmwse]
Seam component name: |Action |
Local interface: [Aj:ljnnLocaI ]
BEean name: [Actiunaean ]
Method name: [acuonmemud ]
Page name: [acti-unPage ]
Package name: [nrg_domain.seamﬁn]ect.sesslan ] Browse
[icd] || Einish | [ Cancel I

Figure 12.3. New Seam Action Wizard

* When Action is created you will see actionPage.xhtml in Package Explorer view.
ActionBean.java will be automatically opened in Java Editor.

Bl =8 Actoraeanjova 55 =5

BE < || package org.domain.seamProject.session;

=

- $ seamProject | ®import javax.ejb.Stateless;[|
b @sre B5tateless
P B4 JRE System Library [jdk1.5.0_12] @Name(~“Action”)
b =k All JBoss Libraries [JBoss 4.2 Runtime public class ActionBean implements Actionlocal {
P B4 EAR Libraries = @lLogger private Log log;
b B\ Web App Libraries
@In FacesMessages TacesMessages;
= build
- = WebContent - public veid actionMethod()
{
B =img

|4 Jfimplement your business legic here =
b 5= layout log.info{"Action.actionMethod() action called”);
TacesMessages.add|~actionMethod” );

I = META-INF }
B = stylesheet
P 4= WEB-INF

i actionPage xhtmi 1

J/fadd additionmal action methods

or error.xhtmi
i home xhtml
o index htmi

X login.page xmi

(]

] IR v a ; D

Figure 12.4. Created Action
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How to use the generated Seam-test project to

run Seam tests?

» Select ActionLocalTest.xml in Seam-test project and run the test with right click Run As >
TestNG Suite.

P = Dn-.

I -

b 3= seamProject
b & seamProject-ear
b & seamProject-ejb
= 12 seamProject-test
= [ pest-src
w i org.domain seamProject test
b [J] ActionLocalTest java

ﬁ ActionLocalTest xmil
MNew ¥

b = META-INF
= components properties  2PeN F3
b 8 embedded-ejb Opan Wih '
Show In Shift+Alt+W
b mA JRE System Library [jdk15 = '
I* B4 Referenced Libraries [ Copy Ctri+C
= lib f f
[ Paste Ctri+V
¥ Delete Delete
Build Path b
Refactor Shift+AIL+T
23 Import
5 Export
«* Refresh F5

Assign Warking Sets._

Validate
=y Deploy To Server

BT S .5 1 o on Server  Snrtiatix R

Debug As A i 2 TestNG Test Shift+AlL+X G
Profile As ¥

3 open Run Dialog..,
Team b

Figure 12.5. Running TestNG

The test process will start and its output will be written in Console View.
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Chapter 12. Using TestNG project

sole & =0

<terminateds test-src.org.doemain seamProject test ActionLocalTest.xmi [TestNG] jusrjavaljak: ' .':ﬁ = - i
01:14:42,614 INFO [Lifecycle] starting up: org.]jboss.seam.ul.graphicImage.dynamicImageResource E
©1:14:42,615 INFO [Lifecycle] starting up: org.jboss.seam.debug. hotDeployFilter
01:14:42,616 INFO [Lifecycle] starting up: org.)boss.seam. servlet.multipartFilter
01:14:42,617 INFO [Lifecycle] starting up: org. jboss.seam.ui, resource, webResource
01:14:42,618 INFO [Lifecycle] starting up: org. jbess. seam. serviet. redirectFilter
01:14:42,620 INFO [Initialization] done initializing Seam
01:14:43,032 INFO [ActionBean) Action. actionMethod() actien called
01:14:43,058 INFO [Ejb] stopping the embedded EJB container
PASSED: test

ActionlLocal Test

Tests run: 1, Failures: ©, Skips: ©
Actionlocal Tests
Total tests run: 1, Failures: O, Skips: © B
] [v)

Figure 12.6. Test is Finished

« After running TestNG you will have the test results in test-output folder in Seam-test project
(press F5 to refresh the Package Explorer view). Open index.html file with Web Browser or
simply use the TestNG view.

The below view shows a successful run of the test.

&1 Tasks | - Seam Components |2 |Boss Server \ﬂew Console e, @ T =0
[ Tests: 171 Methods: 1/1(15317ms) | T Passed 1 B Failed: 0 B8 Skipped: 0
it All Tests | g Failed Tests = Failure Exception g

+ ™ ActicnLocal Tests { 1/0/0/0 )

V7 gl ActionLocal Test { 1/0/0/0 )

g org domain seamProject test ActionLocalTest test

Figure 12.7. Viewing the Test Results

You can see the test results in Web Browser.
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How to use the generated Seam-test project to
run Seam tests?

a3, Test results - Mozilla Firefox = | I | P

Eile Edit View Go Bookmarks Tools Help

<:-_=| - l—> - @ ::5) @ ||_i file: Woptiworkiworkspace/seamProject-testitest-outputindex. html ][ﬂ DO Go

Test results

. Suite ‘ Passed ‘ Failed Skipped | testng.xml
.t 000
| AdioloealTess 1 0 0 | Lk

Done

Figure 12.8. Test Results in Browser

After clicking on ActionLocal Tests link you will see the Results for ActionLocal Tests.

3 Results for ActionLocal Tests - Mozilla Firefox

Edit View Go Bookmarks Tools Help

Eile
LR
G- - & ) &) (L e moptworkiworkspace/seamPraject testiest-outputiActionlocal%20Tests/in ||| © Go

Select aresull on the lefi-hand pane.

Results for
ActionLocal Tests

1 test || class 1 method:
chronological
alphabetical

| not run (0}

0 reporter

~ —— |tesmg.xm]

ou output |

o -
=]
=
o

Figure 12.9. Test Information

Select a result on the left-hand pane and its details will be displayed on the right-hand one.
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Chapter 12. Using TestNG project

)

Resulis for

ActionlLocal Tests

Iiest || class | method:
chronalogical
u.|E|mhelu.':|'|
mok rum {0F

A feporier .

tesing xml

Done

Results for ActlonLocal Tests - Mozilla Firefox

B¢ Ear Miew Go Bockmarks Jools Help

4@ - o - & ) B | memepuworkaworkspace/seamPraject-testiest-outputictontecal®20Testsin | *| @ Go |G

Actionl.ocal Test

Tests passediFailedSkipped: 1/0/0

Starved on: Wed Aug 2901:14:31 MSD 2007
.Tnl.'ll time: .I I seconds (114%]1 ms)

Ine luded groups:

Excleded groups:

{ Hover e met fod mame o see the fest oloss nooe |

Figure 12.10. ActionLocal Test Details

Thus with Seam tooling you can easily take advantage of TestNG framework. As you can see, it
generates its own TestNG project as a separate module within which you can easily monitor the

tests execution and their output.

In conclusion, the main goal of this document is to get you know with a full featureset that JBoss
Tools provides to support Seam development. Thus if you have some questions, comments or
suggestions on the topic, please fell free to ask in the JBoss Tools Forum [http://www.jboss.com/
index.html?module=bb&op=viewforum&f=201]. You can also influence on how you want to
see JBoss Tools docs in future leaving your vote on our page here [http://wiki.jboss.org/wiki/

JBossToolsDocsFuture].

A set of movies on Seam tooling is available here [http://docs.jboss.org/tools/movies].

102



http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
http://wiki.jboss.org/wiki/JBossToolsDocsFuture
http://wiki.jboss.org/wiki/JBossToolsDocsFuture
http://wiki.jboss.org/wiki/JBossToolsDocsFuture
http://docs.jboss.org/tools/movies
http://docs.jboss.org/tools/movies

	Seam Dev Tools Reference Guide
	Table of Contents
	Chapter 1. Introduction
	1.1. What is Seam?
	1.2. Installation into Eclipse
	1.3. Other relevant resources on the topic

	Chapter 2. Creating a New Seam Project via the New Seam Project wizard
	2.1. Create standalone Seam Web Project
	2.2. Select the Project Facets
	2.3. How to Configure Web Module Settings
	2.4. Adding JSF Capabilities
	2.5. Configure Seam Facet Settings

	Chapter 3. Directory Structure of the Generated Project
	3.1. WAR Deployment
	3.2. EAR Deployment
	3.3. Renaming the Projects and Folders

	Chapter 4. Seam Menus and Actions
	4.1. File Menu Actions
	4.2. Navigate Menu Actions
	4.2.1. Find Seam References/Declarations
	4.2.2. Open Seam Component


	Chapter 5. Seam Wizards
	5.1. New Seam Action
	5.2. New Seam Form
	5.3. New Seam Conversation
	5.4. New Seam Entity

	Chapter 6. Seam Generate Entities
	Chapter 7. Seam Editors Features
	7.1. Content Assist
	7.2. OpenOn
	7.3. Seam Validation
	7.4. Structured components.xml Editor

	Chapter 8. Seam Views
	8.1. Seam Components View
	8.2. Project Explorer integration

	Chapter 9. Seam Preferences
	9.1. General Preferences
	9.1.1. Validator Preferences

	9.2. Project Preferences

	Chapter 10. Generate a CRUD Database Application
	10.1. What is CRUD?
	10.2. How to create the CRUD Database Application with Seam

	Chapter 11. The CRUD Application Walkthrough
	11.1. Using CRUD Application

	Chapter 12. Using TestNG project
	12.1. What is TestNG?
	12.2. Other relevant resources on the topic
	12.3. How to use the generated Seam-test project to run Seam tests?


