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Chapter 1.

Introduction

1.1. What is Seam?

This introduction will help you to understand what is Seam.

Seam is a fully featured application framework on top of Java EE 5. It is also one of the most
popular enterprise Java framework today. Seam deeply integrates many other standard-based
or open source frameworks (e.g., JSF, EJB3, JMS, Web Services, jBPM, JBoss Rules, Ajax4jsf,
RichFaces, Facelets, Spring, iText, Quartz, TestNG, etc.), and provides a single programming
model for developers to "drive" those underlying frameworks via simple annotated POJOs (Plain
Old Java Objects). It makes life easier for developers to tackle complex enterprise applications
with many component frameworks.

1.2. Installation into Eclipse

Here, we are going to explain how to install Seam plugin into Eclipse.

Seam is a one module of JBoss Tools project. Since Seam has a dependence on other
JBoss Tools modules we recommend you to install a bundle of all JBoss Tools plug-ins [http://
labs.jboss.com/tools/download/index.html]. Installation instruction you can find on JBoss Wiki in
InstallingJBossTools [http:/labs.jboss.com/wiki/InstallingJBossTools] section.

1.3. Other relevant resources on the topic

The Seam Framework [http://seamframework.org/] - Next generation enterprise Java
development.

All latest release versions of JBoss Developer Studio/JBoss Tools documentation you can find
here [http://docs.jboss.org/tools/2.1.0.GA/].

The latest documentation builds are available here [http://download.jboss.org/jbosstools/nightly-
docs/].
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Chapter 2.

Creating a New Seam Project via the
New Seam Project wizard

In this chapter we provide you with the necessary steps to start working with Seam Framework.

At first, we suggest setting the specific Seam perspective that combines a humber of different
views and editors needed for work with resources concerned. For that select Window > Open
Perspective > Other > Seam or you can also access it through the button in the right top corner.

Seam - Eclipse Platform
File Edit Source Refactor MNavigate Search Project Run Window Help

ro- H- O Q- | EHE @ s @982 bR ([ seam)
4 Pack 3'3 :’_‘;Proje' =7 = B || # jBoss To 53 =5

2 & 7 X b <
.................... |- |Boss Ajaxdjsf

|= |Boss RichFaces

L=+ |Boss Seam

L= JSF HTML
o= Outline &2 =0
An outline is not
available.
0 [ D
[ Properties =8
= e e
- o
Property | Value [£! Problems 2 ¥ Tasks ' Seam Components 73 |Boss Server View T =0

0 errors, 0 wamings. 0 infos

Description Resource Path Location

Figure 2.1. Seam Perspective

2.1. Create standalone Seam Web Project

The best way to get started with Seam is to organise a simple Seam Project and experiment with
it by creating variations.

Thus, you should select File > New > Seam Web Project to run the New Seam Project wizard.
The wizard form allows you to create runtime and server instances in order to get started creating,
running, and debugging J2EE (only) applications.
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Seam Web Project wizard has an option for selecting the actual Server (not just WTP runtime)
that will be used for the project. This allows the wizard to identify correctly where the required
datasource and driver libraries need to go.

Let's get through the wizard step-by-step. First, you should enter a name and a location directory
for your new project.

Mew Seam Project

e

Seam Web Project -

l"l\_:l._:"""-

(Y

@ Target Runtime cannet be empty \

Project name: |seamproject |

Pl‘ﬂlett contents:

& Use default

Target Runtime

¥

[ <None= [Ngw

Dynamic Web Module version

L8]

25

Target Server

[New...-

<)

| <Neone=

Configuration
| Dynamic web Project with Seam 1.2 2 | | Modify...

Configures a Dynamic Web application to use Seam v1.2

(2] | cancel

Figure 2.2. New Seam Project Wizard

Clicking on New... button in the Target Runtime section will bring you to another dialog. Here,
you can specify a new installed Runtime environment or the other type of runtime appropriate
for configuring your project. Let's create a JBoss 4.2 Runtime. For that after choosing it click on
Next button.




Create standalone Seam Web Project

£ New Server Runtime x
MNew Server Runtime
Define a new installed server nuntime environment E
Runtimes are used at build time to compile projects.
C ticnal

Select the puntime type:
|type filter text

[+]

‘ P (= |Boss
7 = |Boss, a division of Red Hat
“J |Boss 3.2 Runtime

74 |Boss 4.0 Runtime

i |Boss 4.2 Runtime

‘3 |Boss Deploy-only

(4]

|Boss Application Server 4.2

[] also create new local server

Figure 2.3. Specifying Target Runtime

All what you need here is to name runtime, type the path to its install directory or locate it by using
Browse button, select a Java Runtime Environment, and select which configuration you want.
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£ Mew Server Runtime *®
]
[ ]
|Boss Runtime Wizard - BU 5 5
ogp 4.2

A |Boss Server runtime references a |Boss installation directory.
It can be used to set up classpaths for projects which depend on this runtime,
as well as by a "server” which will be able to start and stop instances of

JBoss.
Marme

|JBoss 4.2 Runtime 1 |

Home Directory

[.fupmmrh']buss -4 2 0.GA I Browse...

JRE
|jdk15.0_12 2|
Cenfiguration
[ minimal

@ ) I Einish || Cancel f

Figure 2.4. Specifying Target Runtime Configurations

Clicking on Finish returns you to the previous dialog. The next step is to define an installed server
that you can do by clicking on New... button in the Target Server section. In appeared Server

Dialog it's possible to select a server version.

If the chosen server has already got an installed runtime, there appears a combo box with all
declared runtimes under the servers view. Here, you can indicate a server runtime that you need.
Use Installed Runtimes... button to see or edit which runtimes are installed. If there is no any
declared runtime for chosen server, click on Next to specify it on the next preferences page.




Create standalone Seam Web Project

£ New Server
Define a New Server

Choose the type of server to create

Server's host name: |localhost

Select the server type:

(type filter text

L == L]

I = JBoss

= [ |Boss. a division of Red Hat
J |Boss AS 3.2
73 |Boss AS 4.0

2 |Boss AS 4.2

#d |Boss System Copy Server
P = Macromedia

B e ke Fhm.

|Boss Application Server 4.2

[¢]

(4]

Server puntime: | |[Boss 4.2 Runtime

- l llnstalleu Runtimes.

® - | tex> ||

Einish |[ Cancel ]

Figure 2.5. Specifying Target Server

Next dialog allows you to verify the information for chosen server, set login credentials to authorize
an access to the server and specify a directory for deploying. Leave everything as it is and click

on Next.
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¢ New Server X
L .9
Create a new |Boss Server :
* JBoss
&9 4.2

A |Boss Server manages starting and stopping instances of |Boss.
It manages command line arguments and keeps track of which modules have been deployed.

MName

|JBoss 4.2 Server

Runtime Information

If the runtime information below is incomrect, please press back., Installed Runtimes. ...
and then Add to create a new runtime froam a different location.

Home Directory foptiworkijboss-4.2.0.GA

JRE fusrfjavafjdkl 5.0_12 (jdkl.5.0_12)
Configuration  default

Login Credentials

JMX Console Access

User Name [ ]

Password [ ]

Deployment

Deploy Directory I.I'DPWDI'H]DDSS-J-.E.D.GNEQWErfﬂefauWﬁEplﬁy| |BI‘I3W5E... |

@ I = Back ][E--H-E-Ii;'-“’ I Einish ] [ Cancel l

Figure 2.6. Specifying Server Configurations

On the last wizard step you can modify your project to configure it on server.




Create standalone Seam Web Project

Add and Remove Projects

Madify the projects that are configured on the server

Move projects to the right to configure them on the server

Available projects: Configured projects:

B |SFKickStart

Add > |

Add Al == ]

@ < Back fext = | Einish ” Cancel

Figure 2.7. Project Modification for Configuring on the Server

Once you have the Target Server defined click on Finish button to return to the first page of the
New Seam Project wizard.

Tip:
@

We suggest that you look through our AS manager guide [../../as/html_single/
index.html] to find out more about runtimes and servers.
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Mew Seam Project

Seam Web Project \1{\;__‘}'
Create standalone Seam Web Project T\:)

Project name: |5eampm|ect

Project contents:

& Use default

Target Runtime

| |Boss 4.2 Runtime 2 | [ Ngw...

Dynamic Web Module version

L]

[25

Target Senver
<custom= 3 m'
Default Configuration for |Boss 4.2 Runtime
! Dynamic Web Project with Seam 1.2
Dynamic Web Project with Seam 2.1
JavaServer Faces v1.1 Project
JavaServer Faces v1.2 Project
Minimal Configuration

i) { Mext > ' | cancel

Figure 2.8. Completion of Runtime and Server Configuration

The last section on this wizard step is Configuration. Here, you can select one of the pre-defined
project configurations either associated with Seam 1.2 or with Seam 2.0. Furthermore, you can
create your own configuration by pressing the Modify... button. It will open the dialog which allows
to configure your own set of facets for adding extra functionality to your project.

Pass to the next section to find out more details on this dialog.

2.2. Select the Project Facets

The Project Facets wizard allows you to enable or disable specific facets which define necessary
characteristics for the project. In time you switch to this wizard form, all critical facets are already
checked for the chosen Configuration.
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Select the Project Facets

Notice that this page of the wizard also allows you to set the necessary version for any facet.

rﬂ Project Facets [E]-'
Project Facets
Select the facets that should be enabled for this project. \1‘?
Configurations: | Dynamic Web Project with Seam 1.2 ] ] [ Save As... 1 [ Delete I
Project Facet ersion Details |R.|1t|mas|
B 0 Awis2 Web Services B seam 1.2
& Dynarmic Web Module 235 Enables the project to work with |Bo
ava 5.0
&) ) Requires all of the following facets:
[] b Java Persistence 1.0 N .
[ [ JavaScript Toolkit 1.0 I Dynamic Web Module 2.5 or nes
N [4] Java 5.0
(£ JavaServer Faces 12 || JavaServer Faces 1.2 or newer
[ [ Jpess ESB 4.3

b [ [ JBoss Partlets

b [ ) JBoss Web Services
B Seam
[ [ webDoclet (¥Doclet)

Figure 2.9. Project Facets Selection

Moreover, here you can specify your own preset of selected facets by checking needed ones in
project facets window and clicking on Save button.
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rﬂ Project Facets E]
Project Facets
Select the facets that should be enabled for this project. Q?
Configurations: | <custom= 2 ] [ Save As... I
Project Facet Version Details | Runtimes |
p’ [:I : Axis2 Web Servces I-_| Seam 2.0
& Dynamic Web Module 25 Enables the project to work with |Boss Se
ava 5.0
&) ) Requires all of the following facets:
[] b Java Persistence 1.0 N _
(7 B JavaScript Toolkit 10 & Dynamic web Madule 2.5 ar newer
N [ Java 5.0
| JavaServer Faces 1.2 || JavaServer Faces 1.2 ar newer
O & jBoss EsB 43 £ Save Preset *
¥ 2 Portl
b [Z] |Boss Portlets Fr—
B[] 5 JBoss Web Services
[custnrn Facets Preset
B seam 2.0 Daserpt
escription:
[ &) webDoclet (xDoclet) 1.23 E
oK I [ Cancel ]
|
(<] I [0
(] ] ] l=-]|
(i) I oK l [ Cancel ]I

Figure 2.10. Specifying Custom Facet Preset

To see all available Server runtimes click on Runtimes tab on the left. You can create a new one
using the New button. If more than one runtimes are checked here, the Make Primary button
won't be dimmed yet. So you can make use of it to mark primary runtime.
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How to Configure Web Module Settings

Project Facets

Project Facets
Select the facets that should be enabled for this project. \\\?
Configurations: | Dynamic Web Project with Seam 1.2 2 ] [ Save As... | Delete |
Project Facet \ersion Dataitg|§ﬁ._|_r_1_t_i_r1'jlg_§§-|
+ B B Axis2 web Services .IE |3 |Beoss 4.2 Puntime
¥ 52 Dynamic Web Module 25
¥ 1] Java 5.0
[] 4+ Java Persistence 1.0
[ [ Javascript Toolkit 1.0
[Z] JavasServer Faces 1.2
[ [ Jposs EsB 4.3

> OB |Boss Portlets

b [ [ JBoss web Services
[ seam 1.2
[ [ webDaclet (xDoclet) 123

[[] Show all runtimes

(i) oK I | Cancel

Figure 2.11. Runtime Manipulations

Ok button will bring you to the Web Module wizard form again.

2.3. How to Configure Web Module Settings

As we deal with a Dynamic Web Application we should first specify the top level directory of our
application for deploying it to a server afterwards. You know, this kind of application contains both
Web and Java code resources. Thus, it's also important to indicate the content directory as well
as Java source directory. The wizard will put all those values itself. So you can leave everything
asitis.

13
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Mew Seam Project

Web Module

Configure web module settings., E ,.-',

Context Root:

se amproject

Content Directory:

'webContent
Java Source Directory:

IEFC

| Generate deployment descriptor

Figure 2.12. Web Module Settings

Choose Next to switch to the next wizard form.

2.4. Adding JSF Capabilities

This wizard helps you to add JSF capabilities into your project for representing appropriate
behaviours associated with JSF.

Checking Server Supplied JSF Implementation means that you will have a default JSF
implementation given by server.

14



Adding JSF Capabilities

3 Mew Seam Project

|SF Capabilities
Add |SF capabilities to this Web Project

(o]

Il o @ Server Supplied JSF Implementation

O . Mew...

Component Libraries

Deploy Library Mame

JSF Configuration File: | WEB-INF/faces-config xmi |

JSF Serviet Narme: lFaces Serviet |

JSF Serviet Classname: [ja\rax.rac es webapp FacesServiet ]

URL Mapping Patterns: | « cagm

® [ <gack |[ mewts | [ cancer |

Figure 2.13. Adding JSF Capabilities to Web Project

In case when you want to use your custom JSF implementation check a lower radio button. You
are able to create a library of jars by clicking on New button.

Here, it's necessary to type a Library Name, select a Version Supported and add proper Library
jars. Then click on Finish to complete the choice.

15
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r Create |SF Implementation Library x

|SF Library
Create a library of jars that make up a |5F implementation library.

Library Name: Custom)SFimplementation |

Version Supported: (v1_1
Library |ars

i) jsf-api jar - jrooyDesktop/rhds/eclipse/plugins
) jsf-impl jar - froot/Desktop/frhds/eclipse/pluging

(il I Findsh H Cancel I

Figure 2.14. Create JSF Implementation Library

In the Component Libraries section of the wizard you can also add Component Libraries (e.g.
Richfaces [http://www.jboss.org/jbossrichfaces]). Just click on New button. Appeared dialog will
ask you to type the Library name, supported version and add necessary jar's. Press Finish to
complete the choice.

f Create |SF Implementation Library X
|SF Library
Create a library of jars that make up a |5F implementation library.
Library Name: Rich Faces |
Version Supported: UNKNOWN IL.
Library )ars
i_-"'l nichfaces-ul-3.1.2 GA-bin_zip - frootfDesktop : Add...
il
\?_‘ [ Einish | | Cancel

Figure 2.15. Create JSF Implementation Component Library
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Configure Seam Facet Settings

The last wizard options allows to edit a path for JSF Configuration File, a name for JSF Servlet,
JSF Servlet Classname and change URL Mapping Patterns.

£ New Seam Project x

|SF Capabllities
Add |SF capabiliies to this Web Project :

|SF Libraries: ) Server Supplied JSF Implementation

3 | Customn)SFimplementation :] Deplay

Component Libraries

Deploy  Library Mame

Richfaces

Fl ) B

1 W (D))

JSF Configuration File: | WEB-INF/faces-config xmi |

JSF Serviet Name: [Faces Serviet

S

J5F Serviet Classname: [Jauax.r‘ac es webapp FacesSarviet ]

URL Mapping Pattermns:

* faces
Remowve

7 < Back |: MNext = 3 | Cancel I

Figure 2.16. JSF Capabilities Wizard

Finally, as we are arranging the Seam Web project, the last step we should do is to adjust project
configurations associated with the Seam.

2.5. Configure Seam Facet Settings

The last wizard step is related to Seam facet and allows you to do the following:

17
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r MNew Seam Project x

Seam Facet

Configure Seam Facet Settings "n, —
General

Seam Runtime: | Seam 1.2 AP = F [Aﬂu_..]
Deploy as: @ WAR () EAR

Database

Database Type: [ HSQL . ]
Connection profile: |§Del’aultD-5 ¢| |Edit...] [New_..]

Database Schema Name: |

Database Catalog Name: ]

DB Tables already exists in database: J

Recreate database tables and data on deploy: [

Code Generation

Session Bean Package Mame: éorg.dumain.test.sessinn ]

Entity Bean Package Name: | org.domain test.entity |

Test Package Mame: |org .domain test test ]

o

N Einish H Cancel f

o
[

Figure 2.17. Seam Facet Settings

¢ Create Seam runtime and define Seam home folder.

For that click on Add button in the General section. Notice that in this wizard presented below
you can create a Seam runtime only for that version which was selected in the Project Facets
wizard (version 1.2 in our case).
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¢ MNew Seam Runtime
Seam Runtime

Create a Seam Runtime

Name: lSeam_n.lnu'me |
Version: (1.2 s
Home Folder: |.Fuptmur1qi]b055vseamv1.2.1.GA ] [Eruwse]
@ | mnisn || cancer |

Figure 2.18. Seam Runtime Creation

» Select EAR or WAR deployment by checking a necessary radio button.

» Select a Database Type

19
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¢ New Seam Project x
Seam Facet

Configure Seam Facet Settings

DB2
General

DB2/390
Seam Rurtime | Seam 1.2 AP DB2/400
Deploy as: @ WAR ) EAR Derty

Firebird
Database FrontBase
Database Tpe

Informmix
Connection profile: nrorm

Ingres
Database Schema Name: Interbase
Database Catalog Name: Mckol SOL

MysQL

DB Tables already exists in database:
MySOL (InnoDB)

MySGL (MylSAM)
Code Generation MySQL S

Session Bean Package Mame: !nrg.dumaln.sea My3SQL S (nnoDiE)
Oracle 10g

Entity Bean Package Name: iorg.dnmainEea Oracle 8i
Test Package MName: 1org.dnmaln.5e~a Qracle 9i

Pointhase
PastgreSQL

Recreate database tables and data on deploy:

Progress
SAP DB
SQL Server
Sybase
Sybase 11

Sybase Anywhere ]

=3

Figure 2.19. Seam Runtime Creation

 and then specify a Connection profile appropriate for your database.
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r Mew Seam Project x
Seam Facet

Configure Seam Facet Settings III. —

General

Seam Runtime: | Seam 1.2 AP H F [Aﬂu_..]

Deploy as: @ WAR () EAR

Database

Database Type: [ HSQL . ]

Connection profile: |§Del’aultD-5 ¢| |Edit...] [New_..]

Database Schema Name: |

Database Catalog Name: ]

DB Tables already exists in database: J
Recreate database tables and data on deploy: [

Code Generation

Session Bean Package Mame: éorg.dumain.test.sessinn ]

Entity Bean Package Name: | org.domain test.entity |

Test Package Mame: |org .domain test test ]

@ hy Einish H Cancel f

Figure 2.20. Connection Profile Options

You can edit chosen profile by using Edit button or organise a new one by clicking on New
button and selecting necessary for you type of connection profile.
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¢ New Connection Profile x

Wizard Selection Page p—

Please select the connection profile type:

Ed Derby Embedded Database

? Generic |DBC Connection

Ed HSQLDE Connection Profile
Ed PostgreSQL |DBC Connection
Ed sybase ASA

(i3] | Cancel ;

Figure 2.21. Connection Profile Selecting

On the other dialog you'll be asked to enter its name and description. And then you should select
a proper driver and adjust connection details. Press Next to preview all the adjusted settings and
complete the creation of the new profile.
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r HSQLDE Database
Specify a Driver and Connection Detalis

Select a driver from the drop-down and provide login details for
the connection,

Select a driver from the drop-down:

Hypersanic DB

[[] Save Password

Optional properties:

Database: | SAMPLE |
Database location: [MyDB § [Bmwse.._|
User namea: [ ]
Password: | |
URL:

| Test Connection |

@ | <gack || mext> || ginish

] | Cancel

Figure 2.22. Connection Details

The next block of settings in the Seam Facet wizard are describing a Database and a connection

to it.

In the Code Generation section the wizard have already put the names for your Session Bean,
Entity Bean and Test packages. Of course, you can change them into the others which you like.

23
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Code Generation

Session Bean Package Mame: [org.dnmain.seampmiect.sessinh ]

Entity Bean Package Name: |-Drg.dumaln.seampmiect.enﬁw ]

Test Package Name:

|or|; .domain.seamproject test

C] [ coee |

Figure 2.23. Code Generation Section

Click on Finish to generate a project.
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Directory Structure of the Generated
Project

In this chapter we describe where the Seam wizard puts the generated files for both EAR and
WAR deployments.

The Seam Project wizard generates projects like Eclipse WTP style in order to utilize Eclipse WTP
features and to have a correct classpath. To be more precise it generates one project per artifact.

3.1. WAR Deployment

The project layout for WAR projects is:

¥ Package Explorer 22 . | Project Explorer = O

-

b 12f seamproject-test

Figure 3.1. Project Layout for WAR projects

A WAR project can only use Seam JavaBean and JPA Entity bean components; it cannot use
EJB3 Session beans etc.

WAR projects are generated to enable Seam 1.2.1 war hotdeploy feature. Classes put into src/
action will be deployed to WEB-INF/dev from which Seam 1.2.1 automatically will perform
hotdeploy of new components.

GJ Note:
Because of Eclipse WTP limits the hot deployed classes also existed in WEB-INF/
classes, but since Seam gives WEB-INF/dev precedence it will work.

Furthermore the Seam Project wizard generates a test project that is setup to run TestNG directly
against the proper libraries and server runtime libraries. When the TestNG plugin is installed you
can just run your tests via Run As > TestNG Test.

In order to deploy WAR project on server, right-click on the project and select Run As > Run on
Server. Studio will deploy WAR project into one web application on server to deploy folder.

3.2. EAR Deployment

The project layout for EAR projects is:
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Chapter 3. Directory Structur...

[# Package Explorer &2 . [ Project Explorer = 8

-

b 2 seamproject
b @ seamproject-ear
b & seamproject-ajb

b 2d seamproject-test

Figure 3.2. Project Layout for WAR projects
An EAR project can use the whole range of Seam components, including EJB3 Session beans.

In order to deploy EAR project on server, right-click on the project with -ear postfix and select
Run As > Run on Server. Studio will take care about all modules and deploy EAR project into one
enterprise application on server to deploy folder. EAR application keeps ejb and war modules of
the EAR project.

3.3. Renaming the Projects and Folders

If you need to rename one of the Seam Project artifacts (<project_name>, <project_name>-
test, <project name>-test or <project name>-ejb) or any entire folder like <project name>/
WebContent, <project_name>/ejbModule, <project_name>-test/test-src, or project name in
packages org.domain.<project_name>.session, org.domain.<project _name>.entity, you can do
this by brining the context menu and navigating Refactor > Rename... or just pressing Shift +
Alt + R under the chosen resource.

Use Refactor > Move... (or Shift + Alt + V), if you need to move <project_name>/WebContent
folder, <project_name>/ejbModule folder or <project_name>/test-src folder in the other place
within the Project structure.
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Chapter 4.

Seam Menus and Actions

In this chapter we provide a description of Seam actions that are available from

* Menu bar
* Toolbar

» Context menus in views
4.1. File Menu Actions
In a Seam perspective, by default there are the following actions in File > New submenu

Table 4.1. Seam Actions in the New Submenu

Seam Web Runs New Seam Project wizard for creating a new Seam project

Project

Seam Action Runs New Seam Action wizard for creating a new Seam action

Seam Form Runs New Seam Form wizard for creating a new Seam form

Seam Entity Runs New Seam Entity wizard for creating a new Seam entity

Seam Runs New Seam Conversation wizard for creating a new Seam conversation
Conversation

Seam Generate  Runs Generate Seam Entities wizard

Entities

4.2. Navigate Menu Actions

In the next sections we are going to describe Seam actions which can help you to easily navigate
through the source code.

4.2.1. Find Seam References/Declarations

To find EL expretions both in .java and .xhtml files use Find Seam References/Declarations
actions. For that, in the main menu bar click on Search > Find Seam References or Find Seam
Declarations.

Look at the description of the actions in the table below.

Table 4.2. Find Seam References/Declarations actions

Function Keyboard Shortcut

Ctrl+G
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Name

Function

Find Seam Find all references and declarations to the selected

References element. It's available for EL expressions in both .java
and .xhtml files. Differs from normal Eclipse Find

Find Seam D%@E?BR@@S/Declarations by showing an EL or Seam
references in the Search View.

Keyboard Shortcut

Ctrl+Shift+G

also Ctrl + 1 for .java files

On the screenshot example below you could see that the search results are listed in the Search

view.

Gz loginxhemt B

<ful:define>

</h:panelGrid>

< div=
</ rich:panel=

=iy class="actionButtons® >

</ui;composition=>

value="#{identity. rememberMe}” /=

: <h:commandButton value="Login* actim="#{.‘|.ugin}‘..f=-
=fdive
=/h; form=

(o]

Visual/Source Visual '

Source | Preview

4 Search &

= % seamProject

OO X% BB F

* identity - fopt/work/workspace_jbds/seamProject/WebContent/WEB-INF/lib/jboss-seam jar

Figure 4.1. Find Seam Declaration for "ldentity"

You can also use Ctrl + 1 in .java files to activate the actions:
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Open Seam Component

[+

@Logger Log log;

@In Tdentity identity;

public boolean authenticate()
{

log. info("authenticating #0°, identity.getlUsername());

f/Write your authentication 1op, paname in file (Ctri42 A direct access)
/ireturn true if the authentid]

/fisuccessful, Talse otherwise |Ei Copy to Criteria Editor

ddentity. addRole("admin®}; [t Find Seam declarations for ‘identity”

return true;
} s Find Seam references for ‘identity’

¥

['J
4 Search E;':.’

= 3% seamProject
= 2 WebContent - seamProject
= = layout - seamProjectWeb Content

t leginout xhtmil - seamProject/WebCon

@i menu.xhtml - seamProjectWebContentdayout (5 matches)
2% login.page. xml - seamProjectWebContent (2 matches)

Figure 4.2. Find Seam References for "ldentity"

4.2.2. Open Seam Component

To open Seam Components click on Navigate > Open Seam Component in the main menu bar.
This dialog is also available from toolbar icon or with hot keys combination "Ctrl+Shift+Z ".

ERIO

Figure 4.3. Open Seam Components icon

In the table below read a description about the dialog.

Table 4.3. Open Seam Components Dialog

Name Function Keyboard Shortcut

Open Brings up the Open Seam Component dialog | Ctrl+Shift+Z

Seam Compoteendpen a component in the editor. The Open
Seam Component selection dialog shows all Seam
components existing in the workspace. You can
search the components via their short, imported or full
name.
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Enter a name in the text field and see the results as it shown on screenshot:

Enter seam component name prefix or pattemn (? = any character, * = any string):
|capt I

Matching items:

@' org jboss seam captcha captcha - testSeam-ejb

@) org jboss seam capteha captcha - seamProject

@ org jboss seam captcha captchalmage - testSeam

@) org jboss seam captcha captehalmage - testSeam-ajb

@ org jboss seam captcha captchalmage - seamProject

&) org jboss.seam captcha.captcha - testSeam

[ira) [ OK I[ Cancel I

Figure 4.4. Open Seam Components Dialog




Chapter 5.

Seam Wizards

This chapter introduces you with Seam Components.

All the Seam component generations options known from Seam-gen are available as wizards
(with sensible auto-defaulting) for creating various common Seam components:

e Seam Action

* Seam Form

¢ Seam Entity

» Seam Conversation

Go to File > New and select the component wizard.

mﬁdlt Source Refactor Navigate Search Project Bun Window Help

Mew S{e e % Searn Web Project

Open File,.. % Project...
# Package
& Class
¥ Interface
&7 Source Folder
% Folder
| ¥ File
Mowe .. © Seam Form
Rename... F2 | =2 Seam Entity
Refresh F5 Seam Conversation
Convert Line Delimiters To ¥ | o0 Seam Generate Entities
% Example...
Switch Warkspace ¥ | [ Qther...
f=3 Import...,
3 Export...
Properties Alt+Enter
Exit

Figure 5.1. Seam Component Wizards

The wizards create multiple resources and place it in the appropriate folders depending on your
project structure (WAR or EAR).
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Let's create a WAR project using the New Seam Project wizard.

i Package 3 . [(5Projecte | = B8

-

w %l seam_war

8 srefhot

8 grefrmain

B JRE Systern Library [java-1.5
B JEoss 4.2 Runtime [|Boss 4.2 F

h =~~~

=i Web App Libranes
= build
P = resources
(= 5r¢
b i=wWebContent
[ hibernate-console properties
seam_war.launch
= = seam_war-test
P (@ test-sre
I =i Referenced Libranes
P =4 RE System Library [java-1.5.0
=lb

Figure 5.2. Seam Project WAR Deployment

After the project is created you need deploy it on server.

5.1. New Seam Action

In this and following sections you can see example creating Seam Components.

To create a New Seam Action you should select a necessary project, type a name for Seam
component, POJO class, Method, Page and select a Package using Browse button.
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New Seam Action

Mew Seam Action

Seam Action

Create a new Seam action ey B

Seam Project: [seam_war ] lEmwse...] Settings...

Seam component name: |Action

]

l

POJO class name: [ActinnF'OjD

Method name: [actianMethnd

Page name: [actionpage

Package name: [nrg.domain.seam_‘w‘ar.sessinn ] | Browse...

l
]
|

(il Finish I | Cancel

Figure 5.3. New Seam Action Wizard

You can see the action page in WebContent folder. Click on it to open in JBoss Tools HTML Editor.
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12 Package R - [ Project E} = 0| i) ActionPojo,ava =g
B % - <!DOCTYPE composition PUBLIC *-//W3C//DTD ¥HTML 1.0 Transitional//EN® E|
*http:/fwww.w3.0rg/TR/xhtml1/0TD/xhtml1- transitional.dtd*>
= 2 searm_war = <ul:icomposition xmlns="http://www.w3.org/1999/xhtml®
b = srejhot xmlns:s=*http://jboss.com/products /seam/taglib*
umlns:ui="http://java.sun.com/jsf/facelets”
b # srefmain xmlns:f=*http://java.sun.com/jsf /core* =
; . xmlns:h="http://java.sun.com/jsfhtml”
P BAJRE System Lt_'mry lava-1: umlns:rich="http://richfaces.org/rich®
b miBoss 4.2 Runtime [|Boss 4. xmlns:a="http://richfaces.org/a4;"
b maWeb App Libraries template="layout/template. xhtml ">
& build <ui:define name="body*>
P (= resources
<h:messages globalOnly="true® styleClass="message*/>
& sre
v [=WebContent = <rich:panel=
) <f:facet name="header*>actionPage=/f:facet>
b img
b = layout (<] L B3]
P = META-INF - [ e ”.‘\Jclrrnal |C ][ Mormal | B 5 U (:f: ;Y
B (= stylesheet &%
b = WEB-INF %
= actionPage xhtm
= Erfor Messages
g errorxhtml &
o horme st
o index html
s login page.xml !
ﬂ hgh ered Povered by Seam Generaled by seamgen.
& hibernate-console propertic
[ seam_war.launch - ®

\.ﬁsu‘aUSm.rce| Source | Prauswl

Figure 5.4. Action Page in JBoss Tools HTML Editor.

Action component was hot-deployed. Forms and Conversations will work the same way.
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New Seam Form

p = ==

W [http:.f.ﬂucalhnst:Bﬂaomeam_war!acrinnFage.seam |'J =3 l

seam_war:  Home Login

ac tioniMethod

Powarnd by Seam, Gonoratod by saam-gan

Figure 5.5. Action Component

5.2. New Seam Form

Click on actionMethod in the internal browser and add a form in your project using the New Seam
Form wizard File > New > Seam Form.

Select a necessary project, type a nhame for Seam component, POJO class, Method, Page and
select a Package using Browse button.
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[ MNew Seam Form x
Seam Form F“
Create a new Seam form | ‘_u_:' —
Seam Project: [seam_war ] [Bmwse...]
Seam component name: |Form |
POJO class name: [FarmPD]G ]
Method narme: [Tum’ihlemnd ]
Page name: [furmPag-e ]
Package name: [nrg_uomain.seam_war.sesr.lnn ] Browse...

(il | Enish | [ Cancel I

Figure 5.6. New Seam Form Wizard

The Form Page was created in WebContent folder.

= o 7
[% Package Explor \[bPrqect Explorer, = B || @ seam_war |m FormPOJO java  ar formPage xhim

= % - =!DOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.0 Transitional//EN"

= — “http: //www. w3, org/TR/=html1/DTD/xhtmll- transitional. dtd"=

<uli:composition Xmlns="http://www.w3.org/1999/xhtmL"
=mlns:s="http://jboss.com/products/seam/taglib®
xmlns:ui="http://java. sun.com/jsf/facelets”

P = resources xmlns: f="http://java.sun.com/)sf/core”

xmlns:h="http: //java. sun.com/jsf/html"

b =\ web App Libraries
(= build

= sre
= | | *mlns: rich="http://richfaces.ajax4jst.org/rich*
= = WebContent *mlns: a="https://ajax4]sf.dev. java.net/ajax"
b & img template="layout/template, xhtml™>
B layout Gl . o]

[4]

I = META-INF

- - - - B I U S A
b & stylesheet &
P {= WEB-INF #{projectNamel:  Home Welcome, #{identity.username}  Login  Logout ||
o actionPage xhtmi @
o error.xhtrl = &y Error Messages |

Wi formPage xhtmi fermPage.

o home xhimi

HE Index. htmi Value*

4 login page xmi

o login.xntrmil [ rormmetios |

[ hibernate-consale properties

| searn_warlaunch

% [

=
b 1= seam war-test E
1 i I+ VisuaHSour\:e|vlsua1|Source Preview

Figure 5.7. Form Page in JBoss Tools HTML Editor.

Deploy the form on server. Right click on Form Page, select Run As > Run On Server.
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New Seam Conversation

(o5 E, TR - C

fi=] o [hn:p:mucalhnst:auawseam_warﬁunﬂmge.seam |"| =3 n
seam_war: Home Login
formPage
Value *
| formMethod |

Powsrod by Seamn. Gonoratod by sosm-gon

Figure 5.8. Form Component

Form component was hot-deployed.

5.3. New Seam Conversation

Enter some value in the text field (e.g. valuel) and click on formMethod.
Add a conversation using the New Seam Conversation wizard File > New > Seam Form.

You should select a necessary project, type a name for Seam component, POJO class, Method,
Page and select a Package using Browse button.
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f Create New Conversation x
Seam Conversation :z'
Create a new Seam conversation \\ﬁ-
Seam Project: [seam‘_war l ia‘mwse...]
Seam component name: [talk |
POJO class name: [Talk ]
Method name: [talk: J
Page name: [talk ]
Package name: [nrg_uomain.seam_war.-sesr.lnn ] iﬁmwse...]
@ | Enish | [ Cancel I

Figure 5.9. New Seam Conversation Wizard

Conversation page was created in WebContent folder.

B s~

POOEOAN JOUSS LIUNGiES [JOUSS 52 MUnianmieey
P m4 Web App Libraries
= build
P (& resources
& src
= = WebContent
P =img
I = layout
I (= META-INF
P (= stylesheet
P = WEB-INF
o actionPage xhtrmil
o error.xhtmi
o formPage xhtrmi
o home xhimil
o index_html
41X login.page_xmi
o login.xhtrmi
[ hibernate.console properties
|1 seam_warlaunch
b &) seam_war-test

Ll I D)

|2 Package Explor x:\l[bPrqer_tExplcrer = 0| gz
§ <IDOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.0 Transitional//EN®

“hitp: /ffwew. w3, org/TR/xhtmL1/DTD/xhtml1- transitional. dtd">

<ui:composition Xmlns="http://www.w3.org/1999/xhtmL"
xmlns:s="http://jboss.com/products/seam/taglib”
*mlns:ui="http://java. sun.com/jsf/facelets”
xmlns: f="http://java.sun.com/)st"
=mlns:h="http://java. sun.com/jsf/html"
xmlns: rich="http://richfaces.ajaxdjst.org/rich”
template="layout/template. xhtml* =

=ul:define name="body">

<h:messages globalOnly="true” styleClass="message"/=

E = > B I U s A
#{projectame}:  Home Weicome, #{identity.usemame]  Login  Logout
Error Messages
talk
Value #{tab value)
| Beoin | | £nc |

Visual/Source | Visual | Source| Prevlew|

Figure 5.10. Conversation Page in JBoss Tools HTML Editor.
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New Seam Entity

Right click on Conversation page, select Run As > Run On Server.

@ searn_war =08
= ® < |http:/Mocalhost:8080/seam_warftalk.seam "’I [ H
SeamWar: Home Lagin

talk
Value !

[ sogin [ icremenc [ Ens

Prwsre] bry Soam Genbemied by paam-gon

Figure 5.11. Conversation Component
Conversation component was hot-deployed.

Click on Begin and Increment buttons to check the conversation functionality.

5.4. New Seam Entity

Entities cannot be hot-deployed, so we need to stop the server.
Create an Entity using the New Entity wizard File > New > Seam Entity.

You should select a necessary project, type a hame for Entity class, select a Package using
Browse button, type a name for Master Page and Page.
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I Mew Seam Entity x

Seam Entity
Create a new Entity

Seam Project:

[SEEITI_'IH-EF

Seam entity class name: | Customer

Package name: [nrg.dumain_seam_war_entity
Mastar page name: [cusmmerust
Page name: [custnmerPage

| Ensn || cance |

Figure 5.12. New Seam Entity Wizard

The Master Page and the Entity were created in WebContent folder.

I & resources
12 src
= = WebContent
B = img
b 5= layout
I (= META-INF
B = stylesheet
b = WEB-INF
i actionPage xhtrmil
o customerPage xhtmi
i error.xhtmi
o formPage . xhtmi
i home xhtml
i index html
24 login page xmi
e lagin. xhtmi
o talk xhtml
[ hibernate-console properties
[ seam_warlaunch

L ey

Ll 1 T+

xmlns: s="http: //jboss. com/productss/seam/taglib®
wmlns:ui="http://java. sun. com/jsf/facelets”
xmlns: f="http:s/java. sun.com/jsf/core”
amlns:h="http: //java. sun.com/jsf/html"

x*mlns: rich="http://richfaces.ajax4)sf.org/rich”
. template="layout/template. xhtml" =

[% Package Explorer x;'\ =g =g|
= :‘5 - =!DOCTYPE compesitien PUBLIC *-//fW3C//DTD XHTML 1.6 Transitional//EN" [=]
—— — | *http: //wew. w3 org/TR/xhtml1/DTD/xhtml]l- transitional.dtd" = I
& build el <ui:composition XmLns="hTtp://we. w3.org/1999/xhtmL"

#projectName}:  Home

& R«

Errer Messages

customerl ist
Mo customer exists

#customer.id) #customer name]

[E1N

Welcome, #{identity.username]}  Login  Logout

X [

Visual/Source \ﬂsuall Source Frevlew|

Figure 5.13. Master Page in JBoss Tools HTML Editor.
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The Entity page is:

p - " -
m [i5Projecte | = B §{@ customerPage xhtmil B\ =
BS < <!DOCTYPE composition PUBLIC - //W3C//DTD XHTML 1.0 Transitional//EN® =]
B —_— *http://www.w3.0rg/TR/xhtml1/0T0/xhtml1- transitional.dtd*>
= §2 seam_war | <ul:composition xmlns="http://www.w3.org/1999/xhtml® =
b g sreshot xmlns:s="http://jboss. com/products/seam/taglib*
xmlns:ui="http://java.sun.com/jsf/facelets” L
b @ srefmain xmlns:f="http://java.sun.com/jsf /core*
b ; a1 xmlns:h="http://java.sun.com/jsfhtml*®
B4 JRE System Ul:rrary liava xmlns:rich="http://richfaces.org/rich*
b mi|Boss 4.2 Runtime [|Boss 4. template=*layout/template. xhtml*>
b miweb App Uibraries . .
build <ul:define name=*body*=
(= buil
b @ resources <h:messages glebalonly="true® styleClass="message” /=
iere 2 <h:form id="customerForm*> -
= j=WebContent al i B
b Eimg - =
b g layout v | b ol J B I U |2 5
P2 META-INF x | #projectName):  Home Weicome, #{identity.usemame}!  Login  Logout
b [z stylesheet %
b = WEB-INF = Error Messages |
o actionPage xhtml ' EUsonreReoy
o customerList xhtml Mame *
M customerPage schtml
B errorxhtml Erone
o heme xhtrml
o index html
Powered by Seam. Generated by seam-pen.
s login page xml
o login xhtml =l ®
al o ] 3] Vvisual/Source | Source l Praview

Figure 5.14. Entity Page in JBoss Tools HTML Editor.

Run the Entity page on server. This is what you get:

o

9 seamwar 3

=0

é‘a

[http:.f.ﬂucalhust:EIJBO!seam_warfcustumerﬁage.seam

R |

seam_war: Home

Powensd by Soam. Gonorated by seam-gon.

Login

Figure 5.15. Customer Page
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Let's create two customers c1 and c2. Enter the name in the text field and press the Save button.
Customer should be successfully created. Press Done. Do the same for c2 customer. The result
should be:

oo B & [hl‘tp:.f.ﬂncalhnst:Euaomeam_warfcustomeﬂ_ist.5&3m?cid=1&clr=hue&cunversaljnanpa;

ML >

Creake Customer

Povirgd by Soam. Goreealad by Searm-gn

Login

Figure 5.16. Two Customers Are Created
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Seam Generate Entities

The main purpose of this chapter is to tell you about Seam Generate Entities.

Generate Entities is available directly from within Eclipse using Hibernate Tools plugin for the
standard seam-gen generation.

Generate Entities generates a set of CRUD Seam components and web pages based on existing
tables in a database or on existing entities in your application.

Generate Seam Entities

Generate Seam Entities \\%‘x
- . |
Seam Project: seamproject | Browse...| Settings...
Hibernate Conscle Configuration: | seamproject 5
Generation Mode
@ Reverse engineer from database
() Use existing entities
@ Mext > | [ Einish | cancel

Figure 6.1. Generate Seam Entities Wizard

In the Generate Seam Entities wizard there are two generation modes: Reverse Engineer from
database and Use existing entities.

The Reverse Engineer from database mode can be described in four steps:

1. The wizard gets in database, extracts the tables and their connections

2. On basis of this metainfomation the Entity classes are generated into org.domain.project.entity
package

3. For the entities from step 2 the classes EntityList and EntityHome are generated into
org.domain.project.session package
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4. The xhtml pages are generated.

Checking the Use existing entities mode the wizard executes only 3 and 4 steps. It generates
missing classes and xhtml pages.

Read the Generate a CRUD Database Application chapter in order to see how the Generate Seam
Entities wizard can be used.
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Seam Editors Features

7.1. Content Assist

In this chapter you know what Seam Editors Features are and how to work with them.

Content Assist (ctrl + space) is available when using expression language in:

* JSP
« XHTML
« XML

JAVA

The Seam components are available in content assist.

<rich:toolBar =
xmlns="http:// www. w3.0rg/1999/xhtml*
xmlns:uil="http://java. sun.com/]sf/facelets”
=mlns:h="http://java.sun, com/jsf/html"
xmlns: T="http: //java. sun. com/jsT/core”
xmlns: s="http://jboss.com/products/seam/taglib®
wmlns: rich="http://richfaces. ajaxdjsf. org/rich"=
=rich:toolBarGroups>
<h:outputText value="#{projectName}: =/ /=
<s:link view="/home.xhtml" value="Home" />
</ rich:teolBarGroup=>
<rich:toolBarGroup location="right"=
<h:outputText value="Welcome, #{identity.usermame}" rendered="#{identity.loggedIn}"/=>
. =5:link view="/Llogin.xhtml® value="Login® rendered="#{not ident lty.l Wi
=s:link view="/home.xhtml” action="#{identity.logout}" value=[@ ientityaddRole -
=/ rich:toolBarGroup>
</rich: toolBar> @ identity addRole{argo)
y.authenticate
(@ identity. authenticate()
® identity authenticate({loginC ontesxt)

(@ identity. authenticateMethod

@ igentity.checkEntityPermission

(@ identity.checkEntityPermission{argd, argl)
@ identity.checkPermission

K I @ Iidentity.checkPermission(name, action, arg)
LB} identitv checkRestriction

Figure 7.1. Content Assist

Preferences
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7.2. OpenOn

OpenOn let's you easily navigate through your project without using the Package Explorer or
Project Explorer. After pressing ctrl + left click (or just F3) you will see a corresponding method
or class.

<rich: toolBar -
xmlns="http: /S wew. w3, org/ 1999/ xhtml"
xmlns:ui="http: //java. sun. com/jsT/Tacelets”
xmlns:h="http://java,. sun.com/jsf htmL”
xmlns: f="http://java. sun.com/jsf/core”
¥mlns: s="http:/f/)boss. com/products/seam/taglib”
xmlns: rich="http: f/richfaces.ajaxd4jsf.org/rich”=
<rich: toolBarGroups
<h:outputText value="#{projectName}:" /=
=5:1link view="/home.xhtml®” value="Home" /=
<f rich: toolBarG roups
<rich: toolBarGroup location="right">
toutputText values"Welcome, #{identity.username}” rendered="#{identity.loggedIn}”/=
=5:1link view="/login.xhtml® value="Login® rendered="#{not identity.}"/= -
=5:link view="/home. xhtml® action="#{identity.logout}" wvalue="Logout® rendered="#{ident
<frich:toolBarGroups
<frich:toolBar=

Figure 7.2. OpenOn

7.3. Seam Validation

Validation of various possible problematic definitions is implemented for Seam applications.

If an issue is found it will be showed in the standard Problems View.

[ Package Explorer [;\_-,Pro]ect Explorer % = .% ¥ =8 Wﬁ] DifferentAuthentic ator java =g

import org.jboss.seam.annotations. Logger; |=|m
b orgposs.seam.core import org.jboss.seam.annotations.MHame;
B & org jboss.seam.drools import org. jboss. seam.log. Log;

import org.jboss. seam. security.Identity;
P org jboss.seam.security P rg.] ¥ Vi

P ) seam-demo (sss)

= %% |ava Resources: src

[ @Name(*authenticator®)
. public class Authenticator] m
= ¢ org.domain 555 session

3 @ Authenticator = @In Identity identity;
- (] DifferentAuthenticatorjava : ] : =
b @ DifferentAuthenticator
[ @ org.domain.sss test
I (= META-INF

-?“, Online Help |E;_ Problems 5 @ Tasks?

2 errors. 2 warnings, 0 infos

bR || Description Resource Path
import.sql
pari=q = & Errors (2 iterns)
P [E messages_en properties ) ) i :
£ Duplicate component name: authenticator Authenticaterjava seam-.
I [E seam properties ) ) ) ) _
& Duplicate component name: authenticator DifferentAuthenticator java seam-c

b 2 security.dr

. | b & Warnings (2 items)
I i sss-ds xmi L=/|

Figure 7.3. Seam Validation
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Seam Validation

In the preferences page for Seam Validator you can see and modify the validator behavior. Go
to Window > Preferences > JBoss Tools > Web > Seam > Validator and select the severity level
for the optional Seam Validator problem.

[type fiter text ] Validator
b General -] Configure Project Specific
I+ Ant Select the severity level for the following
b Conneciivity optional Seam Validator problems:
) ~ Components
FreeMarker Editor )
b Help Duplicate component name: | Error —
HOL editor Stateful component does not contain @Remove method:
b InstallUpdate Stateful component does not contain @Destroy method: Error e
I+ Internet
Stateful component has wrong scope: Error H
I Java
I+ |Boss jBPM Component class name cannot be resolved to a type:
= |Boss Tools Component class does not contain setter for property: | Error &
I JBoss Servers
J ¢ Entitles
Packaging Archives
Lk ¢ Component life-cycle methods:
- Web
¢ Factories
b Edit
rors » Bijections
[+ |SF
J ¢ Context variables
= Seam
¢ Expression language
Validator
B Struts
Verific ation
b KDoclet
|FA E
I Plug-in Development
I+ Run/Debug
b server
I+ Spring
B SQL Development = ; :
I — Restore Defaults | [ Apply
@ ok || cancel

Figure 7.4. Seam Validator Preferences

On WTP projects validation are enabled by default and thus executed automatically, but on normal
Java projects you will have to go and add the Validation builder to your project . It is available in
the properties of your project under Validation. The validations can be run manually by clicking
Validate via the context menu on your project which will execute all the active WTP validations.
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Chapter 7. Seam Editors Features

7.4. Structured components.xml Editor

When editing components.xml a structured tree editor is available in addition to pure source
editing. It has a graphical view (Tree tab) and source (Source tab).

3 componentsxmi 5

Seam Components 1.2 Editor

* components ~ Seam Components 1.2 Flle

- B2 components xm

3
@

W org jposs seam,

Edit..

&% Factory...
@) orgjbossseam.  Properties... —_— | |
M | class Add...
I+ &) entityManager Framework , |
T semnnetosey e
© persistence unit properties spring N —
% org jboss.seam.core gjb Ramoting , -
b &) securityRules per '
% org jposs seam security identity Core C @
= b org jboss seam notLoggedin Drools C
&l #{redirect captureCurrentView} Security »
b @b org jboss seam postAuthenticate Mail d o
L3 e
& org jboss seam mail mailSession Jas -—
= '

I+

11'ee] Source |

Figure 7.5. component.xml Editor
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[ Project Explorer ES\ B %S <0

= ;= WEB-INF =
P (= classes
b = dev
b &b

= ¥ components xmil

% org jboss seam.core.init
W org jooss seam.core manager
[ & entityManager
[ &) seamEntityManagerfactory
% org jboss seam.core. ejb

[ &) securityRules

'] org. |boss. seam. security.ldentity

[+ ﬁ org jboss seam.notLoggedin
[+ ﬁ org jboss seam postAuthenticate

& org jooss seam.mail. mailsession

B () Fmmnr el caeeld

KDI____II___,__I_.__ E‘E\ - =

1 items selected
|

Advanced Froperty Value
authenticate-methe # {authenticator authenticate}
auto-create Talse
class

installed

jaas-config-name

name

precedence
remember-me true
scope

security-rules #{securityRules}

Figure 7.6. component.xml Editor

49



50



Chapter 8.

Seam Views

8.1. Seam Components View

This chapter introduces you with Seam Components View.

The Seam Components View is available from Seam perspective. It provides a list of seam
components found in a project.

[*. Problemns | & Tasks Wﬁ |Boss S:amrviaw| 4 servers Ll Console =H

= -
B

= G seamproject
b i (default package)
I+ £ orgjboss.seam.core
I # org. jboss.seam.mail
- {# org jboss.seam security
= @ identity (Sessian)
k4 compaonents xml
7| jposs-seam jarforg.jboss seam.secuntyldentity
B 2 seamproject-gb
& seamproject-test

Figure 8.1. Seam Components View

The Seam Components View can show a components default scope in two ways:

« as labels on each component (click on the triangular symbol at the top of the Seam Components
View page and select Scope Presentation > Label)

-E.L Problems ¥ Tasks Wﬂ |Boss Snmr\ﬂuw| 4. servers & Consuln] = |:|I

e s 7|
seam rckage
b 8 (default package) Scope Presentation

b i org.jbess seam core | ONede | 3 Customize View..
I & org.jbess.seam.mail
I £ org.jbess.seam.security
b seamproject-ejb

b @ seamproject-test

[] Link Editor

Figure 8.2. As label
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Chapter 8. Seam Views

 as a node per scope where the components are grouped under a node representing its default
scope.

"

{E.'L Pruhfems[@Tasl:s - Searn Components &2 ©Y |Boss Server view & Eamm] = Cnn:nln] =0

By v

™ B seamproject Seam Packages
b & Application
I G Business Process m 2 Customize View...

b £ Corversation
b Gy Event [] Link Editor
b Method

I+ L Page

b (4 Session

I L3 Stateless

b G Unspecified

Scope Presentation

<]

Figure 8.3. As node

The Seam Packages can be presented in two ways:

* Flat

EL Problems [@ Tasks mﬁ‘ JBoss Server View| Eummé =2 Cansnln] = U.'l

ll"_i]%“'

- By seamproject Seam Packages

b £ (default package) 1 Hierarchical
I+ org.jboss seam core % customize View...
I+ # org.jboss.seam.mail
b & orgjbess.seam security
b 3 seamproject-ejb
B (3 seamproject-test

Scope Presentation

["] Link Editor

Figure 8.4. Flat Presentation of Seam Packages

» Hierarchical
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Seam Components View

(2! Problems | ¥ Tasks WJ |Boss Server View| & Servers [ Console =a|
T

) Flat Seam Packages

b i (default package) Qi Hierarchical Scope Presentation
= i org b Customize View...
— i jboss
> 8 seam . [] Link Editor
b & core
P& mail
P security

B G seamproject-gjb

b (3 seamproject-test

Figure 8.5. Hierarchical Presentation of Seam Packages

The Seam Component View can be filtered by choosing Customize View.

BH ¥=0
Seamn Packages "
Scope Presentation  *

= Custamize View...

[[] Link Editor

Figure 8.6. Customize View

Select the Seam Components from Libraries under the Filters tab. This will make the view ignore
components defined in jars. This will hide the many built-in Seam components and leave only
those that are actually defined in the project or have been actively configured via components.xml.
Therefore, deselecting the filter will show you all available components.

Selecting the Seam Components from Referenced Projects will hide the components that
dependent on other project.
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f Avallable Customizations x

& Filters . % Content
Select the filters to apply (matching iterms will be hidden):

lenter name of filter

Seam Components from Libraries

Seam Components frem Referenced Projects

Figure 8.7. Available Custimozations

8.2. Project Explorer integration

If you don't like to have a view for every piece of information in Eclipse, the content of the
Seam Components view is also available as a node in the built-in Project Explorer (not Package
Explorer!) view in Eclipse.
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Project Explorer integration

s Package Ex EW Nl
S - T
= ¥ seampraoject
I ‘g3 Deployrment Deascriptor: seampraje
= | Seam Components
I Eg Application
P Gf Business Process
I g Comversation
P G Event
I g Method
b Gy Page
I g Session
P GE Stateless
b g Unspecified
b 94 web Resources
b 28 Java Resources: src
b =4 JavaSeript Support
b = build
b (= searnproject
b ¥z seamproject-ear
b & seamproject-ajb
b 2 seamproject-test

(<] | =D

Figure 8.8. Seam Components in Project Explorer
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Chapter 9.

Seam Preferences

In this chapter you get to know how Seam preferences can be modified during the development
process.

9.1. General Preferences

Seam preferences can be set using the Seam preference page. Click on Window > Preferences
> JBoss Tools > Web > Seam.

On this page you can manage the Seam Runtime. Use the appropriate buttons to Add more
runtimes or to Remove those that are not needed.
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Chapter 9. Seam Preferences

Preferences

(T | Seam Gv D v

I+ General =
b Ant Mame viersion Path

Add
H jboss-seam-2.0 2.0 '
I Data Management Edit

Drools Preferences

FreeMarker Editor

I Help

HQL editor
InstalllUpdate
Java
JavaScript
|Boss [BPM
|Boss Tools

4 v = - v

|Boss ESB Runtimes
|Boss Portlet
= Web
P Editors
El variables
b JsF
Label Decoration
e —
walidater
b Struts
verification
JPa
b oXygen
b Plug-in Development

Project Archives =

I [ [ 1)

(i) oK ” Cancel ]

Figure 9.1. Seam Preferences Page

Clicking on Edit button you get the form where you can change the path of Seam runtime home
folder, modify name and version. Press Finish to apply the changes.
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Validator Preferences

Edit Seam Runtime

Edit Seam Runtime E_E
Input new values RN s
P 'u_,_/’j
Home Folder: I.I'Dpt.l'jbOEE-SEEI'I'I-Z.'U.U.GF\ I Browse... |
Marme: jposs-seam-2.0.0.GA
ersign: 1L e
@ | cancel

Figure 9.2. Edit Seam Runtime

9.1.1. Validator Preferences

Seam preference page includes a subsection Validator. See Window > Preferences > JBoss Tools
> Web > Seam > Validator.

On this page you can choose a severity level for the various Seam validator problems. For
example, if you want to ignore the case when component name is duplicated expand the
Components node and select Ignore next to Duplicate component name. After that you won't see
the error.
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r

[type filter text

I+ General
B Ant
I+ Connectivity

4 v v - v

b
4

Validator

FreeMarker Editor
Help
HOL editor
InstallUpdate
Internet
Java
|Boss jBPM
|Boss Tools
I |Boss Servers
Packaging Archives
= Web
I Editors
b JsF
Label Decorations

= Seam

I Struts
Verific ation
B ¥Doclet
|Pa
Plug-in Devealopment

Run/Debug

D]

6]

Preferences x

Valldator

Confi PR
Select the severity level for the following
optional Seam Validator problems:

~ Components

Duplicate component name:

Stateful component does not contaln @Remove method:

Stateful component does not contain @Destroy method:

Stateful component has wrong scope:

Component class name cannot be resolved to a type:
Component class does not contain setter for property:
Entities

Component life-cycle methods:

Factories

Bijections

Context variables

Expression language

Error
Waming
Error 5
| Errar =
Error =

[Fl.esture Qeraulls] [ Apply

[ OK

] | Cancel

Figure 9.3. Seam Validator Preference Page

In the upper right corner of the page there is a Configure Project Specific link. Clicking on it you
get the form where you can choose a project for specific setting. Project specific configuration
allows you to have different validator settings for each project. Check the Show only projects with
project specific settings if you want to see the projects that have been already set. Click on Ok.

60




Validator Preferences

Project Specific Configuration

Select the project to configure:

= seamproject

= seamproject-ejb
= seamproject-test

[] Show only projects with project specific settings

@ Lok ][ concel |

Figure 9.4. Project Specific Configuration

You get the validator properties page for chosen project. Check the Enable project specific settings
to be able to change the settings.
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f

[L‘ype filter text ] B

Seam Validator

Properties for seamProject (Filtered)

Seam Valldator

Enable project specific settings

Select the severity level for the following
optional Seam Validator problems:

~ Components

Duplicate componant nanme:

Stateful compeonent does not contain @Remove method:

Stateful component does not contain @Destroy method:
Stateful cormponent has wrong scope:

Component class name cannot be resolved to a type:
Component class does not contain setter for property:

» Entities

¢ Component life-cycle methods:
» Factories

¢ Bljections

¢ Context variables

¢ Expression language

[

Errar =

Error

o

e

Errar -

rﬁesmre Qeraults] [ Apply

1| cancer

Figure 9.5. Validator Properties Page for Chosen Project

9.2. Project Preferences

Once Seam project is created you can modify its settings. Right click on Seam project in Project
Explorer and select Properties > Seam Settings.

This project properties page allows you to have a flexible project layout. It means that you are
not restricted with a specific project structure. You can use the Seam wizards (New Action, Form,
Entity, etc.) on Maven, command line seam-gen or your own project structure.
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Project Preferences

e Properties for seamproject x
[ ] Seam Settings Cow -
Resource
s rt: "
Beaninfo Path eam suppo
Builders Seam Puntime: [jbuss-saam-z.ﬂ.ﬂ.ﬁﬁl o l IAdd...]
FI'&BMEI'kBI' Context Main Seam projm: Igeampﬂ;je:t J
Hib te Setti
oemate Setlings Connection profile: [Niw HSOLDE = ] [Ed'rt...l [New]
Java Build Path
b Java Code Style ‘Deployment
b Java Compiler Deploy type ) WAR @ EAR
Vo Eiftor Seamn EJB Project: [5eampm1'ect-eib ] | Elmwse...]
Java EE Module Depend
Javadoc Location Mew
B JavaScript View Folder: |.!5earnpruie-:tMEbCuntent ] [Emwse...]
JSP Fragment -M:ldcl
Project Archives Source Folder: [,rs&ampmject ejbfejpModule ] Browse |
Project Facets ) )
Project References Package: [org.dnrnain.s.eampmiect.entity ] [Elmwse...]
Aun/Debug Settings _Action | Form | Conversation
Source Folder: |.'seamprnject-EjbeibMuduEe ] [Emwse...]
Seam Validator
Server Package: |nrg.dumaln.saampmwr.t.sessmn ] [Emws&...]
Service Policies ~Test
Targeted Puntimes Create Test: [/
Task Tags Test Project: |saampruject-tast ] [Emws&...]
b vwalidation
web Content Settings Source Folder: [;seamprnpect-tesmest-src ] Elmma...l
Wweb Project Settings Package: |nrg.dnmain.ﬁeampmieﬂ.Eest ] [Bmwse...]
b XDoclet
0 — D 'Fhstnre Qal‘aul‘ts] [ Apply ]
il [ oK | [ cancel I

Figure 9.6. Properties for Seam Project

Tip:

The wizard doesn't allow the renaming of the artifacts listed in the Seam Settings.
It's possible to do in the . See Renaming the Projects and
Folders.
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Also notice, you are not required to use the New Seam Project wizard to benefit from Seam
artifact wizards. You can just enable Seam on your existing project by checking Seam Support
and targeting to Seam Runtime, and then configure the folders as you want.

Properties for test

[M. ant] ] /Ay Seam runtime is not selected -

Resource

Beaninfo Path
Builders Seam Runtinne:

Seam support:

FreeMarker Context
Hibernate Settings
Jawa Build Path
I+ Java Code Style
I Java Compiler ]
P Java Editor
Jawa EE Module Depend
Javadoc Location
I+ JawasScript
JSP Fragment

Project Archives
Project Facets
Project References
Run/Debug Settings
Server
Service Policies
Targeted Funtimes
Task Tags
b validation
Wweb Content Settings
Web Project Settings
b xDoclet

'HE:tureQel‘aults‘l[ Apply l

(i) oK I | Cancel

Figure 9.7. Properties for Seam Project
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Tip:
\

On the figure above fields for configuring Seam artifacts are dimmed because
Seam Runtime is not selected.

In Seam Wizards (New Action, Form, Entity, Conversation, Generate Entities) you can get a quick
access to project settings using the Settings link in the upper right corner of each wizard.

Mew Seam Action

Seam Action "';I.‘I
Create a new Seam action e e
Seam Project: [seampruiact ] [Emwse...] Settings..,
Seam component name: [Action |
Lecal interface: [Ax:tiun ]
Bean name: [Ad‘iuﬂEEEIn ]
Method name: [actiﬁn ]
Page name: [action ]
Package name: [urg.domain.seamprniect.sessinn ] Browse...

(i) | Einish | [ Cancel f

Figure 9.8. Settings Link
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Chapter 10.

Generate a CRUD Database
Application

10.1. What is CRUD?

CRUD is an acronym for the four basic types of SQL commands: Create , Read , Update ,
Delete . Most applications have some kind of CRUD functionality, and we can assume that every
programmer had to deal with CRUD at some point. A CRUD application is one that uses forms
to get data into and out of a database.

In the next section we will create Seam Web application, connect it to the HSQL [http://
www.hsqgldb.org/] database and add CRUD support.

10.2. How to create the CRUD Database Application
with Seam

« First, you should download [http://docs.jboss.org/tools/resources/] a database and start it by
running ./runDBServer.sh or runDBServer.bat from the database directory.

« Create a new Seam Web Project using New Seam Project wizard or main menu File > New
> Seam Web Project.
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Chapter 10. Generate a CRUD D...

£ New =
Select a wizard p—
Create a Seam Web Project r

Wizards:

(type fiter text |

[v]

< Seam Components File
< Seam Conversation

< Seam Entity

< Seam Form

<~ Seam Generate Entities

5% Seam Page Flow

£ Seam Web Froject
I = Server

Figure 10.1. Seam Web Project Creation

« Name your project as crudapp, specify Target Runtime, Server and Seam Runtime
configuration. Then press Next and follow the next wizard steps keeping default settings.
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How to create the CRUD Database Application
with Seam

New Seam Project

Seam Web Project o
Create standalone Seam Web Project

Project name: I:rudapp |

Project contents:
¥ Use default

Target Runtime

| |Boss 4.2 Runtime ¢ | [Ngw...|
Dynamic Web Module version

(25 &l
Target Server

[]Enss 4.2 Server o+ ] [Nm]
Configuration

[EDynarnic web Project with Seam 2.0 z] |M°d'r".'r'---]

Configures a Dynamic Web application to use Seam v2.0

@ | <pack || Mex> || pnish ][ cancel |

Figure 10.2. New Seam Project Wizard

Tip:
\

Please have a look here how to create Target Runtime and Seam Runtime in order
to get started creating, running, and debugging J2EE applications.

« On Seam Facet page click New... next to the Connection profile section to create a new
Connection profile.
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New Seam Project

Seam Facet J}
Connection profile is not selected \’
General
Seam Runtime: | jbass-seam-2.0.2.GA v ] H.:.EIE_!
Deploy as: ® WAR () EAR
Database
Databasze Type: [HSQL o] ]
Connection profile: l o | 1‘Edit..._] [New]
Database Schema Mame: [ ]
Database Catalog Name: | ]
DE Tables already exists in database: O
Recreate database tables and data on depley: [
Code Generation
Session Bean Package Mame: [arg.domain.:rudapp.ses:.ian |
Entity Bean Package Narme: [nrg.dnmain.:mdapp.entit}r ]
Test Package Mame: [wg.damain.:rudapp.test ]

(] <Hack || 1 Cancel |

Figure 10.3. Seam Facet page

» On New Connection Profile dialog select the HSQLDB connection profile type, name it cruddb
and click Next.
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with Seam

8 MNew Connection Profile 1

Connection Profile p—

Create an HSQLDE connection profile. f_

Connection Profile Types:

[type filter text ]

E DB2 for Linux, UMX, and Windows
& D82 for isfos
Ed oB2 for z/0s
ES Derby

Ed Generic JDBC
Ed Informix

Ed maxDB

& MysaL

Ed Oracle

ES PostgresqL
Ed SOL Server
ES Sybasze asa
Ed Sybase ASE

Mame:
| cruddb |
Description (opticnal):

@ I [ext = ] Eir | cancel |

Figure 10.4. New JDBC Connection Profile

« On the next page click the round icon next to the Drivers field to select a database driver.
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Mew Connection Profile

Specify a Driver and Connection Details £

Select a driver from the drop-down and provide login details for
the connection. T U

Drivers: | =

Properties

Connect when the wizard completes

[] Connect every time the workbench is started

|’-\.
C

Cancel

Figure 10.5. New JDBC Connection Profile Database Driver

« Now you should see the New Driver Definition dialog. On the first tab select the HSQLDB JBDC
Driver. Underneath in the Driver name field you can change its name if you need.
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MNew Driver Definition

Specify a Driver Template and Definition Name

& Unable to locate |AR/zip in file system as specified by the driver definition:
hsqldb jar.

Name/Type q Jar List | Properties |
Svailable driver templates:

Mame Vendor Version

= Database

HSQLDB |DBC Driver HSQLDB

Driver name:
|HSQLDB |DBC Driver ]

Driver type:
[HEQLDE JDEC Driver ]

7 : Il Cancel |

Figure 10.6. Database Driver Type

with Seam

* You may notice the note on the previous figure. It prompts that you should specify the driver
of the type you pointed. Set the location of the driver by switching to the next tab and press

Add JAR/Zip button.
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Mew Driver Definition

Specify a Driver Template and Definition Name

Specify a driver template, then modify details in the fields below to provide a

unigue narme, a list of required jars, and set any available and applicable
Namertype | Jar List | Properties

Driver files:

Joptfhsgldb jar Add JARZip..

| Clear All
(il oK ] [ Cancel ].

Figure 10.7. Driver Definition

« On the Properties tab set the Connection URL, Database Name and User ID and click OK.
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MNew Driver Definition

Name/Type :i'Jar Lis':. Properties

Broperties:

Specify a Driver Template and Definition Name

Specify a drver template, then modify details in the fields below to provide a
unigue narme, a list of required jars, and set any available and applicable

Property

Walue

= General
Connection LURL
Database Mame

User ID

jdbe hsgldb:hsglydocalhost: 1701

amplayes

[ oK ” Cancel ]

Figure 10.8. Driver Definitions Properties

with Seam

« After clicking OK to submit the newly created driver you can observe and if you need edit all

specified connection details.
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Mew Connection Profile

Specify a Driver and Connection Details p—
Select a driver from the drop-down and provide login details for
the connection. T
Drivers: | HSQLDB JDBC Driver | & A
Propertias
Database: |emplnyee |
Database location: [hsql:}ﬂucalhnst:l?ﬂl | ~ _! [Emws&..._!
User name [55 |
Password: [ ]
Save Password
URAL [tdbc:hsqldh:hsql;ﬁduc alhost:1701 |
Connect when the wizard completes -Iest conne:tiun]
[] Connect every time the workbench is started
il [ < Back lf Mext = | Einish I [ Cancel

Figure 10.9. Driver and Connection Details

* Now click Test Connection to be sure that connection can be established.

Success

@ Ping succeeded!

Figure 10.10. JDBC Connection is OK

» Validate JDBC Connection profile settings and press Finish or Back if something is wrong.
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with Seam

Mew Connection Profile

Summanry —

Information gathered from previous pages.

| Property value
MName cruddb
| Description |

Auto connect at startup  false
| Auto connect on finish  true |

Driver name HSQLDE |DBEC Driver

| Database employee |
Database location hsql:flecalhost:1701

| User name ] |
URL jdbchsgldb:hsgliflecalhest: 1701

| Save password true |

Connection properties

Figure 10.11. Validate JDBC Connection settings

 After clicking Finish two projects crudapp and crudapp-test will be created.
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AR, Proect = O

8%~

= ¥4 erudapp
B ® srefhot
b @# srefrmain
b =& JRE Systern Library [java-1.5.0
b =i )Boss 4.2 Runtime [|Boss 4.2 R
b =8 web App Libraries
= build
P = resources
= sre
- {=WebConternt
b Eimg
b= layout
b= META-INF
b= stylesheet
P = WEB-IMNF
o errarxhtrml
o hame shtrmil
o index html
ko3 login.page xmil
o legin.xhtml
[5) erudapp launch
(= hibernate-console properties

b 1= crudapp-test
al . | [2]

Figure 10.12. CRUDAPP Seam Project

* Have a look at the created projects. You can expand WEB_CONTENT folder and open
home.xhtml or login.xhtml with JBoss Visual Editor.
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with Seam
r = i ==
=ul:composltion xmlns=*http:/ www.w2. org/15998/xhtml * (=]
xmlns:s="http://jboss. com/preducts/seam/taglib® —
imlns:ul="http://java.sun.com/jsf/facelets”
xmlns:f=*http://j1ava.sun. coms)sf core” =
gmlns:h="http://java.sun. com/jsf/html"
umlns:rich="http:/srichfaces.org/rich” | 3
template="layout template. xhtml "=
=yl ;define name=*body*=
H <h:messages styleClass="message”/>
<h:form id="legin®=
<rich:panel> =
(<] . B
- Normal 2 ][ Mormal 2| B 1 O & A
® B
iy Emor Messages e
] Login
Pleas e IDQIn USING any USename and password
Usemame f#{identity usemame} 1
Passwond
Remember me =2
Losgiir 5
[<] IiL Dbl
uizcomposition uidefine h:messages ¥

visual/Source Source | Praview

Figure 10.13. login.xhtml in VPE

« Switch to Database Development perspective with Window->Open Perspective->Other...

connect to the cruddb database.

and
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=% (8= uwd B
+ (= Databases
i —
= = 0DA Data St |
(& Flat Fila D ping...
(= Web Servi
(= XML Data
Repame F2
Delete Delete
Duplicate
Refresh Fs
Open SQL Scrapbook
Properties Alt+Enter

Figure 10.14. Connecting to the CRUDDB database

e Expand cruddb nodes to view its Schemas, Tables, Columns etc.

=08

B% (s < wd BT

= = Databases 1=

= ¥ cruddb (HSQL Database Engine v.

= () employee
0 autherization IDs
= [ 5chemas
b EH INFORMATION_SCHEMA
= BH puBLIc
P 3 Dependencies
b [0 Sequences
= [ Tables
I B CUSTOMERS 3
I 9 EMPLOYEES
b [E3 OFFICES
I £ ORDERDETAILS
I+ =1 ORDERS
I =1 PAYMENTS
I F7 PRODUCTLINES
b E9 PRODUCTS
P [ userDefined Functions
b Coviews
* [~ 0ODA Data Sources

(= Flat File Data Source

| D)

Figure 10.15. CRUDDB Database

» Switch back to the Seam perspective. From the toolbar select New->Seam Generate Entities
to create a set of CRUD Seam components and web pages based on existing tables in the
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database. On the first page of Generate Seam Entities wizard keep everything by default and
press Next.

Generate Seam Entities

Generate Seam Entities

Seam Project: crudapp

Hibernate Console Configuration: | crudapp £

Generation Mode

@ Reverse engineer from database

(O Use axisting entities

@ [ Mext = | Einish ” cancel |

Figure 10.16. Generate Seam Entities

» Click Refresh to display all the tables from the database.
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Generate Seam Entities

Generate Seam Entities P

Select Tables \’
Database schema:, Table filters:
| | include...
. ' |t cataleg Schema Table

Refresh

@ I : l Einish ” Cancel ].

Figure 10.17. Dialog for Selecting Tables

* Now you can filter the tables. Use the Include button to include only necessary ones.
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Generate Seam Entities
Select Tables

Datsbase schema:———————
+ [ =Default catalog=
- 55 puBLIC
2 CUSTOMERS
T EMPLOYEES
= OFFICES
[ ORDERDETAILS
! ORDERS
W PAYMENTS
! PRODUCTLIMES
I PRODUCTS

=

How to create the CRUD Database Application

Genperate Seam Entities

Include... |

with Seam

y
Table filters:
I! Catalog Scherma Table
b PUBLIC CUSTOMERS
20 PUBLIC ORDERS
X PUBLIC EMPLOYEES
ez PUBLIC PAYMEMTS

| = Back

Einish H Cancel !

Figure 10.18. Selecting Tables

* Under WebContent folder you can find all generated xhtml files:
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| 1% Package Ex B\[b Project Expl | =8 ”fr@g Customers.xhtrmil w

- 3 erudapp

b @ srcihot Error Messages
b @ srejmain #fcustomersHome.managed 7 "Edit’ : "Add’} Customers
P mi)Boss 4.2 Runtime [|Boss 4.2 Runt customemumber *

I =& JRE System Library [java-1.5.0-su
I =i web App Libraries

customemame *

contactlastname *

= build
I (=resources 3 .
= e phone *
= j=wWebContent addresshinel *
b &img addressline2 *
b = layout
b = META-INF oy *
b = stylesheet state *
b (& WEB-INF postalcode *
is Custormers page.xml country *
7 Customers xhtml eredittimit -
fs CustomersEdit. page xml « requined ks

= CustomersEdit xhtml

fs CustamersList.page xml

@ CustomersList xhtrml

. lo

i% Employees page.xml Hocmplayees = = =

i Employees xhtml X mme e 2
#employ ees employeenumber} | #{employees lastname} | S{employees Hemployees

© % T | sprojectName):  Home  Customersiist  Empioyeeslist Paymentsiist Orderslist  Weicome, #(identity.usemame}!  Login

Hemployees emai} | #{employees olficecode}

is EmployeesEdit page xmi
i EmployeesEdit xhtml

1Y

{=3 EmployeesList.page xml &l T

2]

ol Ermmlasmaet ied bt mal

] | 1 D) Visual/Source | Source Preview

Figure 10.19. Entities Web Pages

« And under src folder java classes are created.
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AT RSl Pt 9 = O
H - T
- ¥ erudapp -
- (@erefhot
= [ org.demain.crudapp.session
B [1) authenticator.java
B 1) custemersHeme java
B [0 CustomersList. java
b 1) EmployeesHome java
B [J) EmployeesList java
B [1) OrdersHome java
B [J) OrdersList java
B 1) PaymentsHome java
B [J) PaymentsList.java
[E seam.properties
= (®srcfmain
= # org.demain.crudapp.entity
B [0 Customers.java
B [1] Employees.java
I [J] Orders java
B 1] Payments java
P = META-IMF [~
(<] [ | )

Figure 10.20. Entities Java Classes

« Switch to Hibernate perspective with Window->Open Perspective->Other.... On Hibernate
Configurations view expand the crudapp configuration. Right click on Customers and select
Open Mapping Diagram from the popup menu.
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[# Packag =g
m & @

= |5 crudapp
= |6, Configuration

b ® Empl & HOL Editer
m
ployees ] Hibernate Criteria Editor
b @ orders
[ c ] Payments B Add Configuration...

b W Session Factory £ Refresh
- [ Database

= #5 PUBLIC

b 3 CUSTOMERS

1 OFFICES '
E7 ORDERDETAILS
£ ORDERS
= PAYMENTS
ET PRODUCTLINES
EZ PRODUCTS

Ly Open Source Fle
@ Open Mapping File

- -

| | | |_"]

Figure 10.21. Hibernate Configurations View

« Observe the Mapping Diagram opened in the editor. Here you can see the relations between
models and database tables. For better navigating on the diagram use the Outline view.

5 Diagram fororg.demain.crudapp.entity. Custemers B ) = U.”-:p Query Pa W

[-] org.hibernate.mapping.RootClass{org.domain.crudapp.entity. Orders) R 5
B, ordernumber : java lang.nteger L+ Qorg.h
# comments : java.lang.String ___] [EL custor
#-1 org.hibernate. mapping.Propertylcustomers) al 1l B addre:
M orderdate : java.util Date —1 1 addre:
[ requireddate : java.util Date I B city : i
® shippeddate : java.utilDate (— B contac
B status : java lang.String — [ contac
B countr
B credit |~
B custor
#-1 org.hit
=3 org.hil
| B key
Hod ixele
' ¥ org.hil
] key
1wele
# phone
B postal
[Fl state :
& org.hibernate.mapping.RootClass{org.domain.crudapp.entity. Payments)  # RS
B, paymentnumber : javalang.integer e
® amount : java.lang.Double i
® checknumber : java lang.String LIl B
+-10rg.hibernate mapping Property{customers) ® —
¥ paymentdate : java.util.Date _._E i H
(] [ ] e D]

Figure 10.22. Mapping Diagram
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» For example, select Customers entity, right click and select Open Source File. This will open
the Customers.java file in the java editor. You can also do this by right-clicking on the same

entity on the Mapping Diagram.

/2 Packag | = =] Diagram fororg.demain.crudapp entity.Customers [} customers java &
m & ol e
1| £ * Customers generated by hbm2java
= [§ crudapp */
@Entity

= |6 Configuration

@Table(name = " CUSTOMERS®, schema = "PUBLIC")
: nublic class implements java.ic.Serializable {
& HQL Editer

b @ Employ . . .

] Hibernate Criteria Editor fivate int customernumber;
b @ Orders rivate Employees employees;
b @ paymer @ Add Configuration... rivate String customername;

rivate String contactlastname;
rivate String contactfirstname;
= I Database rivate String phone;

; ivate String addresslinel;
Ki Open Source File fiva '
< 58 puaLic R, : vatc string addreseline2,

b % SessionF: _.
_ 2 Rafresh

= public Customers() {
1 PRODUCTLINES

b I cus ') Open Mapping File rivate string city;
— rivate String state;
b EZEMPI ¥, Open Mapping Diagram rivate String postalcode;
b = OFFICES private String country;
b= i private Double creditlimit;
B ORGERDETAILS : private Set<Orders> orderses = new HashSet<Orders>(0);
P T ORDERS g private Set<Payments> paymentses = new HashSet<Payments=(0);
b I PAYMENTS
[
[

£ PRODUCTS s s :
== public Customers{int custemernumber, String customername,

e — .I ,,,,,,,,,,,, I_)_ -' [_T

Figure 10.23. Entity class from Mapping Diagram

__Strina contactlastname. Strina contactf .i_.-:s.'.c.na.m.-..__ﬁ_t_.r.in.s:.__.c.'.t_-.-?.ne.:__T_,]

[T>

(<]

So far, you are ready to deploy your application to JBoss Application Server. This is described

in the next chapter.
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Chapter 11.

The CRUD Application Walkthrough

After you familiarized oneself with example of creating the CRUD Database Application with Seam,
you can read this charter.

11.1. Using CRUD Application

To run your CRUD Application you should do the following steps:

* Run a project on the Server.

On Package Explorer View right click on the crudapp project, select Run As > Run on Server.

1 erudapp : 51
b @ srefhor Go Into

B srefmain

b =4 JRE Systern Library [javs

Open in New Window

) Open Type Hierarchy F4
Gonrym Show In shift+alt+w >
b miweb App Libraries '
& build |5 copy ctiac
b = resources 52 Copy Qualified Name
Esre [ paste Ctri+v
v = WebContent X Delete Delete
b =img Build Path 5
P G layout Source shift+alt+s >
P (= META-INF Refactor shift+Alt+T >
P = stylesheet Ry (POTL ..

P (= WEB-INF &4 Export...

i errarxhtml )
" Refresh FS

Cloge Project
Assign Working Sets...

e home xhtml
e index.html

isi login page.xml

i login ahtml ) Convert to Drools Project | )
I hibernate-console.propt Debug As » M 2 Java Applet Shift+Alk+x A
b & crudapp-test profile As »| @ 2 Java Application Shift+Alt+x |
validate

] Fup Configurations...
Team 3l

Compare With »
Restore from Local History...

Figure 11.1. Run Project on Server

Select a Server and click Finish

89



Chapter 11. The CRUD Applicat...

¢ Run On Server *
Define a New Server
Choose the type of server to create E
How do you want to select the server?

@ Choosa an existing server

) Manually define a new server

Select the server that You want to use:

type filter text

= = localhost

& JBoss Application Server 4.2

JBoss Application Server 4.2

[] Always use this server when running this project

@ - | mext> || mnisn || cance |

Figure 11.2. Select a Server

Home page of the crudapp project should appear in Web Browser .

|Q crudapp ® ) = I:l|
® & |httpidocalhost:8080/crudappihome.seam v > B
crudapp: Home Cuglomerslist EmployeesList Payments List  Orders List Legin
Weleome!
This empty shell application includes:

« Ant bud seript
& Depioyment to JBass AS (EAR of WAR)

& Development and production profiles

w Integration 1esling using TestNG and Embedded JBoss
» JavaBean or EJB 3.0 Seam components

= JPA entity classes

» A configurable DataSource and JPA Entity Manager

» Templated Facelets views

= RichFaces panets and tables

» Defauk GSS stylesheet

» Intermationalzation Support

Powered by Seam Genemted by seam-gen.

Figure 11.3. Home page

After that you can use CRUD application with "employee" database.
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Using CRUD Application

You can use internal JBDS Web Browser or your external Web Browser with the same link (http:/

/localhost:8080/crudapp/home.seam).

Click on the Employees List link and observe that data from employee database is displayed.

crudapp - Mozilla Firefox

EEEERE R

g
=

File Edit View History Bookmarks Tools Help

o = v @ (3¢ ﬁ [ i, http:ylecalhost:2080/crudapp/EmployeesList seamijsessionid=2317 | w ] “Q]v

7 Most visited ¥ [ Smart Bookmarks v e Getting Started [5iLatest Headlines ~

erudapp: Home Customers List Employees List  Payments List  Orders List

Employees search parameiers
lasmane
firstame
EXIENSion
email
officecode
jobute
Employees search results

employeenumber  lasmame firsmame  extension email officecode  reportsto johtte
1002 Murphiy Diare =5500 dmurphy@classicmodelcars com 1 President
1055 Paiterson  Mary 4611 mpaiterso@classicmodelcars com 1 1002 VP Salez
1075 Firrell Jatt ®9273 frreli@classicmodelcars com 1 1002 WF Marketing
1088 Parterson  Wiliam #4871 wpatersoni@classicmodelcars com & 1066 Sales Manager (APAC)
1102 Bondur Gerard 5408 ghondur@classicmodelcars com 4 1056 Sale Manager (BMEA)
1143 Bow Arghony %5428 ahow@classicmodelcars com 1 1056 Sales Manager (HA)
1165 Jennings Lesies =291 ffenningsi@ classicmodelcars com 1 1143 Sales Fep
1165 Thompson | Lesks *4065 thampson@classicmodelcars. com 1 1143 Sales Fep

I 1188 [Firrell Juslie #2173 ifirreli@classicmadelcars com 2 1143 Sales Rap

| Done

Figure 11.4. Employees List

Use Employees search parameters fields to filter the selected list.

Press Select opposite one of employees.
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crudapp - Mozilla Firefox
Ele Edit “iew History Bookmarks Tools Help

adq > v e (% G [:'.': http:flecalhost:20B0/crudapp/Employees seam?employeasEmploye |v] [@v

5 Most visited ¥ [ Smart Bookmarks ~  #feGetting Started [5Latest Headlines ~

Employees

employeenumber 1002

lasmame: Murpiky

firsmame Dizree

EXTEASION w5800

armail dmurphy@classicmodelcars com

officccode 1

reportsto

jobiite President
=3 E3

CUSTOmErses

There are Nd CUSIOMETSES AsSociared with this emplayees,

Add custormars

Fowered by Seam. Generated by seam=gen.

' Done

Figure 11.5. Employee details
Press Edit to edit employee fields.

Enter Login and Password to login. (Use "crudapp-user'/"secret" for example)
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J crudapp - Mozilla Firefox
FEile Edit View History Bookmarks Tools Help

4 = v @ (% ﬁ li’; httpyjlacalhost:B0B0/crudappflogin.seamicid=" 'vl l@v @

f5Most visited ¥ [3Smart Bookmarks v #eGetting Started [5jLatest Headlines ~
crudapp: Home Customerslist Employees Lisi Payments List  Orders List Login

= Please log in first

Login
Fleass kagn here
Username erudapp-user
Password LLllll)
Rememiber me W

Hoe - Yiou may login using any usernamsaipassword combination.

Powered by Seam Gendrated by seam-gen

b 1#] ]

Figure 11.6. Login page
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2 crudapp - Mozilla Firefox
Eile Edit View History Bookmarks Jools Help

4 > v @ OB l‘: http:flocalhost:2080/crudapp/EmployessEdit seam?amp

1 v] l@v . G‘|

5 Most visited ¥ [ Smart Bookmarks ~  #eGetting Started [5iLatest Headlines ~
crudapp: Home Customerslist EmployeesLisi Payments List = Orders List

= Welcome, crudapp-user

employeenumber * 102

lasmame * Murghy
firsmame * Mary
extension * =SB0
il *
drunphnE classicrnodelcars, com

officecode * 1
FEpOTTSID
jobute * Presdent
* required fhekis

[seve Jf odee |
CUFIOmErses

Add custormars

Welcome, crudapp-user!  Logoui | |

<[]

| Done

| #]

Figure 11.7. Edit Employee
Fill in firsthame and press Save.

Database will be updated.
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Chapter 12.

Using TestNG project
With the help this chapter you will get to know with TestNG.

12.1. What is TestNG?

TestNG ("Testing, the Next Generation") is a Java unit testing framework that aims to overcome
many limitations of JUnit. TestNG introduces some new functionalities that make it more powerful
and easier to use, such as:

« JDK 5 Annotations (JDK 1.4 is also supported with JavaDoc annotations)
» Flexible test configuration

» Support for data-driven testing (with @DataProvider)

* Support for parameters

« Allows distribution of tests on slave machines

» Powerful execution model (no more TestSuite)

» Supported by a variety of tools and plug-ins (Eclipse, IDEA, Maven, etc...)
« Embeds BeanShell for further flexibility

 Default JDK functions for runtime and logging (no dependencies)

» Dependent methods for application server testing

More information can be found on home page: www.testng.org [http://testng.org]

12.2. Other relevant resources on the topic

Next-Generation Testing with TestNG (An Interview with Cedric Beust) [http://www.artima.com/
lejava/articles/testng.html]

TestNG: The next generation of unit testing [http://www.javaworld.com/javaworld/jw-04-2005/jw-
0404-testng.html]

Test Categorization Techniques with TestNG [http://dev2dev.bea.com/pub/a/2006/09/testng-
categorization.html]

TestNG makes Java unit testing a breeze [http://www-128.ibm.com/developerworks/java/library/
j-testng/]
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Chapter 12. Using TestNG project

In pursuit of code quality: JUnit 4 vs. TestNG [http://www-128.ibm.com/developerworks/java/
library/j-cq08296/index.html]

12.3. How to use the generated Seam-test project to run
Seam tests?

» Create a new Seam Web Project with EAR deployment using the New Seam Project wizard.

« After a project is created you will have the generated Seam-test project that is setup to run
TestNG directly against the proper libraries and server runtime libraries.

i Package Ex 2 . [SProject Expl = B

= |

&®

b 52 seamproject
b ¥z seamproject-ear
b & seamproject-ajb
- Dseamproectien |
| = B test-srec |
[ [ META-INF
components.properties
seam.propertias
I+ =4 Referenced Libraries
[+ = JRE System Library [java-1.5.0-5un
= lib

Figure 12.1. Seam-test Project

» Add Seam Action to your project via File > New > Seam Action.
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How to use the generated Seam-test project to

run Seam tests?

~ y Go nto

Open in Mew Window

& seamproject/src

- = Open Type Hierarchy F4
showin Shit +A+W >

Close Project
Assign Working Sets...

I+ m4 JRE System Library [java- 1.} fE' Lopy Ctri+C
) 5 Copy Qualified Name
I+ m4)Boss 4.2 Runtime [|Boss 4.
b b ibrari (2 Paste Ctri+v
=, Web App Libraries % Delete -
[ =) EAR Libraries
& build Build Path ,
= seamproject Source shift+ak+s >
b i2WebContent Batacior Shift +AR+T >
b 3= seamproject-ear g4y Import...
b ! seamproject-ejb i3 Export...
" _— _
b = seamproject-test e e

9 Conwvert to Drools Project

Figure 12.2. Seam Action Creation

Bun As »
Debug As »

|
: Profile As »

(™ Seam Web Project
I Project...
& pPackage
& Class
& Interface
&7 Source Folder
5 Folder
[ Fila
¢ Seam Form
! Seam Entity
. Seam Conversation
¢ Seam Generate Entities

I Example...

"] Cther... Ctrl+M

« Fill out the wizard fields. New Seam Action wizard will create resources and place them in the

appropriate folders dependent on EAR project structure.
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E

Seam Action

Seam Project:

Local interface:
Bean name:
Meathod name:
Page name:

Package name:

MNew Seam Action

Create a new Seam action

[seampmjact

| |Browse...| settings...

Seam component name: |Action

[ActinnLuc al

[An:tiunaean

[actianmethud

[actionpage

[nrg.domain.seamprniect.sessiun ] [Eimwse...
[ Finish ” Cancel l.

Figure 12.3. New Seam Action Wizard

* When Action is created you will see actionPage.xhtml in Package Explorer

ActionBean.java will be automatically opened in Java Editor.

view.

Mﬁi [t5 Projecte | = o | [3] ActionBean java m\_

B %
- & seamproject
b @#@ere
I mi)RE Systern Library [jzva-1.
P m4)Boss 4.2 Runtime [|Boss 4.
P =i 'Web App Libraries
P BAEAR Libraries
= build
= (=WebContent
P img
B layout
I (= META-INF
I (= stylesheet
P (= WEB-INF

) errorxhtrml

i home xhtml
de index.html

& login page xml

-

I package org.domain.seamproject.session;

wimport javax.ejb.Stateless;[]

@stateless
@Name("Action®)

public class ActionBean implements ActionLocal {

@ogger private Log leg;

@In FatesMessages fac esﬁassages;

= = public void actionMethod()
3 {

J/implement your business logic here
log.infol"Action.actionMethod() action called*);
facesMessages.add("actionMethod");

}

/rfadd additional action methods

2 ST D)

Gl

Figure 12.4. Created Action
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How to use the generated Seam-test project to

run Seam tests?

» Select ActionLocalTest.xml in Seam-test project and run the test with right click Run As >
TestNG Suite.

e, ™ ~roe |~ O
Bs v
% seamproject
b 85 seamproject-ear
b & seamproject-ejb
= |2 seamproject-test :
= [@test-src New ’
¥ i org.domain.seam  Open F3
b [J) ActionLocalTes Open With ¥
Show In Shift-+Alk+w 3
P @ META-INF & Copy ctri+c
[ components prop (i3 copy Qualified Name
[Bl seam properties | (7 paste Ctri+v
I @i Referenced Libraries| 3 Delete Delete
I+ =& JRE Systern Library [| Build Path ;
) & lib Refactor Shift+AR+T »
- - ] 23 Import...
5 Export...
+# Refresh Fs

Assign Working Sets...

Validate
= Make Deployable

Debug As bl " 5 2 TestMG Suite sShift+aAlk+X G

Erofile As . '
Fun Configurations...

Team =

Compare With ¥

Figure 12.5. Running TestNG

The test process will start and its output will be written in Console View.
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sole & =0

<terminateds test-src.org.doemain seamProject test ActionLocalTest.xmi [TestNG] jusrjavaljak: ' .':ﬁ = - i
01:14:42,614 INFO [Lifecycle] starting up: org.]jboss.seam.ul.graphicImage.dynamicImageResource E
©1:14:42,615 INFO [Lifecycle] starting up: org.jboss.seam.debug. hotDeployFilter
01:14:42,616 INFO [Lifecycle] starting up: org.)boss.seam. servlet.multipartFilter
01:14:42,617 INFO [Lifecycle] starting up: org. jboss.seam.ui, resource, webResource
01:14:42,618 INFO [Lifecycle] starting up: org. jbess. seam. serviet. redirectFilter
01:14:42,620 INFO [Initialization] done initializing Seam
01:14:43,032 INFO [ActionBean) Action. actionMethod() actien called
01:14:43,058 INFO [Ejb] stopping the embedded EJB container
PASSED: test

ActionlLocal Test

Tests run: 1, Failures: ©, Skips: ©
Actionlocal Tests
Total tests run: 1, Failures: O, Skips: © B
] [v)

Figure 12.6. Test is Finished

« After running TestNG you will have the test results in test-output folder in Seam-test project
(press F5 to refresh the Package Explorer view). Open index.html file with Web Browser or
simply use the TestNG view.

The below view shows a successful run of the test.

&1 Tasks | - Seam Components |2 |Boss Server \ﬂew Console e, @ T =0
[ Tests: 171 Methods: 1/1(15317ms) | T Passed 1 B Failed: 0 B8 Skipped: 0
it All Tests | g Failed Tests = Failure Exception g

+ ™ ActicnLocal Tests { 1/0/0/0 )

V7 gl ActionLocal Test { 1/0/0/0 )

g org domain seamProject test ActionLocalTest test

Figure 12.7. Viewing the Test Results

You can see the test results in Web Browser.
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run Seam tests?

Test results - Mozilla Firefox
file Edit View History Bookmarks Tools Help

B v @ Q‘t’ [Ij fileyyrootpworkspace/seamproject-testitest-output/findex.html |v] l[gv 9‘]

{5 Most Visited ¥ [ Smart Bookmarks v i Getting Started [5Latest Headlines v

Test results

| Suite ' Passed | Failed | Skipped  testng.xml

: Done

Figure 12.8. Test Results in Browser

After clicking on ActionLocal Tests link you will see the Results for ActionLocal Tests.

Results for ActionLocal Tests - Mozilla Firefox
Ele Edit View History Bookmarks Toocls Help

< ~ e‘ O ) I_] fileyjjirootpworkspace/seamproject-test/test-out |v] G~ 2,

Most Visited ¥ [ Smart Boockmarks v e Getting Started [ELatest Headlines v

Select a result on the left-hand pane.
Results for P

ActionLocal Tests

1 test |1 class 1 method:
chronological
alphabstical
not run {0}

Q jpeRorter dooing xml

group |output

Daone

Figure 12.9. Test Information

Select a result on the left-hand pane and its details will be displayed on the right-hand one.
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Results for ActionLocal Tests - Mozilla Firefox

Fle Edit View History Bookmarks Tocls Help

-:1 W @ (% ﬁ [ g] filejiirootjwarkspace/seamproject-testtest-outputjactionLocal Tests I b | “Qv
s Most visited ¥ [ Smart Bookmarks ~  #eGetting Started [5Latest Headlines ~

Results for Actionlocal Test

ActionlLocal Tests

|Tests passed/Failed/Skipped:|1/0/0

1test |[1class 1 method: IStarted on: |Tue Dec 02 15:40:31 EE
chronological [Total time: [18 seconds (18077 ms)
alphabetical
not run (0) Included groups:

[Excluded groups:

10 group |reporter output [testng.xml

ctionlocal Test(U00)  Fesli |

file JMMirootfworkspace/seamproject-testftest-output/ActionLocal TestsfActionLocal Test.htmil

Figure 12.10. ActionLocal Test Details

Thus with Seam tooling you can easily take advantage of TestNG framework. As you can see, it
generates its own TestNG project as a separate module within which you can easily monitor the
tests execution and their output.

In conclusion, the main goal of this document is to get you know with a full featureset that JBoss
Tools provides to support Seam development. Thus if you have some questions, comments or
suggestions on the topic, please fell free to ask in the JBoss Tools Forum [http://www.jboss.com/
index.html?module=bb&op=viewforum&f=201]. You can also influence on how you want to
see JBoss Tools docs in future leaving your vote on our page here [http://wiki.jboss.org/wiki/
JBossToolsDocsFuture].

A set of movies on Seam tooling is available here [http://docs.jboss.org/tools/movies].
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