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Chapter 1.

Getting Started with JBoss
Developer Studio

1.1. What is JBDS?

JBoss Developer Studio is a set of eclipse-based development tools that are pre-configured
for JBoss Enterprise Middleware Platforms and Red Hat Enterprise Linux. Developers are not
required to use JBoss Developer Studio to develop on JBoss Enterprise Middleware and/or Red
Hat Linux. But, many find these pre-configured tools offer significant time-savings and value,
making them more productive and speeding time to deployment.

This guide covers the first steps to get started working with JBoss Developer Studio. You will learn
how to install and configure necessary software for your OS (currently Linux, Microsoft Windows
or Mac OSX).

Thus this guide will provide you with detailed info on how to start JDK, JBDS and JBoss Tools.

1.2. Key Features of JBoss Developer Studio

For a start, we propose you to look through the table of main features of JBoss Developer Studio:

Table 1.1. Key Functionality of JBoss Developer Studio

Feature Benefit

JBoss Enterprise Application | JBoss Developer Studio includes and integrates JBoss

Platform Enterprise Application Platform, the same version of the
middleware platform that Red Hat supports in production for 5
years.

New Seam Tools JBoss Developer Studio includes brand new tools for Seam.

They provide wizards for creating new Seam projects,
validation tools, expression language code completion, testing
tools, and wizards for generating entity objects.

Visual Page Editor JBoss Developer Studio includes a Visual Page Editor for
combined visual and source editing of Web pages. The
Visual Page Editor even renders AJAX-enabled RichFaces
components.

AJAX Capabilities JBoss Developer Studio includes a Technology Preview of
JBoss RichFaces. RichFaces provides nearly 70 skinnable
components, including calendar, tree, dropdown menu, drag-
and-drop components, and more. JBoss Developer Studio’s
Visual Page Editor can render RichFaces components.
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Feature Benefit

JBoss Tools Palette The JBoss Tools Palette contains a developer’'s project tag
libraries and enables inserting tags into a JSP with one click.
The Tools Palette supports custom and 3rd party tags.

JBoss jBPM Tools JBoss Developer Studio includes jBPM tooling for defining
Seam page flows.

Spring Tools JBoss Developer Studio includes Spring IDE for developing
Spring applications.

Struts Tools JBoss Developer Studio includes Struts tools for Struts 1.x
applications.

Optimized JBoss Application | JBoss Developer Studio's advanced JBoss AS adapter
Server adapter includes features like incremental deployment for fast
development and is pre-configured for the included JBoss
Application server.

Red Hat Enterprise Linux and | JBoss Developer Studio includes access to Red Hat Enterprise
RHN Access Linux, Linux development tools, and Red Hat Network for
development purposes.

Business Intelligence Report | JBoss Developer Studio includes Business Intelligence Report
Tool (BIRT) Tool, a reporting system that integrates with Java/J2EE,
extracts certain information, analyzes it, and generates report
summaries and charts.

JBossWeb Service JBoss WS is a web service framework developed as a part
of the JBoss Application Server. It implements the JAX-WS
specification that defines a programming model and run-time
architecture for implementing web services in Java, targeted at
the Java Platform, Enterprise Edition 5 (Java EE 5).

1.3. Configuring Your Java Environment

You must have a working installation of JDK 5 before you install JBoss Developer Studio. Currently
it will only fully work with a 32-bit JVM, not a 64-bit JVM. On a 64-bit JVM the visual editor fails to
launch because of feature of OS architecture. Thus in this guide we will show you how to install
a 32-bit Sun JDK 5.0 on a Linux Platform and Microsoft Windows Platform.

1.3.1. Installing and Configuring 32-bit Sun JDK 5.0 on Linux

To install 32-bit Sun JDK 5.0 on Linux and configure it, you should follow the next steps:

* Download the Sun JDK 5.0 (Java 2 Development Kit) from Sun's website. Choose "JDK 5.0
Update <x>" (where "x" is the latest update number) for download and then select "Red Hat
Package Manager in self-extracting” file for Linux. Read the instructions on Sun's website for
installing the JDK.



http://java.sun.com/javase/downloads/index_jdk5.jsp

Installing and Configuring 32-bit Sun JDK 5.0

on Linux

« If you don't want to use SysV service scripts you can install the "self-extracting file" for Linux
instead of choosing the "RPM in self-extracting” file. In that case you can skip the next step
mentioned here. But it is recommended to use the SysV service scripts for production servers.

» Download and install the appropriate -compat RPM from JPackage here. Please ensure you
choose a matching version of the -compat package to the JDK you've installed.

« Create an environment variable that points to the JDK installation directory and call it
JAVA_HOME. Add $JAVA HOME/bin to the system path to be able to run java from the
command line. You can do this by adding the following lines to the .bashrc file in your home
directory.

#In this example /usr/java/jdk1.5.0_11 is the JDK installation directory.
export JAVA_HOME-=/usr/java/jdk1.5.0_11
export PATH=$PATH:$JAVA HOME/bin

Q #If you have JDK already installed and added in your system path, you should add
$JAVA_HOME/bin before the old $PATH (not after it) so that the new version of
JDK can be found first, i. e. export PATH=$JAVA_HOME/bin:$PATH This way,
the machine will pick up the new JVM first. You only need to run "alternative" as
a safe guard for the right JVM.

Set this variable for your account doing the installation and also for the user account that will run
the server.

« If you have more than one version of JVM installed on your machine, make sure you are using
the JDK 1.5 installation as the default java and javac. You can do this using the alternatives
system. The alternatives system allows different versions of Java from different sources to co-
exist on your system.

1.3.1.1. Select alternatives for java, javac and java_sdk_1.5.0

« As a root user, type the following command at the shell prompt and you should see something
like this:

[root@vsr ~]$ /usr/sbin/alternatives --config java
There are 2 programs that provide 'java'.
Selection Command
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1 {usr/lib/jvm/jre-1.4.2-gcj/bin/java
*+ 2 usr/lib/jvm/jre-1.5.0-sun/bin/java
Enter to keep the current selection[+], or type selection number:

Make sure the Sun version [jre-1.5.0-sun in this case] is selected (marked with a '+' in the output),
or select it by entering its number as prompted.

* Repeat the same for javac and java_sdk_1.5.0.

[root@vsr ~]$ /usr/shin/alternatives --config javac
There is 1 program that provides 'javac'.
Selection Command

*+ 1 lusr/lib/jvm/java-1.5.0-sun/bin/javac
Enter to keep the current selection[+], or type selection number:

[root@vsr ~]$ /usr/sbin/alternatives --config java_sdk_1.5.0
There is 1 program that provide 'java_sdk_1.5.0".
Selection Command

*+1 {usr/lib/jvm/java-1.5.0-sun
Enter to keep the current selection[+], or type selection number:

You should verify that java, javac and java_sdk 1.5.0 all point to the same manufacturer and
version.

; You can always override this step by setting the JAVA_HOME environment
variable as explained in the previous step.

« Make sure that the java executable is in your path and that you are using an appropriate version.
To verify your Java environment, type “java -version" at the shell prompt and you should see
something like this:

[root@vsr ~]$ java -version

java version "1.5.0_11"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
Java HotSpot(TM) Client VM (build 1.5.0_11-b03, mixed mode, sharing)
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1.3.2. Installing and Configuring 32-bit Sun JDK 5.0 on
Microsoft Windows

To install and configure 32-bit Sun JDK 5.0 on Microsoft Windows, follow these steps:

« Download the Sun JDK 5.0 (Java 2 Development Kit) from Sun's website. Choose "JDK 5.0
Update <x>" (where "x" is the latest update number) for download and then select your Windows
Platform options to perform the installation.

« Create an environment variable called JAVA_HOME that points to the JDK installation directory,
for example:

In order to run java from the command line, add the jre\bin directory to your path, for example:
C:\Program Files\Java\jdk1.5.0_11\jre\bin

To do this, open the Control Panel from the Start menu, switch to Classic View if necessary,
open the System Control Panel applet ( System ), select the Advanced Tab, and click on the
Environment Variables button.

Now, when 32-bit Sun JDK 5.0 has been successfully installed, we can pass on to the next step.

1.4. JBoss Developer Studio Installation

This chapter will provide you with detailed information on how to install JBoss Developer Studio.

JBDS comes with a simple installer, bundled with tested/pre-configured versions of Eclipse, WTP,
JBossEAP, Seam, and SpringIDE. Thus, to start perform the next steps:

« First of all you need the appropriate installation file for your platform from Red Hat website.

¢ Then run in console:

java -jar jbdevstudio-linux-gtk-2.0.0.GA.jar

» Follow the instructions presented by the installation wizard:
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L |Boss Developer Studio GA

Introduction

';'.I-=|_| 1of 10

| Please read the following information:
This installer will guide you through the installation of JBoss Developer Studio GA
It is strongly recormrmended that you quit all prograrms before continuing with this installation

Zhick the "Mext" button to procesded to the next screen. If you want to change something on a
previous screen, click the "Previous” button.

You ray Stop this installation at any time by clicking the "Cuit” button

JBoz3, & divigion of Red Hat

£ Next €3 Quin

Figure 1.1. JBoss Developer Studio Installation Wizard

* Provide the installation path

» Select Java VM
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of JBoss Developer Studio GA

Select Java VM

Step 4 of 10

JBous

DEVELOPFER STUDIO

JBoss Developer Studio needs Java 5 and does not work with gij java

) Default Java ¥

™ Specific Java VM

[fusr/java,jdk1.5.0_12 fjre | =¥ Browse. .

JBoss, a divislon of Red Hat

{3 Previous | £ Next i €3 Quin |

Figure 1.2. Select Java VM

Tip:

By selecting you set default Java VM of your system (to verify
your Java environment, type "java -version" in console).

Selecting Specific Java VM you can provide the path to non-default Java VM.

: JBoss Developer Studio needs Java 5 and "gij" isn't available on every platform.

* Installation process includes JBoss Enterprise Application Platform. Select Yes to use it
in JBoss Developer Studio. This step lets you configure locally available JBoss Application
Servers:
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|Boss Developer Studio 2.0.0,.CR1

% of 10

JBoss Enterprise Application Platform

Developer Studio includes |Boss Enterprise Application Platform. Would vou like 10 install it?
=) ¥es, and have it ready for use in Dewveloper Sudio
Mo

Add Servers you want 1o be configured in Developer Studio.
Mame Tvoe | Wersion Location Find... |

Add.... |

JBoss, & diizlon of Fed Hat

(3 Previous | | €J Next | | €3 Quit |

Figure 1.3. JBoss Enterprise Application Platform Installing

* You can fill the list automatically using the Find button: click Find, select a folder where search
of available JBoss Application Servers should be started and click on Ok:

|"- Select [Hoss AS Installation Root Folder [
Look In: |2 user | (&) R D:I,
'é Deskiop |5 Fictures E
[ﬂ Docurments E Public E
=l Eclipse |2 Templates ]
|E3 Examples & videnos E
= ibdevstudio IS wark &
émaven-z.o.l E'ﬂmrksnace =
[ﬂ Music Ewnrkipace’l k:
== Mewfolder |2 workspace 23 ]
File Mame: :fnnme,ruser l
Files of Type: | All Files =
Ok Cancel

Figure 1.4. Finding Servers in the Selected Directory
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« All available servers in the selected directory will be added to the list with the following
information specified: Name, Type, Version and Location.

|Boss Developer Studio 2.0.0.CR1

s Enterprise Application Platform

% of 10

Developer Studio includes |Boss Emerprise Application Platforrm. Would vou like 1o install it?
=) %es, and have it ready for use in Dewveloper Studio

Mo
Add Servers you want 10 be configured in Developer Studio.
Mame Tvpe | YWersion Location Eind...
jboss-as AR 4.3 Shomejfuser/jbdevsiudiafjboss-soa-p. 4.2, 0/jboss-as ’
Add...

JBoss, & diizion of Ped Hat

() Prevous || € Next | | €3 Quit |

Figure 1.5. List of Servers Added

* You can also add servers one by one using the Add button:

|"- Add server x|

Server

Add Server @
Location: | | [Browss._.. [
Name:

Tvpe: E&P S04~ A5

wersion: bl

Cancel |

Figure 1.6. Add Server to be Configured
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Click on Browse and select the server location. Fields Name, Type and Version will be filled in
automatically:

- Add Server x

Server £
Add Server @

Location: |/home user/jbdevstudio/jboss-eap | | Browse... |

Name: |jbuss—eap |

Type: @ EAP O S0A-P () AS

Yersion:

Figure 1.7. Specify Server Location

Click on Ok. The server is added to the list with the details on its type, version and location.

The Remove button will the remove the selected server from the list. If necessary, you can edit
the server details clicking on the Edit button:

- Edit S5erver x

Server
Edit Selected Server @}

Location: |fuser)jbdevstudiofjboss-soa-p.4.3.0/jboss-as| | Browse... |

Marne: |jbuss—as |

Type: (DI EAP () SDA-P (3) AS

Wersion:

Figure 1.8. Edit Server

» Click Next. Check your installation paths and see the components to install. If you'd like to
change something, press the Previous button. Click Next to start installation.

10
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[ |Boss Developer Studio GA |

Summary Information

Step 7 of 10

Feay 1o install. Imporiant data are listed below. Press “Mext” 1o star installation,
Install ation path
foptfwork)jpds . ga
Java VM path:
jusrjjava/jdkl 50_12)jre
Following components will be installed:
JBE0sE Developer Studid GaA
Eclipse
JBoss Enterprise Application Platform
Disk Space:
Available Disk Space: 1.28 GE
Required Disk Space: £35.9 ME

JB033, & divigion of Red Hat

3 Previous £ Next l €3 Quit

Figure 1.9. Summary Information

1.5. JBoss Developer Studio and JBoss Tools

This section uncovers the points on the differences between JBoss Developer Studio and JBoss
Tools and provides the steps on JBoss Tools installation as well.

1.5.1. What is the difference?

JBoss Tools is what went into our JBoss Developer Studio which comes as an easy-to-install
Eclipse based IDE fully configured and ready to run with the bundled JBoss Enterprise Application
Platform.

In short JBoss Tools are just a set of Eclipse plugins and JBoss Developer Studio adds:

An installer

 Eclipse and Web Tools preconfigured

JBoss EAP with JBoss AS and Seam preconfigured

3rd party plugins bundled and configured

11
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» Access to RHEL and Red Hat Network
» Access to the JBoss/Red Hat supported software

For additional information see JBoss.com

1.5.2. JBoss Tools Installation and Update

Here, let's consider the installation of the JBoss Tools modules.

JBoss Tools is an umbrella project for the JBoss developed plugins that will make it into JBoss
Developer Studio. The JBoss Tools modules are:

» JBoss AS Tools

* Seam Tools

* Hibernate Tools

* Visual Page Editor
» JST Tools

» JBPM Tools

To install the JBoss Tools plugins for Eclipse, you need the following:

» Get Eclipse and Web Tools

The current version of JBoss Tools (3.0.1.GA) targets at Eclipse 3.4.2 and WTP 3.0.4

We recommend you do not use Eclipse.org update site to go from Eclipse 3.3 to
Eclipse 3.4. Instead we suggest that you download the full binary from here.

If you can only use Eclipse 3.3 use JBoss Tools 2.1.2, but JBoss Tools 2.x will not have any of
the new features.

12
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JBoss Tools Installation and Update

* Get the latest JBoss Tools build

Some of our newer plugins, like TPTP and BIRT, need additional drivers. On the left side of the
download page you can find all of the required drivers for chosen build and their versions.

Instead of downloading the nightly build version manually, it's also possible to get the latest release
of JBoss Tools from one of our update sites:

» Stable Updates: http://download.jboss.org/jbosstools/updates/stable

» Development Updates: http://download.jboss.org/jbosstools/updates/development

* Finally, install the build

Unzip the file(s) directly into your Eclipse plugins/features directory and it will be readily available.
It might be necessary to start Eclipse with eclipse -clean to make sure it starts clean and rereads
the new list of plugins.

If you need to install any standalone plug-in from JBoss Tools visit a JBoss Tools Wiki page to
read about dependencies between standalone plug-ins.

You can update Jboss Tools and install a new version with the help of "Install" wizard (Help >
Install New Software...)

13
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3 Install

Available Software

Chack the tems that you wish ta install

Work with: ||Boss Tools Development Release Update Site - hitpi/download,boss.orgjjbosstools/updates/develop ment| by [

Find more software by warking with the 'available Software Sites' p

Mame “arsion

- W " Baoss Tools 3,1.0.M1-M200806060434-H241 (Developmeant Release)

© FrasMarker IDE 1.1.0 M1-M200906060434-H241
[+] &= Hibernate Tools 3.3.0.ML-M200906060434-H241
¥ % |Boss Archives Tools 3.1.0.ML-M2005906060434-H241
@ |Boss BIRT Integration 1.1.0.ML-M200906060434-H241
“u |Boss Drools Core 5.1.0.trunk-MN200206060434-HZ41
[¥] % |Boss Droals Guwnor 5.1.0.trunk-KN200906060434-H241
%y |Boss Drools Task 5. 1.0.trunk-N200906060434-H241
d:és |8oss ESE Tools 1.3.0.ML-M200908060434-H241
- [+] % 1Boss Portlet 1.1.0.M1L-M200506050434-H241
. Il
Details

|Boss Tools 3,1.0,M1-M200906060434-H241 (Development Release) 0.0.0

~ Show only the |atest versicns of available software | Hide items that are already installed
~ Group items by categary what is already installad?

+ Contact all update sites during install to find required software

@ Ea et = ] [ Cancel

Figure 1.10. Updating Jboss Tools

In "Work with" field add the path to the source to update from (e.g. http://download.jboss.org/
jbosstools/updates/development), check the necessary software to install, more information about
chosen software can be found in "Details" section.

Follow "Available Software Sites" link to find more site to update from

14
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b java o httpiidownload.eclipse orgmedelingrmdrupdates! Disabled
Java EE = htipurdownload.eclipse orgtoolsigefrupdatesireleases/sit  Disabled
il httpyidownload eclipse orgiwebtoolsfupdates Disabled

[ |Boss JBPM

o |Boss Tools

I Plug-in Development
Froject Archives

P Runekug

I Server

-

Team
wWalidation
Wwalb

Wab Sanvices
“Doclet

XKML

A

@ C

Figure 1.11. Available Software Sites

1.6. Welcome to JBoss Developer Studio

In this section we'll show you how to work with the welcome page of the JBoss Developer Studio.

The welcome page is the first page you see when you first launch JBoss Developer Studio.
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) Welcome 25 )

Welcome to
JBoss Developer Studio

e -~ T @

Getting Started Create New... Perspectives Web Resources
Workbench

Figure 1.12. Welcome to JBoss Developer Studio

With the help of its page you will be able:

 to get quick access to Getting Started Documentation (guides, tutorials and viewlets)
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& Welcome 232 i

Welcome to
JBoss Developer Studio

Getting Started

JBoss Developer Studlo Is a set of eclipse-based development tools that are pre-configured for
|Boss Enterprise Middleware Platforms and Red Hat Enterprise Linux. Developers may find these
pre-configured tools offer significant time-savings and value, making them more productive and
speeding time to deployment.

I . Getting Started with |Boss Developer Studio
! Geftting Started with |Boss Developer Studio.

[ % Viewlets and Tutorials

e Hibernate Console Viewlets
@, Hibermnate Tools Viewlets illustrating various parts of Hibernate Tools.,

~ _ ]JBoss Seam Tutorial
& |Boss Seam Reference Guide and Tutorial

— _ WTP JZEE Tutorials
= Web Tools Platform | 2EE Tutorials

e & T e &

Getting Started Create New... Perspectives Web Resources Workbench

Figure 1.13. Getting Started Documentation

« to create new Seam projects, jBPM Process, JSF or Struts projects using JBDS wizards
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e R

Welcome to
JBoss Developer Studio

Create New...
Start using |Boss Developer Studio
|Boss Developer Studio includes a New Seam Project Wizard that allows you to setup project for full

featured web application in Seam. You can use any combination of Java EE frameworks integrated to |Boss
Seam.

L " Create Seam Project

| o

- Create |BPM Process Project

il
E| |Boss Developer Studio includes a New JBPM Process Project that allows you to create applications
using jBPM Frameweork

" Create |SF Project
‘_] |Boss Developer Studio allows you to create brand new |SF projects. A new |SF project will have all JSF
libraries, tag libraries and a JSF configuration file. |Boss Developer Studio comes with a number of
predefined project templates. These templates are flexible and easily customizable.

7 Create Struts Project
S |Boss Developer Studio includes a New Struts Project Wizard that radically simplifies the process for getting
started with a new Struts project.

e H = e e

Getting Started Create New... Perspectives Web Resources Workbench

Figure 1.14. Create New...

« to get short description of perspectives that JBBDS offers for more productive development
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.m' e o ==

Welcome to
JBoss Developer Studio

Available

|Boss Developer Studlo offers a number of perspectives making the development more productive

=== )ava EE Perspective
The Java EE perspective includes workbench views that you can use when developing resources for
enterprise applications, EJB modules. Web modules. application client modules, and connector projects or
modules,

I_l Seam Perspective
I_Il" J The Seam perspective helps you to use all advantages of Seam Framework in your applications.
=

=== Database Development perspective
The Database Development perspective allows you to create, modify, and execute database objects and
SOL files.

FSSS= Hibernate Console perspective
The Hibernate Conscle perspective allows you to configure database connections, provides visualization
of classes and their relationships and allows you to execute HQL queries interactively against your
database and browse the query results,

e ® = " .

Getting Started Create New... Perspectives Web Resources Workbench

Figure 1.15. Perspectives

* to visit JBoss Developer Studio web resources.
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= Welcome &3 1

Welcome to
JBoss Developer Studio

Related Links

JBoss Developer Studio Web Resources

Forum
_____ M |Boss Developer Studio Users Forum

News
_@x News on |Boss Developer Studio

e & = ®© o

Getting Started Create New... Perspectives Web Resources Workbench

Figure 1.16. Web Resources

Start work with JBoss Developer Studio by clicking on Workbench button or simply close the
Welcome page.

1.7. Upgrading

To upgrade, just uninstall your current version and install the new one.

1.8. Uninstalling

» Make sure JBoss Developer Studio is not running

« Uninstall your current version of JBoss Developer Studio by running Uninstaller

1.9. Support

If you have comments or questions, you can discuss them at our JBoss Developer Studio Forum.

When writing to the forum for questions, please include the following information:

1. JBoss Developer Studio version
2. Exact error message
3. Steps to reproduce the issue

JBDS subscribers can get necessary support on our Support Portal.
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Other relevant resources on the topic

1.10. Other relevant resources on the topic

JBDS on JBoss: JBoss Developer Studio

Forum: JBoss Forum

Subscription: JBDS Subscription

The latest documentation builds are available here.
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Chapter 2.

Manage JBoss AS from JBoss
Developer Studio

In this chapter we'll focus more on how to operate the JBoss AS from JBoss Developer Studio.

JBoss Developer Studio is shipped with JBoss EAP . When you followed the default installation of
JBoss Developer Studio, you should already have a JBoss EAP 4.3 Server installed and defined.
To run JBoss AS you need JDK 1.5, JDK 6 is not formally supported yet, although you may be
able to start the server with it.

2.1. How to Manage the JBoss AS Bundled in JBDS

This section covers the basics of working with the JBoss Server supported directly by JBDS via
bundled AS plug-in. To read more about AS plug-in, refer to the Server Manager guide.

2.1.1. Starting JBoss Server

Starting JBoss Server is quite simple. JBoss Developer Studio allows you to control its behaviour
with the help of a special toolbar, where you could start it in a regular or debug mode, stop it or
restart it.

* To launch the server click the green-with-white-arrow icon on the JBoss Server View or right
click server name in this view and select Start . If this view is not open, select Window > Show
View > Other > Server > JBoss Server View

{5 Problerns | & Tasks | - Seam Components |©J |Boss Sanver Wiew £ = Q| & 507 =8

~ i jboss-aap [Stopped, Synchronized] IStart the serve

% ISFKickstart [Synchronized]
4 Filesets

= ¥ xmML Configuration
b = Ports

Figure 2.1. Starting from Icon

While launching, server output is written to the Console view:
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£ Problems | & Tasks

‘4 |Boss Server View

|Boss-server 4.2 [|Boss Application Server] fusrfjavafjdkl 5.0_12/minjava (jul 11, 2007 4:31:14 PM)

= Ga &0 4 Ev e

16:31:17, 324 INFO [Server] Starting JBoss (MX MicroKernel)... [<]
16:31:17, 378 INFO [5erver] Release ID: JBoss [EAFP] 4.2.0.6A (build: SVNTag=]BFAPF_4_2 0 _GA d
16:31:17,373 INFO [Server] Home Dir: fopt/work/rhds_beta/jboss-eap/jboss-as

16:31:17,373 INFO [Server] Home URL: fTile:/foptfwork/rhds_betasjboss-eap/sfjboss-as/
16:31:17, 377 INFO [Server] Patch URL: mull

16:31:17,378 INFO [Server] Server Name: default

16:31:17, 379 INFO [Server] Server Home Dir: fopt/work/rhds_beta/)jboss-eap/jboss-as/server/de
16:31:17, 381 INFO [Server] Server Home URL: file:/opt/work/rhds_beta/jboss-eap/jboss-as/sery
16:31:17,382 INFO [Server] Server Log Dir: fopt/work/rhds_beta/jboss-eap/jboss-as/server/def
16:31:17, 384 INFO [Server] Server Temp Dir: fopt/work/rhds_beta/jboss-eap/jboss-as/server/de

16:31:17,396 INFO [Server] Root Deployment Filename: jboss-service. xml
16:31:19, 103 INFO [ServerInfTo] Java version: 1.5.0_12,5un Microsystems Inc.

16:31:19,118 INFO [ServerInfo] 05-5ystem: Linux 2.6.18-8.el5xen, 1386
16:31:20,559 INFO [Server] Core system imitialized
16:31:29,515 INFO [WebService] Using RMI server codebase: hittp://127.0.0.1:8083/

16:31:32,045 INFO [TransactionManagerService] JBossTS Transaction Service (JTA version)
16:31:32,829 INFO ([TransactionManagerService] Starting recovery manager

16:31:33, 323 INFO [TransactionManagerService] Recovery manager started
16:31: 33,325 INFO [TransactionManagerService] Bimding TransactionManager JNDI ReTerence

16:31:19, 187 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_12-bB4,Sun Microsys|

16:31:29,534 INFO [LogdjServicefURLWatchTimerTask] Comfiguring Trom URL: resource: jboss-logd

- J8

16:31:32,049 INFO [TransactionManagerService] Setting up property manager MBean and JMX laye

] ' I

Figure 2.2. Console Output

When the server is started you should see Started in the square brackets right next its name
in JBoss Server View.

- ra -

[ Problems | 4 Tasks | Seam Components <2 JBoss Serverview £ . ¥ O & m £ T 0O

il jposs-eap [Started, Synchronized]
% ISFKickStart [Synchronized]
|5 Flesats

= [§) XML Configuration
[ = Ports

Figure 2.3. Server is Started

2.1.2. Stopping JBoss Server

To stop the server, click the Stop icon in JBoss Server View or right click the server name and
press Stop.

24



Server Container Preferences

I g r =
[ Problems | & Tasks . Seam Components =3 |

%
Ictop the serve

* i jposs-eap [Started, Synchronized]

% J5FKickStart [Synchronized]
|5 Filesats

=[] ¥ML Cenfiguraticn
[ = Pors

Figure 2.4. Stopping Server
When the server is stopped you will see Stopped in the square brackets next to its name.
2.1.3. Server Container Preferences

You can control how JBoss Developer Studio interacts with server containers in the Server editor.
Double-click the server to open it in the editor.
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) |Boss 4.2 Server

3 Overview

General Information

Specify the host mame and other common settings.
Sarver name; |Boss 4.2 Server

Host name: loealhast

Funtime Environment: |__|Bl.':|55 4.2 Runtime

L]

Opan launch configuration

- Deployment

The temporary deploymeant location is where files will
be copied to before being renamed into the deploy directony:
This falder shauld be an the same file system

as the deploy folder.
& Usa workspace metadata (does not modify |Boss deploy falder]
Lise the |Boss deploy folder
7 Use a custorn deploy folder
Deploy Directery
lemporary Deploy Directory
[ Deploy projects as compressed archives

= Login Credentials

Set the login and password for vour server,
This will ensure it starts and stops properly.

ser Mame admin

Password admin

Browse...

Brawse...

*: Publishing
b Timeouts
 Server Polling

Startup Paller [JMK Poller o |

Y

Shutdown Paller [ Process Terminated Pollar 2

- Server Ports

The parts entared hare are which ports the toals
will poll the server on. Changing these fields
will nat change the ports the server tself listans

[MDI Port ¥ Automatically detect

Wwab Port ¥ Auternatically detect

|

Owvarview

Figure 2.5. Server Overview

Here you can specify some common settings: host name, server name, runtime as well as settings

related to the publishing, timeouts and server ports.

2.2. How to Use Your Own JBoss AS Instance with

JBDS

Although JBoss Developer Studio works closely with JBoss EAP 4.3 we do not ultimately tie you to
any particular server for deployment. There are some servers that Studio supports directly (via the
bundled Eclipse WTP plug-ins). In this section we discuss how to manage self-installed JBoss AS.
Suppose you want to deploy the application to JBoss 4.2.3 server. First of all you need to install it.
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JBoss AS Installation

2.2.1. JBoss AS Installation

» Download the binary package of JBoss AS, e.g. JBoss 4.2.3 and save it on your computer:
http://labs.jboss.com/jbossas/downloads

It does not matter where on your system you install JBoss server.

; The installation of JBoss server into a directory that has a name containing spaces
provokes problems in some situations with Sun-based VMs. Try to avoid using
installation folders that have spaces in their names.

There is no requirement for root access to run JBoss Server on UNIX/Linux systems because
none of the default ports are within the 0-1023 privileged port range.

» After you have the binary archive you want to install, use the JDK jar tool (or any other ZIP
extraction tool) to extract the jboss-4.2.3.GA.zip archive contents into a location of your choice.
The jboss-4.2.3.GA.tgz archive is a gzipped tar file that requires a gnutar compatible tar which
can handle the long pathnames in the archive. The extraction process will create a jboss-
4.2.3.GA directory.

2.2.2. Adding and Configuring JBoss Server

Now we should add just installed server into server manager in JBoss Developer Studio.

e Open the JBoss Server View by selecting Window > Show View > Other > Server > JBoss
Server View

 Right click anywhere in this view and select New Server

» Select JBoss Community > JBoss 4.2 Server
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MNew Server

Define a New Server
Choose the type of server to create Igr

Server's host name: Iluﬁlhurst l

Select the server type:
I ype hlter text

b = BM

= = |Boss Community
‘W |Boss AS 3.2
“J |Boss AS 4.0

“J |Boss AS 5.0

“J |Boss Deploy-Only Server
b (= |Boss Enterprise Middleware

b @ Objectweb N
|Boss Application Server 4.2 -
Server name: |JBoss AS 4.2 at localhost

@ [ = Back ]I Mext > I I Einish ] [ cancel

Figure 2.6. Selecting Server Type

' Note:

* To create a new runtime, which Jboss AS 4.2 matches to, click Next

* In the next step make JBoss Developer Studio to know where you have installed the Server
and define JRE.
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Adding and Configuring JBoss Server

Mew Senver Runtime Environment

Edit a |Boss Runtime
|Boss Application Server 4,2

A |Boss Server runtime references a |Boss installation directory
It can be used to set up classpaths far prajects which depand on this runtime,
as well as by a "server' which will be able to start and stop instances of |Boss.

MName

[_]ans 4.2 Auntirme ]

Home Directony

I.‘Bpt!]buS*s-d.E.E.GA r |Brnwsa...|
JRE

[Defauh: |RE :]
Configuration

Directory: |ggmar I Browse...

41 all copy...

A rminimal

@ = Back | [Wext = | | Cancel ] I Einich

« Inthe next dialog verify the specified information and if something is unfair go back and correct it
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New Server

Create a new |Boss Server .l

.. B .
|Eoss Application Server 4.2

og 4.2

A |Boss Server manages starting and stopping instances of |Boss,
It manages cammand line arguments and keeps track of which medules have been deployed.
Funtime Information

if the runtime information below is incorrect, please press back, Installed Runtimes....
and then Add to ereate a new runtime fram a different location,

Harme Directory Jopt/jboss-4.2.3.GA

|RE jusrlibjwmyjava-1.5.0-sun-1,5.0.16 (java-1.5.0-5un-1.5.0.158)
Configuration Location senver

Configuration default

Cancel Einish

Figure 2.8. Configuring Projects

« Inthe last wizard's dialog modify the projects that are configured on the server and click Finish .
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New Server x
Add and Remove Projects

Maodify the projects that are configured on the server

Mowve projects to the right to configure them on the server

Available projects: Configured projects:

(& |SFKickStan

Add Al ==

(] || Einish |[ Cancel ]

Figure 2.9. Configuring Projects

A new JBoss Server should now appear in the JBoss Server view.

p - - = —— - - ",
[%i Problems | £ Tasks | - Seam Compaonents | s Server View & . ¥ O & ge = =0

* o |Boss 4.2 Sanver

% J5FKickstart

4 Filesets
= & XML Configuration
I (= Ports
b ©J jboss-eap [Stopped, Synchronized]

Figure 2.10. New JBoss Server

Now, we are ready to create the first web application.
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Chapter 3.

Write Your First Project with JBoss
Developer Studio

This chapter is a set of hands-on labs. You get step-by-step information about how the JBoss
Developer Studio can be used during the development process.

3.1. Create a Seam Application

In this section you get to know how to create a Seam project in JBDS, how to start the server and
what a structure your project has after creating.

3.1.1. Start Development Database

Before opening the JBoss Developer studio you need to download and start a Workshop
Database.

To start the database just run ./runDBServer.sh or runDBServer.bat from the database directory.

The end result should be a console window that looks like:

| Terminal
File Edit Yiew Terminal Taps Help

Starting database engine... =l
[Server@la?58ch]: [Thread[main,5,main]]: checkRunning(fTalse) entered
[Server@la?58ch]: [Thread[main,5,main]]: checkRunning(false) exited
[Server@la758cbh]: Startup sequence initiated from main() method
[Server@la?58cbh]: Loaded properties from [/fopt/work/database/database/server.pro
perties]

[Server@la?58cbh]: Initiating startup seguence...

[Server@la7?58ch]: Server socket opened successfully in 19 ms.

[Server@la?58ch]: Database [index=08, id=8, db=Tile:employee, alias=] opened suce
ssTully in 938 ms.

[Server@la758ch]: Startup sequence completed in 964 ms.

[Server@la?58ch]: 2007-12-29 15:55:32.311 HSOLODB server 1.8.0 is online
[Server@la758chb]: To close normally, connect and execute SHUTDOWN SOL
[Server@la758cb]: From command line, wse [Ctrl]+[C] to abort abruptly

Figure 3.1. Starting DataBase

3.1.2. Create and deploy Seam Web Project

Minimize the terminal window and run the JBoss Developer Studio from Applications Menu or
from the desktop icon.
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First of all you get the Workspace Launcher. Change the default workspace location if it's needed.
Click on Ok.

Workspace Launcher

Select a workspace

|Boss Developer Studio stores your projects in a folder called a
workspace.

Workspace: [/froot/workspace | o ] [ Browse...

D Use this as the default and do not ask again

[GK] [ Cance

Figure 3.2. Workspace Launcher Dialog

After startup, you see the welcome page. You could read how to work with welcome pages in
previous chapter. Now select Create New... icon and then press on Create Seam Project link.

The New Seam Project wizard is started. You need to enter a name (e.g., "workshop") and a
location directory for your new project. The wizard has an option for selecting the actual Server
(and not just WTP runtime) that will be used for the project. This allows the wizard to correctly
identify where the needed datasource and driver libraries need to go.
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Create and deploy Seam Web Project

Mew Seam Project

Seam Web Project ‘\E' '5;”
Create standalone Seam Web Project T\—',./j
[
Project name: [workshup ]
Contents
& Use default

Target Runtime

| |Boss EAP 4.3 Runtime S| [New...|

Dynamic Web Module version

[2-'-" o

Target Server

[Jsuss EAP 4.3 Server v ] [Nuw |

Configuration

[D}rnamic Web Project with Seam 1.2 o ] |Mo|:!ify._.]

Configures a Dynamic Web application to use Seam v1.2

Figure 3.3. New Seam Project Wizard

All settings are already specified here, you can just modify the Configuration. Click on the Modify...
button to configure your custom facets pattern:
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Project Facets

Project Facets
Select the facets that should be enabled for this project.

Configurations: ’Dynamic Wweb Project with Seam 1.2

. Project Facet \ersion

(W B Axis2 web Senvices

[] Lz Dynamic Web Module 25
Ml ¢l Java 5.0
[] 4 Java Persistence 1.0
[ & Javascript Toolkit 10
[+ ] JavaServer Faces 1.2
1 &l Jeoss ESB 4.3

b [ £ JBoss Portlets

b [ [ JBoss web Services
¥ [ Seam 1.2
[ [ webDoclet (xDoclet) 1.2.3

Details | Runtimes

_\’?

¢-|[5wehs... | Delete |

| Axis2 Web Services

Enables Web senices generation
through the Axis2 web services engine.

| cancel

Figure 3.4. Project Facets Specifying

On the whole the dialog allows to select the "features" you want to use in your project. Doing
this JBoss Developer Studio setups the appropriate tooling for your project. Since JBoss Seam
integrates all popular Java EE frameworks, you can select any combination of technologies from
the list. Here, for the default configuration, Dynamic Web Module, Java, JavaServer Faces (JSF),
and Seam Facet are already selected for a typical database-driven web application. The default

project facets should suffice.

In the Project Facets form you can also bring up server runtimes panel by clicking Runtimes tab
on the right corner. This panel shows available server runtimes.
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Project Facets

Project Facets )
Select the facets that should be enabled for this project. \1?
Configurations: !Dynamic web Project with Seam 1.2 2 ] [ Save As... [ Delete ]
Project Facet Wersion Details Fl.lntlmes|
K . i ME‘: W'Eb SET\HEGE E I.ﬂ'.:: ]ans 4.2 mntlme
@ Dynamic Web Module 25
&l Java 5.0
[[] 4+ Java Persistence 1.0
[ [ Javascript Toolkit 1.0
[ Javaserver Faces 1.2
[ 2 jposs ESB 4.3

b [ £ |Boss Portlets
b [ [ Jposs web Services

[} seam 1.2
[ [ webDaclet (xDoclet) 1.2.3
[[] Show all runtimes
- MNew... l
(] i B
@ oK | [ Cancel ]I

Figure 3.5. Runtimes Selecting
Click on Ok and then Next to proceed further.

A dynamic web application contains both web pages and Java code. The wizard will ask you
where you want to put those files. You can just leave the default values or choose another folder.

37



Chapter 3. Write Your First P...

Y New Seam Project

x
Web Module a
Configure web module settings. E "

Context Root:

[wnmshop

Content Directory:

\WebContent |

Java Source Directory:

[src |

Generate Deployment Descriptor

)] I < Back ]rrﬂext::-II Einish ” Cancel

Figure 3.6. Web Module Settings

On the next form, you will be able to select where those library JARs come from. The easiest is
just to select the JARs provided by the JBoss AS runtime associated with this project. That is why
it is important to chose the right JBoss AS 4.2 runtime in the project setup window.

e Check Server Supplied JSF Implementation . We will use JSF implementation that comes with
JBoss server

¢ Click Next
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Create and deploy Seam Web Project

Foio)

Mew Seam Project

x

|SF Capabilities _ o

Add |SF capabilities to this Web Project E J
I Al @ Server Supplied JSF Implementation

Campaonent Libraries
Deploy Library Mame
[ == | |

J5F Configuration File: [NiEE-INFﬂaces-c onfig . xmil ]
J5F Serviet Name: [Faces Serviet |
|SF Serviet Classnarme: [jauax.ra: es webapp FacesSarviet ]
URL Mapping Pattems: |« coazm
(i3] [ < Back ]ruext:a- 1 [ Finish ] | Cancel |

Figure 3.7. JSF Capabilities Adding

Next wizard step needs more settings that previous. Let's start with General section.

Leave the default Seam runtime and check a WAR deployment.

£n
ey

New Seam Project x

Seam Facet \1}2_
Configure Seam Facet Settings T‘.\;')
L%

General

Seam Runtime: | Seam 1.2 AP :i [Aﬂu...]

Deploy as: 3 WAR () EAR

Figure 3.8. Seam Facet Setting

Next Database section is a little tricky. The Connection Profile needs to be edited so that the new
project works properly with the external HSQLDB server. By default the project wizard tries to use
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the JBoss embedded HSQLDB, but the tutorial uses an external database to replicate a more real
world development scenario. Click on Edit to modify the Connection Profile.

Database
Database Type: | HSQL = ]
Connection profile: | Default H | |iEdit...] [New...l

Database Schema Name: [ |

Database Catalog Name: | ]

DB Tables already exists in database: (||

Recreate database tables and data on deploy: []

Figure 3.9. DataBase Setting

Select JDBC Connection Properties. Make sure the URL is set to jdbc:hsgldb:hsql:/
localhost:1701

#h
]

Properties for x

[L‘ype filter text ] JDBC Connection Properties

Common Select a driver from the drop-down:

Default Schema Filter
| Hypersonic DB

Default Stored Procedure Fiter

Default Table Filter Database: |SAMPLE
JDBC Connection Properties URL: [pum: ‘hsgldb:hsgl:flocalhost: 1701
Version

User name: |sa

JUUU®

Password: [

[] Save Password

Figure 3.10. JDBC Connection Properties

Try click on Test Connection button. It probably won't work. This happens if the hsql jdbc driver
is not exactly the same. This can be worked around by modifying the HSQLDB database driver
settings. To modify the settings, click the “...” next to the drop-down box.

The proper Driver JAR File should be listed under Driver File(s). Select the hsqldb.jar file found
in the database/lib directory and click on Ok.
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Edit Driver Definition

Provide Driver Details

mMadify details in the fields below to provide a unigue name, a list of requirad
jars. and set any availzble and applicable property valuas.

Mamefype |JarL|st| Properties

Criver files:
fhomefvchukhutsing/jbdevstudiofjboss-eap/jboss-as/server/defaultlibR Yl JRT .o

Edit |AR/Zip...
Bemowve |AR/Zip
Claar all

i : cCancel

Figure 3.11. Driver Details

Select Hypersonic DB and click on Ok. Again, this only happens if the selected hsqldb.jar is

different from the running database.
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Driver Definitions x
Avallable Driver Definitions

Add, edit, or remove driver definitions to manage available driver
definitions.

[»]

- 0 Derby
C& 100
G101

(3 10.2 Remove

Cd Generic |DBC Driver Caopy

= [ Hypersonic DB
- Gk1s

i Hypersonic DB

= U Informix
G100
G 9.2
Gko3
G 0.4

= 3 MysQL
G40 |
ka1
k5.0
G&51

- % Oracle
%10

7 [ oK ” Cancel I

Figure 3.12. Hypersonic DB Selecting

Now, the Test Connection should succeed. After testing the connection, click on Ok.
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-

& Properties for [E]

[l:ype filter text ] JDBC Connection Properties . .

Common Select a driver from the drop-down:

 Hypersonic DB = [:]
I
l
|
]

Default Scherma Flter

Default Stored Procedure Filter

Default Table Filter Database: [S“AMH'E

JOBC Connection Properties URL: [j:lbc ‘hsgldb:MyDE

WVersion

User name: [sa

Passwaord: [

[ Save Password

@ Ping succeeded!

Jest Connection

(i oK ][ Cancel ]

Figure 3.13. Connection Testing

You can leave the Code Generation section as is. It refers to Java packages in which the generated
code will be placed.
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Code Generation

Session Bean Package Mame: |org.dumain.wurkshup.sessiun ]

Entity Bean Package Name: [nrg.dnmaln.wnmshup_enﬁw |

Test Package Mame: |org.dumain.wnrk5hup_test ]

@ | < Back

Cancel |

Figure 3.14. Code Generation Setting

Click on Finish button. Now, there should be a new Seam project called “workshop” listed in
Package Explorer view.

ek, > oo T

-

5

w ¥ workshop
by srefhot
b (8 ercfrmain
P+ =4 JRE Systern Library [java-1.5.0
I» @m0 )Boss 4.2 Runtime [|Boss 4.2 F
P = Web App Libraries
= build
P (= resources
= ere
b = wWebContent
hibernate-console properties
[ workshop launch
- =Sworkshop-test
P (®Btest-src
I m Referenced Libraries
I =4 JRE Systern Library [java-1.5.0
= lib

al I [2]

Figure 3.15. "worskhop" Project in the Package Explorer

3.1.3. Start JBoss Application Server

The complete information on how to manage JBoss AS from JBoss Developer Studio you can
read in a corresponding chapter.
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Now you just need to start the server by clicking
on the Start the server icon (
o

) in the JBoss Server View.

Then run the project by selecting the project and use Run As... > Run on Server.

Your project looks like this:

r@ workshop ﬁ\ =g

@ . |hitp:iocalhost:8080/workshop/home seam AMEN |
warkshop: Home Login
Welcome!
This empty sheld appleation inclides:
* Anl buid scripl

# Deployment to JBoss AS

* [negration lesting using TestNG and JBoss Embeddable EJB3
# EJB 3.0 Seam components

# Templated Facedats views

®* HSOL (or MyS0L) Dalasource

# Defauk G5S styleshest

* Infernationalz ation support

Povwarad by Soam. Ganralad Iy Seam-gen,

Figure 3.16. "workshop" Project Started

3.1.4. Workshop Project Code Overview

Now let's examine the project and its structure. Go back to the Package Explorer view in JBoss
Developer Studio.

It seems like it's not much for project but this shell application contains a login screen with default
login logic, a menu template that can be further modified, and other layout templates.

It's important to note that the business logic will reside in the src/hot folder, by default. And,
the package naming conventions that were used in New Seam project wizard could have been
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changed to something different from org.domain.workshop.session. Also, notice that there is a
default Authenticator. java file. This is where custom security logic can be added. Seam has a nice
declarative security model that we will explore in a bit more detail later on. The src/main folder
is a model directory. It stores the project's JPA entity beans.

[§ packagaEx 3 . [[oProjectExpl = O
= & ~|

v = workshop =4
b 18 org.domain.workshop.session
seam properties
= {®srcfmain
b i# org.domain.werkshop.entity
P META-IMNF
[E components . properties
[ import.sql
[E messages_en.properties
[E seam.properties
) security.drl
I» =3 RE Systern Library [java-1.5.0-s5u
I+ =i |Boss 4.2 Auntime [|Boss 4.2 Rurl
[ mi web App Libraries
(= build

I (= resources

(=, &re ot |

Figure 3.17. Project Structure

The view tier of the application is also important. Seam uses facelets and there is a built-in facelets
GUI editor that has some nice WYSIWYG and component drag/drop functionality. Try this out by
opening home.xhtml from WebContent folder.
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[% Package =2 . [5Project € | = O o home.xhtmi

= s = <!DOCTYPE composition PUBLIC "-//W3C//DTD XHTML 1.0 Transitional/
o "http://www.w3.0rg/TR/xhtml1/DTD/xhtmll-transitional .dtd
= T2workshop <ul:composition xmlns="http://www.w3.org/1999/xhtml "
b @@ srehot xmlns:s="http://jboss. com/preducts/seam/taglib"
- smlns:ul="http://java.sun.com/jsf/facelets”
P (2 srefmain xmlns:f="http://Java.sun.com/jsf core”

xmlns:h="http://java.sun.com/jsf /html~

I m RE System Library [java-1 : -
— B rery i smlns:rich="http: /srichfaces.arg/rich”

b mi)Boss 4.2 Runtime [|Boss 4. template="layout/template. xhtml *=
I =i web App Libraries .
<ul:define name=*body*>
(&= build
I (= resources <h:messages globalOnly="true" styleClass="message”/> o
& sre ! AL ]
= = WebContent - B
P = im . "
& img | Hoojectiame):  Home s{identity. Login  Logout
P = layout ®
P (= META-INF By Errar Messages
P (= styleshest Welcome!
P = WEB-INF
This emply shel appbeation nclides
i errorxhtmml
» Ant buid scrpt
# Depioyment to JBoss AS (EAR or WAR)
; » Development and producton profes
o indesx htrml « Integration testing using TestNG and Embedded JBoss
i . » JavaBean or EJB 3.0 Seam components [
= login.page xmil P,
a login.axhtml | ]
T | visu al/Source Source Preview

Figure 3.18. Facelets GUI Editor

Notice that the templates reside in the WebContent/layout folder. There is a stylesheet in the
WebContent/stylesheet folder. There is also a login and default error page. The Facelet editor
will be explored in more detail later in the lab.

The project already has a datasource that was created per the Seam project wizard database
settings. And, obviously all of the Seam specific configuration files and JAR dependencies are
included and placed in the proper locations. On last noteworthy line item is related to the build
script. There isn't a build script because the Eclipse WTP(Web Tools Project) plugin is used to
publish web application changes. As you can see, JBoss Developer Studio is removing a great
deal of complexity from the enterprise Java project setup/deployment process. The end result is
a developer that is writing code, not spending days/weeks trying to figure out how to get a decent
development environment and project build process.

3.2. Seam Action Development

Now, it's time to write some code. The good news is that JBoss Developer Studio can also help
out in this respect. In this section, we will create a new Seam Action POJO and facelet with some
custom business logic and some GUI changes.

3.2.1. Create a New Seam Action

Go to main menu bar and click on File > New > New Seam Action to start the New Seam Action
wizard.
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Specify a Seam component name (e.g., "myAction"). The other properties will be auto-completed
for you so there is no need to change them. Click on Finish.

£ New Seam Action x|

Seam Actlon

Create a new Seam action L_' s
Seam Project: [wumsnup Brnwse...l Seftings..
Seam component name: [myﬂ.ctin:ln ]
POJO class narme: [Myﬂ.ctmn ]
Method name: [mwﬁ.ctiun ]
Page name: |myAcliun |
Package name: [urg.uumain.wnmshnp.sessiun ] Browse. ..
@ E Finish ] | Cancel

Figure 3.19. New Seam Action Wizard

Now, open the MyAction.java file and replace the "myAction" method with this logic:
public void myAction() {

Calendar cal = Calendar.getinstance();

log.info("myAction.myAction() action called");
facesMessages.add("MyAction Executed on:" + cal.getTime());

}

You also need to import the java.util.Calendar class by clicking CTRL + Shift + O.

3.2.2. Test Seam Action

The new action can be tested by browsing the workshop-test project. JBoss Developer Studio has
already created a TestNG test case for you.
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Test Seam Action

% Package Explorer 3% . =g| . =8
= 4 v | package org.domain.workshop.test;
b (= resources /| #®import org.testng.annotations.Test;[!
= sre

N public class MyActionTest extends SeamTest {
I = wWebContent

M hibernate-console properties = @Test
public void test() throws Exception {

i@ workshop.Jaunch = new FacesRequest() {

= = workshop-test ~ @override
~ -~ protected void invokeApplication() {
= test-sre
& Sfcall action methods here
= i} org.domain warkshop test invokeMethod("#{myAction. myAction}");

+ I MyActionTest java ¥
)
}

|¥] MyActionTest xrml
I (= META-INF - i
[ components_properties
I ® embedded-ejb
P mA JRE System Library [jdk1.5.0_12;
I = Referenced Libraries

= lib E

& ] B || GI D]

Figure 3.20. "workshop-test" Project
The test case simulates a Seam component/method execution for the MyAction.myAction() logic.

To run the test case, right click on MyActionTest.xml and click Run As > TestNG Suite or use
the Run As... toolbar shortcut as shown below.

| s |- 0- Q- & [B@o-| /|02 noee i
.E & e ..HIWEhI'EEDUFEE

W Aun As N .5 1 Run on Server Shift+Al+X R

3 Open Rup Dialeg... : 2 TestNG Suite Shift-+Al+X G

. Qrganize Favortes... |
I = workshop ~——wxz#port org.testng.annotations.Test;|]

= = workshop-test
- P public class MyActionTest extends SeamTest {

= [# test-src

- _damain workshop test @Test
& org.domain.wo ap es [ public void test() throws Exception {
P[] MyActionTest java [ & new FacesRequest() {
B MyActionTest xmi [ ® @Override
| protected vold invokeApplication() {
[ = META-INF | Jfeall action methods here
B components properties [ invokeMethod (“#{MyAction. myAction}"};
[ 1
P (# embedded-ejb }.run();
I = JRE System Library [jdk1.5.0 12| H
[ = Referenced Libraries [ }
=y

Figure 3.21. TestNG Running

With any luck, the test case will pass. Look at the TestNG view.
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zEi MyAction java [E] MyActionTestjava 3 ; =0

[ package org.domain.workshop.test;
#import org.testng.annotations.Test;[]
public class MyActionTest extends SeamTest {

= @Test
public void test() throws Exception {
= new FacesRequest() {
= @0verride
L protected vold imvokeApplication() {
ffcall action methods here
invokeMethod (" #{myAction. myAction}”);

1 =]
| Il D
-~ — r - -~ ~
Ll consale [*T.J |Boss Server \ﬁewm Q 2@ ¥=0O
| Tests: 1 Methods: 1/1 (12112 ms) L Passed 1 B Failed: 0 @ Skipped: 0
i All Tests | p® Failed Tests| = Failure Exception £

= [ workshop-test { 1/0/0/0 )

v ..r'! org.domain workshop test MyActionTest [ 1/0/0/0 )

£ test

Figure 3.22. TestNG Results

Now, it's safe to test the new Seam Action in a web browser. The fastest way to do that is to right
click on myAction.xhtml and use Run As... > Run On Server which will show the appropriate url in
the browser. Alternatively you can manually enter http://localhost:8080/workshop/myAction.seam
into a browser.

Frcegespme s 70 Quonsp "o

i BB 7| ® & |nitp:/ocalnost:8080/workshop/myAction.seam| ¥ | b [l
............... . =

workshop:  Home Login
I* (= META-INF
P (= stylesheet
b 5= WEB-INF ® MyAction Execubed on:Sun Dee 30 02:20:06 MSK 2007
o error.xhtmil myAction

o home xhimil

o index_himi B EE

4% login.page xmi

m 10g|l'l.3l|1t|"f'|| Powerod by Seam . Gonorabod by seam.-gan
i myAction . xhtmml -

& hibernate-console properties

|| workshop launch

P 1= workshop-test
(=] i D]

(4]

Figure 3.23. Seam Action in a Web Browser
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3.2.3. Modify Seam Action User Interface

Browse to http://localhost:8080/workshop/myAction.seam and click on myAction. This executes
the “myAction” method. This looks pretty good, but we could make this page look a little better.

Open WebContent/myAction.xhtml in JBoss Developer Studio to use the nice facelets editor.

=0

xmins:
*mLlns:
KMLnS:
xmLns:
*MLns:
*mlns:

=ui:define name="body*

*7 <!DOCTYPE composition PUBLIC *-//W3C//DTD XHTML 1.8 Transitional//EN"

"http: //www.w3.org/TR/xhtmL 1/DTD/xhtmll-transitional.c

<ul:composition xmlns="RTEp: . //wwwW.w3.org/1999/xhtml"

s="http://jboss. com/products/seam/taglib”
ui="http://java.sun.com/jsf/facelets”
f="http://java.sun.com’jsf/core"
h="http://java.sun.com/jsf /html"™
rich="http://richfTaces. ajaxd]sT.org/rich”
a="https://ajax4jsf.dev.java.netl/ajax"

template="layout/template.xhtml” >

=

[

—

- w

ﬁfln{n|u1u~|-uu:mu|.m1:n«ﬂ

@

Eh Error Messages
myAction

I

X [

Visual/Source | Preview |

Figure 3.24. Open Seam Action with Editor

Right click on the "myAction!" button in the visual part of editor and select <h:commandButton>

Attributes.
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-

- ¢ | Normal :HNGFIT‘I3| 3/ B r u Z A
[a]
X #{projectMame):  Home Welcome, #{identity.username}  Login - Logeut )
@&
% Ermror Messages
myAction
:-::-urnm.andﬁm_tmn.‘- Aftributes |
Farent Tag 4
_ ]
3
ui:composition ui:defin oot Around dButton s
Vieual = | Insert Before r
sual/Source view Insert After "
Cut
Copy
Paste
Remove

Figure 3.25. Seam Action Editing

Change the value of the button to something different. If desired, you can change any other text
on the page. Then, type CTRL + S to save the facelet.

=h:commandButton=> @

name valua

[¥]

renderad
style
styleClass
tabindesx
title

type

Figure 3.26. Attributes Dialog
Refresh http://localhost:8080/workshop/myAction.seam and now you should see your changes.

Notice that you did not have to publish the application. JBoss Developer Studio auto-published
it for you.
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[ iy Action khtrmi 53 =0
glprojeciName]l:  Home Welcome, g[identity.usemame}  Login Legout
Error Messages
myAction
Click on My Action Button
Soamn

Visualfsource Preview

Figure 3.27. Seam Action Is Modified

3.3. Declarative Security

In this section you will see how it's easy to secure the facelets and facelet components in Seam.
Let’'s go ahead and secure the action button, then we will secure the entire page.

3.3.1. Edit Login Authentication Logic

There is a class called Authenticatorjava. The login page will execute the
Authenticator.authenticate() method by default, so we’ll start by adding some custom login logic.

Open Authenticator.java in JBoss Developer Studio and replace the authenticate() method with
this code:

public boolean authenticate() {

if (identity.getUsername().equals("admin™)

&& identity.getPassword().equals("password")) {
identity.addRole("admin™);

return true;

}

else

return true;

}

3.3.2. Secure Seam Page Component

Open myAction.xhtml and add a new secured command button:
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<h:commandButton id="myActionSecured"
value="Secured Action Button"
action="#{myAction.myAction}"
rendered="#{s:hasRole(‘admin’)}"/>

Refresh http://localhost:8080/workshop/myAction.seam If you are not logged in you will only see
one button. If you are logged in, there will be two buttons.

[1] Authenticator java o myAction. xhtrml m =0

] ® .7 |http:Mocalhost:B080/workshop/myAction.seam |'I B -

workshop: Home Login

myAction

Click on My Action Button

Powerod by Seam. Gonorated by seam-gon

Figure 3.28. One Button on a Page
The secured button is not visible because the user isn’t logged in as "admin".

[I] Authenticatorjava  |dE myAction.xhtrml m =0

o o W &7 | http:iocalhost:B0B0/workshop/myAction. seam |"| B -
workshop:  Home Welcome, admin Logout
myAction

Click on My &ctlon Button Secured Actlon Button

Powsend by Seam, Gonorated by samm-gen

Figure 3.29. Secured Button is Visible

The user is logged in as "admin”. Securing components is easy but securing pages is pretty simple
as well.
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Open WebContent/WEB-INF/pages.xml . Then add this markup directly underneath the <pages>
element:

<page view-id="/myAction.xhtml" login-required="true"/>

Refresh http://localhost:8080/workshop/myAction.seam If you are not logged in you will get
bounced back to the login page.

J] Authenticator java o myAction_khtrmil i workshop EI pages_xmi =0
=] @ .7 |http:/ocalhost:8080/workshopdogin.seam?cid=625&cir=true = | =3 n
workshop: Home Login

® Please log in first
Login

Please login using any usermname and password

Usemame
Password

Remember me =

Lisgin

Figure 3.30. Login Page

Thus, if you enter login credentials for the "admin" user, you will be re-directed to the secured
page and secured component. If you enter different login credentials, page access will be granted,
but the secured component will not be displayed.

Congratulations! You have secured your new action both at the facelet component and page level.
You also added custom authentication logic to the login action.

3.4. Browsing Workshop Database

In this section you get to know how to use the workshop database that was started at the beginning
of the lab.

3.4.1. Database Connectivity Setup

The workshop data can be browsed inside of JBoss Developer Studio.
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To open the Data Source Explorer, click on Window > Open Perspective > Other > Database
Development.

In the Data Source Explorer, expand a Databases node and select a Default database. Right click
on it, select Connect from the context menu.

E = I:ID'.

8% (a0 ma "

+ = Databases
ot e
Ed seamPr
r ODA Data|
& e Ping...

Rename
Dalete Delate
Duplicate
Refresh FS
Properties Alt+Enter

Figure 3.31. Data Source Explorer

3.4.2. Browse Workshop Database

Then in the current view, drill down to the CUSTOMERS table.
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! =5
:-'l'i-‘bﬂﬂ’ﬁ (TT I L

¥ = Databases

< £4 Default (HSQL Database Engine v, 1.8.0)
= |J SAMPLE
= [ Schermas
b B INFORMATION_SCHEMA
- BY puBLIC
L0 Dependencies
0 Sequences
= [ Tables
= EMPLOYEES
= OFFICES
=] ORDERDETAILS
= ORDERS
1 PAYMENTS
5 PRODUCTLINES
= PRODUCTS

User-Defined Functions

-
v v v Y Y vV

| Views

|

[ (= ODA Data Sources

Figure 3.32. "CUSTOMERS" Table

Right click on CUSTOMERS, select Data > Sample Contents to view the data in the table.

There should be a SQL Results view on the workbench, but it could be hidden. Click on the

"Resultl" tab in the right side and you should see the data in the CUSTOMERS table.
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Ec:msme] R I RAL]
Type query expression here ] Status | Resultl]

Status Operation Date CUSTOMER CUSTOMERMAME CONTACTLAST CONTACT FHONE ADDRESSLINE1 A -]
237 ANG Resellers  Camino Alejandra  (91) 74 Gran Vw00Scul
2 242 Alpha Cognac Roulet Annette  61.77.6 1rue Alsace-Lo
3 206 Asian Shopping N Walker Brydey  +612 9 Suntec Tower T1 8|
4 103 Atelier graphique Schmitt Carine 40.32.2 54, rue Royale
5 144 Volvo Model Replis Berglund Christina 0921-1 Berguvsv\u00Sc
6 189 Clover Collection: Cassidy Dean +353 1i 25 Maiden Lane F
7141 Euro+ Shopping ¢ Freyre Diego (91) 55 C/Moralzarzal,
8 216 Enaco Distributort Saavedra Eduarda  (93) 20 Rambla de Cats
9 201 UK Collectables, L Dewvaon Elizabeth (171) 5 12. Berkeley Ga
10 148 Dragon Souveniel Natividad Eric +65 22 Bronz Sok. B
11 209 Mini Carawvy Citeaux Friu005cul 88.60.1 24, place Khu0C
12 240 giftsbymail.co.uk Bennett Helen (198) 5 Garden House €
13 223 Matw005culi5cu Kloss Haorst 0372-3 Taucherstraiu0C
14 169 Porto Imports Co. de Castro Isabel (1) 356 Estrada da salu
15 118 La Rochelle Gifts Labrune Janine 40.67.8 67, rue des Cint
16 112 Signal Gift Stores  King Jean 702555 8489 Strong St o
I S T s O
| [ [+ Total S0 records shown

Figure 3.33. SQL Results View

Congratulations! You just connected to the workshop database and queried the content using
Database Explorer tools.

3.5. Database Programming

Now, it's time to reverse engineer the workshop database into a fully functioning Seam
CRUD(Create Read Update Delete) application.

3.5.1. Reverse Engineer CRUD from a Running Database

In JBoss Developer Studio, switch to Seam perspective, and then right-click the project and select
New > Seam Generate Entities.

"workshop" project in the Seam Generate Entities wizard will be selected automatically. There is
no need to change something more, click Next to proceed further.
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Generate Seam Entities

Generate Seam Entities

Seam Project: Iworkﬁhmp Browse,.. | Settings...

Hibernate Console Configuration: | workshop | &

Generation Mode

@ Reverse engineer from database

Cr Use existing entities

()] | Mext = | Einish ” cancel |

Figure 3.34. Generate Seam Entities

On the next page use the Include button to include all the tables from the database and click
Finish.
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Generate Seam Entities

Generate Seam Entities

Select Tables

Database schema:

= [ =Default catalog= @
- B PUBLIC
lude...

o cueromERs | exclude... |
[ EMPLOYEES
[ OFFICES —_—
_ CROSFDETALS
£ ORDERS
[ PAYMENTS @
I PRODUCTLINES [m

Refresh

-
rTable filters:
! cCatalog Schema Table
b PUBLIC CUSTOMERS
PUBLIC EMPLOYEES
b PUBLIC OFFICES
- PUBLIC ORDERDETAILS
b PUBLIC ORDERS
- PUBLIC PAYMEMNTS
b PUBLIC PRODUCTUNES
- PUBLIC PRODUCTS

= Back |

Einish

| [ Cancel

|

Figure 3.35. Selecting Tables

After running the Generate Entities action, you will see new org.domain.workshop.entity classes.
These classes represent insert/update/delete/query logic.
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il Package &3 . [(5Projecte = O

- g =
|+ = workshop E
| = & erefhot

= [B org.domain.workshop.se
b [1) Authenticatorjava
| iI] CustornersList java
11 EmplayeesHome javs
11 EmpleyeesList java
11 officesHome java
11| OfficesList.java
11| OrderdetailsHame ja
11| OrderdetailsList java
I OrdersHome java
11| OrdersList.java

1] PaymentsHame java

L - - A - T - - -

11| PaymentsList.java

| Y] Drndur_ﬂinnql—lnmn.iw{;?‘

[»

A CustormersHome java 232

package erg.demain.workshop.session;
#impert org.domain.workshop.entity.*;

@ame("customersHoma")
public c¢lass CustomersHome extends EntltyHome=Customerss {

@In{ecreate = true)
EmployeesHome employeesHome;

public veid setCustomersCustomernumber(Integer 1d) {
setld(id);
1

public Integer getCustomersCustomernumber() {

return {Integer) getId();
}

@dverride

protected Customers createlnstance() {
Customers customers = new Customers();
return customers;

¥

public weid wire{) {
Employees employees = employeesHome.getDefinedInstance();

Figure 3.36. org.domain.workshop.entity Classes

There are also org.domain.workshop.entity package that contains the JPA classes. These are
the entity beans that are mapped to database tables.

Last, but not least, there are facelets for all of the CRUD screens. The best way to get a feel
for the generated code is to open a browser and play around with the application. Go to http:/
/localhost:8080/workshop and insert/update/delete/query a few records. There is quite a bit of
AJAX in this application, but which we will explore further later on in the lab. For now, take note
of the page tabs, required field logic and data table sorting in the list pages.
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Error Messages

Customers search paramelers .
cusiomermame # {customersList.customer
contactiastname #{customersList.customer
contactfirstname #{customersList.customer
phone 2 {customersList.customer
sddrasslinet #{customersList.customer
addressline? # {customersList.customer
city #{customersList.customer —
state #{customersList.customer
postalcade £ {customersList. customer
country #{customersList.customer
| search |
Customers search resullts

Mo cuslomers exists
[4l | [+]

Visual/Source | Preview

1

Figure 3.37. CustomersList.xhtml in the Editor

Congratulations! You now have a fully functioning CRUD application that is already AJAX enabled.

3.5.2. Use Hibernate Tools to Query Data via JPA

Now, it's time to write some JPA queries using the Hibernate perspective in JBoss Developer
Studio.

In the upper right corner of the workbench there is a small icon (see the figure below), click on
it and choose Hibernate.
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[FR—
-

[ Database Development

& Web Development
P Java EE

Figure 3.38. Hibernate Perspective

Look at the Hibernate Configurations view. In the "workshop" project, drill down on the Session
Factory and notice that the JPA entities/attributes are listed in a nice tree view.

(o =g

B @M @

= |i workshop

I [£ Configuration

| - i3 Session Factory

-

@ org. domain workshop entity Offices

b @ org.domain workshop. entity Customers
b @ org.domain.workshop.entity Employees
b @ org.domainworkshop.entity Products

b @ org.domainworkshop entity Orderdetails
b @ org.domain workshop entity Orders

b @ org.domain.workshop.entity Productlines
b @ org domain workshop entity Payments

b [ Database

Figure 3.39. Hibernate Configurations View

Right click on the Session Factory and select HQL Editor. This will open a JPA query scratch
pad window.

Write your query and click on the "Hibernate Dynamic SQL Preview" tab. You should see the SQL
that will be executed if this JPA query is run.
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S *workshop H =0

= | workshop | % | Max results:

select ¢ Trom Customers C

L4 [+]

@] Error Log | % Hibernate Query Result. %4 Hibernate Dynamic SQL Previe & . Bl Console = O
0: org.domain.workshop entity. Customers :
select
customers0_ CUSTOMERNUMBER as CUSTOMER1_9_,
custorners0_ADDRESSLINEL as ADDRESSLZ 9,
custormersd_ADDRESSLINEZ as ADDRESSL3 9.
custerners0_CITY as CITY9_,
customersd_ CONTACTFIRSTNAME as CONTACTFS_9_,
customers0_ CONTACTLASTNAME as CONTACTLS 9,
customersd_.COUNTRY as COUNTRYS_,
customers)_CREDITLIMIT as CREDITLIE_9_.
customersd_CUSTOMERNAME as CUSTOMERS 9 _,
customers0_ SALESREPEMPLOYEENUMBER as SALESRE13_9_,
customersd_ PHOME as PHONES_,
customersd_ POSTALCODE as POSTALCODES _,
custormers)_STATE as STATES_
from
PUBLIC CUSTOMERS customers(_

(& D

Figure 3.40. JPA Query Editor
Run the query by clicking on the green run icon.

The results are listed in the "Hibernate Query Result" tab. There is a "Properties" tab in the
workbench that can be used to see a specific JPA result. These results represent the JPA objects
because our query did not specify column names.
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- . . .
O Properties 8 * ¥ = B ||& *workshop ﬁ\ =08
ropery > v rests 1o

= ldentifier

select ¢ from Customers c
customemumbe 103

= Properties
addresslinel 54, rue Royale
addressline2 [ I+]
EL LEWET € Hibernate Dynamic SQL Pr | B Consale| = 0|
contactfirstnami Carine
contactlastname Schmitt * ?
country France (1] -
credidirnit 21000.0 org.domain workshop _entity & _
customername Atelier graphique org.domain.workshop.entity. Customers@841423
P employees org.demain.weorkshop entity. Customers@1463027
I orderses org.demain.werkshop entity. Customers@1038048
P paymentses org.demain.werkshop entity. Customers@db0d07
phone 40.32 2555 org.domain.workshop.entity.Customers@134817a
postalcode 44000 org.domain workshop entity. Customers@207655
state org.demain.werkshop.entity. Customers@138dafa
org.demain.werkshop entity. Customers@12d2db8
org.demain.werkshop entity. Customers@11499ff =
51 I [ [¥] | select c from Custnrnlselect ¢ from Custorn |select ¢ from Custom ﬂ_/’-"’g

Figure 3.41. Hibernate Query Result View

The query can be refined, and take note that there is nice code completion in the JPA query editor.
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select c.customername, C.employees.| from Customers ¢ lZI

&' customerses - Employees
@ email - Employees

& employeenumber - Employees

extension - Employees

@ firstname - Employees

al : @ jobtitle - Employees
9] Error Log | % Hibernate Query Result £ "% ® lastname - Employees
@ officecode - Employees

@ reportsto - Employees

org.domain.workshop entity. Customers@cofc2
org.domain workshop entity. Customers@B41423
org.domain.workshop entity. Customers@1463027
org.domain workshop entity. Custormers@1038048
org.domain.workshop entity. Customers@db0dd 7

select C from Custom |_5elef.t ¢ from Custom | select ¢ from Custom Iﬁ /'i“q

Close
Wiritable Insert 1l: 36 l—

Figure 3.42. Code Completion

A refined query will return results that are more ResultSet oriented. Notice the join logic that JPA
supports.
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—

&3 *workshop & =8

= |w0r1cshup + || Max resu|t5:|10 -

select c.customername, C.employees. extension from Customers C

& Error Log | *4 Hibernate Query Result & - ¥4 Hibernate Dynamic SQL Prev B Console = B

X
Q 1
Atelier graphique x2028
Signal Gift Stores x4065

Australian Collectors, Co. x101

La Rochelle Gifts x2028
Baane Mini Imports ®102
Mini Gifts Distributors Ltd, x3291
Blauer See Auto, Co *102
Mini Wheels Co. x3291
Land of Toys Inc x4102

Euro+ Shopping Channel x2028

select c from Custom |select ¢ from Custom | select ¢ customemam 23 n]_u

Figure 3.43. The Results

There was no need to specify an Employees table in the from part of the JPA query because
JPA supports reference traversal via Java class attribute references. Not only are JPA and HQL
queries fully supported, but Criteria based queries can also be written in the Criteria Editor. You
should spend some time tinkering with different queries and possibly Criteria based queries, even
though the instructions are not provided in this lab.

67



Chapter 3. Write Your First P...

| & *workshop 2 =0

[ | workshop | % | Max resulls:

select c.customername, C.employees.extension from Customers C =

| [+]

& Error Log | ¥ Hibernate Query Result
0: string, string =2

¥4 Hibermate

salect
custorners)_ CUSTOMERNAME as col_0_0_,
employeesl_EXTENSION as col_1_0_
froem
PUBLIC CUSTOMERS customers(_.
PUBLIC EMPLOYEES employeesl_
where
custormersl_ SALESREPEMPLOYEENUMBER=employees]l_ EMPLOYEEMUMBER

(] [r)

Figure 3.44. Criteria Editor

3.5.3. Use Hibernate Tools to visualize the Data Model

Now, it's time to view the data model for the workshop database.

In the Hibernate Configurations view, select "workshop" project and expand the Configuration
node. Select the Customers entity, right click on it, choose Open Mapping Diagram.
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= |i workshop
= [§ Configuration

v € Customers
] HQL Editor

Employess
ploy T Hibernate Criteria Editor

P

b @ oOrfices

[ Orderdetaile | B Add Configuration...
b

P

B

c .
3 orders ) Refresh

Fayrrents

LI Open Source File
I Open Mapping File

@ productiines
b Froducts
[ s =l - Open Mapping Diagram

£ Database

Figure 3.45. Mapping Diagram Opening

You see a Diagram tab for the CUSTOMERS table and any tables that have FK references. This
is a handy way to view the data model and JPA mappings. Now, you've got access to something
that the Erwin Data Modeler can’t do.

=a 5\

0 org.hibernate.mapping.RootClass{org.domain.workshop.entity.Orderdetails) % «

B, orderdetailnumber : java lang Integer . |+ @ org.nibernate.map

[# orderinenumber : java.lang.Short [E, ordernumber - java la

#-1 org hibernate mapping Property{orders) 2 { B comments - javalang

[ priceeach : javalang.Double ] #1 0rg hibernate mappin | =
+-10rg hibernate mapping Property (products) & : M orderdate ; Java.utilD

E guantityerdered : javalang.integer =} org.hibernate mappin

[ key

i 1% element
[ requireddate : java.uti| |
[El shippeddate : java.uti
[El status : java.lang.Strir

|# org.hibernate.mapping.RootClass{org.domain.workshop. entity. Payments)

B paymentnumber : java lang integer

[ amount : java lang Double

¥ checknumber : java.lang String

#40rg hibemate mapping Property{customers) S
| B paymentdate - |ava utbl Date

3

al o I B v

Figure 3.46. Diagram Tab
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3.6. Rich Components

This lab will conclude with one last AJAX twist. In this section we add a RichFaces
inputNumberSlider to the Order Details edit screen.

3.6.1. Add a Richfaces component to the CRUD Application

Switch to Seam perspective, open WebContent/OrderdetailsEdit.xhtml in JBoss Developer
Studio.

Change the form field values using the visual editor. Seam has generated the form field names
that match the database column names. This is not ideal for business users.

R B TN _°
</h: inputTexts aE
=/s5:decarate=
] <s:decorate id="orderlinenumberDecoration® template="layout/edit.xhtml"=
04 =ui:define name="1Llabel">orderlinenumber</ui:define> —
<hi:inputText id="orderlinenumber®
required="true"®
value="#{orderdetail sHome. instance. orderlinenumber}” >
=a.support event="onblur® reRender="orderlinenumberDecoration®/=
=fh:inputText=
</5: decorates
<div style="clear:both" > =
(] T I+
: = I sl B r u| s A
[a]

.
ﬁ orderdetaiinumber ° :"‘-'“!‘E“"‘-’Eﬂ"s“?‘““"f“'i Error Messages
@ quantityorderea-  (#{orderdetailsHomednstar, [ G
> | — Qe R e —
' :#{&Ej;ardage;llsl-i@:ng;rgs‘taé Error Messages
* required fields
[ sove [l sove B Ocice |

products * orders *

[4]

Visual/Source Prewview

[4]

Figure 3.47. Form Fields Editing

Also, replace the QTY Ordered input field with a inputNumberSlider. You can use the JBoss
Developer Studio palette or right click on the form and insert the RichFaces component.
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required="true"
disabled="#{orderdetail sHome.managed}"®
value="#{orderdetailsHome. instance. orderdetailnumber}” > <rich:dndPararm=
=a! support evemt="onblur® reRender="orderdetailnumberDecoration®/> <rich:dragindic ators
=/h:inputText=
<fs:decorate=»

<nich:datascroller>

<rich:dragListener=
<nch:dragsupport=

<s:decorate id="guantityorderedDecoration” template="layout/edit.xhtml"> <rich-dropDownMenus
<uidefine name="label"=>gquantityordered=/ui define>
<h:inputText id="quantityerdered® =rich:dropListener=
required="true” =fich:dropSupport=

valwe="#forderdetail sHome. instance. onant itvordered}® =

<rich:effect>

-—

=rich:gmap>

¥ o : - [ z)| B I U A <rich:inputNumbersiider=
I T ETTOT eSS EE |
5( =rich;inputlumberSpinner:=
i Edit Crderdetails | =rich:insert>
B <rich:jQuery=
orderdetailnumber . )
=<rich:listShuttle >
quantityardered * B <rich:menuGroup=>
<s:decorate> Attribute: <rich:menulterm:
pricesach * i
Parent Tag L4 <rich:menuSeparator>
oarderdinenumber * Insert Around ™ <rich:message>
* required fiekts Insert Befare o <rich:messages>
=<rich:modalPanel>
; | =rich:nodeSelectlistener=
i  riciroces |
- _ | Cut | Searn . <rich:orderingList=
Copy L | <rich:paint2D>
Mo products Paste =rich:panel>
producicode . productname productscale Pedl srich:panelBars
move i
= Strip Ta <rich:panelBaritern>
Visual/Source Preview P 129 <=rich:panelMenu=

Figure 3.48. RichFaces Component Inserting

One the last option is to use the source view and manually copy the inputNumberSlider markup
listed below:

<rich:inputNumberSlider id="quantityOrdered" required="true"
value="#{orderdetailsHome.instance.quantityordered}"/>
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=ui:define name="label”=quantityordered</ui:define=
<h:inputText id="guantityordered®
reguired="true"
value="#{orderdetailsHome. instance. quantityorderad}”
=<a:support event="onblur® reRender="quantityorderedDecoration®/=
=/h:inputText>
</s:decorate>

<rich:inputNumberSlider id="quantityOrdered® required="true”
value="#{orderdetailsHome. instance.quantityordered}" />

<5:decorate id="priceeachDecoration” template="layout/edit.xhtml==>
=qi:define name="label">priceeach</ui:define>
<h:inputText id="pricesach"®

IC

e
[4] i [+]
- 2 | Normal l|Wormal [#|| B F U | & A
[ :
| iyt -ty | [] B
& arderdetailnumber ® :‘i‘!‘!‘."ﬁ'.'!"."?*!?‘i“".!’_“_“‘i Error Messages '-*u E #lord
quantityordered®  i#{orderdetallsHomednstat | o0
priceeach * fHonderdetmlislome sty | o aescanss
arderdinenumber © :_'{WIHHTELM_J Error Messages
| | %4
1 I| *

Visual/Source | Preview |

Figure 3.49. Adding the Source

The end result is an edit page that has better form labels and a new RichFaces control.
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o OrderdetailsEdit xhtmi m =g

& & W & htp:/ocalhost:8080/workshop/OrderdetailsEdit seam I~ B

workshop: Home OfficesList Customers List Employees List Products List  Orderdefails List  Orders List  Productlines Lisi  Payments List

Edit Orderdetails
[1] 100
orderdetailnumber® ¢ - 0
quantityordered * o
0.0
produciname  produciscale | productvendor produchdescription quanlityinstock  buyprice  msrp | action
Thes 118 scale repica of the 1917 Grand
Touring car has all the features you would
1917 Grand ) Wedy Discast expect from museum qualty reproductions: all

S18_1748 | \inlage Cars 118 four doors and bi-fold hood opening detaied | 2724 867 1700 View
Tiasing Slecki TOACLONS | o gine and instrament panel, chrome-Jook trim,
and tufied upholstery, al topped off with &
factory bakad-enamed finsh,

Powerod by Seam. Gonorated by seam-gon.

al ! ] I

Figure 3.50. The Result Page

Congratulations! You have completed the JBoss Developer Studio lab.
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Developing a simple JSP web
application

; We highly recommend developing in Seam. This chapter is for users who for some
reason cannot use Seam.

In this chapter you'll find out how to create a simple JSP application using the JBoss Developer
Studio. The application will show a classic "Hello World!" on the page.

We'll assume that you have already launched JBoss Developer Studio and also that the Web
Development perspective is the current perspective. If not, make it active by selecting Window
> Open Perspective > Web Development from the menu bar or by selecting Window > Open
Perspective > Other... from the menu bar and then selecting Web Development from the Select
Perspective dialog box.

4.1. Setting Up the Project

We are going to start with the creating a Dynamic Web Project with a minimal structure, i.e. with
just required facets. Thus this section will perform you all necessary steps on how to do this.

* Go to the menu bar and select File > New > Other...
e Select Web > Dynamic Web Project in the New Project dialog box

Click Next

Enter "jspHello" as a project name

* Then select Minimal Configuration from the list of possible configurations and click Finish
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Mew Dynamic Web Project

Dynamic Web Project

Create a standalone Dynamic Web project or add it to a new or existing Enterprise L_o
Application.

Project name: [jspHeIIu ]

Project contents:

& Use default

Target Runtime

| |Boss 4.2 Runtime ¢ | [new..|

Dymamic Web Module version

|25 2]

Configuration

[h-ﬁnimal Configuration e | [Mud'rl‘y...l

The most conservative starting point. Only the required facets are installed. Additional facets
can later be installed to add new functionality to the project.

EAR Membership
[ Add project to an EAR

i) [ = Back ]_f Mext = | Einish ” Cancel

Figure 4.1. Create New Web Project

The jspHello node should appear in the upper-left Package Explorer view.
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[ Project Explorer 3% =0

-
= &
L

+ 8 Java Resources: src
P = Libraries
b build
= = WebContent
I (= META-INF
b (= WEB-INF
I 1= Servers

Figure 4.2. New Web Project

4.2. Creating JSP Page

This section covers all the points how to create, edit and then preview JSP page.

In our simple application we need to create only one JSP page which displays a "Hello World!"
message.

 Right click WebContent > New > JSP.
» Type "hello.jsp" for a file name and click the Next button.

In the next window you can choose a template for your jsp page and see its preview.

e Select New JSP File (xhtml) template and click Finish button.
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Mew |avaServer Page

Select |SP Tempilate i |

Select a termplate as initial content in the |SP page.

Use JSP Template
Termnplates are 'New |SP* temnplates found in the |SP Templates preference page.

le7xml version="1.8" encoding="%{encoding}* 7=

|-1@ page language="java" contentType="text/html; charset=f{encoding}”
pageEncoding="${encoding}" %=

=IDOCTYPE html PUBLIC "-//W3CS/DTD XHTML 1.8 Transitional//EN" “http://www. w3 org/TRSx

I-:htm]. ¥mins="hitp: f www . w3, org/ 1999/ xhtml" >

<head=

|-:|net=1 http-equiv="Content-Type" content="text /html; charset=%{encoding}” /=

!-:tlth::—lnsert title here=/title>

Gl l D

Name Description

Mew |SP File {htmi) J5P with htmil markup

Mew |SP File (xhtmil) J5P with xhtmil markup

Mew JSP File {xhtml, xml syntax) J5P with xhtrml markup and xmil style syntax
Praview

(2]

® Mext = Einish I[ Cancel

I

Figure 4.3. Create JSP Page

Our hello.jsp page will now appear in Project Explorer.

4.2.1. Editing a JSP Page

Let's now make a little change so that a jsp page displays "Hello World!" message.

« Insert this line inside the <body> </ body> tag:

<% System.out.printIn("Hello World!"); %>

Notice that content assist functionality is always available when you are typing:
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Visual/Source Visual

a]
Source | Preview

4 *hello jsp 3 \_ =g
<?xml version="1.9" encoding="UTF-8* 7= E!
=%@ page language="java" contentType="text/html; charset=UTF-8"

pageEncoding="UTF-8 %>
=!DOCTYPE htmbl PUBLIC *-//W3C//DTD XHTML 1.8 Transitiomal//EN"
"http: /Swww W3, org/TR/2hEmL1/DTD/xhtmLll- transitional  dtd" >
=html xmins="http:/ www.w3.org/ 1999/ xhtml" >
<heads=
=meta http-equiv="Content-Type® content="text/html; charset=UTF-8" />
<title=Insert title here</title=
</head=>

__ =body=

B < &M, o %> o
</body> + autoFlush boolean - PrintStream
=fhtml>

o charfut OutputStreamWriter - PrintStream r

o closing boolean - PrintStream

o formatter Formatter - PrintStream

< out  OutputStream - FilterOutputStrean

o textOut  Bufferedwriter - PrintStream

o trouble boolean - PrintStream

@ append{char c}) PrintStream - PrintStream

@ append|{Charsequence ¢sq) PrintStream - FrintStream —
(1 I 1)

& append|{CharSequence csq, int start. int end) PrintStream B )

| I [v]

Figure 4.4. Content Assist in JSP Page

After changes made your hello.jsp page should look like this:

79



Chapter 4. Developing a simpl...

g hello jsp &

<?xml wersion="1.9" encoding="UTF-8° 7=

=%@ page language="java"™ contentType="text/html; charset=UTF-8"
pageEncoding="UTF-8 %>

<!DOCTYPE html PUBLIC *-//W3C//0TD XHTML 1.8 Transitiomal//EN®

"http: //www W3, org/TR/hEmL1/DTD/xhtmll- transitional  dtd" >

=htmlL Xxmlns="http:// wee.w3.0org/ 1999,/ xhtml" >

<head=

<meta http-equiv="Content-Type® content="text/html; charset=UTF-8"
ztitle=Insert title here=/title=

=</head>

=hody =

=% System.out.println("Hello World!"}); %=

=/body>

=/html>

f=

al

VisualfSource Visual Source  Prewview

Figure 4.5. Hello.jsp Page

This line will actually output "Hello World!" message in the Console. To make the message

displayed in the Browser, just replace this line with the simple Hello World!.

4.2.2. web.xml file

When you are creating web project the wizard creates the web.xml for you automatically. The
web.xml file editor provided by JBoss Developer Studio is available in two modes: Tree and

Source.
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i hellojsp  webaxeml B -0

Web XML Editor

- web = Web Descriptor 2.5

- =4 web xml d |web |

5y Context Params

Display-Name: |DynamP’rnject |

(2 Filters
(5 Listeners 52 hello jsp [¥] web. xmi & =0
[ Serviets <?xml wersion="1.0" encoding="UTF-8" 7> =

. . <web-app xmlns: xsi="http: / www.w3.0rg/2001/XMLSchema- instance®
W SessIon-C  ymins="http://java.sun. com/xml/ns/javace”
55 Mime Maj xmlns:web="http: //java. sun.com/xml/ns/javaee/web-app_2_5.xsd"
xsi:schemalocation="http://java.sun.com/xml/ns/javaee http://java. sun.com/xmL/
<display-names>jspHallo</display-names
I Errar Pag.: <welcome-file-list=
5 ! <walcome-Tile=index. hEml</welcome-Tilex
# J5P Confic <welcome- file=index.htm=/welcome- file=
5 Security 1| <welcome-file=index.jsp</welcome-Tile>
i <welcome-file>default. html</welcome- Ffile>

I & welcome

J* login-con zwelcome- file=default. htm=/welcome-file=
Iy Security | <welcome-Tilexdefault.jsp</welcome-Tilex
. . </welcome- file-list=
L
% Env Entri <fweb- app>
B ER
= Services
5 Resource

Tree Source

(4] [+]

Design | Source

Figure 4.6. Web.xml in Designh and Source Mode
Both modes are fully synchronized. Let's add mapping to our hello.jsp page in web.xml file.

» Switch to Source tab.

* Add the next code into <wel cone-file-list>:

<welcome-file>hello.jsp</welcome-file>

If you come back to Tree mode you will see that the changes made are automatically reflected
in that mode.

Actually you don't really need to do any configurations right now.
4.2.3. Deploying the project

While creating any web project you could experience a pain writing ant scripts and managing the
packaging even when writing the most trivial web applications. With JBoss Developer Studio you
are saved from such a pain. All you need is to start JBoss Server and launch your application in
your favorite browser.
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You can also create a war archive with JBDS's Archive Tools and export it to any web server.

4.2.3.1. WAR Config

Project archives managing is available through Project Archives view.

» Select Window > Show view > Other > JBoss Tools > Project archives from menu bar
» Select a project in Package Explorer you want to be archived

In Project Archives you will see available archive types for the project:

| Project archives 52 . 4 Tasks [T Properties| 4 Servers (3 = O

PI"'D]EL'_E has no defined archives. Create an Archive:
I 18R

(@ wa

@& EJB JAR

(4 EAR

Figure 4.7. Project Archives

* Click, for example, WAR option to create war archive

In the New WAR dialog you can see automatically selected default values.

Create a new archive

Create a new archive cansisting of filesets in the workspace.

Archive information

Archive name: [ []spHellc.war |
Destination: = [jspHeIIo l [w-url-:spa:e...] [Hlesyﬁtem...]
Archive type

@ :S“tandard archive using zip cumpressiuné

8] Exploded archive resulting in a folder (no compression)

@ | Next> I Cancel |

Figure 4.8. New WAR Archive
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Deploying the project

» Click Next to see a stub archive configuration for your project:

i New WAR

WAR Archive Stub

Below is a stub archive configuration for your project.
You can customize this structure further after pressing finish.

Preview
= [ jspHello war
= (= WEB-INF
= = lib
|4 ##* jar: jspHello
= [= classes
|4 ¥H*: classes

[ **r*: WebContent

I+

(2]

[ Finish

] [ Cancel I

Figure 4.9. Stub Archive Configuration

» Click Finish. The .war file will appear in Package Explorer and also in Project Archives view

as structure tree:

4 Package Explorer 55 =
B~
+ 1 jspHello
I+ B4 JRE System Library [jdkl,5.0_12]
b =4 All JBoss Libraries [JBoss 4.2 Runtime]
(= build
P = WebContent

|7 jspHello war

Figure 4.10. Archive is Created
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¥ Tasks < |Boss Server View O Console

= (= WEB-INF
P i

¥ [= classes

|54 #*p+: classes
| &+ WabContant

Figure 4.11. Archive in Project Archives View

Via Project Archives view you could now edit your archive, add new folders, publish to server,
and so on:

« Tasks 77 JBoss Server View & Console

New Archive r
+ = WEB-INF
= Mew Folder
bE= il

4 New Fileset
+ [ classe

[ +++ (B Build Archive

(%, Edit Archive

H Delete Archive
%% Publish To Server

[5 +*re: Wel

Figure 4.12. Configure Archive

4.2.3.2. Auto redeploy

When you are creating a web application and register it on JBoss Server it is automatically
deployed into /deploy directory of the server. JBDS comes with the feature of auto-redeploy.
It means that you don't need to restart JBoss Server. Any changes made in the application in
exploded format will trigger a redeployment on the server.

You can also use the "Finger touch" button for a quick restart of the project without restarting the
server:

B ucsoa|see e osrola v o) -

Figure 4.13. Finger Touch button

The "Finger" touches descriptors dependent on project (i.e. web.xml for WAR, application.xml for
EAR, jboss-esh.xml in ESB projects).
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4.2.4. JSP Page Preview

JBDS comes with JSP design-time preview features. When designing JSP pages you can easily
preview how they will look during runtime. You can even attach your stylesheet to the Preview.

» Make a little change to hello.jsp page, e.g. put this code snippet:

<%= new java.util.Date() %>

e Click Save button.

« Switch to Preview page by clicking Preview tab at the bottom of the page. You will see how
the page will look at runtime.

4.2.5. Launch JSP Project

Let's now launch our project on server. We'll use JBoss Server that is shipped with JBoss
Developer Studio. You can do it by performing one of the following actions:

o Start JBoss Server from JBoss Server view by clicking
the Start the server icon (
¥
).

» Click the Run icon or right click your project folder and
select Run As > Run on Server. If you haven't
made any changes in web.xml file or cleared it out
you can launch  the  application by right clicking the hello.jsp
page and selecting Run on the Server (

-

).

You should see the next page in a Browser :
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../../as/html_single/index.html#JBossServerView

Chapter 4. Developing a simpl...

@ Internal Web Browser & =08

® & |httpyflocalhost:8080/jspHellof ML

Hello World! Mon Oct 13 13:06:02 EEST 2008

Figure 4.14. Running Project

Thus with the help of this chapter you've learnt how to organize a Dynamic Web Project with a
minimal configuration, add any staff to it (in our case it's just one jsp page) and deploy and run
it on the JBoss Server shipped with JBDS.
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Chapter 5.

RAD development of a simple JSF
application

: We highly recommend developing in Seam. This chapter is for users who for some
reason cannot use Seam.

In this chapter you will see how to create a simple JSF application being based on "RAD"
philosophy. We will create the familiar Guess Number application. The scenario is the following.
You are asked to guess a number between 0 and 100. If the guess is correct, a success page is
displayed with a link to play again. If the guess is incorrect, a message is printed notifying that a
smaller or a larger number should be entered and the game continues.

We'll show you how to create such an application from scratch, along the way demonstrating
powerful features of JBoss Developer Studio such as project templating, Visual Page Editor, code
completion and others. You will design the JSF application and then run the application from inside
JBoss Developer Studio using the bundled JBoss server.

5.1. Setting up the project

First, you should create a JSF 1.2 project using an integrated JBDS's new project wizard and
predefined templates. Follow the next steps:

* In Web Projects View (if it is not open select Window > Show View > Others > JBoss Tools
Web > Web Projects View) click Create New JSF Project button.

K. Web Projects & =08
ey e

| Create New |SF Project

Figure 5.1. Create New JSF Project
* Put GuessNumber as a project name, in JSF Environment drop down list choose JSF 1.2

» Leave everything else as it is and click Finish
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Chapter 5. RAD development of...

Our project will appear in Project Explorer and Web Projects Views. As you can see JBoss
Developer Studio has created for us the whole skeleton for the project with all needed libraries,
faces-config.xml and web.xml files.

I{5 Project Explorer IZ = = =

- 1= GuessNumber

I By Deployment Descriptor: GuessNumber
b A GuessNurnber
[+ £® Java Resources: |avaSource
b= ant
- (= WebContent

P = META-INF

= = WEB-INF

= classes
b=k

b |4 races-config.xmil

&, Web Projects 2 =nA

= |1 GuessNumber
= = WebContent
P = META-INF
[ (5 WEB-INF
L= Tag Libraries
L= Resource Bundles
= Configuration
L= Beans

L= Tiles

L A A

web. xml

Figure 5.2. New JSF Project

As the project has been set up, new JSP pages should be created now.

5.2. Creating JSP Pages

Here, we are going to add two pages to our application. The first page is inputnumber.jsp. It
prompts you to enter a number. If the guess is incorrect, the same page will be redisplayed with
a message indicating whether a smaller or a larger number should be tried. The second page is
success.jsp. This page will be shown after you guess the number correctly. From this page you
also have the option to play the game again.

Now, we will guide you through the steps on how to do this.
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Creating JSP Pages

* Open faces-config.xml file
* Right click anywhere on the diagram mode

* From the context menu select New View

New View

Auto Layout
Select Elernent

o Verify

Input Methods ]

Diagram [Tree | source|

Figure 5.3. Create New View

» Type pages/inputnumber as the value for From-view-id
» Leave everything else as is and click Finish

* In the same way create another jsf view. Type pages/success as the value for From-view-id

Select File > Save

On the diagram you will see two created views.
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M races-config.xmil =

[} fpages/inputnumber.jsp

r
o

W glte

/pages/success.|sp

Diagram | Tree  Source

Figure 5.4. New Views

5.3. Creating Transition between two views

Then, we should create connection between jsp pages.

 In the diagram, select the Create New Connection icon third from the top along the upper left
side of the diagram to get an arrow cursor with a two-pronged plug at the arrow's bottom

M *faces-config.xml £

D3 /pagesfinputnumber.jsp

=1
[

.
&

Create New
Connection

Figure 5.5. Create Connection
» Click on the pages/inputnumber page icon and then click on the pages/success page icon

A transition should appear between the two icons of views.
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Creating Resource File

M faces-config.xmil &3 =0

fpages/inputnumber.jsp

SuUccess

Bl iE

/pages/success.|sp

Diagram | Tree  Source

Figure 5.6. Created Connection

+ Select File > Save from the menu bar

5.4. Creating Resource File

A resource file is just a file with a .properties extension for collecting text messages in one central
place. JBoss Developer Studio allows you to create quickly a resource file. The messages stored
in resource file can be displayed to you on a Web page during application execution.

With resource file first, you don't hard code anything into the JSP pages. And second, it makes it
easier to translate your application to other languages. All you have to do is to translate all your
messages to the other language and save them in a new properties file with a name that ends
with the appropriate 1ISO-639 language code.

It is a good idea to keep your resources inside the JavaSource folder, where you keep your
.java files. Every time you build the project, all .properties files will then be copied to the classes
folder by default.

* Right click JavaSource folder and select New > Folder
* Type game for Folder name and click Finish

Your resource file and java bean will be stored in this folder.
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» Right click on game folder and select New > Properties File
« Type messages as the value for "name" attribute and click Finish

JBoss Developer Studio will automatically open messages.properties file for editing.

[E Messages properties 2 =0
Messages properties

name value

Froperties Source

Figure 5.7. Messages.properties File

Click Add button for adding new attribute to your resource file

» Type how_to_play for "name" and Please pick a number between 0 and 100. for value

Click Finish

« In such a way add the next properties:

makeguess_button=Make Guess

trayagain_button=Play Again?

success_text=How cool.. You have guessed the number, {0} is correct!

tryagain_smaller=0ops..incorrect guess. Please try a smaller number.
tryagain_bigger=0ops..incorrect guess. Please try a bigger number.

¢ Click File > Save from the menu bar

Your .properties file should now look like follows:
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Creating Java Bean

M, faces-configxml @ inputnumberjsp [l messages properties i3

messages properties

nare
how_to_play
makeguess_button
tryagain_button
success_text

tryagain_smaller

tryagain_bigger

Properties ‘Source

value

Please pick a number between a 0 and 100.

Make Guess

Flay Again?

How cool.. You have guessed the number, {0} is comect!
Oops.. Incorrect guess. Please try a smaller number.

Oops.. incorrect guess. Please try a bigger number.

dlidl}

Edit

Delete

Figure 5.8. Properties are Added

Up and Down buttons allow you to move you attribute on the list. For delete the attribute, choose

it and press Delete button.

If you want to change a value or a name of your attribute, click on it and than on Edit button.

5.5. Creating Java Bean

In this section you'll see how to create a Java bean that will hold business logic of our application.

 Right click game folder

¢ Select New > Class

e Type NumberBean for bean name

A java bean is created.

« Declare the variable of your entered number:

Integer userNumber;

JBDS allows to quickly generate getters and setters for java bean.

« Right click NumberBean.java in Package Explorer
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» Select Source > Generate Getters and Setters...

¢ Check userNumber box and click OK

Select getters and setters to create:
= ~  userMumber

&l e getUserMumber()
oo setUserMNumber(integer)

o
)

Desalect All
Select Getters

Select Setters

[[] Allow setters for final fields (remove 'final' modifier from fields it necessary)

Insertion paoint:

[ Last method - |
Sort by:

[Helns in getterfsetter pairs -] |

Access modifier
(3 public () protected ) default () priyvate
[ final [ synchronized

[[] Generate method comrments

The farmat of the getters/setters may be configured on the Code Ternplates preference page.

i 2of 2 selected.

® | oK

—

[ Cancel

Figure 5.9. Generate Getters and Setters

» Add the declaration of the second variable

int randomNumber;

» .. other bean methods:
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public NumberBean ()
{
randomNumber = (int)(Math.random()*100);
System.out.printin ( "Random number: "+randomNumber);
}
public String playagain ()
{
FacesContext context = FacesContext.getCurrentinstance();
HttpSession session =
(HttpSession) context.getExternalContext().getSession(false);
session.invalidate();
return "playagain”;
}
public String checkGuess ()

{

Il if guessed, return 'success' for navigation
if (userNumber.intValue() == randomNumber )

{

return "success";

}
else
{
FacesContext context = FacesContext.getCurrentinstance();
ResourceBundle bundle = ResourceBundle.getBundle("game.messages",
context.getViewRoot().getLocale());
String msg = "";
/l'if number bigger, get appropriate message
if (userNumber.intValue() > randomNumber )
msg = bundle.getString("tryagain_smaller");
else // if number smaller, get appropriate message
msg = bundle.getString("tryagain_bigger");
/I add message to be displayed on the page via <h:messages> tag
context.addMessage (null, new FacesMessage(msg));
[l return 'tryagain' for navigation
return "tryagain”;

* And the import declarations:

import javax.faces.context.FacesContext;
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import javax.servlet.http.HttpSession;

import javax.faces.application.FacesMessage;
import java.util.Locale;

import java.util. ResourceBundle;

The whole java bean should look as follows:

import javax.faces.context.FacesContext;
import javax.servlet.http.HttpSession;

import javax.faces.application.FacesMessage;
import java.util.Locale;

import java.util.ResourceBundle;

public class NumberBean
{

Integer userNumber;

int randomNumber; // random number generated by application
public Integer getUserNumber ()

{

return userNumber;

}

public void setUserNumber (Integer value)

{

this.userNumber = value;

}

/I constructor, generates random number
public NumberBean ()
{
randomNumber = (int)(Math.random()*100);
System.out.printin (
"Random number: " + randomNumber);

}

public String playagain ()
{
FacesContext context = FacesContext.getCurrentinstance();
HttpSession session =
(HttpSession) context.getExternalContext().getSession(false);
session.invalidate();
return "playagain”;

}
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Editing faces-config.xml File

/I check if user guessed the number
public String checkGuess ()
{
Il if guessed, return 'success' for navigation
if (userNumber.intValue() == randomNumber )

{

return "success";
}
I/l incorrect guess
else
{
Il get a reference to properties file to retrieve messages
FacesContext context = FacesContext.getCurrentinstance();
ResourceBundle bundle =
ResourceBundle.getBundle("game.messages”,
context.getViewRoot().getLocale());
String msg ="
/l'if number is bigger, get appropriate message
if (userNumber.intValue() > randomNumber )
msg = bundle.getString("tryagain_smaller");
else // if number smaller, get appropriate message
msg = bundle.getString("tryagain_bigger");

/I add message to be displayed on the page via <h:messages> tag
context.addMessage (null, new FacesMessage(msg));

[ return 'tryagain' for navigation

return "tryagain”;

5.6. Editing faces-config.xml File

In this section you know about faces-config.xml file.

This file holds two navigation rules and defines the backing bean used.

* Open faces-config.xml file in a source mode

» Add here one more navigation rule and a managed bean declarations that the content of the
file looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<faces-config version="1.2" xmlIns="http://java.sun.com/xml/ns/javaee
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xmins:xi="http://www.w3.0rg/2001/XInclude"

xmins:xsi="http://www.w3.0rg/2001/XMLSchema-instance"

xsi:schemal.ocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-facesconfig 1 2 .xsd">

<navigation-rule>
<from-view-id>*</from-view-id>
<navigation-case>
<from-outcome>playagain</from-outcome>
<to-view-id>/pages/inputnumber.jsp</to-view-id>
</navigation-case>
</navigation-rule>

<navigation-rule>
<from-view-id>/pages/inputnumber.jsp</from-view-id>
<navigation-case>
<from-outcome>success</from-outcome>
<to-view-id>/pages/success.jsp</to-view-id>
</navigation-case>
</navigation-rule>

<managed-bean>
<managed-bean-name>NumberBean</managed-bean-name>
<managed-bean-class>game.NumberBean</managed-bean-class>
<managed-bean-scope>session</managed-bean-scope>
</managed-bean>

</faces-config>

The first navigation rule states that from any page (* stands for any page) an outcome of playagain
will take you to /pages/inputnumber.jsp . Outcome values are returned from backing bean
methods in this example. The second navigation rule states that if you are at the page /pages/
inputnumber.jsp , and the outcome is success, then navigate to the /pages/success.jsp page.

5.7. Editing the JSP View Files

Now, we will continue editing the JSP files for our two "views" using Visual Page Editor.

5.7.1. Editing inputnumber.jsp page

First, let's dwell on how to edit inputnumber.jsp.

On this page we will have an output text component displaying a message, a text field for user's
number entering and a button for input submission.
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Editing inputnumber.jsp page

e Open inputnumber.jsp by double-clicking on the /pages/inputnumber. jsp icon

The Visual Page Editor will open in a screen split between source code along the top and a
WYSIWIG view along the bottom. You can see that some JSF code will be already generated as
we choose a template when creating the page.

At the beginning it's necessary to create a <h: f or n> component where all others components
are put.

» Place the mouse cursor inside <f : vi ew> </ f: vi ew>
* Go to JBoss Tools Palette and expand JSF HTML folder by selecting it

¢ Click on <h: f or n» tag

¥ |Boss Tools Palette I3 =0

X b <
.= |Boss Ajaxdjsf
.= |Boss RichFaces
= |Boss Seam
L= JSF HTML +
& |SF HTML taglib
=¥ colurmn
_lcommandButton
& commandLink
EB dataTable
5! form
Bgraphiclma 2
R inputHidden
= inputSecret
kb inputText
inputTe;-:ta rea
Mmessage
Mmessages
¥ outputFormat
# outputLabel
Fb outputlink
#F outputText
B panelGrid
¥ panelGroup
¥ selectBooleanCheckbox
i= selectManyCheckbox
B selectManyListbox

w

Figure 5.10. Insert h:form

* Inthe dialog Insert Tag select id and click on this line below the value header. A blinking cursor
will appear in a input text field inviting to enter a value of id
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b Insert Tag x
=h:form> attributes

Attribute name Value —
acecept
acceptcharset
binding

dir

anctype e

[ (]

lang

onclick
andblelick
onkeydown
onkeypress

(4]

[i57) Finish ” Cancel I

Figure 5.11. Define Id of Form
e Type inputNumbers and click Finish

In source view you can see the declaration of a form.

8 aces o | "o

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %=
=%@ taglib uri="http://java.sun.com/jsffcore” prefix="f" %=

<html=
=head=
=title=</title=
=/head=
<body=>
=T views>
<h: form id="inputNumbers®=

</h: form= -
=ffiview=
=/body=
(4] | [¥]

(4]

Figure 5.12. Created Form

First let's declare the properties file in inputnumber.jsp page using the loadBundle JSF tag.
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Editing inputnumber.jsp page

« Put this declaration on the top of a page, right after the first two lines:

<f:loadBundle basename="game.messages" var="msg"/>

As always JBDS provides code assist:

. faces-config xmi mﬂ messages properties = B | # |Boss Tools Falette i =0
=W taglib wris"http:/S]ava, sun.com/jsfshtml™ prefixs™h® &= | % B O
=l taglib wris"http: /S java, sun.comfjsficore prefics"1" %= ol

B <r:1 [ |Boss Ajaxdjsf
£ . [ loadBundie Load a resource bundle kecalized for the Lecale of the curment

view, And Expose it A5 & java uti Map in the request attributes
of the current rbquest under the key specified by the value of
the “wvar~ attribute of this tag. The Map must behave such that if
a getl) call is made for a key that does not exist in the Map, the
Eteral string 77 TREEYT?7 is rebumnad from the Map. where KEY is
the key beindg looked up in the Map, nstead of a
MissingResourceException being thrown, ¥ the ResourceBundie
dogs not guist, a spExcepbion must be thrown

F outputlabel
& outputt ink
F outputText
B panelGna
£ paneiGroup
F zelectBoolsanCheckbox
= selectManyCheckbox
|| B selectManyListbax
_ = BlselectmanyMenu
- I[. I ~! B selectOneListiox

_ _ _ _ B selectoneMenu
VisualfSource Visual | Source Preview & gelectOneRadio

Figure 5.13. Code Assist

 Switch to Visual tab, so it could be possible to work with the editor completely in its WYSIWYG
mode

» Click on outputText, drag the cursor over to the editor, and drop it inside the blue box in the
editor

» Select value and click on this line below "value" header
¢ Click ... button next to the value field

JBDS will nicely propose you to choose within available values:

101



Chapter 5. RAD development of...

Edit Value b4

<h:outputText>

& Managed Beans

b @ Resource Bundles
P = JSF Variables

Ok | | Cancel

Figure 5.14. Choose Value

* Expand Resource Bundles > msg

* Select how_to_play value and click Ok. Then click Finish

Edit Value x

&

% Managed Beans -

- ﬁ Resource Bundles

<h: outputText>

= [ msg
:
o makeguess_button
o success_text

o tryagain_bigger

o tryagain_button

0 trvanain smaller

(4]

Ok | | Cancel

Figure 5.15. Selecting Value

The text will appear on the page:
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Editing inputnumber.jsp page

M faces-config.xmi sz Yinpumurnberjsp 22 [E messages properties =0

Please pick a number between a 0 and 100.

&R

html body f:view h:form x

Visual/Source Visual Source Preview

Figure 5.16. Created OutputText Component

» Switch to Source mode and insert <br / > tag after <h: out put Text > component to make a new
line.

¢ Click Save button.

« On the Palette click on inputText, drag the cursor over to the editor, and drop it inside the
editor after the text.

» Switch to a Source mode and insert <br/ > tag after <h: out put Text > component to make a
new line

¢ Click Save button

« On the Palette click on inputText, drag the cursor over to the editor, and drop it inside the
editor after the text

» Select value and click on this line below "value™ header
 Click ... button next to the value field

* Expand Managed Beans > NumberBean

» Select userNumber value and click Ok

* Switch Advanced tab

» Select id and click on this line below "value" header

e Type userNumber in text field
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« Select required and click on this line below "value" header
 Click ... button next to the value field
e Expand Enumeration and select true as a value

= Edit Required x

<h:inputText> @

.v = Enumeration
= false
I+ E& Managed Beans
b (g Resource Bundies
I = )SF variables

| Ok | | Cancel

Figure 5.17. Add "required" Attribute

* Click Ok, then click Finish
* Go to Source mode

» Add the validation attribute to <f : val i dat eLongRange> for user input validation

<h:inputText id="userNumber" value="#{NumberBean.userNumber}" required="true">
<f:validateLongRange minimum="0" maximum="100"/>
</h:inputText>

Click Save button

Again select Visual mode

On the Palette, click on commandButton, drag the cursor over to the editor, and drop it inside
the editor after the inputText component.

In the editing dialog select value and click on this line below "value" header

Click ... button next to the value field

Expand Resource Bundles > msg and select makeguess_button as a value

Click Ok
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* Select action and click on this line below "value" header
e Type NumberBean.checkGuess in text field
* Click Finish

 In Source mode add <br / > tags between <out put Text >, <i nput Text > and <conrmandBut t on>
components to place them on different lines

inputnumber.jsp page should look like this:

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
<f:loadBundle basename="game.messages" var="msg" />
<html>
<head>
<title></title>
</head>
<body>
<fview>
<h:form id="inputNumbers">
<h:outputText value="#{msg.how_to_play}" />
<br />
<h:messages style="color: blue" />
<br />
<h:inputText value="#{NumberBean.userNumber}" id="userNumber"
required="true">
<fvalidateLongRange minimum="0" maximum="100" />
</h:inputText>
<br />
<br />
<h:commandButton value="#{msg.makeguess_button}"
action="#{NumberBean.checkGuess}" />
</h:form>
</f.view>
</body>
</html>

5.7.2. Editing success.jsp page

In the same way like inputnumber.jsp, edit success.jsp page. Its whole source should be the next:

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
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<f:loadBundle basename="game.messages" var="msg"/>

<html|>
<head>
<title></title>
</head>
<body>
<fview>
<h:form id="result">
<h:outputFormat value="#{msg.success_text}">
<f:param value="#{NumberBean.userNumber}" />
</h:outputFormat>
<br />
<br />
<h:commandButton value="#{msg.trayagain_button}"
action="#{NumberBean.playagain}" />
</h:form>
</fview>
</body>
</html|>

Again you can use code assist provided by JBDS when editing jsp page:

@ paramvValues
L&) renuestSoons

4l faces-config xml |5 Inputnumber jsp B messages properties 2 & = B # jBoss Tools Palette 52 - T 8
=%@ taglib uri="http://java.sun.com/jsT/html® prefix="h" %> =L 5( &, <
=%@ taglib uri="http://java.sun.com/JsT/core” prefix="f" %= . :
<f:loadBundle basenames="game.messages” vars"msg" /= &]BDSS Ajaxdjsf
<html= L= JBoss RichFaces

"“ead: emertitt (= |Boss Seam
<title=</title> i e
=/head= E]SFH ML -
<body> &7 |SF HTML taglib
<f:view= | &> column
<h:form id="result"> u JlcommandButton
| =h:outputFormat value="#{msg.success_text}"> & commandLink
: T =" 4
</h: :u tgﬂ:iz:::::g . @ ms dataTable
I : 9 ! form
g e 2 herBea graphicimage
- - @ applicationScape inputHidden
5( @® cookie * inputSecret
How cool.. You have quessed the n| ® inputText
& facesContext inputTe: "
2 @ header message
@ headerValues messages
@ initParam < putputFormat
# outputLabel
@ param

panelGrid

html body fiview h:form h:outputFormat f:param

Visual/Source |visual| Source | Preview |

¥ panelGroup
W selectBooleanCheckbox
= selectManyCheckbox

11E= selecmamrl_lsyou

s

Figure 5.18. Code Assist for <f:param>
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Creating index.jsp page

This page, success.jsp, is shown if you correctly guessed the number. The <h: out put For mat >
tag will get the value of success_text from the properties file. The {0} in success_text will be
substituted for by the value of the value attribute within the <f : par an» tag during runtime.

At the end, you have a button which allows you to replay the game. The action value references a
backing bean method. In this case, the method only terminates the current session so that when
you are shown the first page, the input text box is clear and a new random number is generated.

« Switch to Preview mode to see how this page will look in a browser:

| faces-config.xmi 2| inputnumber.jsp 3 B messages properties 12 SUCCess.jsp * =8

Please pick a number between a 0 and 100.
|# {NumberBean.userNumbe

Make Guess

Visual/Source Visual | Source Preview
Figure 5.19. Success.jsp in Preview Mode

5.8. Creating index.jsp page

Now you know how to create index.jsp page.

The index.jsp page is the entry point of our application. It's just forwarding to inputhumber.jsp page.

Right click WebContent > New > JSP File
» Type index for name field and choose JSPRedirect as a template

Click Finish

» The source for this page should be like the following:

<ldoctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<body>
<jsp:forward page="/pages/inputnumber.jsf" />
</body>
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</html>

Note the .jsf extension of a page. It means that we trigger the JSF controller servlet to handle the
page according the servlet mapping in the faces-config.xml file.

5.9. Running the Application

Finally, we have all the pieces needed to run the application.

« Start up JBoss server by clicking on the Start icon in JBoss Server view. (If JBoss is already
running, stop it by clicking on the red icon and then start it again. After the messages in the
Console tabbed view stop scrolling, JBoss is available)

 Right-click on project Run AS > Run on Server

» Play with the application by entering correct as well as incorrect values

| Mozilla Firefox
fle Edit View Go Bookmarks Tools Help

@ - - £ ) #]) |5 nttpiocainost:8080/Guesshumber/ [[¥| @ Go

Flease Fu:lc a number between a O and 100,

Make Guess

Done

Figure 5.20. You are Asked to Enter a Number Between 0 and 100
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Running the Application

J Mozilla Firefox = o=
Eile Edit View Go Bookmarks Tools Help {:-

'@ = L:& x @ @ @ 7. hitp Mocalhost; 8B0B0/GuessNumber/pagesfinputnumber jsf J[ﬂ D Go @,

Please pick a number between a0 and 100.

® inputNumbers:user Mumber: Validation Error: Specified attribute is not between the expected values of 0 and 100,

|6

Make Guess |

Done

Figure 5.21. Your Input is Validated and an Error Message is Displayed if
Invalid Input was Entered
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J

Mozilla Firefox = | |
Eile Edit View Go Bookmarks Tools Help &%
'@ T L.:) x @ -:_,3;1 @ <. hitp Mocalhost; 80B0/GuessNumber/pagesfinputnumber jsf |[E| 0 Go
Please pick a number between a0 and 100,
#® Oops.. incorrect guess. Please try a smaller number.
jas
Make Guess |
Done

Figure 5.22. After You Enter a Guess, the Application Tells You Whether a
Smaller or a Larger Number Should be Tried

110



Running the Application

} Mozilla Firefox - o=
Eile Edit View Go Bookmarks Tools Help s

@ = L} x @ @ |’.; hitp Mocalhost: B0B0/GuessNumber/pagesfinputnumber.jsf ]B D Go

How cool. You have guessed the number, 32 is correct!

Flay Again?

| Done

Figure 5.23. Your Guess is Correct
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Project Examples

JBoss Developer Studio provides an option to download and import a ready-made project that
you can explore and derive some useful technology implementation lessons.

6.1. Downloading a Project Example

To download a project example and start working with it you need to take a few steps:

* Go to the menu bar and select File > New > Other...

» Select Jboss Tools > Project Examples(You can also call the Project Examples from menu bar:
Help > Project Examples...)

Mew Project Example

Project Example p—

Impart Project Example [

Site: | Al |

Projects:

type filkar text ]

Seam
Portlet
ESE
RichFaces
RESTEasy

R A

Description;

Project name: | |

Project size: | |

URL: | ]

| Sheow the Quick Fix dialag

Cancel

Figure 6.1. Project Examples
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* Now in the New Project Example dialog you can select a project you would like to explore and
a site to download it from

Project Examples Wizard provides a filter field to more easily locate the project examples you
want, so you can type in the project you would like to explore in the field.

Mew Project Example

Project Example

1

Import Project Example

Site: | Al =
Prajects:

[ty‘pe filtar tomt ]

~ Seam E

Seam DWD Store Example - EAR

Seam Booking Example - EAR
Seam Booking Example - EAR mavenized -

Seam Booking Example - EAR mavenized - Seam 2.1.1.GA

Saam Eoo |-:'|r|-;| Example - WaAR Standalone

Description:

This example demonstrates the use of Seam in a Java EE 5 emaronment,
Transaction and persistence context management is handled by the g2 container,
This example can also run in Tomcat with |Boss Embedded.,

Project namea: ljh 055-58aM-pa |

Project size: | 5.24M ]

LIRL: [http ‘ffanonsvn jboss.orgireposfbosstoolsfworkspacefsnjeza/sea m-exampl|

| Show the Quick Fix dialog

@ | Iext = | Einish ] | Cancel

Figure 6.2. Selecting a Project Example

Quick Fixes

» Press Finish to start downloading the project from the repository
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When downloading is finished the project will be imported automatically and you will be able to
see it in the Package Explorer.

Now you can run the application on the server.

() |Boss Suites: Seam Framewark 53 =8

(O [http:f.ﬂocalhust:HDEijDsE-seam-ipa.l'h-:me.searn v| B .

jboss suites | seam framework demo

Hthe fusion of the best
p % y = el |

Login Name

Password

Account Login

Reqister Maw User

Created with JBoss EJB 3.0, Seam, MyFaces, a:
[<] | I*]

Figure 6.3. Seam Demo Application run on the Server

6.2. Quick Fixes

Project Examples Wizard has an option for making quick fixes for the imported project to easily
fix possible issues like missing servers, Seam runtimes etc.

To enable quick fixing option you need to check the Show the Quick Fix dialog while choosing
the Project Example.

When the project you selected is downloaded it will be checked for missing dependences and if
there are some you will see a dialog listing the problems.
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Quick Fix

Quick Fix '\J

Select @ marker and click the Quick Fix button, 5-!
Markers:

Description Resource Type

Seam Funtime *Seam 2.0 FP* booking Seam Project Problem

Unbound classpath container: booking-ejb Ewild Path Problem

The project cannot be built unt booking-gjb Jawva Problem

()] Quick Fix | Finish ]

Figure 6.4. Quick Fix Dialog box

To fix the problem you need to:

 Select the problem from the list
 Click Quick Fix button

You will be offered a solution or a number of solutions to the problem.
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Quick Fix
Quick Fix ]
Select the fix for '‘Seam Funtime *Seam 2.0 FP* specified for Seam project "booking® does not exist. ;f
Select a fic

et Searmn properties

Problermns:
Resource Location | select all
| @ bookin Urknown ————
g |Qﬂse!ect Al

7 Einish | cancal I

Figure 6.5. Quick Fix Dialog box: Selecting a Fix

In this case(see the image above), when the Finish button is pressed, Seam Settings dialog box
will be displayed where you need to provide a path to the Seam environment to fix the issue.

When the problem is fixed you will be returned to the Quick Fix dialog box with the remaining
problems to be fixed.
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FAQ

For more information on JBoss Developer Studio features, refer to the following FAQ to get the
answers on the most "popular" questions.

7.1. What should I do if Visual Page Editor does not
start under Linux

Linux users may need to do the following to get the Visual Page Editor to work correctly on their
machines.
1. On Red Hat based Linux distributions install the xpLib.i386 package

2. Type

In -s libstdc++.50.5.0.7 libstdc++.s0.5

3. and/or use

yum install libXp

4. Open the JBDS perspective. If you see the Help view open, close it and restart JBDS

5. If it doesn't help and you use Fedora Core Linux and Eclipse Version: 3.4.1,the issue can
be produced because libswt-xulrunner-gtk-3449.so file doesn't present in eclipse-swt-3.4.1-
5.fc10.x86_64.rpm/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_64_3.4.1.v3449c.jar.To add
this file to eclipse you should:

» Decompress eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.4.1.v3449c.jar form eclipse-
SDK-3.4.1-linux-gtk-x86_64.tar.gz

» Copy libswt-xulrunner-gtk-3449.so file to your Fedora Eclipse location.

« Open the file eclipse.ini,which can be found in your Fedora Eclipse location and add the
following line:

-Dswt.library.path=/ust/lib/eclipse

,where /usr/1i b/ eclipse is the path to your eclipse folder.

6. If none of these work, do the following:
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 Clear the Eclipse log file, <workspace>\.metadata\.log

 Start Eclipse with the -debug option:

eclipse -debug

» Post the Eclipse log file (<workspace>\.metadata\.log) on the forums.

7.2. Do | need to have JBoss Server installed to run
JBoss Developer Studio?

No. JBoss Developer Studio already comes bundled with JBoss Server. We bundle it together so
that you don't need to download any additional software and can test your application in a Web
browser right away.

If you want to use a different JBoss server installation, after JBoss Developer Studio is installed
open Servers View (select Window > Show View > Others > Server > Servers), then right click on
this view > New > Server and follow the wizards steps to point to another Jboss Server installation.

JBoss Developer Studio works with any servlet container, not just JBoss. For more information
on deployment, please see the Deploying Your Application section.

7.3. 1 have an existing Seam 1.2.1 project. Can | migrate/
import the project to a JBDS Seam project?

We highly recommend you to create Seam 1.2.1 project using the JBDS. In other case try to do
manually:
» Create a Seam Web project to get the JBoss tools structure

Then from your Seam 1.2.1 seam-gen project start doing the following:

» Copy srctosrc
» Copy view to Web content

» Copy resources individual files to where they are in the seam web project etc.

7.4. 1 have an existing Struts or JSF project. Can | open
the project in JBDS?

Yes. From main menu select File > Import > Other > JSF Project (or Struts Project) and follow
wizards steps.
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Can | import a .war file?

7.5. Can | import a .war file?

Yes. Select File > Import > Web > WAR file, then follow importing steps.

7.6. Is it possible to increase the performance of
Eclipse after installing your product?

JBoss Developer Studio preconfigures eclipse via the eclipse.ini file to allocate extra memory, but
if you for some reason need more memory then by default, you can manually make adjustments
in this file. For example:

-vmargs -Xms128m -Xmx512m -XX:MaxPermSize=128m

7.7. How can | add my own tag library to the JBoss
Tools Palette?

See Adding Tag Libraries in Visual Web Tools Guide.

7.8. How to get Code Assist for Seam specific
resources in an externally generated project?

To get Code Assist for Seam specific resources in an externally generated project, you should
enable Seam features in Project Preferences. Right click an imported project and navigate
Properties > Seam Settings. Check Seam support box to enable all available Seam Settings.

7.9. How to import an example Seam project from
jboss-eap directory?

To import an example Seam project from jboss-eap into your working directory, you should
perform the following steps:

e Goto New > Other > Java Project from Existing Buildfile
» Point to the build.xml of any chosen project by pressing Browse button
e Hit Finish to open the project

As these seam examples are non WTP projects, next you should enable Seam support for them.
To do that, right click the project and go to Properties > Seam Settings.
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7.10. Is a cross-platform project import possible for
JBDS?

Yes. You can easily import created in Linux JSF, Struts or Seam project to Windows and vice
versa.

To do the transferring JSF, Struts or Seam project, go to Menu > Import > General > Existing
Projects into Workspace, select the folder where your project stored and press Finish.
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Further Reading

« Seam Dev Tools Reference Guide (html)

This guide helps you to understand what Seam is and how to install Seam plug-in into Eclipse.
It tells you the necessary steps to start working with Seam Framework and assists in a simple
Seam Project creation. Also you will learn how to create and run the CRUD Database Application
with Seam as well as find out what Seam Editors Features and Seam Components are.

« Visual Web Tools Reference Guide (html) provides general orientation and an overview of
JBDS visual web tools functionality. This guide discusses the following topics: editors, palette,
web properties view, openOn, content assist, RichFaces support.

» JBoss Server Manager Reference Guide (html)

This guide covers the basics of working with the JBoss server manager. You will read how
to install runtimes and servers and quickly learn how to configure, start, stop the server and
know how deployment and archiving process. You will find out how to manage installed JBoss
Servers via JBoss AS Perspective. You will also read how to deploy modules onto the server.

* jBPM Tools Reference Guide (html)

With jBPM Tools Reference Guide we'll help you to facilitate a cross-product learning and know
how you can speed your development using special editors and visual designers. We'll also
guide you through the steps on how to create a simple process and test it within j[BPM jPDL
perspective.

» Hibernate Tools Reference Guide (html)

Throughout this guide you will learn how to install and use Hibernate Tools bath via Ant
and through Eclipse. We'll supply you with the information on how to create mapping files,
configuration file as well as a file for controlling reverse engineering by using specific wizards
that Hibernate tooling provides. Also you will know about Code Generation and peculiarities of
work within Hibernate Console Perspective.

+ ESB Editor Reference Guide (html)

This guide provides you with the information on ESB Editor and all necessary wizards for ESB
files development.

» JBoss Portal Tools Reference Guide (html)

The guide gives a detail look at how you can easily build a Portlet Web Application with JBoss
Tools and deploy it onto JBoss Portal.

» JBoss WS User Guide (html)
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This guide gives you practical help on JBossWS usage. You will learn how to create a web
service using JBossWS runtime, find out how to create a web service client from a WSDL
document using JBoss WS and also see how to set your development environment.

* Smooks Tools Reference Guide (html)

This guide is packed with useful and easy-to-understand information about graphical,
configuration and source editor pages.

» Drools Tools Reference Guide (html)

The guide help you to discover how to create a new Drools project, use debugging rules and
work with different editors.

* JMX Tools Reference Guide (html)

With the help of this guide you'll explore the best practices to follow when working with MBean
Explorer, MBean Editor, Connections and etc.

» Eclipse Guvnor Tools Reference Guide (html)

The purpose of this guide is to describe briefly the functionality present in the Eclipse Guvnor
Tools (EGT) for Drools 5.

* JSF Tools Tutorial (html)

This tutorial will describe how to deal with classic/old style of JSF development and how to
create a simple JSF application using the JBoss Developer Studio.

* JSF Tools Reference Guide (html)

From this guide you'll discover all peculiarities of work at a JSF project. You'll learn all shades
that cover the process of project creation and take a closer look at the JSF configuration file.
Also you'll get to know managed beans and how to work with them and find out, how to create
and register a custom converter, custom validator and referenced beans in a JSF project.

» Struts Tools Reference Guide (html)

In Struts Tools Reference Guide you will learn how to create and work with a new struts project.
This guide also provides information about graphical editor for struts configuration files, tiles
files, and struts validation files.

» Struts Tools Tutorial (html)

This tutorial will describe the classical style of Struts development, and will step-by-step show
you how to create a simple Struts application in JBoss Developer Studio.

» Exadel Studio Migration Guide (html)

This document is intended to help you to migrate an existing Exadel JSF or Struts projects from
Exadel Studio into JBoss Developer Studio.
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If there's anything we didn't cover in this guide, please feel free to visit our JBoss Developer Studio
Users Forum or JBoss Tools Users Forum to ask questions. There we are also looking for your
suggestions and comments.
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