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Chapter 1.

Introduction

If you prefer to develop web applications using Struts technology JBoss Tools also meet your
needs. The professional developer toolset provides all necessary editors and wizards for creating
Struts resources that enhances the process of building high-quality web applications.

E] Note:
Note that JBoss Tools support the Struts 1.1, 1.2.x versions.

In this guide you will learn how to take advantage of Struts support that JBoss Tools provide.
1.1. Key Features of Struts Tools
For a start, we propose you to look through the table of main features of Struts Tools:

Table 1.1. Key Functionality for Struts Tools

Feature Benefit Chapter
Struts Support Step-by-step wizards for creating a new struts | struts support

project with a number of predefined templates,
importing existing ones and adding struts
capabilities to non-struts web projects.

Support for Struts Working on file using three modes: diagram, | graphical editor for
Configuration File tree and source. Synchronization between the | struts configuration
modes and full control over the code. Easy  file debugger
moving around the diagram using the Diagram
Navigator. Working with struts projects that
have multiple modules. Possibility to use Struts
configuration file debugger allowing to set
break points on struts diagram and then launch
the server in debug mode.

Support for Struts A Struts module (struts-config.xml) is | modules
modules automatically created while creating a new
project. There is also possibility to add new
ones or edit already existing modules in
your existing project or while importing Struts

project.
Verification and All occurring errors will be immediately | verification and
Validation reported by verification feature, no matter in | validation

what view you are working. Constant validation
and errors checking allows to catch many of
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Chapter

Feature

the errors during development process that
significantly reduces development time.

1.2. Other relevant resources on the topic

All JBoss Developer Studio/JBoss Tools documentation you can find here [http://docs.jboss.org/

tools/].

The latest documentation builds are available here [http://download.jboss.org/jbosstools/nightly-
docs/].
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Chapter 2.

Projects

JBoss Tools provide the following functionality when working with Struts:

» Create new Struts projects

Import (open) existing Struts projects. You can import any project structure

Add Struts capabilities to any existing Eclipse project

Import and add Struts capabilities to any existing project created outside Eclipse.

Now, we'll focus on all these points more fully.

2.1. Creating a New Struts Project

JBoss Tools provides a New Struts Project Wizard that radically simplifies the process for getting
started with a new Struts project. You just need to follow these steps:

» Select File > New > Project... from the menu bar. Then, select JBoss Tools Web > Struts >
Struts Project in this dialog box. Click Next:

= New Project ®

Select a wizard s

Wizards:
type filter taxt

I & JBoss jBPM E
= (= |Boss Tools Web
b= )sF
= [= Struts
P
P& Jra
I & Plug-in Development
P = Seam

h 0 Coetes —

@ Mext = I Cancel
ST

Figure 2.1. Selecting Struts Wizard
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 On this form, provide the Project Name. You can also select where to create the project or use
the default path.

Next to Struts Environment set which Struts version to use.

= New Struts Project X

Create Struts Project af}

The Create New Project Wizard is used for creating

a brand new project, If you already have a pre-existing
project, just use the Import Project Wizard to start working
with it in JBoss Tools.

Project Name* [51:-utsprn;ect ]

[F] Use default path*

cation® 'optMorkMorkspa:ejbdsfStmtsﬁ‘uje:t i Change ]

Struts Environment: - Struts 1.1 ‘

Ternplate*

'@' : || Mext = ]| Finish H Cancel

Figure 2.2. Creating Struts Project

Tip:

Don't put spaces in project names since some OS could experience problems with
their processing and searching these files.

You can select the KickStart template, then the project created will include a simple Hello World
type application that is ready to run.




Creating a New Struts Project

- New Struts Project x

Create Struts Project @

The Create New Project Wizard is used for creating

a brand new project. If you already have a pre-existing
project, just use the Import Project Wizard to start working
with it in JBoss Tools.

Fraject Name* StrutsProject

Use default path*

‘optiworkiworkspace_jbds/StrutsProject

Ak

Struts Environment® Struts 1.1

Termplate* Blank

KickStart

(il Mext = ” Finish H Cancel |

Figure 2.3. Choosing Struts Template

» Next, you register this application with the current servlet container defined for your workspace
(JBoss AS, by default) in order to allow you to test your application more easily while still
developing it. A new entry will be added in the servlet container configuration file to enable
running the application in-place (called null deployment or link deployment). Uncheck the
"Target Server" check box if for some reason you don't want to register your application at
this point.
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= New Struts Project x

Web 0"}

Serviet Version [2.4 =]

Context Path* | strutsApplication

Runtirne: * []Eoss 4.2 Auntime = Mew. ..

LIRS |Boss Application Server 4.2 New

Select All

Deselect All

i

()] [ < Back ][ Mext = ” Einish [ Cancel I

Figure 2.4. Registering The Project at Server

« On the next form, you can select the TLD files to include in this project:




Creating a New Struts Project

- New Struts Project x
Tag Libraries
Select tag library files you want to use in your project @
TLDs
L] struts-nested.tid
L Fmit.tid
L] sqltid
L ctid
L oxtid

& struts-htrml tid
& struts-bean.tid
& struts-logic td
L] struts-tiles td

@ i "Enlgr\” Cancel ]

Figure 2.5. Selecting Tag Libraries

After the project is created, you should have the following project structure (if you used the
KickStart template):
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MR & > |

(S

= F# StrutsApplication

b ® JavaSource
I =i Web App Libraries
I mi JRE System Library [jdk1.5.0_12]
I =k Al JBoss Libraries [|Boss 4.2 Runtime]
I = ant
= = WebContent
I (= META-INF
= = WEB-INF
b &b
i struts-bean.tid
[¥] struts-cenfig.xmi
w struts-htrmil.td
& struts-logic Hd
¥ validation.xmil
¥ validator-rules.xmi
=t web xmi

il index jsp

Figure 2.6. Project Structure

Tip:

If you want to hide the jar files from Web App Libraries in view, select the down-
pointing arrow in the upper right corner, select Filters..., check the box next to
Name filter patterns (matching names will be hidden), and type *.jar into the field.
Then, click OK.

2.2. Importing an Existing Struts Project with Any
Structure

For detailed information on migration projects to JBoss Developer Studio see Migration Guide
[../../Exadel-migration/html_single/index.html].
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Adding Struts Capability to an Existing Web
Application

2.3. Adding Struts Capability to an Existing Web
Application

Here, we'll consider how to add Struts functionality (Struts libraries, tag libraries and a Struts
configuration file) to any existing Web application project in your Eclipse workspace.

By adding a Struts Nature to your project, you can now edit files using JBoss Tools editors, such
as the Struts configuration editor and the JBoss Tools JSP editor. To take advantage of this just
right-click the project and select JBoss Tools > Add Struts Capabilities from the context menu.
This will start the process of adding all necessary libraries and files to make a Web Struts project
from your one.




Chapter 2. Projects

UsaRR B we- oiecs| ~ O

&

New

b % Strutes
& oo

Open in New Window
Open Type Hierarchy Fa
Show In Shift+Al+W  »

[E Copy Ctri+C

[ Paste Ctri+v
K Delete Delete

Build Path 8
Source Shift+Alt+5  »
Refactor Shift+Alt+T »

g2 Import...
Ly Export.

+ Refresh F5
Close Project
Close Unrelated Projects
Assign Working Sets..

Run As ¢

1 m—— '

Profile As ¥

Validate

Add Spring Project Nature | '
o QB 2 st Copavities—
Compare With p | b AdH ]S abilitle

Restore from Local History...

Add Custom Capablles. .

FDE Tools / Remove |5F Capabilities
Java EE +
Verify

Properties Alt+Enter

Figure 2.7. Adding Struts Capabilities

In the wizard you should point to location of your deployment descriptor file web.xml and name
of the project.
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Application
- Import Struts Project x
Project Location
Please select web xml location @J

web xmil Location® [mntmumibuS_Mﬁvumspace.r]SFHelluMEDCuntenLWEE-INFmeb.xml | Change... |

[ |SFHello |

Cancel

@ . Hep |

Figure 2.8. Choosing Project Location

After hitting Next, you will see the following screen. This screen simply means that you need
to add at least one Struts module to your project to make this project a Struts project. Adding a
Struts module means that a new struts-config.xml will be added to your project and registered in
the web.xml file. In addition, all required Struts libraries will be added. To add a Struts module,
select the Add Struts Support button.
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F:' g Import Struts Project =
Project Modules
i The project should contain at least one Struts module to be imported Q
Name URI |

Add Struts Support

® [ hep | [ <Baek ] e~ I==n

Figure 2.9. Project Modules

Here you can select what Struts Version, Servlet Class, URL Pattern and TLDs to add to this
project.
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Adding Struts Capability to an Existing Web

Application
= Add| Struts Support x
Struts Project
Please select struts support options @
Version® 12 |~ ]

Serviet Class.* lr:rg apache struts action ActionServiet ] l Change... ]

URL Pattern:* [*.da ]

TLD Files:* [ struts-nested tid

O fnt.td

[ sqi.tid

O cud

[0 =xud
struts-himi td
struts-bean td
struts-logic tid
O struts-tiles tid

(il | Finish ” Cancel I

Figure 2.10. Selecting Struts Support Options

When done, you will see the default Struts module configuration information. See how to Edit
Struts modules.
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- Import Struts Project x
Project Modules
Configure Project Modules @ s

Name URI

=default= MWEB-INF/struts-config.xml

Name | =default>

URI [MEB-INFED’UIS-c onfig.xmi

Path on Disk F:t.mmrh'jbds_GA.MurkspaceijFHeIIuMebCuntenuWEB-INF.*stmts-t:unﬁg.xmlE [ Change...

Sources Path | foptiworkijbds_GA/workspace/JSFHello/javasource || change..

Web Root [.mpt.mnnq']hus_GmancspaceﬂSFHellaMenCantent [ Change...

@ [ Help ” < Back H Mext =

Figure 2.11. Project Configuration Information

On the last screen you can set the different folders for your project as well as register this
application with a servlet container. If you want the libraries (.jar files) will be automatically added
to your project, click on the checkbox Add Libraries.
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Adding Struts Capability to an Existing Web

Application
= Import Struts Project x
Project Folders @
Select Project Folders
: |
Classes Folder [Inpthmrkﬂbds_GMmrkspac &/|SFHello/MWebContent WEB-INF/classes ] [ Change... ]
Lib Folder | foptiworkiibds_GAMworkspace/JSFHello/MebContent/WEB-INF/ib || cnange... |

Ant Build File [ || Change... |

[] Add Libraries

Envirenment [su-uu 12 =]
Serviet Version:  |2.4 =]
Context Path*  [JSFHello |
Runtirme:* [JEloss 4.2 Runtime ;l [ Mew... l
Target Server: Choice list is empty. New,,.

Select All

Deselect All

@ [ Help H < Back Next > Einish ][ Cancel ]

Figure 2.12. Registering the Project at Server

When done, you can open end edit the struts-config.xml file using useful Struts configuration file
editor provided by JBDS. (The Struts configuration is shown below in the Tree viewer).
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RN, S rconmgomi B oe

= % ¥ | Struts Config Editor
Y =]
¥ & JSFHello 1| ~ struts-config v Properties Editor
B JavaSource
&) u = = ctruts-config.xmi struts-config 1.1
b =k Web Libraries ;
App L data-sources N |sl.mls-conng |
P =L JRE Systern Library [jok1.5.0_12 ;
IRE 5y vl 12 g form-beans
P =i Al JBoss Libraries [JBoss 4.2 Runtirr ) ) |""" |
= % global-exceptior
B = ant ; . I ]
= g global-forwards ld:
= [= WebContent E X
L action-mapping: Comment: | ” Change... l
P = META-INF
3} controller ) T
= [ WEB-INF e Encoding: ”I ITF-8 =]
) resources
= ity B
u_j' ! % plug-ins
] Faces-config.xmil
< struts-bean tid
] B struts-config.xmi
‘] I ] D]
i web Projects 12 =8
o EE s
b 4 JSFHello 2
= |§) StrutsApplication
P = WEB-ROOT (WebContent)
= = Configuration
= % default
v = struts-config.xmi ]
P [ ]
B web sl (] )
b = Resource Bundles |v)|| Diagram Tree | Source

Figure 2.13. Struts-config.xml File

2.4. Relevant Resources Links

You can find more in-depth explanation on how to work with special wizards, editors and views
that can be used in various scenarios while developing Struts applications in our Visual Web Tools
guide [../../jsf/html_single/index.html].
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Chapter 3.

Editors

In this chapter we'll introduce you to featured graphical editors for specific Struts files such as
Struts Configuration files, Tiles files and Struts Validation files.

3.1. Graphical Editor for Struts Configuration Files

First, let's dwell on the Struts Configuration file editor.

This editor has three views with different representation of struts-config.xml: Diagram, Tree and
Source. The views can be selected via the tabs at the bottom of the editor. Any changes made in
one view are immediately visible when you switch to any other view.

Now, we'll consider every view in more detail.
3.1.1. Diagram View

The Diagram view graphically displays the Web flow of the application defined in the Struts
configuration file.

£ struts-config.xmi £ S0
5

7| [Ceemame]

>

M

i /pagesiinputname.jsp

%

:

(%)

fgreating

o | GetNameForm
sayHello

/page sfgrasting.|sp

Diagram Tree Source

Figure 3.1. Diagram View

The Diagram view allows to edit navigation in your Struts application. Just by right-clicking
anywhere on the diagram, you can use a context menu to create the building blocks of a Struts
application:

17
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» Actions

Global forwards

Global exceptions

« JSP Pages
£ struts-config.xmil &3 =8
b
-
A R
< Create Comment... ~ Global Forward. ..
e £ Global Exception..,
zﬁ Page...
Select Element
Auto-Layout
—
W Werify

page sfgresting.|sp
Properties . | &

™ Generate Java Code..

Input Methods v

Diagram | Tree Source

Figure 3.2. Diagram Context Menu

Along the upper-left side of the editor is a stack of seven icons for changing the behavior of the
cursor in the diagram.

vy

T
L

& Wi

27

Figure 3.3. Editor Icons

The first icon switches to the default regular selection cursor, the second to the marquee selection
cursor and the third to the new connection cursor. The last four icons switch the cursor to an insert
cursor for each type of Struts build block listed above (and in the order listed).

18



Tree View

For instance, clicking on the first of these four icons (the one with the gears) will switch the cursor to
insert actions. Clicking anywhere in the diagram with this cursor has the same effect as right-click
and selecting Add > Action... from the context menu with the regular cursor active. It's just more
efficient to use this cursor if you're adding more than one action at once.

3.1.2. Tree View

The Tree view represents the different elements of the Struts application that are organized into
functional categories on the left-hand side and a form for editing the properties of currently selected
items on the right-hand side.

£ struts-config.xmil 53 =0

Struts Config Editor

- struts-config - Properties Editor =
= By struts-config. xmil forward
% data-sources Id: | |
& form-beans 1
t lassham | | Browse... |
% global-exceptions :
= L global-forwards ContextRelative | - I
& gethame Module I |
= L& action-mappings
Mame: | sayHello |

= W /greeting

e [pagerrestng o} change...|

B} controller Redirect i
o resourcas

Small-lcon: I |
3 plug-ins

L-ﬂl'ge-lcﬂl"l: | |

Diagram Tree  Source

Figure 3.4. Tree View

You can also right-click on any node in the category tree and perform appropriate operations
through a context menu. For instance, by right-clicking on the action-mappings category node,
you can add new actions to the application.
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o sts-connig ! . ~d

Struts Config Editor

= struts-confilg - Properties Editor

- B struts-config.xmil action-mappings

5% data-sources Idd: | |

& form-beans Type | |

% glebal-excaptions

= L@ global-forwards Comment: | “ Lhange... ]

i gethame

~ B action-rmappinos

= G igreeting

& sayHelI(f sort
B contratler |
) resources Properties...
L plug-ins _
|V Veriry

[1] 1l 0

Diagram Tree | Source |

Figure 3.5. Tree Context Menu

3.1.3. Source View

In the Source view, you have complete editing control of the underlying XML coding.

20



Source View

ii.iiiiii“liiiii' ﬁiii

=?xml version="1.0" encoding="I50-8859.1" 7=

<struts-config=
=data-sources/=
<Torm-beans/=>
=form-beans name="GetNameForm® type="demo.GetNameForm® />
</ farm-beans=>
=global-exceptions/>
=global-forwards>
=forward name="getName® path="/pages/inputname.jsp” /=
</global- forwards>
<action-mappings>

=forward name="sayHello" path="/pages/greeting.jsp”/=>
<faction=
<faction-mappings=
<controller/=
</struts-contig

<IDOCTYPE struts-comfig PUBLIC *-/fApache Software Foundation/sDTD 5t
"http://struts. apache, org/dtds/struts-

=action name="GetNameForm" path="/greeting"score="request" type="de

[4] |

D)

Diagram | Tree Source

Figure 3.6. Source View

When working in Source view, you always have all the following features available:

« Content Assist
* Open On Selection

« File Folding

You can take advantage of code assist
index.html#CodeAssistAndDynamicCodeAssist42BasedOnProjectData].

[../../jsf/html_single/
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=8

<STruts-contigs
=data- sourcess/>

<?xml version="1.8" encoding="I150-8859-1"7>
<IDOCTYPE struts-config PUBLIC *-.//Apache Software Foundation//DTD 5t

"http://struts. apache.org/dtds/struts-

<> action-mappings
<> controller
<> data-sources

<> description

< form-beans

< glabal-exceptions
< glabal-forwards

< message-resources

<> plug-in

# display-name 3

L# comment - ¥l conrent

- [Element : display-name
The "display-name® element contains a short {one line)

tools.

fData Type : 2PCDATA

LT

description of the surrounding element, suitable for use in GUI

(<]

[+]

Diagram |'Itee ‘Source

Figure 3.7. Code Assist

The editor will also immediately flag any errors.

I =L web App Libraries

I B\ JRE Systemn Library [jdkl
I =4 All |Boss Libraries [|Boss

b & ant
= = WebContent
[* (= META-INF
I (= pages
= G2 WEB-INF
b &b
s carDetail jsp
|¥| faces-config.xmil

«» struts-bean tid

+4 struts-config.xmi

“_» struts-htmi tid
& struts-logic td

8%~

@ <struts-config>

Bwent s 577 0| G

=0

=7xml wersiom="1.8" encoding="I50-8859-1" 7>

=!DOCTYPE struts-config PUBLIC *-//Apache Software Foundation//DTD St_

"http://struts. apache. org/dtds/struts-

<data- sources/>
<form-beans/>
<form-beans name="GetNameForm® type="demo.GetNameForm® />
<fform-bheans=>
<global-exceptions/>
<global- ferwards>
=forward name="getName" path="/pages/inputname.jsp"/>
=/global- forvardss
<action-mappings>
=action name="GetMameForm" path="/greeting”score="request” type="de
=forward mame="sayHello® path="/pages/greeting.]jsp®/=

lgs ometag>

<faction=>
<faction-mappings>
<controller/>
<fstruts-config

! T B

I*]

Diagram Tree Source|

Figure 3.8. Errors in Source View

Finally, you can use the Outline view with the editor to easily navigate through the file.
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Graphical Editor for Tiles Files

|E'a> struts-config.xmi 3 =0 Si ain ﬁ # jBos = 0O

<7xml version="1.0" encoding="UTF.8" 7= =] e

<IDOCTYPE struts-comfig PUELIC *-/f/Apache Software Foundation//D
"http://jakarta.apache.org/struts - E&EMS{B!‘IHQ.HH‘II

<struts-config= )

<data- Sources/s 4 data-sources

<form-beans= [+ L& form-beans

=form-bean name="GetNameForm® type="demo.GetNameForm® /> ) i
</farm-beans= % global-exceptions

<global-exceptlions/> [* (@ global-forwards
=global-forwards=

=farward name="getName" path="/pages/inputname.jsp” /= ¥ g action-mappings

</global- forwards> - U fgresting
'r:ﬁi.'t"l.l:ll'l-l'l'lapp'l.r'll.]‘u} . hell
=action name="GetMameForm® path="/greeting" scope="request® ty

=forward name="sayhello" path =‘:"pége5.-fg reeting. jsp*/ a controller
=faction=
</action-mappings>
scontrollers/= 55 plug-ins
</struts-contTig=>

2 resources

_ [ | D
Diagram |Tree Source a 1]

Figure 3.9. Outline View

Find more information about editor features here [../../jsf/html_single/index.html#editors_features].

3.2. Graphical Editor for Tiles Files

Here, you'll know how to make use of the special graphical editor for Tiles configuration files.

The editor has three main views: Tree, Diagram and Source. The views can be selected via the
tabs at the bottom of the editor. Any changes made in one view are immediately visible when you
switch to any other view.

Before we consider each view of the editor, let's look at the way of creating new Tiles files.

3.2.1. Create New Tiles File

To create new Tiles files, right click any folder and select New > Tiles File.

23


../../jsf/html_single/index.html#editors_features
../../jsf/html_single/index.html#editors_features

Chapter 3. Editors

E.i Web Pro i “a ﬁ =8
5% <
= 3 struts
P+ i@ JavaSource
[+ = Web App Libraries
I+ Bl JRE System Library [jok1.5.
I+ =i a0 JBoss Libraries [|Boss 4.2
b ant

b = ME Go |nto
b = pa
DPEI'I In Mew Window
| = i ShtsAtsW >
Lo ch
i) co| B Sopy Ctri+C
g Cu
. _ | [ Paste Ctri4V
[ T
.| H Delete Delete
EG ing
i sta Build Path »
Refactor Shift+aIt4T »
i3 Import....
5 Export...
4 Refresh F5

Assign Working Sets...

—
Figure 3.10. Creating a New Tiles File

3.2.2. Tree View

= & weo ] 3 )5F Project

| & struts Project
7 Project...

t# Package

(& Class

& Interface

&7 Source Folder
5 Folder

LT File

E% Struts Config
|9 Faces Config
% validation File
> TLD File

4 |SP FAle

% XHTML File
% HTMI File

The Tree view represents the different elements of the Tiles file that are organized into functional
categories on the left-hand side and a form for editing the properties of currently selected items

on the right-hand side.
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Tree View

| esdetsami

1

Tiles Editor

- tlles-defs

= tiles-dafs ximil

= [ tiles layout
[=] titie

|#] action

[ tiles head

IC

| tiles.action
%] tiles root
m
IC

"n tiles.error

|"s| tiles layout.errors

(] T ITe]

~ Tiles Config Description

|=i|es-aefs

Encoding: I

4

~ Definitions

narme extends path

tiles layout

tilesfayout jsp

tiles head tiles/head jsp
tiles. action tiles/action jsp
tiles foot tiles/foot jsp
tiles .error tiles/error.jsp

tiles layout.error tiles layout

i1

Bemove. .,

Tree Diagram Source

Figure 3.11. Tree View

To edit the file, simply right click any node and select among the available actions.
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Chapter 3. Editors

o
™
]

(4]

Tiles Editor
- tlles-defs ~ Basic
= |4 tiles-defrs_ xmi MName: Emes,layout
- [l tiles layout —
e “ =
! st...
[#] action |tiles.flayruut.j5p |I Change... J
] Rename...
%] tiles head | |I Browse... ]
Cu tles.action | 15 copy | || cnange... |
|"s| tiles Foot TRy
["s] tiles error
— K Deleta Delate
% tiles layeut.
Properties...
T LT Ty P e | d
Description | || Change. . ]
Role; [ b
a T [Ty)  smaldcon: | |
Tree Diagram Source

Figure 3.12. Editing in Tiles Editor

3.2.3. Diagram View

The Diagram view allows you to create complex Tiles files in the form of a diagram.
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Diagram View

B

=

3
o

m S . _ tiles. lmyout errors
|

ETE

Tree | Diagram  Source

Figure 3.13. Diagram Mode

To create new definitions, simply right click anywhere in the diagram.
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" tiles-defs.xmi £3 =0
= tites. layout
= .
3 B ]
il @ rar

5] I

tibas. foat MNew Definition...

tibe s Bction

] I

tiles . lmacl

5] Prererences..

Input Methods .

Tree Diagram | Source

Figure 3.14. Creating New Definition

You can also use the Diagram toolbar to make editing easier.

tiles-ders xml 2

tiles_layout

7] )

P lwt) |

Figure 3.15. Diagram Toolbar

It contains four icons for changing the cursor state. The first one is the default cursor state for
selecting existing nodes. The second icon is marquee selector. The third is used for creating new
connections and the last one is for adding definition template to the content.

3.2.4. Source

The other view of the Tiles editor is the Source view that gives you full control over the source.
Any changes here will immediately appear in other modes when you switch to them.

When working in Source view, you always have all following features available:

+ Content Assist

« Open On Selection
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Source

=0

=7xml wversion="1.0%7=>

<tiles-definitions=
=put name="title*/=

<put name="action"/=
</definition=

</tiles-definitions>

<IDOCTYPE tiles-definitions FUELIC *-//Apache Software Foundation//DTD Tiles Comf
“http://jakarta. apache.org/struts/dtds/tiles-c

=definition name="tiles, layout®” path="tiles/layout.jsp™=>

=gdefinition name="tiles. head" path="tilesshead.jsp"“/> L
=definition name="tiles. action” path="tiles/faction.jsp"/=>
=definition name="tiles.foot® path="tiles/Toot.jsp"/>
<definition name="tiles.error® path="tilesferror. jsp*/=
<deTinition extends="tiles.layout” name="tiles.layout.errors"/=

I»]

Tree Diagram Source

Figure 3.16. Source View

Code assist

index.html#CodeAssistAndDynamicCodeAssist42BasedOnProjectData]
Source mode.

[../../jsf/html_single/
is available in the

=7xml wersion="1.8"7=>

=<tiles-definitionss

=put name="title” />
=put name="action®/=
=/definition>]

=IDOCTYPE tiles-definitions FUELIC *-//Apache Seftware Foundation//DTD Tiles Conf
“http://jakarta. apache.org/struts/dtds/tiles-c

=definition name="{iles,layout” path="tiles/layout.jsp">

€3 put

<> putList

# description

<> display-narme
< icon
& comment - xml comment

# XSL processing instruction - X5L processing instruction

|Element : description

========== Info Elameants

The
“description” elerment contains descriptive (paragraph length)
text about the surmounding element, suitable for use in GUI
tools. operties: value, link, icon, tooltip. This properties are to bel
interpreted by the jsp page using them. By default the bean is
of type "org.apache . struts tiles.beans SimpleMenultern®. This
bean is useful to create list of beans used as menu items. valug
The bean ‘value' property. link The bean link’ property. lcon The|
bean ‘icon’ property. tooltip The bean 'tooltip’ property. classtyps
The fully qualified classname for this bean. If specified, the
classname must be a subclass of the interface
“org.apache struts tiles.beans Menultem®. For compatibility with

=ftiles-definitions>

<definition name="tiles, foot" path="tiles/foot.jsp"/=>
<definition name="tiles.error” path="tiles/error.jsp™/=
<definition extends="tiles.layout® name="tiles.layout.errors®/>

[ 1

[#]

Tree Diagram Source

Figure 3.17. Code Assist
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Chapter 3. Editors

Any errors are immediately reported as shown below:

i him ﬁ EiwebpPro = O [ tiles-defs xmi &2 =8
B G ~ <7xml version="1.07= [<]m

- <IDOCTYPE tiles-definitions PUELIC *-//Apache Software Foundation//DTD Tiles Conf

= 5% WEB-INF “http://jakarta.apache. org/struts/dtds/tiles-c

. <tiles-definitions>

b &l <definition name="tiles,layout" path="tiles/layout.jsp"=
gz carDetall sp <put name="title"/=

<put name="action"/>

<fdefinition>

7 struts-bean tid <sometags

=definition name="tiles.head" path="tiles/head.jsp"/=

<definition name="tiles.action® path="tilessfaction.jsp*/=>

<7 struts-hitmil tid =definition name="tiles.foot" path="tiles/foot.jsp"/>

<definition name="tiles.error® path="tilesferror.jsp~/=

<definition extends="tiles.layout" name="tiles.layout.errors"/>

|¥] faces-config.xmi

\¥] struts-config.xmi

o struts-logic td B
| tiles-defs xmi

£ web.xml B </tiles-definitions>

Figure 3.18. Errors Reporting

You can also use the Outline view together with the editor's Source mode. It provides an easier

navigation through the file.

%] tiles-ders.xmi 2 =8 EM ﬁ # o 50O

=7xmlL wversion="1.0"7= =
<!DOCTYPE tiles-definitions PUBLIC *-//Apache Software Foundation//DTD Tiles Conf
“http://jakarta. apache. org/struts/dtds/tiles-c

<tiles-definitions>

=definition name="tiles,layout” path="tiles/layout.jsp">

<pUT mames="Title® /=

=put name="action®/=

</definition>

=definition name="tiles.head" path="tiles/s/head. jsp"/=

<definition name="tiles.action” path="tiles/action.

<definition name="tiles, foot" path="tiles/foot. jsp"/=
<definition name="tiles.error® path="tiles/error.jsp"/=
<definition extends="tiles.layout” name="tiles.layout.errors®/>

=ftiles-definitions=

Figure 3.19. Outline View

3.3. Graphical Editor for Struts Validation Files

(e)er ~

= | tiles-defs xml
= [ tiles layout
[=] title
|= action
% tiles head
& tiles action
% tiles foat
1“4 tiles_error

sl tiles layout.errors

Providing full support for development Struts applications JBoss Tools comes with a visual
validation editor. To open the editor double-click on the validation file or if you don't have it create

a new one.

To create a new validation file, right click any folder in Project Explorer and select File > New >
Other... from the context menu and then JBoss Tools Web > Struts > Validation File.
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Graphical Editor for Struts Validation Files

Select a wizard p— e

Wizards:
type filter text ]

[¥]

.'ﬂ' (= |Boss Tools Web
% £S5 File
o HTML Flle
N S File
& JSP File
™ Properties File
% TLD File -
™4 web Descriptor
o XHTML File
b= )sF
= (= Struts
£ struts Config
& struts Project
% Tiles File

%, Validation File

b & Pa

[4]

lid] . Mext > I | Cancel
S— |

Figure 3.20. Creating New Validation File

The validation editor works with five modes: Formsets, Validators, Constants and standard Tree
and Source that you can easily switch over using tabs at the bottom of the editor.

The Formsets view shows forms and their elements on the left side and the dialogue for defining
their validation rules on the right side.
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=0
Formsets . ' Page 1 || Eat |
BEad > d
Indexed List Propi || Ear |
= W Formset (default)
‘Msg - Corresponded Message Template:
? SRSl name key resource [ Add ]
[+ & AlertWizard 1
I+ & dashboardManagerForm | =4 |
= @ dashboardveiwForm o - ) | Delete |
¥ @ name Arg - Replacement Value for Message Template :
narme arg  key resource

'@ mask

[* @& dashboardWizandMew

a m B P
Var - Validator Parameter
var-narme var-value d

~[{}A-Za-z0-9()_1+[A-Za-z0-9']

Del

Pl

[4] Il | [¥]

Formsets | Validators | Constants | Tree | Source |

Figure 3.21. Formsets View

The Constants view let you set constant values for your validation rules.
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Graphical Editor for Struts Validation Files

Current Global se:tiun X @

constant-name constant-value

Pl |

Delete

Formsets |valld.!tors | Constants | Tree | Sm.rce|

Figure 3.22. Constansts View

The validation file can also be viewed in a Tree view.

33



Chapter 3. Editors

= T farmset (default)
P& Alertwizard

I & dashboardManagerForm
= & dashboardvelwForm
T 3 name
T mask
0 arg0 for reguired
I & dashboardwWizardNew

Formsets |Val|l:lators | Constants Tree Source |

Figure 3.23. Tree View

At any point you have full control over the source by switching to the Source view. Any editing in
this view will immediately be available in other views of the editor.
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=7xml version="1.8" encodimg="I50-8859-1"7= L=
=IDOCTYPE form-validation PUELIC *-//Apache Software Foundation//DTD Commons Vali
"http://jakarta.apache.org/commons/dtds/validato

IE]

<form-validations
=/global=
<global>
=constant= r
=constant-name=standartName=/constant-name=
<constant-value>~[ (JA-Za-z0-9()_)+[A-Za-z8-9']</constant- value>
<fconstant>
</global=>
=formset> -
<form name="AlertWizard"/>
=form name="dashboardManage rForm® /=
=form name="dashboardVeiwForm" >
<field depends="required, mask” property="Name">
=arg kKey="name" name="required® position="argd®/=
=var>
<Var-Name=mask</var-namna:>
=var-value="[()A-Za-20-9()_]+[A-Za-z0-9'])=/var-value=
=fvar=
=/Tield=
=fform=
<form name="dashboardWizardNew" /=
=<fformset>
<!-- An example formset
Gl I I [+
Formsets |Val|d.!mrs |Cunslan1s Tree Source|

(4]

Figure 3.24. Source View
You can also open your own custom or Struts-standard validation-rules.xml file.

The Validators view shows the validation rules for a selected validator. You can of course add
your own rules.

P

o/ pvan ii =5
Cmn:&oﬂalsecﬁoh T |

Validaters o | Depends I ‘ il.':hange |
O d &
Message Key Iermrs.llmenmumher ] icmnge]
name
Java
long
Class Name Icom.ecnnpass_proul-slonlng.rra.vallaator.ﬂmeomumne] il:nange]
float
double Method [validateTimeorNumber | | cnange |
date Method Fhramliava.lang.Obiect. org.apache.commons.\] icnange J
intRange JavaScript
creditCard Function Narmy | iChange J
email Function Body
= =]
var timeMask = “~([0-9]){1,3}:[0-5][0-9]}{0,2}%";
var booleanMask = "~ active|inactive$®;
time_numberforthresholds var anyMask = "~ *$";
var percentMask = " [0-9]+.7[0-9]7%7$";;
war statistic = new Arrayi); =]
(] 1l [+]

Formsets |Val|dalors| Constants | Tree | SDI.I"Cel

Figure 3.25. Validators View

Here are the validation rules shown in the Source mode.
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(<] il [ 1+

=08
m5g=hﬂ :
jsFunction="org. apache. commons. validator. javascript.validateUtilities" /=
<validator name="time_numbe r"
classname="com.echo yrovisioning. rra.validator. Time0d rlumber*
metho validateT imel rNumbe r” ||
methodParams="7java.lang.0bject, =
arg.apache, common s. validator.ValidatorAction, =
- alidator.Field,
g.apache action.ActionMessages,
arg. apache ator.Validator,
javax. servliet.http.HttpServietRequest”
ds=="
sg="errors.timeormumber® >
=javascript=<'[CDATA[
var timeMask = "~([0-9]){1,3}(:[0-5][0-9]){0,2}$";
var numberMask = "“[0-9)+, 7[0-9)%";
var booleanMask = ""active|inactive$”;
var anyMask = "7, %"
var percentMask = "“[0-9]+. Y[0-9] PRTE";;
var statistic = new Arrayi();
statisticl® " 1=anvMask: L

Formsets Validators Constants Tree Source |

Figure 3.26. Validation Rules
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Chapter 4.

Modules

JBoss Tools support working with Struts projects that have multiple modules. You can easily do
the following:

* Add new modules
 Edit modules for an existing project or during Struts project import

Now, let's discuss this functionality in more detail.

4.1. When Importing a Struts Project

During Struts project import, if the project has multiple modules, you will see a screen with all
existing modules. You can select each module and edit its details.

= Import Struts Project x
Project Modules
Configure Project Modules Q
Name LRI
=default= SWEB-INF/struts-config.xmil
MName | =default= |
URI [JWEB-INFETJ‘UIE-chﬁg.KH‘II ]
Path on Disk | fopt/work/jbds_GA/workspacey/Struts/WebContent/\WEB-INF/struts-config.xm || change.. |
Sources Path | jopt/work/jbds_GA/workspace/Struts/Javasource || change... |
Web Root [.fupwuanu]hds_GAMamspacemensmenCantent J [ Change... ]
(il [ < Back H Mext = ] [ Finish | [ Cancel I

Figure 4.1. Configuring Project Modules

37



Chapter 4. Modules

4.2. Editing Modules in an Existing Project

To edit modules in an existing project, right click the project and select JBoss Tools > Modules
Configuration.

Walidate

Add Spring Project Nature

Team *
Compare With L

Restora from Local Hislorr...

|Boss Tools L G

POE Togls * | |d; Add |SF Capabiliies...

Java EE » .
Remowe Struts Capabilities

Properties Alt+Enter Add Custormn Capabilities...
Werify

Modules Configuration

Figure 4.2. Choosing Modules Configuration

You will see the same screen as above where you will be able to select a module and edit its
details.

& Modules Configuration x

Struts Project a

Hame LRI Deleted Add |

<default= PWEB-INF/struts -config.xmi

Mame lc:derault:-

URI | IWEB-INF/struts-config xmi

Path on Disk Mnmspacaﬁwmbc nntent.MEB-IMF.n'sl:n.rrs-cunflg.xml] [ Change...

—_— et e )

Sources Path |Juptfwuncﬂbds_ﬁwwnmspace.ﬁmns.!]avaSuurce ] [ Change...
WebRoot |/opuworkibds_GA/werkspace/Struts/WebContent || change..
Fnish || cancel |

Figure 4.3. Modules Configuration
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4.3. Adding New Modules

Adding a new module is very simple. First switch to Web Project view. Expand your project to
the Configuration folder. Under that folder you should see the current modules. Right click on
Configuration and select New > Struts Config.

- |§) struts
I = WEB-ROOT (WebContent)

~ & Configuration

b Zhdefay  Modules Configuration .

b ez web.:-_.:
b [ Resource Bundles
P+ 2 Tag Libraries
b= Tiles
b (= Validation

a - I [

Figure 4.4. Adding New Modules

You will see the screen below. You can specify a new module name and also add the new Struts
configuration file to web.xml file.

L= Struts Config x

Struts Conflg 0

Folder* | /Struts/WebContent/WEB-INF || Browse.. |

MName:* uuts-conng-nmcl

Version: |11

ik

Module: [.fmucll

Register in web xmi

| Finish || Cancel

Figure 4.5. Adding New Modules
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Code Generation

JBoss Tools comes with a code generation feature. You can generate stub code for Struts Actions,
FormBeans, Forwards and Exceptions.

The code generation that JBoss tooling provides is based on Velocity templates which can
be modified for your use. The templates are located at {JBossStudioHome} > templates >
codegeneration.

There are a number of ways to invoke code generation. One is simply right-clicking the Struts
diagram and selecting Generate Java Code....

&
14
L | [&]osthems |
L
& ipages/inputname.jsp
o
Add L4
Create Comment. ., =
Select Element /pages/gresting.jsp
Auto-Layout 2,
 verify
Properties...
&' Generate Java Code...
Input Methods L

Diagram Tree Source

Figure 5.1. Selecting Generate Java Code

On this screen you can select for which elements to generate code. If you select Next you will be
able to specify more options for each of the categories you selected.
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'f‘- Generate - Step 1 o

java Code Step 1 e

Generate classes for Actions

[] Generate classes for FormBeans
Generate classes for Forwards
] Generate classes for Exceptions

[] Overwrite existing files

Base Package: | |

E Mext == || Generate ” Cancel |

Figure 5.2. Generate - Step 1

Tip:

Please be careful not to override your existing files.

When generation is complete, a result window will appear letting you know how many classes
were generated:

= Generate - Finish x

Java Code Step 7
Generation finished. 0

Message:

[+]

Eenerated classes: 1
orm beans: 1

Figure 5.3. Generation Finished
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You don't always have to generate code for all elements at once. You can invoke generation
for just an individual Struts artifact as well. Right-click an element on the diagram of the Struts
configuration file and select Generate Java Code... from the context menu.

lgreating

¥ | GetNameFor... |
sayhello Open Declaration

Cpen Form-bean Source

£} Create Exception...

™ Create Forward...

™8 Create Property...
Create Comment...
Set as unknown
Select Referring tem

B Generate Java Code._.

Run on Server

Figure 5.4. Generation For Individual Struts Artifact

The same can be done from within the Tree viewer for the editor of the Struts configuration file.

[ sind=-configam! 2 _°

Struts Config Editor

- struts-config = Properties Editor

- = siruts-config xml struts-config 1.1

b3 dat:  Rename... |5tml3-cnn1'|g |
P Ii-;fnn" Add , |xm |
3 glok
b G glot B Generate Java Code. . | |
b L act Properties... Bt | H e ]
3 controller

Encoding: [L.ITF-B o |

53 resources

b 3 plug-ins

Diagram Tree Source

Figure 5.5. Generation in Struts Config Editor
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Struts Configuration File Debugger

JBoss Tools come with Struts configuration file debugger. It allows you to set break points on
Struts diagram and then simply launch the server in debug mode.

Simply right click an Action or a page and select Add Breakpoint.

a : .

Iy

/pages/inputname.jsp

rea
Lo
b -

[ gethame >|a] 1.9
i Open Page

nr Rename Page...

0 Create Link. ..

Lo

Create Comment._.
Show/Hide Links
Select Referring Itermn

[ Copy Ctrl + € | jpagesrgreeting.sp

of Cut Crl + X :-

¥ Delete Delete
Input Methods ¥

[
|
[
|
[ Run on Server
[
|
|
[

Diagrarm | Tree | Source

Figure 6.1. Adding Breakpoint
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Customizable Page Links

Recognizer

Custom page links allow you to define custom Struts page links that will be recognizable in
the Struts application diagram. You can define these links by selecting Window > Preferences
from the menu bar and then selecting JBoss Tools > Web > Struts > Customization from the

Preferences dialog box.

=

|type filter text ]

I General

b Ant

I+ Connectivity
FreeMarker Editor

I+ Help

HOL editor

InstallUpdate

Intermet

Java

JBoss jBPM

JBoss Tools

I JBoss Servers

d = = - v

Packaging Archives
= Web
P Editors
B JSF
P Seam
= Struts
P Autornation
I+ Project
Struts Pages
Verification
P XDoclet
ol : D

@

Preferences

Customization

Link Recognizer E

Tag Attribute
hErnl:lirk action
hkrnl:lirik: page
Rl lirk forward
htmil:frame action
htmil:frame  page
htmil:frame  forward
hrnl: farm action
|I:H;|C forward name

Iaglc rredirect forward

Refer to

Fforward Struts
action Struts
Fforward Struts
Forward Struts

x

B o

action Struts E_dit |
page Struts

Forward  Struts Reiete ]
action Struts
page Struts

1)

| Restore Defautts| | apply |

l OK |[ Cancel I

Figure 7.1. Customization Panel

47



Chapter 8.

Struts Project Verification

In this section we'll consider one more functionality that JBoss Tools provide for Struts projects,
namely adjusting projects verification.

To configure Struts project verification select Window > Preferences from the menu bar, select
JBoss Tools > Web > Verification from the Preferences dialog box and then expand the Struts

Rules node.

£

|type fiter text ]

= |Boss Tools
I |Boss Servers
Fackaging Archives
= Web
b Editors
bsF
I Seam
b Struts
b xDoclet
JPA
Flug-in Development
Run/Debug
Server
Spring
SQL Development
Team
TesthiG

- - - =

@

0

Preferences

Verification

I Check Renderer Attributes
P Check Validator Attributes
P Check Web Descriptor

[ Check Web Descriptor
Check Struts Message Resources

E

Check Struts configuration controller
Check Struts configuration file

Check action forward

EE A A

Check action name

E

Check action references

E

Check action type

E

Check global exception

E

Check global forward
- Web Rules
[ Web Descriptor Rules

% Struts Rules

[ 1+

[*]

[4]

OK

| [ Cancel

Figure 8.1. Struts Rules

Suppose you are working in the Source viewer for a Struts configuration file as shown below:
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Chapter 8. Struts Project Ver...

tName* path="/pages/inputname.jsp* /=

 NameForm® path="/greeting® scope="request™ type="sample.GreetingAction®>
ayHello”™ path="/pages/greeting. jsp™/=

="org.apache. struts. tiles.TilesPlugin®=
perty="moduleAware” value="true®/ /=
perty="definitions-contig” wvalue="/WEB-INF/t1lesl.xml, /WEB-INF/t1les-examples-defs, xmL" /=

1] | [+]
Diagram Tree Source

Figure 8.2. Struts Configuration File

While typing a class name or entering it from the graphical editor, you might make a minor typo (like
"sample.GreetingAction1" instead of "sample.GreetingAction™ ). After saving the file, verification
checks to make sure everything is correct and finds the error below:

P & META-INF
tName" path="/pages/inputname.jsp" />
b = pages
= G WEB-INF = :
o |3 NameForm* path="/greeting® scope="request® type="sample K GreetingActionl®=
b &b | ayHello®" path="/pages/greeting.jsp"/=

i struts-bean.tid e

4 struts-config.xml

& struts-html tid | ="org.apache.struts.tiles. TilesPlugin®=
perty="definitions-config" value="/WEB-INF/tilesl.xml, /WEB-INF/tiles-examples-defs, xml" />

Figure 8.3. Error Reporting
Notice that the Package Explorer View shows a marked folder and a marked file where the error is.

You can place the cursor over the line with the error to view a detailed error message:

G Naction /greeting type attribute is not compilediest® type="sample.GreetingActionl®=
ayHello™ path="/spages/greeting.jsp /=

Figure 8.4. Error Message

The verification also checks to make sure you have specified the correct JSP page for the forward:

50




b = META-INF </global- forwards=>
b & pages <action-mappingss>
=action name="GetNameForm® path="/greeting” scope="request” type="sample. GreetingAction
¥ = WEB-INF I8  <forward name="sayHello" path="/pages/greetingl,isp'/>
b G lib <faction=

- </action-mappings>

& struts-bean. tid <controller/>

3 struts-config.xml <plug-in className="org.apache.struts. tiles. TilesPlugin®=

7 struts-htmi td

Figure 8.5. JSP Page Verification

Once you place the cursor over the line, you can see the error message:

<action name="GetNameForm® path="/greeting® scope="regquest” type="sample.GreetingAction

|Forwarl;l sayHello of Action /greeting path attribute reference to non-existent pagal

=faction=
<faction-mappingss

Figure 8.6. Error Message

You can always invoke the verification by switching to the Diagram viewer, right-clicking and

selecting Verify from the context menu:

EE

L []eeteme
i [pages/inputname.|sp
& @ 2
Add ]

Create Comment...

ages/graeting.jsp
Select Element 5 5
Auto-Layout
Properties...

™ Generate Java Code...

I t Method! LA
Diagram | Tree Source | npLt TeTacs

Figure 8.7. Verify Command




Chapter 9.

Relevant Resources Links

Find out necessary information on Struts technology [http://struts.apache.org/] if you don't know
enough.

In summary, this reference should help you to get familiar with those parts of JBoss Tools which are
meant for development with Struts technology. If you've carefully gone through the document, you
should know now how to create/import Struts project or enable Struts capabilities for an existing
web project as well as organize and edit all necessary staff for your Struts application using a set
of views and editors provided by JBoss Tools.

If you'd like to contribute your feedback is always appreciated. You can leave your questions and
suggestions on our Forum [http://www.jboss.com/index.html?module=bb&op=viewforum&f=201].

We hope, this guide helped you to get started with the JBoss Struts Tools. Besides,
for additional information you are welcome on JBoss forum [http://www.jboss.com/
index.html?module=bb&op=viewforumé&f=201].
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