1. Introduction ............................................................................................................. 1
   1.1. What is Smooks? ............................................................................................... 1
   1.2. What is Smooks Tools? .................................................................................... 2
   1.3. How to install Smooks dev tools? ................................................................. 2
2. Quick Start ............................................................................................................... 3
   2.1. Download Smooks Java-to-Java Example ....................................................... 3
   2.2. Smooks Configuration File Wizard ............................................................... 3
   2.3. Smooks Editor ................................................................................................. 6
   2.4. Choosing the Source/Target Data ............................................................... 8
   2.5. Mapping ........................................................................................................ 10
3. Smooks Graphical Editor Page .................................................................................. 17
   3.1. Introducing the areas of graphical editor ...................................................... 18
   3.2. Load Source/Target Data .............................................................................. 18
   3.3. Using Graphical Editor for Mapping ............................................................ 21
   3.4. Error Messages ............................................................................................. 21
   3.5. Properties View ............................................................................................ 21
4. Smooks Configuration Editor Page .......................................................................... 23
   4.1. Smooks Parse Type ....................................................................................... 23
   4.2. Import File ..................................................................................................... 24
   4.3. Date Decoder Detail Page ............................................................................. 24
5. Smooks Source Editor Page ...................................................................................... 27
   5.1. XML Source Editor ...................................................................................... 27
   5.2. Error Messages GUI ................................................................................... 27
Introduction

This chapter gives you a short introduction to Smooks, Smooks tools and its installation.

1.1. What is Smooks?

Smooks is a Java Framework/Engine for processing XML and non XML data (CSV, EDI, Java, JSON etc).

I. Transformation: Perform a wide range of Data Transforms. Supports many different Source and Result types -XML/CSV/EDI/Java/JSON to XML/CSV/EDI/Java/JSON.

II. Java Binding: Bind into a Java Object Model from any data source (CSV, EDI, XML, Java, JSON etc).

III. Huge Message Processing: Process huge messages (GBs) - Split, Transform and Route message fragments to JMS, File, Database etc destinations. Route multiple message formats to multiple destinations in a single pass over a message.

IV. Message Enrichment: Enrich a message with data from a Database, or other Datasources.

V. Combine: Combine the above features in different ways e.g. add Message Enrichment as part of a Splitting and Routing process.

Figure 1.1. Smooks

For more information about Smooks, please visit Smooks official site [http://www.smooks.org].
Chapter 1. Introduction

1.2. What is Smooks Tools?

Smooks tools is a set of graphical tools for editing Smooks configuration file based on Eclipse.

![Smooks Form editor](image)

Figure 1.2. Smooks Form editor

1.3. How to install Smooks dev tools?

The Smooks tools was included by the JBoss Tools since 3.0.0 Beta1 version. You can download the JBoss Tools from [JBoss download site](http://www.jboss.org/tools/download/index.html).

Smooks tools (JBoss Tools) run with the latest Eclipse and other required plug-ins (GEF, EMF, etc.).

You should download the latest IDE for Java EE developers from [Eclipse site](http://www.eclipse.org/downloads/). It contains many plug-ins (GEF, EMF, etc.) required by Smooks dev tools.

Now let's progress to more advanced topics.
Quick Start

This "Quick Start" will show how to use the Smooks tools to create/edit the Smooks configuration file for Java2Java data transformation.

This chapter gives you a brief understanding of the Smooks tools.

2.1. Download Smooks Java-to-Java Example

Visit [here](http://www.smooks.org/documentation/documentation-smooks-1-1-x/examples/example---java-to-java) to download the "java-to-java" example project.

Tip:
The example project is based on Maven, we suggest you to create a new eclipse Java project, copy the example code and .jar files from the example project and paste them into the eclipse Java project.

2.2. Smooks Configuration File Wizard

Select the Smooks Java-to-Java example project that you created and right-click, select the menu New > Other, then find Smooks > Smooks Configuration File. Click the Next button.

![Selecting Smooks Configuration File Wizard](image)
Chapter 2. Quick Start

The first wizard page is a file path creation page. Select the src folder to be the files container, and input the name newConfig.smooks. Click Next.

Figure 2.2. Choosing the configuration file container and the file name

The second wizard page is a transform data type choose page.

As the quick start introduces how to create/edit the Java-to-Java Smooks configuration file, let's select the Java-to-Java type as the source/target transform data type.
On the next page you are prompted to choose the source data for transformation. Let's select the `Order` class from the example project as the source JavaBean class.

Figure 2.4. Selecting the Source Data
Then the wizard page asks you to choose the target data for transformation. We select the `ListOrder` class as the target JavaBean class.

![Image of New Smooks Configuration File](image.png)

**Figure 2.5. Selecting the Target Data**

**Tip:**
You can omit two these steps and just press `Finish`. This will open the empty Smooks Configuration file. It's possible to select source/target data afterwards in the Smooks Graph editor.

### 2.3. Smooks Editor

When all the wizard steps are passed, a new Smooks Configuration file is created and the Smooks Editor will be opened automatically:
Figure 2.6. Smooks Editor

This editor contains several parts:

Table 2.1. The Smooks Editor Parts

<table>
<thead>
<tr>
<th>Editor feature</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Problems area</td>
<td>If there are any errors when you are editing the file, the Problems area displays them</td>
</tr>
<tr>
<td>Source data tree</td>
<td>The tree displays a structure of the transformed source data</td>
</tr>
<tr>
<td>Target data tree</td>
<td>The tree displays a structure of the transformed target data</td>
</tr>
<tr>
<td>Mapping graphical area</td>
<td>Show the data mapping connection lines</td>
</tr>
</tbody>
</table>
2.4. Choosing the Source/Target Data

To choose the transform data you should make use of the data selection links:

- **Source Select** for selecting source data
- **Target Select** for selecting target data

After clicking the link the Data Type Selection wizard is opened, and there are two data types on the list: Java and XML.

**Note**

There will become more and more data types on the list as the development goes on.

**Figure 2.7. Data Type Wizard**

Select the **Java** data type and click **Next**, you will see the JavaBean class selection page:
Choosing the Source/Target Data

Figure 2.8. JavaBean Data Selection

When you select all the necessary java classes, click Finish and the structure of the java class is displayed on the source/target data tree.
2.5. Mapping

As you see, the source/target data tree displays the structure of the java class.

How to map it?

First, you should know what to transform:

a. Bind the "customerName" property of the Order#header to the "customerName" property of LineOrder.

b. Bind the "customerNumber" property of the Order#header to the "customerId" property of LineOrder.

c. Bind the "price" property of the OrderItem to the "unitPrice" property of LineItem.

d. Bind the "productId" property of the OrderItem to the "productCode" property of LineItem.
e. Bind the "quantity" property of the OrderItem to the "unitQuantity" property of LineItem. Make sense?

OK, let's select the "customerName" item of the "header" item on the source data tree and start to drag it. When the drag item crosses the Mapping graphical area, you will see a connection line. Drop the item onto the "customerName" of the LineOrder on the target data view.

Now a dialog is opened asking you to connect the root node:

![Figure 2.10. Dialog Asking You to Connect to the Root Nodes](image)

Please, click Yes to connect the root node. If you don't do that, this dialog is opened again when you connect other nodes.

**Note:**

Please, remember that the root nodes of the source data and target data *MUST* be connected.
This rule is not only for Java-to-Java, but also is relevant for XML-to-Java

Now let's do the same operation with the "customerNumber", that is what you should see:

![Figure 2.11. Correctly Mapping Editor](image)

Next, you are going to bind the properties of the OrderItem to the properties of the LineItem.

Select the "price" and drag it onto the "unitPrice" of the other side tree viewer. The Problems area shows an error:
Figure 2.12. Connection Error 1

How to deal with the error?

Please click the *Fix it* link, a menu is popped-up with several resolve methods on it.
Figure 2.13. Fixing the Connection Error

Select the first resolve method: ‘Connect the “OrderItem” to the “LineItem”’. As the result the “OrderItem” is connected with the “LineItem”.

But the notify message area still shows some other errors:
Figure 2.14. Connection Error 2

OK, let's deal with the fire error. Click the Fix it link and select the first resolve method. The "orderItems" is connected with the "lineltems".

Tip:

Why does the error occur?

You will find that, if you only connect the property node without connecting the parent node of the property, the "connection error" occurs.

The connection of the "price-to-unitPrice" is the "Binding Connection", but it needs an "Instance Creation Connection" - the connection of the "OrderItem-to-LineItem".

After that, connect "quantity" to the "unitQuantity" and "productld" to the "productCode".
Figure 2.15. Complete Mapping

Now, you should save the file and the Smooks tools generate the correct configuration file content.

OK, let run the test class: `example.Main`. (Please, make sure that the Smooks engine loads the correct configuration file).

Success!
This chapter is packed with useful information about Smooks Graphical Editor Page usage.

Smooks Graphical Editor page is one tab of the Smooks Editor.

Figure 3.1. Graphical Editor

This Graphical editor allows you to perform drug/drop operations with the nodes of transform data to map the source data to target data.

When you save the changes in the Graphical editor the correct Smooks Configuration file content is generated.

To adjust the properties of the connection lines in the editor, you should use the Properties view (activate it by following to Window > Show View > Other > General > Properties).

For example, if you defined a date decoder in the Smooks Configuration Editor, in the Properties view you can select it as a Mapping type for the "Date" type element.
Figure 3.2. Browsing Custom Type for the Date Type Element

3.1. Introducing the areas of graphical editor

Information on the topic could be found in the Quick Start/Smooks Editor section.

3.2. Load Source/Target Data

Click the links under the data view, the Data Type Selection wizard page will be shown.
Figure 3.3. Data Type Selection Wizard Page

There are sets of transform data type on the wizard page, select one type and click Next, the data source selection wizard page will be shown.

Note:
For different data type, the Data source selection wizard are different too.
Chapter 3. Smooks Graphical E...

When you finish the data selection (file path selection), click *Finish*, the data view displays the selected data structure.

**Figure 3.4. Java Data Source Selection Wizard Page**

**Figure 3.5. XML File Path Selection Wizard Page**
3.3. Using Graphical Editor for Mapping

To get information on the topic please, read the Quick Start/Mapping section.

3.4. Error Messages

When you do any mapping operations, the Smooks tools validate the file content with "Mapping Logic". If there are any errors of the configuration file content, error messages are shown in the Problems area.

Please, read the Quick Start/Mapping section to find how to fix the errors.

3.5. Properties View

You can edit the properties of the connection lines with the Properties view.

Navigate to Window > Show View > Other > Properties, to open the Properties view.

When you select the connection line, the Properties view will show a set of section GUI for editing its properties.

**Tip:**

This GUI on the Properties view is displayed when the Smooks Graphical editor is active, if not, the Properties view displays empty GUI.

If the source data type of the selected connection line is "XML", the Properties view shows an XML Properties section GUI.

But if the source data type of the selected connection line is "Java", the XML Properties section GUI isn’t displayed.

It means that if the source/target data type of the selected connection line is different, the Properties view shows a different GUI.

![Figure 3.6. JavaBean Properties Section](image-url)

---

Using Graphical Editor for Mapping
Chapter 3. Smooks Graphical E...

Figure 3.7. XML Properties Section

Figure 3.8. Mapping Properties Section

To discover about other Editor pages, read the next chapters
Smooks Configuration Editor Page

In this section you will explore the details of Smooks Configuration Editor usage

**Smooks Configuration Editor** is one tab of the **Smooks Editor**.

![Graphical Editor](image)

**Figure 4.1. Graphical Editor**

You can add/edit/remove the **Date Decoder** on the Configuration page of the **Smooks Editor**.

The configuration editor also edits the **Smooks parse type** and manages the **Import Files**.

### 4.1. Smooks Parse Type

Open the **Other Configurations** section, we will see there is a set of radio buttons:
Figure 4.2. Smooks Parse Types

Select the needed radio button to change the Smooks parse type.

4.2. Import File

Open the Other Configurations section, there is an Import Files list under the Smooks parse type buttons (see the figure above).

There are three buttons on the right side of the File Import list. You can click those to add/edit/remove the import files.

Tip:

If the import file doesn't exist, the image of the import file is changed to "Error Image". If you double-click the import file in the Import File list, the file is opened with a new default editor.

4.3. Date Decoder Detail Page

Date Decoder is a resourceConfig element in the Smooks configuration file. It describes how to transform the "Date" type.

Click the New button to open the New Resource Type wizard dialog.
There are several resource type on the list. Select the *Date Decoder* and click the *Finish* button, a new *Date Decoder* item was added and shown on the resource type list.

There are several parameters in the *Date Decoder* resourceConfig element:

- Format
- Locale-Language
- Locale-Country

You can modify the parameters of the *Date Decoder* item with the left detail page.
Chapter 4. Smooks Configuration...

Figure 4.4. Date Decoder Detail Page

When you defined a new Date Decoder, then you can use the JavaBean Properties GUI to set it to be the "Java type".

Now when we've learnt Smooks Configuration Editor Page, let's have a look at one more Smooks Editor Page - Smooks Source Editor Page and investigate its functionality.
Smooks Source Editor Page

This section provides information about Smooks Source Editor Page

5.1. XML Source Editor

You can use this editor to edit the Smooks Configuration file directly.

![Graphical Editor](image)

**Figure 5.1. Graphical Editor**

5.2. Error Messages GUI

If the Smooks tools can't understand the configuration file or the configuration file is illegal (XML structure isn't right for Smooks Configuration file, etc.), the error is underlined.
Figure 5.2. Graphical Editor

We hope, our guide will help you to get started with JBoss Smooks Tools. Besides, for additional information you are welcome on [JBoss forum](http://www.jboss.com/index.html?module=bb&op=viewforum&f=201).