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Introduction

1.1. What is ESB?

ESB (Enterprise Service Bus) - an abstraction layer on top of implementation of an enterprise

messaging system that provides the features Service Oriented Architectures may be implemented

with.

If you want to develop applications using ESB technology JBoss ESB also meets your needs. The

JBoss Tools provide an ESB editor and all necessary wizards for creating an ESB file.

In this guide we provide you with the information on JBoss ESB support (installation, configuration

and deployment) and usage of ESB Editor which allows you to develop an ESB file much faster

and with far fewer errors so sparing your time.

1.2. Key Features of ESB Tools

For a start, we propose you to look through the table of main features of ESB plugin:

Table 1.1. Key Functionality of ESB Tools

Feature Benefit Chapter

JBoss Tools Project

Examples Wizard

Some kinds of projects with predefined

structure are available for usage.

Creating ESB Project

using JBoss Tools

Project Examples

Wizard

JBoss Enterprise

SOA Platform

The SOA Platform integrates specific versions

of JBoss ESB, jBPM, Drools and the

JBoss Enterprise Application Platform that are

certified to work together in a single supported

enterprise distribution.

using and configuring

SOA Platform

ESB Editor JBoss ESB tooling has powerful editor features

including syntax validation, support for XML

Schema and other.

ESB editor

1.3. Other relevant resources on the topic

You can find a set of benefits and other extra information on:

• JBoss ESB [http://www.jboss.org/jbossesb]

• JBoss Wiki [http://wiki.jboss.org/wiki/JBossESB]

• JBoss ESB Documentation Library [http://www.jboss.org/jbossesb/docs/index.html]

http://www.jboss.org/jbossesb
http://www.jboss.org/jbossesb
http://wiki.jboss.org/wiki/JBossESB
http://wiki.jboss.org/wiki/JBossESB
http://www.jboss.org/jbossesb/docs/index.html
http://www.jboss.org/jbossesb/docs/index.html
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The latest JBoss Tools/JBoss Developer Studio documentation builds are available  JBoss Tools

nightly documentation page [http://download.jboss.org/jbosstools/nightly-docs/].

http://download.jboss.org/jbosstools/nightly-docs/
http://download.jboss.org/jbosstools/nightly-docs/
http://download.jboss.org/jbosstools/nightly-docs/
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ESB Support
In this section we will focus on all concepts that JBoss Tools integrate for working with JBoss ESB.

2.1. ESB Tools Installation

This chapter will provide you with the information on how to install JBoss ESB plugin into Eclipse.

ESB Tools come as one module of JBoss Tools project. Since ESB Tools have a dependence

on other JBoss Tools modules we recommend you to install a bundle of all JBoss Tools plug-ins

[http://labs.jboss.com/tools/download.html]. You can find all necessary installation instructions on

JBoss Wiki in the InstallingJBossTools [http://labs.jboss.com/wiki/InstallingJBossTools] section.

2.2. Creating a ESB Project

In this chapter we suggest a step-by-step walk-through of creating a new ESB project. Let's try

to create a new JBoss ESB project.

We will show you how to use the ESB Project Creation wizard for creating a new ESB project and

setting basic ESB classpath.

Select  File >New > Project...  in the main menu bar or context menu for selected project and then

ESB > ESB Project  in the dialog opened:

Figure 2.1. Select a Wizard dialog

http://labs.jboss.com/tools/download.html
http://labs.jboss.com/tools/download.html
http://labs.jboss.com/wiki/InstallingJBossTools
http://labs.jboss.com/wiki/InstallingJBossTools
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Clicking  Next  brings you to the JBoss ESB Project wizard page where a project name, ESB

version and target JBoss Runtime are to be specified. Specify, for example,  helloworld  as a

Project name and accept the default ESB version.

Figure 2.2. JBoss ESB Project wizard

By clicking Modify  button you can open Project Facets Wizard  page,where you can select facets

that should be enabled for this project. On the Project Facets Wizard  page you can also configure

runtime for the application
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Figure 2.3. Project Facets Wizard

Next step provides you an opportunity to configure your project for building a java application

Clicking  Next on this form  brings you to the ESB facet installation page where you can specify

Java Source Directory and ESB Content Directory. ESB Content Directory is a folder that contains

the most of artifacts that an ESB archive needs. You also can configure ESB libraries to the project

by selecting a ESB runtime using one of the options:

1. Use  Server Supplied ESB Runtime

2. Select a ESB runtime from the JBoss ESB runtime list predefined in the preferences. If you

choose the first option, make sure that the project has the Target JBoss Runtime set and this

runtime has a ESB runtime installed.

3. Choose ESB Config Vertion. From the version 3.1.0 JBoss ESB Tools supports three different

jboss-esb.xsd versions: jbossesb-1.0.1.xsd, jbossesb-1.1.0.xsd and jbossesb-1.2.0.xsd.

Note:

If you use ESB 4.7 you should select jbossesb-1.2.0.xsd.
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Figure 2.4. Install ESB facet step

Click  Finish  and a ESB project with the default jboss-esb.xml will be created.

Figure 2.5. The generated ESB project structure
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2.3. Creating ESB Project using JBoss Tools Project

Examples Wizard

JBoss Tools provides a Project Example wizard that is an easy way for users to create some

kinds of projects to be used as examples with some predefined structure. Let's start creating a

ESB project using this wizard.

Before creating a ESB project example create JBoss Runtime with name  JBoss 4.2 Runtime, it

will be used by your ESB project example.

Select  File >New > Others   , in the main menu bar or context menu for selected project and then

JBoss Tools > Project Examples  in the New dialog:

Figure 2.6. Select a wizard - Project Examples

Clicking  Next  brings you to the wizard page where you can select a ESB project example from

the example list. Every ESB example has two projects, one is a ESB project and another is a Java

project used to test the ESB project.

Here is a list of ready examples available:

• JBoss ESB HelloWorld Example - demonstrates the minimal files necessary to make a basic

ESB component execute as well as to prove that the ESB os properly configured.
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• JBoss ESB HelloWorld Action Example - demonstrates the use of multiple action invocations

from a single configuration. You can use a single Action class and make multiple method calls

or use multiple Action classes.

• JBoss ESB HelloWorld File Action Example - demonstrates using the File gateway feature

of the JBoss ESB. Files that are found in a particular directory with a particular extension are

sent to a JMS queue with actions for processing.

• JBoss ESB Web Service consumer1 Example - demonstrates how to consume a 181 Web

Service in an ESB action.

• JBoss ESB Web Service producer Example - demonstrates how to deploy a JSR181

Webservice endpoint on JBossESB using the SOAPProcessor action.

• JBoss ESB Smooks CSV -> XML Example - demonstrates how to transform a comma

separated value (CSV) file to an XML.

• JBoss ESB Smooks XML -> POJO Example - demonstrates the use of Smooks performing

a simple transformation by converting an XML file into Java POJOs.

• JBoss ESB Smooks XML -> XML date-manipulation Example - demonstrates how to

manually define and apply a Message Transformation within JBoss ESB.

• JBoss ESB Smooks XML -> XML Example - a very basic example of how to manually define

and apply a Message Transformation within JBoss ESB. It applies a very simple XSLT to a

SampleOrder.xml message and prints the before and after XML to the console.

We will take as our example JBoss ESB HelloWorld Example  ESB and Client project:
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Figure 2.7. JBoss Tools ESB Project Examples

Choose them using the Ctrl button and then click Finish. As a result you will get two projects

created:
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Figure 2.8. JBoss ESB Project Examples: helloworld and

helloworld_testclient

Deploy the HelloWorld ESB project and run a test class in the client Java project to see the test

result in the Console view.

2.4. Deploying a ESB Project

In this chapter you will see how to deploy a ESB project using the WTP deployment framework.

Before deploying the project, open the JBoss Server View by selecting Window > Show View >

Other > Server > JBoss Server View, create a JBoss Server in the Server view and start it, and

then right click the created JBoss server, select   Add and Remove Projects, and add the ESB

projects you want to deploy from the left side to the right side in the opened dialog.
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Figure 2.9. Add and Remove Projects

Click Finish  to add the project to the server. You also can drag the ESB project from the Project

View to the server.

Figure 2.10. JBoss Server View

Thus, you have just added the ESB project to the JBoss server module list. Right click the JBoss

Server and select Publish to publish the project on the server. You can check the deploying result

in the Console view.
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The Run and Debug options work on ESB projects causing a (re)deploy for a user designated

server.

You can also use the "Finger touch" for a quick restart of the project without restarting the server:

Figure 2.11. Finger Touch button

The "Finger" touches descriptors dependent on project (i.e. web.xml for WAR, application.xml for

EAR) and now it is also available for jboss-esb.xml in ESB projects.

You can also deploy your ESB project as an .esb archive. Right-click on the project, choose Export:
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Figure 2.12. Export of ESB project

Choose ESB > ESB File and click Next:
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Figure 2.13. Choosing ESB File

And finally export the ESB project to the file system: choose the destination, choose the target

runtime if need a specific one and make the appropriate settings for the archive. Then click Finish.
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Figure 2.14. ESB Export

Your project is deployed as an .esb archive.

An ESB archive can be created for ESB projects only. It is also possible to deploy an .esb archive

to a JBoss AS based server with JBoss ESB installed.

2.5. Creating a ESB File

In this chapter we suggest a step-by-step walk-through of creating your own simple file. Let's try

to organize a new ESB file.

We will show you how to use the Creation wizard for creating a new ESB file.

At first you should open any project. Select  File >New > Other...  in the main menu bar or context

menu for selected project and then  ESB > ESB File  in the New dialog:
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Figure 2.15. Select a wizard - ESB File

Clicking  Next  brings you to the wizard page where a folder, a name and a version for the file

should be specified. Choose, for example,  jboss-esb.xml  as the name and accept the selected

projects folder and the default version.

Note:

From the version 3.1.0 JBoss ESB Tools supports three different jboss-esb.xsd

versions: jbossesb-1.0.1.xsd, jbossesb-1.1.0.xsd and jbossesb-1.2.0.xsd. If you

use ESB 4.7 you should select jbossesb-1.2.0.xsd.
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Figure 2.16. Folder, Name and Version for ESB file

Thus, your file will be created in the selected projects folder by default. If you want to change the

folder for your future file click  Browse...  button to set needed folder or simply type it.

Clicking on  Finish  results in the file being generated. The wizard creates one xml file.

2.6. Configuring ESB Runtime in Preferences

In this chapter you will know how to predefine a JBoss ESB runtime on the Preferences page.

You may already know, there are two ways to set JBoss ESB runtime when creating a ESB project,

one is to use the project target JBoss runtime, and another is to select a JBoss ESB runtime

predefined in JBoss Tools preferences. Let's configure it.

Select  Window >Preferences > JBoss Tools > JBoss ESB Runtime , to open the JBoss ESB

Runtime Preferences page where you can add, remove and Edit a JBoss ESB runtime.
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Figure 2.17. JBoss ESB Runtimes

Select Add to open a dialog where you can specify the JBoss ESB runtime location, name and

version number. It's also possible to define configuration if you point the home location to a Jboss

AS or SOA-p, in case you select a standalone ESB runtime location, the configuration combo will

be empty and should be ignored. You can also customize the libraries of the runtime by checking

the Customize JBoss ESB Runtime jars  checkbox.
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Figure 2.18. Configure new JBoss ESB Runtime

The new JBoss ESB Runtime will be configured. Click  OK  to finish and save the preferences.

You can use the configuration when creating a JBoss ESB project.

When a ESB runtime is configured for your ESB project you are able to change it to any other

using the classpath container page for ESB runtime. To do that, turn to the Package Explorer view

and right-click the "JBoss ESB Runtime" library. Select Properties and a table listing all available

JBoss ESB runtimes will appear:
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Figure 2.19. Classpath Container Page to change ESB runtime

Choose one of them to set to the ESB project and click Ok.

ESB container allows Source and JavaDoc locations to be set via the Properties dialog on each

contained .jar: right-click on any .jar file, select Properties. Choose Java Source Attachment and

select location (folder, JAR or zip) containing new source for the chosen .jar using one of the

suggested options (workspace, external folder or file) or enter the path manually:
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Figure 2.20. Classpath Container: Java Source Attachment

Click on Apply and then on Ok.

To change Javadoc Location choose Javadoc Location and specify URL to the documentation

generated by Javadoc. The Javadoc location will contain a file called package-list:
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Figure 2.21. Classpath Container: Javadoc Location

Click on Apply and then on Ok.

2.7. Using and Configuring SOA Platform

In this chapter you will know what is JBoss Enterprise SOA Platform and how you can configure

it to use for your ESB projects.

JBoss Enterprise SOA Platform delivers a flexible, standards-based platform to integrate

applications, SOA services, business events and automate business processes. The SOA

Platform integrates specific versions of JBoss ESB, jBPM, Drools and the JBoss Enterprise

Application Platform that are certified to work together in a single supported enterprise distribution.

Having configured JBoss Enterprise SOA Platform for your ESB project you don't need to install

and configure ESB server and runtime as they are already included.

Check here to find more details on the platform: JBoss Enterprise SOA Platform [http://

www.jboss.com/products/platforms/soa] and JBoss Enterprise SOA Platform Component Details

[http://www.jboss.com/products/platforms/soa/components].

You can find out what is SOA here: Basics of SOA [http://www.jboss.org/jbossesb/resources/

SOABasics.html] and SOA and EOA [http://www.jboss.org/jbossesb/resources/SOAEOA.html].

To configure the JBoss Enterprise SOA platform select  Window > Preferences > Server > Runtime

Environments, that will open the Server Runtime Environments Preferences page where you can

add, remove and edit a Server Runtime Environment.

http://www.jboss.com/products/platforms/soa
http://www.jboss.com/products/platforms/soa
http://www.jboss.com/products/platforms/soa
http://www.jboss.com/products/platforms/soa/components
http://www.jboss.com/products/platforms/soa/components
http://www.jboss.org/jbossesb/resources/SOABasics.html
http://www.jboss.org/jbossesb/resources/SOABasics.html
http://www.jboss.org/jbossesb/resources/SOABasics.html
http://www.jboss.org/jbossesb/resources/SOAEOA.html
http://www.jboss.org/jbossesb/resources/SOAEOA.html
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Figure 2.22. Configure new Server Runtime Environment

Select Add, choose JBoss 4.2 Runtime as a type of runtime environment, check the Create a new

local server checkbox and click Next:
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Figure 2.23. Type of Server Runtime Environment

On the next step you can specify a name of the server runtime environment and browse to its

location. Click Finish to add the server runtime environment.
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Figure 2.24. New Server Runtime Environment Details

Now you have your SOA platform configured. To check the configuration create a ESB Project

using instructions described here. As a result you will have two projects created:
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Figure 2.25. Helloworld Projects Created

Then you will need to add JBoss ESB libraries to your projects to configure the SOA server runtime

exactly for your projects. Right-click on your project, select Build Path > Add Libraries:
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Figure 2.26. Add Libraries

Choose JBoss ESB Libraries and click Next:
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Figure 2.27. ESB Libraries

Select the necessary runtime to add to the project classpath:
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Figure 2.28. Select a ESB runtime

Click Finish.

Now you can deploy your Helloworld project to the server and run a test class in the client Java

project to see the test result in the Console view.
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ESB Editor
ESB editor has lots of useful features, they are described in details in this chapter. In addition

you'll get to know with how ESB Editor uses combined visual and source editing of esb files.

3.1. ESB File Editor

ESB File Editor is a powerful and customizable tool. ESB File Editor allows developing an

application using ESB technology.

ESB file editor has two tabs: Tree and Source.

You can switch to Tree. The Tree view for the editor displays all ESB artifacts in a tree format. By

selecting any node you can see and edit its properties which will appear in the right-hand area.

For example, a Provider:

Figure 3.1. Tree View

Some properties are represented as links to the associated editors.
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Figure 3.2. Property Link to the Associated Editor

Now when editing ESB actions which refer to other files (Drools, Groovy, Smooks, etc.), the label

for the field turns into a link to launch the editor associated with that type of file.
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Figure 3.3. Property Link to the Associated Editor

You can easily switch from Tree to Source by selecting the Source tab at the bottom of the editor

and work in Source view.
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Figure 3.4. Source View

The Source view for the editor displays a text content of the ESB file. It is always synchronized

with Tree view, so any changes made in one of the views will immediately appear in the other.

No matter what view you select, you get full integration with Outline view. For example, you can

work in the Source view with the help of the Outline view. The Outline view shows a tree structure

of the ESB file. Simply select any element in the Outline view and it will jump to the same place

in the Source editor, so you can navigate through the source code with Outline view.
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Figure 3.5. Outline View

Adding, editing or deleting of some artifacts operations are available right in the Tree view . Right-

click any node and select one of the available actions in the context menu. For example, you can

easily add a new Provider:

Figure 3.6. Adding New Provider
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Then you can add Channels and Properties for the Providers the same way or using the forms

with Add, Edit and Remove buttons to the right.

You can easily add a new Service too:

Figure 3.7. Adding New Service

The same way you can create a listener for service and other elements of ESB:

Figure 3.8. Adding New Listener for Service
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The same actions can be done in the right part of Tree view tab (Form editor) using Add, Edit

and Remove buttons.

Filter can be also edited this way

Figure 3.9. Editing Filter

In order to add a new custom Action to your ESB XML file you should select the Actions node

under the Services, then right-click and choose  New > Custom Action.
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Figure 3.10. Adding New Action in the Tree View

Or instead make use of  Add...  button in the Form editor on the left.
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Figure 3.11. Adding New Action in the Form Editor

Note:

Some new components are available to support ESB 4.7,such as: new actions

(XsltAction, PersistAction, BpmProcessor, ScriptingAction), new processors

(EJBProcessor), new routers (HttpRouter, JMSRouter, EmailRouter).

As you can see on the bath figures above, the context menu will also prompt you to insert one

of the Actions that are supplied out-of-the-box with JBoss ESB. After choosing one an appeared

New Action wizard will ask you to fill out a name field and other fields specific for each Action

property. For example, for  Content Based Router  Action the wizard looks as follows:
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Figure 3.12. New Action Wizard

After confirming creating the Action you can see it in the Tree under the  Actions  node and preview

as well as edit its settings in the Form editor on the left.



Chapter 3. ESB Editor

40

Figure 3.13. Form Editor for Content Based Router

ESB editor can recognize some specific objects. On the figure you can see

org.jboss.soa.esb.actions.ContentBasedRouter in the  Class  section.

3.2. ESB Editors Features

JBoss ESB tooling has powerful editor features that help you easily make use of content and

code assist.

This last chapter covers capabilities on how you can use ESB editor.

3.2.1. ESB syntax validation

When working in JBoss ESB editor you are constantly provided with feedback and contextual

error checking as you type. In the Source viewer, if at any point a tag is incorrect or incomplete,

an error will be indicated next to the line and also in the Problems view below.

3.2.2. Support for XML Schema

JBoss ESB Framework fully supports XML files based on schemas as well as DTDs.

The schema checks the child elements of any kind of provider element; the ESB generates errors

on startup if you attempt to define an incorrect combination (e.g.: a jms-bus inside an ftp-provider).
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Note:

The schema used behind ESB editor now uses the latest version available (from

SOA-P 4.3). This removes the errors/warnings some users have reported seeing

when using SOA-P specific esb.xml files.

3.2.3. Content Assist for ESB XML file

When you work with any ESB XML file Content Assist is available to help you. It provides pop-

up tip to help you complete your code statements. It allows you to write your code faster and with

more accuracy. Content assist is always available in the Source mode. Simply type  Ctrl-Space

to see what is available.

Content Assist for ESB XML file:

Figure 3.14. Content Assist for ESB XML file

Content Assist for attributes:
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Figure 3.15. Content Assist for attributes

3.2.4. OpenOn for ESB XML file

ESB file comes with the OpenOn feature that allows to make use of multiple file references in the

file just with a click and the  Ctrl key hold down.

The OpenOn is implemented for different types of files/pages inside the <action> tag: .xsd, .xml,

etc.
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Figure 3.16. OpenOn for smooks configuration file

It is also available for classes:
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Figure 3.17. OpenOn for classes

3.2.5. Synchronized Source and Visual Editing

ESB file can be edited in either source or extra visual modes at the same time.

JBoss Tools provide you two different editors to speed your development: a graphical view (Tree)

and source (Source). At the same time, you always have full control over esb source file. Any

changes you make in the source view will immediately appear in the tree view. Both views are

synchronized, you can edit the file in any view.
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Figure 3.18. Two Views are Synchronized

In summary, this reference supplies you with all necessary information on the functionality that

JBoss ESB Editor provides for work with JBoss ESB.

We hope, this guide helped you to get started with the JBoss ESB Tools. Besides, for

additional information you are welcome on JBoss forum [http://www.jboss.com/index.html?

module=bb&op=viewforum&f=201].

http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
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