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Chapter 1.

Introduction

1.1. What is BIRT?

BIRT plugin is an Eclipse-based open source reporting system for web applications based on
Java and J2EE. BIRT consists of two main components: a report designer based on Eclipse, and
a runtime component that can be added to your app server. BIRT also offers a charting engine
that lets you add charts to your own Web application.

With the help of BIRT you can generate a great number of reports to be used in your application:

e Lists

e Charts

Crosstabs, or cross-tabulation, or matrix

Letters and Documents
e Compound Reports

You can find more detailed information on the BIRT plugin, its report types and anatomy on the
BIRT Homepage [http://www.eclipse.org/birt/phoenix/intro/].

To understand the basic BIRT concepts and to know how to create a basic BIRT report, refer to
the Eclipse BIRT Tutorials [http://www.eclipse.org/birt/phoenix/tutorial/]. What extensions JBoss
Tools provides for Eclipse BIRT you'll find out in the next sections.

1.2. JBoss BIRT Integration Functionality Overview

The key feature of JBoss BIRT Integration is the JBoss BIRT Integration Framework, which allows
to integrate a BIRT report into Seam/JSF container. The framework API reference is in the JBoss
BIRT Integraion Framework API Reference chapter of the guide.

This guide also covers functionality of JBoss Tools module which assists in integration with
BIRT. The integration plug-in allows you to visually configure Hibernate Data Source (specify a
Hibernate configuration or JNDI URL), compose HQL queries with syntax-highlighting, content-
assist, formatting as well as other functionalities available in the HQL editor.

To enable JBoss Tools integration with BIRT you are intended to have the next:

 Eclipse with JBoss Tools installed (how to install JBoss Tools on Eclipse, what dependences
and versions requirements are needed reed in the JBoss Tools Installation section)

* BIRT Report Designer (BIRT Report Designer 2.3.2 you can download from Eclipse
downloads site [http://www.eclipse.org/downloads/download.php?file=/birt/downloads/drops/
R-R1-2_3 2-200902181355/birt-report-framework-2_3_2.zip])
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« BIRT Web Tools Integration ( BIRT WTP Integration 2.3.2 you can download from Eclipse
downloads site [http://www.eclipse.org/downloads/download.php?file=/birt/downloads/drops/
R-R1-2_3 2-200902181355/birt-wtp-integration-sdk-2_3_2.zip])
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Tasks

In this chapter of the guide you will find information on the tasks that you can perform integrating
BIRT. The required version of BIRT is 2.3.2 or greater.

2.1. Adding BIRT Functionality to Standard Seam Web
Project

In this section you'll know how to integrate BIRT into a Seam web project.

You are supposed to have Seam runtime and JBoss Application Server downloaded and
extracted on your hard drive. You can download Seam from the Seam Framework [http:/
seamframework.org/Download] web page and JBoss Application Server from JBoss Application
Server [http://jboss.org/jbossas/downloads/] official site.

Tip:

We used JBoss SEEE 2.0.1 GA [http://sourceforge.net/
project/showfiles.php?group_id=22866&package _id=163777] and JBoss
Application Server 4.2.2 GA [http://sourceforge.net/project/showfiles.php?
group_id=22866&package_id=163777] in examples of this guide.

2.1.1. Creating Seam Web Project with Birt Facet

We recommend to open Seam perspective by going to Window > Open Perspective > Other >
Seam, this way you will have all the tools to work with Seam at hand. To create a new Seam Web
project navigate to File > New > Seam Web Project . Otherwise you should go to File > New >
Other > Seam > Seam Web Project if Seam perspective is not active.

1. On the first wizard page enter the project name, then specify the target runtime and target
server. We recommend to use JBoss AS server and runtime environment to ensure best
performance.
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Mew Seam Project

Seam Web Project r\\?_‘ﬁ‘

Create stzndalone Seam Wweb Project \

Project name: [HeIIuEirt

Project contents

[ Lize default

Target runtime

| |Boss 5.0 Runtime = ] [Ngw...]

Dynarmic web rmodule version

[25 |

Target Server

| |Boss 5.0 Funtime Server o ] |-New...-|

Configuration-

( Crynamic Web Project with Seam 2.2 bz [Mudify...]

Configures a Dynaric Wweb application to use Seam 2.2

@ [ = Back l Next =  cancel

Figure 2.1. Creating Seam Web Project

2. In the Configuration group choose the version of Seam framework you are planning to use in
your application. In this guide we used Seam 2.2.

3. Click the Modify button and enable the Birt Reporting Runtime Component facet by checking
the appropriate option.




Creating Seam Web Project with Birt Facet

Project Facets
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Figure 2.2. Adding the Birt Reporting Runtime Component Facet

Alternatively you can just choose the JBoss BIRT Integration Web Project configuration from
the drop-down list in the Configuration group
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Mew Seam Project

Seam Web Project ’ RS«:_\
\ =
Create stzndalone Seam Wweb Project ’\-"_.J
.
Project name: [H@IIuElirt
Project contents
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Target runtime
| |Boss 5.0 Runtime = ] [Ngw...]
~Dynarmic web module version
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Configuration
| |Bess BIFT Integration Web Project oz | Mudify...]
|Eoss BIFT Integration Welk Project
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Figure 2.3. Choosing the JBoss BIRT

Configuration

Integration Web Project

4. You may leave the next two pages with default values, just press Next to proceed.

5. On the Birt Configuration page you can modify the BIRT deployment settings, which you can
edit afterwards in the web.xml of the generated project. Let's keep the default values for now.
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Mew Searm Project

BIRT Configuration

Fr
Configure BIRT Deployment Settings defined in web xml L E

Deployment Folder Settings

Resource Folder:

' ] lElmwsed..l

working Falder:
[

HElmwse...]

Termporary documents Folder:

|docurments | | Erawse... |

Ternporary jmages Folder;

|'repnr‘tjimages ] | Brnﬂse...]

Scriptlib Folder;

| zeriptlib ] lElmwga |

Log Folder:

|logs HElmwsg...]

Other settings

[[] Only access the report and document under working folder

Select Log Level: |WHRNIHG | L

Print report on the server side: |DN o

DiataSet Max Rows: [

Max cube fetching row levels: [

|
|
Max cube fetching column levels: | |
|

Max mernery size for ereating cube:

Cancel Finizh |

Figure 2.4. Configuring BIRT Deployment Settings
6. You can also leave the JSF Capabilities page with default values.

7. Onthe Seam Facet page you should specify the Seam runtime and Connection profile. Please
note, that the Seam runtime must be of the version you initially specified in the project settings
(See the Creating Seam Web Project figure).

When creating a Seam project with BIRT capabilities you can use the BIRT Classic Models
Sample Database connection profile to work with the BIRT sample database.
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For more details on how to configure database connection for a Seam project please read
the Configure Seam Facet Settings [http://docs.jboss.org/tools/3.0.0.GA/en/seam/html_single/
index.html#seamFacet] chapter of Seam Dev Tools Reference Guide.

Hew Seam Project

5eam Facet

Configure Seam Facet Settings g
General

Searn Runtime: | sesm * |ﬁ-.dd...|
Deploy as: ® WaR ) EAR

Dstabase

Diatabase Trpe:

Connection profile:

Database Scherma Mame: [ . |
Database Catalog Mame: [ ]
D Tables already evists in database: ]

Recreste database tables and data on deploy: [

Code Genaration

Seszion Bean Package Mame: [n rg.dormain.hellabirt.session ]

Entity Bean Package Mame: |_c|rg.dumain.hellobirt.ent'rt'}r |

Test Package Marne: [n rg.demsain.hellobirt.test ]

@ = Back | Cancel | Finizh |

Figure 2.5. Configuring the Seam Facet settings
8. Hit Finish to create the project with BIRT functionality enabled.
2.1.2. Integration with Seam

In the previous section you have created a Seam project with BIRT capabilities. Now you can
create a simple kick start project to see that everything is configured correctly.

1. Now create a BIRT report file and insert test data into the file. Name
the report file helloBirt.rptdesign, the report should print the data from the
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CLASSI CMODELS. CUSTOVERS table of the BIRT Classic Models Sample Database,
namely: customer number (CLASSI CMODELS. CUSTOMVERS. CUSTOVERNAME), contact person
first name ( CLASSI CMODELS. CUSTOMERS. CONTACTFI RSTNAME) , contact person last
name (CLASSI CMODELS. CUSTOVERS. CONTACTLASTNAME) and contact person phone
number(CLASSI CMODELS. CUSTOVERS. PHONE).

The title of the report should be set via report Ti t | e parameter

As this guide is primarily focused on the BIRT integration and not the BIRT technology itself we
will not show the steps required to make the report. If you do not feel strong about creating a
BIRT report file please read BIRT documentation [http://eclipse.org/birt/phoenix/tutorial/].

You can download the file helloBirt.rptdesign here [files/helloBirt.rptdesign] and copy it to the
WebContent folder of your Seam project.

. When you are done with the helloBirt.rptdesign file, you should create a .xhtml file that will
contain the BIRT report you have just created.

The JBoss BIRT Integration framework provides 2 components represented as <b:birt>
and <bh:param> tags. The jboss-seam-birt.jar library implements the functionality of the
components. To find more information about the framework pleas read the JBoss BIRT
Integraion Framework API Reference chapter. To use that tags on the page you need to declare
the tag library and define the name space like this:

xm ns: b="http://jboss. conf products/seanf birt"

The <b:birt> is a container for a BIRT report, that helps you integrate the report into Seam
environment. You can manage the properties of the report using the attributes of the <b:birt>
tag.

The <bh:param> tag describes report parameters. To set a parameter you need to specify it's
name the value you want to pass. You can use EL expressions to bind the representation layer
with back-end logic.

. Create the helloBirt.xhtml file in the WebContent with the following content:

<! DOCTYPE conposition PUBLIC "-//WBC//DTD XHTM. 1.0 Transitional//EN'
"http://ww. w3. org/ TR xht ml 1/ DTD/ xht ml 1-transi ti onal . dtd">
<ui : conposi tion xm ns="http://ww. w3. org/ 1999/ xht m "
xm ns:s="http://jboss. com products/seanm taglib"
xm ns: ui ="http://java. sun.com jsf/facel ets"”
xm ns:rich="http://richfaces.org/rich"
xm ns: b="http://jboss. conf products/sean birt"



http://eclipse.org/birt/phoenix/tutorial/
http://eclipse.org/birt/phoenix/tutorial/
files/helloBirt.rptdesign
files/helloBirt.rptdesign

Chapter 2. Tasks

tenpl ate="1 ayout/tenpl ate. xhtm ">
<ui : def i ne nane="body" >
<rich: panel >
<b:birt desi gnType="enbed" desi gnNane="hel |l oBirt.rptdesign"
enbeddabl e="true" >
<b: param nane="report Titl e" val ue="Custoners Contacts" />
</b:birt>
</rich: panel >
</ ui : define>
</ ui : conposi tion>

From this listing above you see that the title of the report is set via <b:param> by setting the
parameter name and defining the "value" attribute with the "Customers Contacts" value.

. We have created a Seam project and inserted the helloBirt report into the helloBirt.xhtml view

file.

To see that the application works correctly and as you expect, you need to launch it on the
server.

. In the Servers view (If it is not open navigate to Windows > Show View > Other > Server >

Servers), select the server the application is deployed to and hit the Start button.

. When the server is started, open your favourite browser and point it to http://

| ocal host: 8080/ HelloBirt/helloBirt.seam.

10
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@ HelloBirt &3

] W ° |httpi/localhost:2080/HelloBirt/helloBirt.seam

HelloBirt: Home

Customers Contacts

Customer First Last Phone
Atelier graphique Carine Schmitt 40.32.
Signal Gift Stores Jean King 70255
Australian Collectors, Co. Peter Ferguson 03 952
La Rochelle Gifts Janine Labrune 40.67.
Eaane Mini Imports Jonas Bergulfsen 07-98
Mini Gifts Distributors Ltd. Susan Melson 41555
Havel & Zbyszek Co Zbyszek Piestrzeniewicz (28) 6
Blauer See Auto, Co. Roland Keitel +49 6¢
Mini Wheels Co. Julie Murphy B5055!
Land of Toys Inc. Kwai Lee 21255
Euro+ Shopping Channel Diego Freyre (91) 5¢
volvo Model Replicas, Co Christina Berglund 0921-]
Danish Wholesale Imports  Jytte Petersen 3112
Saveley & Henriot, Co. Mary Saveley 78.32!
Dragon Souveniers, Ltd. Eric Matividad +65 2.
Muscle Machine Inc Jeff Young 21255
Diecast Classics Inc. Kelvin Leong 21555
Technics Stores Inc. Juri Hashimoto 65055
Handii &Eiftes, ©m s el Wit Tatatats) +EE D

A

Figure 2.6. Integrating BIRT into Seam Project

2.2. Using Hibernate ODA Data Source

The JBoss BIRT Integration feature includes the Hibernate ODA Data Source which is completely
integrated with Hibernate Tools. You can use it the way as you would use any of BIRT ODA drivers.

1. First, you need to reverse engineer from the database to generate Seam entities.
You can perform this operation going to File > New > Seam Generate Entities
in the Seam perspective. More details on the Seam Generate Entities please read
Seam Dev Tools Reference guide [http://download.jboss.org/jbosstools/nightly-docs/en/seam/
html_single/index.html#generate_entities]). In this guide we will use the Employees table of the
DATAMODELS database.

11


http://download.jboss.org/jbosstools/nightly-docs/en/seam/html_single/index.html#generate_entities
http://download.jboss.org/jbosstools/nightly-docs/en/seam/html_single/index.html#generate_entities
http://download.jboss.org/jbosstools/nightly-docs/en/seam/html_single/index.html#generate_entities

Chapter 2. Tasks

Tip:

Before performing Seam Generate Entities, you should have a connection
profile adjusted and connected to a database. How to do this see in the
CRUD Database Application [http://download.jboss.org/jbosstools/nightly-docs/
en/seam/html_single/index.html#d0e2725] chapter of the Seam Dev Tools
Reference guide.

If you followed the steps described in the Adding BIRT Functionality to Standard
Seam Web Project chapter, you would have a connection profile already
configured.

2. Next you should create a new BIRT report file ( >File > New > Other > Business Intelligence
and Reporting Tools > Report) to represent the data from the Employees table. Call the file
employees.rptdesign.

3. Now switch to the BIRT Report Design perspective.

4. In the Data Explorer view right-click the Data Source node and choose New Data Source.

B Data Sou
5 Data Sets
& Data Cub], 1 paste
({3 Report Parameters

Mew Data Source

Figure 2.7. Creating a New Data Source

5. The wizard will prompt you to select data source type. Choose Hibernate Data Source and
give it a meaningful name, for instance HibernateDataSource . Hit Next to proceed.

12
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Using Hibernate ODA Data Source

[ £ Mew [ata Source S
select a Data Source Type or Choose a Connec [ji

Provide all the settings for 2 new data source, or
Cl'ICIDEE =] PFE-dEﬁI'IE'd I:UI'II'IEEtiDI'I PrﬂﬁlE‘.
@ Create from a data source type in the followang list

) Create fram a cannection prafile in the profile stare

Classic Models Inc. Sarmple Database
Flat File Data Source

JDEC Data Source

Seripted Data Source

web Services Data Source

XML Daka Source

Data Source Mame: |HIbernateDataSource

Figure 2.8. Creating Hibernate Data Source

6. On the next wizard's dialog you can leave the everything with default values, press the Test
Connection button to verify that the connection is established successfully.

The Hibernate Data Source enables you to specify a Hibernate Configuration or INDI URL.

13
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(5 Mew Hibernate Data Source Profile [x]

Hibernate Data Source p—

Edit the selected data source [

Configuration: [HelluE!ir‘t w |

| LURL: [iava yHelloBirt ]

Mz results: |lCIl.'JI |

Test Connection...

Test connection

'= Connection successfull,
=t

@ | = Back I [ Canceal ] ( Finigh

Figure 2.9. Hibernate Data Source Profile
7. Press Finish to complete New Data Source wizard.

8. Now you need to configure a new Hibernate ODA data set. Launch the New Data Set wizard.
In the Data Explorer View right-click the Data Set node and select New Data Set.

9. Select HibernateDataSource as target data source and type in the new data set name. Call it
HibernateDataSet.
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Mew Data Set

MNew Data S5et
Create a new data set,

Data Source Selection

= Hibernate Data Source

HibernateDataSource

Data Set Tvpe:
| Hibernate Data Set

in

Data Set Mame:

[Hib grnateCataset

@ ; | st = Cancel '

Figure 2.10. Creating a Hibernate ODA Data Set
10The next dialog of the wizard will help you compose a query for the new data set.

We will make a report that will print all employees in the database who has Sales Rep job title.

select jobtitle, firstnanme, |astname, enil
from Enpl oyees as enpl oyees where enpl oyees.jobtitle = 'Sal es Rep'

To validate the entered query you can press the Test query button. All the HQL features like
syntax highlighting, content assist, formatting, drag-and-drop, etc., are available to facilitate
query composing.

15
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Mew Hibernate Drata Set

b

A= = A~ A - A = A - A = A

Query
Define the guery text for the data set

Fezilable lterns
= @ org.damain.hellobirt entityEmployees

& id : Jawva langlLong

emall ; java.lang. String
emploveenumber : javalang Integer
extension ; javalang.Strng
firstname ; java.lang.String

jobitle ;javalang.String

|zstname ; java.lang.String
officecode ; java.lang. String

reportsto : javalang.nteger

1select jobtitle, firstname, lastname, email
2from Employees as employees where employess.

o email - Emplove:
o emploveenumbe
o extension - Emp
@ firstnarme - Emp!
& id - Employees

@ lastname - Empl
@ officecede - Emp
@ reportsto - Empl

= Back I

I[=E

(e Canc

Figure 2.11. Composing query for Data Set

11Pressing Finish will call the Edit Data Set dialog where you can adjust the parameters of the data
set and preview the resulted set. If everything looks good, hit Ok to generate a new data set.

12Now you can insert the data set items of HibernateDataSet into the employees.rptdesign.

Tip:

If you don't know how to do this we suggest that you refer to the Eclipse BIRT
Tutorial [http://www.eclipse.org/birt/phoenix/tutorial/].

16
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You can also use parameters in the query to add dynamics to your report. In the previous
example we hardcoded the selection criterion in the wher e clause.

To specify the job title on-the-fly your query should look like this:

select jobtitle, firstnane, |astnane, emil
from Enpl oyees as enpl oyees where enpl oyees.jobtitle = ?

The question mark represents a data set input parameter, which is not the same as a report
parameter. Now you need to define an new report parameter to pass the data to the report, call
it JobTi t | e. The dataset parameter can be linked to a report parameter. In the Data Explorer
view click the Data Set node to open it and right-click on the data set you created previously(in
our case it is HibernateDataSet), choose Edit and navigate to the Parameters section. Declare
a new data set parameter, nameitj obti t | e and map it to the already existing JobTi t | e report
parameter.

13You report is ready, you can view it by clicking on the Preview tab of the BIRT Report Designer
editor.

You will be prompted to assign a value to the report parameter. For instance you can enter
"Sales Rep".

17
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=

| employees rptdesign 2

‘Show Feport Parameters|  Mote: Currant masdmurn number of data rows is limited te 500. (Click to change Preview Praferenc

Employees
Job Title First Mame Last Mame Email

Sales Rap Leslie |ennings izrnings@classiemodelears.e
Sales Rep Leslie Thompson lthompsan@classicmodsalcars
Sales Rep Jule Firrelli firrelli@classicmodelcars com
Sales Rep Steve Patterson spatterson@classicmodelcars
Sales Rap Foon Yua Tsamg ftseng@classicrmodelcars.comr
Sales Rep George wanauf gvanauf@classicmodelcars.co
Sales Rep Loui Bondur lbondur@classicmodslcars.col
Sales Rep Gerard Hemandez ghernande@classicmodelcars
Sales Rep Pamela Castillo peastillo@classicrmodelcars.co
Sales Rep Larry Eott lbott@classicrmodelcars.com
Sales Rap Bafry Janes bjonas@classicmodelcars .corr
Sales Rep Andy Fister sfister@classicmodelcars. corr
Sales Rep Peter Marsh pmarshi@classicmodelcars.co
Sales Rep Tom King tking@classicmodelcars.com
Sales Rap Mami Mizhi rrnishi@classicmodelcars.con
Sales Rep Yoshirmi Kato yhato@elassicmodelcars.com
Sales Rep Martin Gerard mgerard @classicmodelcars.co
Mow 3, 2009 12:51 PM

|
Layout Master Page Script | XML Source Prewiew

Figure 2.12. Resulted Dynamic Report

2.3. Creating a Dynamic BIRT Report

The Adding BIRT Functionality to Standard Seam Web Project and Using Hibernate ODA Data
Sourc sections tell how to integrate a BIRT report into a Seam web project and how to use
Hibernate data source to generate a dynamic report. In this section we will create a Seam web
project that can make a dynamic report using the parameters that are defined on a web page.

We will use the PRODUCTS table of DATAMODELS database for the purpose of this demo
project. In the first place, you need to generate Seam entities like we did in the previous chapter
(Hibernate ODA Data Source ). The demo application will generate a report about the company's
products, whereas it will allow to specify a product line.

1. The next step is to create a Java class that will store the sort Or der variable and its assessors,
register the class in faces.config.xml. The variable will be needed to pass dynamic data to the
report via report parameters, therefore it has to be of session scope.

2. The report will print the data from the Pr oduct s table, hence you need to create a report file
first. You can use either the BIRT JDBC Data Source or Hibernate Data Source data source
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to create the data set for this project. If you want to use the latter please read the previous
chapter Hibernate ODA Data Source.

The data set should have at least the following data set items: product vendor, product name,
quantity in stock and buy price. The data is retrieved from the database with this query :

SELECT product vedor,

pr oduct nane,

quanti tyi nst ock,

buypri ce

FROM Products as products

. Make a table in the report and put each data set item into a column.

. As it was stated in the beginning of the chapter the report will be dynamic, therefore you need
to declare a report parameter first, let it be sort Or der and to add the parameter to the query.
BIRT offers rich JavaScript API, so you can modify the query programmatically like this:

<xm - property nanme="queryText"><![ CDATA
SELECT productvedor,
pr oduct nane,
quanti tyi nst ock,
buypri ce
FROM Products as products
]1></xm - property>
<met hod nanme="bef or eCpen" ><! [ CDATA[
queryString = " ORDER BY
product s. " +r eport Cont ext . get Par amet er Val ue("sort Order") +" " +"DESC';
this.queryText = this.queryText+queryString;
]1></ net hod>

. The report is ready. You can preview it to make sure it works properly.

. To set the report parameter you should create an .xhtml view page, call it Products.xhtml. On
the page you can set the value of the sort Or der Java bean variable and press the Generate
Report button to open another view page that will display the resulted report.

The source code of the Products.xhtml should be the following:
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<! DOCTYPE conposition PUBLIC "-//WBC//DTD XHTM. 1.0 Transitional //EN'
"http://ww. w3. org/ TR/ xht i 1/ DTDY xht ml 1-transi ti onal . dtd">
<ui : conposi tion xm ns="http://ww. w3. org/ 1999/ xhtm "
xm ns: s="http://]jboss. con product s/ seanitaglib"
xm ns:ui ="http://java. sun. conijsf/facel ets"
xm ns: h="http://java.sun.conmljsf/htm"
xm ns: f="http://java. sun. conijsf/core"
xmns:rich="http://richfaces.org/rich"
xm ns: adj="http://richfaces.org/a4j" tenplate="I|ayout/tenplate.xhtm ">
<ui : def i ne nane="body" >
<rich: panel >
<f:facet name="header">BI RT Report Generator</f:facet>
<adj :form aj axSubnmi t="true" reRender="criterion">
<t abl e>
<tr>
<td>Sel ect sort order criterion:</td>
<t d><h: sel ect OneMenu onchange="subm t ()"
val ue="#{your JavaBean.sortOrder}"> <!-- Bind to your Java Bean -->
<f:selectltemitenVal ue="buyprice" itenlLabel ="buy price" />
<f:selectltemitenVal ue="quantityinstock" itemLabel ="quantity i n stock" /

</ h: sel ect OneMenu>

</td>
</tr>
</ tabl e>
</ a4j:forne
<s:button
vi ew="/#{! enpty report Par anet er s. or der ? ' Product s’ :
"ProductsReport'}.xhtm " id="generate" val ue="CGenerate Report" /> <!-- |f the

sertOrder variable is not set the button won't work -->
</rich: panel >
</ ui : define>
</ ui : conposi tion>

The logic of the file is quite simple, when the sort order criterion is select the value of
your JavaBean. sor t Or der is set automatically via Ajax and the report is ready to be generated.

. Now you need to create the web page that will print the report, name the file

ProductsReport.xhtml. The file to output the report should have the following content:

<! DOCTYPE conposition PUBLIC "-//WBC//DTD XHTM. 1.0 Transitional//EN'
"http://ww. w3. org/ TR/ xht ml 1/ DTD/ xht m 1-transitional . dtd">
<ui : conposi tion xm ns="http://ww. w3. org/ 1999/ xht m "
xm ns:s="http://jboss. com products/seanitaglib"
xm ns:ui ="http://java. sun. com j sf/facel ets"
xm ns: f="http://java. sun. conijsf/core"
xm ns: h="http://java.sun.conljsf/htm"
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xm ns: b="http://jboss. conf products/sean birt"
xm ns:rich="http://richfaces.org/rich" tenpl ate="1ayout/tenplate.xhtm ">
<ui : def i ne nane="body" >
<ri ch: panel >
<f:facet nanme="header">Products Report</f:facet>
<b: birt desi gnType="enbed" desi gnNane="pr oducts. rptdesi gn"
enmbeddabl e="true" masterpage="true">
<b: param name="sort Order" val ue="#{yourJavaBean. sortOrder}" />
</b:birt>
</rich: panel >
</ ui : defi ne>
</ ui : conposi tion>

As you know from the Adding BIRT Functionality to Standard Seam Web Project chapter, before
using the BIRT Integration framework tags on the page you need to declare the tag library and
specify the name space with this line:

xm ns: b="http://jboss. conf products/sean birt"

The dynamics to the report adds this line:

<b: param nanme="sort Order" val ue="#{yourJavaBean. sortOrder}" />

We bound the sortOrder report parameter to Java Bean variable
val ue="#{your JavaBean. sort Order }" using EL expression, and the value to the variable is
assigned in the Products.xhtml file.

By default if you embed a report into HTML page the HTML-format report contains the <html>,
<head>, <body> etc., tags. However if your HTML page already has those tags, you can rid of
them using the enbeddabl e="t rue" attribute of the <b:birt> component.

. Deploy the project onto the server and open your browser to see the report is
successfully generated. You should navigate to ht t p: / /| ocal host : 8080/ your Pr oj ect Nane/
Product s. seam to select the criterion and press the Generate Report button. You will be
redirected to the http: / /| ocal host : 8080/ Hel | oBi rt/ Product sReport. seam
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m Products =htmil i ProductsfReport xhimil ) HalloEirt 2

=] [T ' httpiilocalhast ;808 0MelloBirk/Product sReport . seamoid= 10

HelloBirt:  Home Browse data

Products Repaort

sart order buyprice

Products Report

Product Vendor Product Name Buy Price Quantity in Stock
Second Gear Diecast 1962 Lanciah Delta 16W 103.42 57091
Gearbox Collectibles 1998 Chrysler Plyrmaouth 101.51 4724
Prowler
Classic Metal Creations 1952 Alpine Renault 1300 58,58 7305
Classic Metal Creations 1955 Porsche 356A Coupe 98,3 G600
Second Gear Diecast 2001 Ferrari Enzo 85,59 3619
Autoart Studio Design 1953 Ford Mustang 55,34 GE
Min Lin Dizeast 1995 Honda Civie C3.B9 Q772
Min Lin Digcast 1570 Triummph Spitfire 91.92 5545
Fed Start Diecast 2003 Harley-Davidson Eagle 91.02 5582
Crag Bike
Welly Diecast Productions 1969 Corvair Monza B9,14 G305
welly Diecast Productions 1917 Grand Touring Sedan B6.7 2724
Maotor City Art Classics 1572 alfa Romeo GTA B5.68 3252
Mator City Art Classics 19405 Ford truck Bd.75 3128
Highway 66 Mini Classics 1993 Mazda R¥-7 R 3575
Second Gear Diecast 1969 Ford Falcon B3.05 1049
Carousel DieCast Legends  18th century schooner B2.34 1858
Unimax Art Galleries 19592 Ferrari 260 Spiderrad  77.5 8347
welly Diecast Productions 15958 Setra Bus 77.9 1579
Red Start Diecast 13805 Black Hawk Helicopter 77.27 5330
welly Diecast Productions 1968 Dodge Charger 75,16 9123
Unimasx Art Galleries 15964 Mercedes Tour Bus 74,86 8258
Gearbox Collactibles 1976 Ford Gran Toring 7249 9127
Exoto Designs 1952 Citroen-15CW 72.82 1452
Gearhoe Callackibles 15978 Merredss-Rens SO T2 ER S48

Figure 2.13. Dynamic Report

Thus, a Seam project that includes the BIRT facet can be deployed as any project. If you define
the Hibernate ODA driver, the JBoss BIRT engine will use JNDI URL that has to be bound to
either Hibernate Session Factory or Hibernate Entity Manager Factory. If you don't specify the
JNDI URL property, our engine will try the following JNDI URLSs:

* java:/<project_name>

* java:/<project_name>EntityManagerFactory

When creating a Seam EAR project, Hibernate Entity Manager Factory is bound to java:/
{projectName}EntityManagerFactory. All you need to do is to use the Hibernate Configuration
created automatically. You can use default values for the Hibernate Configuration and JNDI URL
within the BIRT Hibernate Data Source.
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When using a Seam WAR project, neither HSF nor HEMF aren't bound to JNDI by default. You
have to do this manually. For instance, HSF can be bound to JNDI by adding the following property
to the persistence.xml file:

<property nane="hi bernate. sessi on_factory_nane" val ue="j ava:/ proj ect nane"/ >

And you can use java:/projectname as the JINDI URL property when creating a BIRT Hibernate
Data Source.

@ Note:
If you want to test this feature using PDE Runtime, you need to add osgi.dev=bin
to the WebContent/WEB-INF/platform/configuration/config.ini file.

In conclusion, the main goal of this document is to get you to know with a full feature set that
JBoss BIRT Tools provide. Thus if you have some questions, comments or suggestions on
the topic, please feel free to ask in the JBoss Tools Forum [http://www.jboss.org/index.html?
module=bb&op=viewforum&f=201]. You can also influence on how you want to see JBoss
Tools docs in future leaving your vote on the article Overview of the improvements required by
JBossTools/JBDS Docs users [http://www.jboss.org/community/docs/DOC-10795].
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Chapter 3.

JBoss BIRT Integraion Framework
APl Reference

3.1. <b:birt> Component

The <b:birt> component servers to integrate a BIRT report into Seam/JSF container. The
<b:birt>tag recognizes most of the parameters described on the BIRT Report Viewer Parameters
[http://lwww.eclipse.org/birt/phoenix/deploy/viewerUsage2.2.php#parameters] page, though it has
attributes of its own.

Table 3.1. <b:birt> Component Reference

Attribute Correspondance to BIRT Description/

Report Viewer parameters

designType - Corresponds to the BIRT
servlet mappings. Possible
values are run, frameset,
preview and embed. If
the attribute is set to
embed the component is
used for embeddable html.
This type ignores all the
attributes except designName
and masterpage.

embeddable - A BIRT report occupies the
whole page by default. It
contains the <html>, <head>,
<body> etc., tags. Embedded
report can be a part of
another page. It doesn't
contain the above mentioned
tags. Only HTML report can be
embedded.

designName __report Sets the name of the report
design to process. This can
be an absolute path or relative
to the working folder. Valid
values are run, frameset and
preview
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Chapter 3. JBoss BIRT Integra...

Attribute

Correspondance

Report Viewer parameters

to BIRT Description/

format

__format

Specifies the desired output
format, such as pdf, html, doc,
ppt, or xls.

title

__title

Sets the report title.

showtitle

toolbar

navigationbar

document

locale

__showtitle

__toolbar

__navigationbar

__document

__locale

Determines if the report title is
shown in the frameset viewer.
Defaults to true.

Determines if the report
toolbar is shown in the
frameset viewer.Defaults to
true. Valid values are true and
false.

Determines if the navigation
bar is shown in the frameset
viewer. Defaults to true. Valid
values are true and false.

Sets the name for the
rptdocument. The document
is created when the report
engine separates run and
render tasks, and is used
to support features like table
of contents and pagination.
This setting can be an
absolute path or relative to the
working folder. If no document
parameter is used, a unique
document is created in the
document folder.

Specifies the locale for the
specific operation. Note that
this will override the default
locale.

svg

__svg

Specifies whether SVG is
supported.

page

pagerange

—_page

__pagerange

Specifies specific page to
render.

Specifies page range to
render. Eg 1-4,7.
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<b:param> Component

Attribute

Correspondance to BIRT Description/

Report Viewer parameters

masterpage

overwrite

bookmark

rtl

fittopage

resourceFolder

__masterpage

___overwrite

___bookmark

il

__fittopage

__resourceFolder

Indicates that the report
master page should be used or
not. Validvalues are true and
false.

This setting if set to true
will force an overwrite of the
existing report document.

Specifies a specific bookmark
within the report to load. The
viewer will automatically load
the appropriate page.

Specifies whether to display
the report in right to left format.
This setting defaults to false.

Specifies whether PDF
generation should fit content to
a page. Valid values are true
and false.

Specifies the resource folder
to use. This setting will
override the default setting
in the  web.xml. The
resource folder is used to
locate libraries, images, and
resource files.

3.2. <b:param> Component

The <b:param> tag describes report parameter.

Table 3.2. <b:param> Component

Attribute Description

name
value

isnull

islocale

The parameter name. Required.
The parameter value. Required.

Specifies that a report parameter has a null

value

Specifies whether the parameter is localized
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Chapter 4.

Other Relevant Resources on the
Topic

All JBoss Developer Studio/JBoss Tools release documentation you can find at http://
docs.jboss.org/tools [http://docs.jboss.org/tools/] in the corresponding release directory.

The latest documentation builds are available at http://download.jboss.org/jbosstools/nightly-docs
[http://download.jboss.org/jbosstools/nightly-docs/].
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