1. Visual Web Tools ................................................................. 1
  1.1. Key Features of Visual Web Tools ........................................ 1
  1.2. Other relevant resources on the topic ...................................... 2
2. Spring Tools ................................................................. 3
  2.1. Spring IDE guide .......................................................... 3
      2.1.1. Add Spring Project Nature ......................................... 3
      2.1.2. Create New Spring Project ....................................... 3
      2.1.3. Add References To Other Spring Projects ....................... 3
      2.1.4. Add Spring Beans Config Files .................................... 3
      2.1.5. Create Spring Beans Config Sets .................................. 3
      2.1.6. Open Spring Explorer .............................................. 3
      2.1.7. Validate Spring Beans Config .................................... 3
      2.1.8. Open Spring Beans Graph ......................................... 3
      2.1.9. Search Spring Beans ................................................ 3
3. Editors ....................................................................... 5
  3.1. Editors Features ......................................................... 5
      3.1.1. OpenOn .................................................................. 5
      3.1.2. Content Assist ....................................................... 10
      3.1.3. Synchronized Source and Visual Editing ......................... 23
  3.2. Visual Page Editor ......................................................... 25
      3.2.1. Visual/Source View ................................................ 26
      3.2.2. Page Preview ......................................................... 37
      3.2.3. Setup notes for Linux ............................................. 38
  3.3. More Editors ............................................................... 39
      3.3.1. Graphical Properties Editor ....................................... 39
      3.3.2. Graphical TLD Editor ............................................... 40
      3.3.3. Graphical Web Application File (web.xml) Editor ............ 45
      3.3.4. CSS Editor ........................................................... 50
      3.3.5. JavaScript Editor ................................................... 52
      3.3.6. XSD Editor ........................................................... 54
      3.3.7. Support for XML Schema ........................................... 60
4. JBoss Tools Palette .......................................................... 63
  4.1. Palette Options ............................................................ 64
      4.1.1. Palette Editor ......................................................... 64
      4.1.2. Show/Hide ............................................................. 71
      4.1.3. Import .................................................................. 73
  4.2. Using the Palette ........................................................... 73
      4.2.1. Inserting Tags into a JSP File ..................................... 73
      4.2.2. Adding Custom JSF Tags to the JBoss Tools Palette .......... 76
  4.3. RichFaces Support .......................................................... 81
5. Web Projects View ............................................................ 83
  5.1. Project Organization ........................................................ 83
  5.2. Drag and Drop ............................................................. 84
    5.2.1. For a Property ........................................................ 84
6. JBoss Tools Preferences

6.1. CodeAssist ................................................................. 96
6.2. Editors ........................................................................ 97
6.3. JBoss Servers .............................................................. 98
6.4. JSF ............................................................................ 99
6.5. JSF Flow Diagram ....................................................... 100
6.6. JSF Page ................................................................. 102
6.7. JSF Project .............................................................. 103
6.8. Packaging Archives .................................................... 105
6.9. Plug-in Insets ........................................................... 106
6.10. Resource Insets .......................................................... 108
6.11. Seam ...................................................................... 109
6.12. Seam Validator .......................................................... 110
6.13. Struts ..................................................................... 111
6.15. Struts Customization ................................................ 113
6.16. Struts Flow Diagram ................................................ 114
6.17. Struts Pages ............................................................ 116
6.18. Struts Project ........................................................... 117
6.19. Struts Support ......................................................... 119
6.20. Title Diagram .......................................................... 120
6.21. Verification ............................................................. 121
6.22. View ....................................................................... 123
6.23. Visual Page Editor ................................................... 124
6.24. XDoclet .................................................................. 126
6.25. XDoclet Templates ................................................... 127
6.26. XDoclets Variables .................................................. 132
6.27. Changing Default Environment During Project Creation ........................................ 133
6.28. Changing Default Project Template During Project Creation ..................................... 134
Visual Web Tools

This guide covers the usage of Visual Web Tools in JBoss Developer Studio and JBoss Tools. The difference between these products is that JBoss Tools are just a set of Eclipse plugins where JBoss Developer Studio adds the following functionality:

- an installer
- Eclipse and Web Tools preconfigured
- JBoss EAP with JBoss AS and Seam preconfigured
- 3rd party plugins bundled and configured
- access to RHEL and Red Hat Network
- access to the JBoss/Red Hat supported software

For additional information, please visit the JBoss Developer Studio home page at: http://www.jboss.com/products/devstudio.

In JBoss Tools there is an extensive collection of specialized wizards, editors and views that can be used in various scenarios while developing Web applications. The following chapters walk through these features.

1.1. Key Features of Visual Web Tools

Here is the table of the main features of Visual Web Tools:

Table 1.1. Key Functionality for Visual Web Tools

<table>
<thead>
<tr>
<th>Feature</th>
<th>Benefit</th>
<th>Chapter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual Page Editor</td>
<td>Powerful and customizable visual page editor. Possibility to develop an application using any web technology: jsf, seam, struts, jsp, html and others. Developing using four tabs: visual/source, visual, source and preview. Fast and easy switching between these tabs. Split screen design of visual and source views. Full and instant synchronization between source and visual views. Integration with properties and outline views. Graphical toolbar to add inline styling to any tag.</td>
<td>visual page editor</td>
</tr>
<tr>
<td>JBoss Tools Palette</td>
<td>Organizing various tags by groups, inserting tags into a jsp or xhtml page with one click,</td>
<td>jboss tools palette</td>
</tr>
</tbody>
</table>
# Chapter 1. Visual Web Tools

<table>
<thead>
<tr>
<th>Feature</th>
<th>Benefit</th>
<th>Chapter</th>
</tr>
</thead>
<tbody>
<tr>
<td>adding custom or 3rd party tag libraries into the palette, easy controlling the number of tag groups shown on the palette.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Web Projects View</td>
<td>Visualizing and displaying projects by function. Easy selecting of different kinds of items and dropping them into jsp pages. Using context menus to develop the application. Using icon shortcuts to create and import JSF and Struts projects. Expanding and inspecting tag library files. Selecting custom and third-party tag libraries to drag and drop onto the JBoss Tools Palette.</td>
<td>web projects view</td>
</tr>
<tr>
<td>OpenOn</td>
<td>Easy navigation between views and other parts of your projects.</td>
<td>openOn</td>
</tr>
<tr>
<td>Content Assist</td>
<td>Code completion proposals while working in java, xml, jsp, xhtml, xhtml, seam project and jsf configuration files. Content assist based on project data (dynamic code assist); with graphical editor. Code completion for values from property files, beans attributes and methods, navigation rule outcomes and jsf variables.</td>
<td>content assist</td>
</tr>
<tr>
<td>Drag-and-Drop</td>
<td>Possibility of inserting any tag onto the page you are editing by just drag-and-dropping it from the palette to this page. Adding any properties, managed bean attributes, navigation rules, tag library file declarations, jsp files from web projects view by clicking them and dragging to source code.</td>
<td>visual page editor drag-and-drop</td>
</tr>
</tbody>
</table>

## 1.2. Other relevant resources on the topic

All JBoss Developer Studio/JBoss Tools documentation you can find [here](#). The latest documentation builds are available [here](#).
Chapter 2.

Spring Tools

JBoss Developer Studio is bundled with Spring IDE for Eclipse. Visit Spring IDE site for the latest versions and documentation.

2.1. **Spring IDE guide**

*Spring IDE* is a graphical user interface for the configuration files used by the *Spring Framework*. It's built as a set of plugins for the Eclipse platform.

2.1.1. **Add Spring Project Nature**

2.1.2. **Create New Spring Project**

2.1.3. **Add References To Other Spring Projects**

2.1.4. **Add Spring Beans Config Files**

2.1.5. **Create Spring Beans Config Sets**

2.1.6. **Open Spring Explorer**

2.1.7. **Validate Spring Beans Config**

2.1.8. **Open Spring Beans Graph**

2.1.9. **Search Spring Beans**
Editors

In the *JSF Tools Reference Guide* and *Struts Tools Reference Guide* you had possibility to read about Graphical Editor for JSF and Struts configuration files, *Graphical Editor for Tiles Files*, *Graphical Editor for Struts Validation Files*. All these editors have *OpenOn* and *Content Assist* features, which are described in more details in this document. In addition you get to know a *Visual Page Editor* for combined visual and source editing of Web pages and many *other editors* for different types of files.

3.1. Editors Features

JBoss Developer Studio has powerful editor features that help you easily navigate within your application and make use of content and code assist no matter what project file (jsp, xhtml, xml, css, etc...) you are working on.

3.1.1. OpenOn

*OpenOn* lets you easily link directly from one resource to another in your project without using the Package Explorer view (project tree). With OpenOn, you can simply click on a reference to another file and the file will be opened.

OpenOn is available for the following files:

- *XML files*
- *JSP/XHTML Pages*
- Java files

3.1.1.1. XML Files

Press and hold down the Ctrl key. As you move the mouse cursor over different file references in the file, they display an underline. When you hover the name of the file you want to open, click and the file will open in its own editor. In this example the managed bean NameBean will open.
Figure 3.1. NameBean Managed Bean

This is the result of using OpenOn.

Figure 3.2. NameBean Java Class

You can also use OpenOn with defined attributes.
Figure 3.3. OpenOn With Defined Attributes

You can also open any JSP pages.

Figure 3.4. JSP Page OpenOn
3.1.1.2. JSP Pages

OpenOn is also very useful in JSP pages. It will allow you to quickly jump to the reference instead of having to hunt around in the project structure.

You can easily open the imported property files.

![OpenOn with Imported Property Files](image)

**Figure 3.5. OpenOn With Imported Property Files**

Use OpenOn to open a CSS file used with a JSP page:
For JSP files in a JSF project, you can also easily open the navigation rules by applying OpenOn to the JSF tag for the navigation outcome:
3.1.2. Content Assist

Content assist is available when working with

- Seam project files
- JSF project files
- Struts project files
- JSP files
- RichFaces components

3.1.2.1. JSF Project Files

When working with JSF project in JBoss Developer Studio, you can use various Content Assist features while developing:

- Content Assist for XML, JSP and JSF configuration files
- Content Assist based on project data
- Content Assist with graphical JSF editor

3.1.2.1.1. Content Assist for XML, JSP and JSF configuration files

At any point when working with any XML, JSP and JSF configuration files Content Assist is available to help you. Simply type **Ctrl-Space** to see what is available.
Content Assist for JSF configuration file:

![JSF Configuration File Diagram]

**Figure 3.9. Content Assist in JSF Configuration File**

Content Assist for JSF JSP file:

![JSF JSP File Diagram]

**Figure 3.10. Content Assist in JSP File**
Chapter 3. Editors

Content Assist for other JSF XML project files (web.xml shown):

![Figure 3.11. Content Assist in web.xml File](image)

3.1.2.1.2. Content Assist Based on Project Data

JBoss Developer Studio takes Content Assist to the next level. Studio will constantly scan your project and you will be able to insert code into the JSP page from your project that includes:

- Values from Property files
- "Managed beans" attributes and methods
- Navigation Rule Outcomes
- JSF variables (context, request etc...)

The figure below shows how to insert message from a Properties files. You simply put the cursor inside the "value" attribute and press Ctrl-Space. JBoss Developer Studio will scan your project and show a list of possible values to insert.
Figure 3.12. Inserting Message

In the following screenshot we are inserting a "Managed bean" attribute value. Again, by simply clicking Ctrl-Space, JBoss Developer Studio will show a list of all possible values that you can insert.

Once you select a Managed bean, it will show you a list of all available attributes for the selected Managed bean (userBean).
Chapter 3. Editors

Figure 3.13. Attributes List

Code Assist based on project data will also prompt you for navigation rules that exist in your JSF configuration file.

Figure 3.14. Code Assist

3.1.2.1.3. Content Assist within Tree JSF Editor

JBoss Developer Studio also provides Content Assist when working within the Tree JSF configuration editor. Just click  Ctrl-Space.
3.1.2.2. Struts Project Files

Content Assist features are available when you work with Struts projects.

3.1.2.2.1. Content Assist for Struts Configuration File

Content Assist helps you in Struts Configuration file.

Figure 3.15. Content Assist in Tree JSF Configuration Editor
3.1.2.2.2. Content Assist for Struts JSP File

Using Code Assist in Struts JSP file is shown below.
3.1.2.3. JSP Pages

3.1.2.3.1. Content Assist for JSF Tags

JBDS provides full code completion for JSF tags:

![JSF Tags Content Assist](image)

**Figure 3.18. JSF Tags Content Assist**

When the tag is selected the required attributes, if there any, are already inserted and the cursor is located to the first attribute. At this point you can ask for attribute proposals.
Figure 3.19. Attributes Content Assist

3.1.2.3.2. Content Assist for JSTL Tags

Figure 3.20. JSTL Tags Content Assist

3.1.2.3.3. Content Assist for HTML Tags

Content assist for HTML tags has the same mechanism as for JSF tags:
Figure 3.21. HTML Tags Content Assist

You can use as well attributes proposals for HTML tags:

Figure 3.22. HTML Tags Content Assist

3.1.2.3.4. Content Assist for JavaScript Tags

Figure 3.23. JavaScript Tags Content Assist

3.1.2.4. RichFaces components

JBDS indeed provides code completion for RichFaces framework components. All you have to do is to install RichFaces libraries into your project. See here how to install it.
Figure 3.24. Content Assist for RichFaces Components

- To insert a RichFaces component on a page expand *JBoss RichFaces* group on the palette
- Click on some component
- Put the needed attributes in the *Insert Tag* dialog and click *Finish* button

Figure 3.25. Insert Tag

The RichFaces tag will be inserted on your page displayed in source and visual modes:
3.1.2.5. Adding dynamic code assist to custom components that were added to JBoss Tools Palette

Here is what you need to do to add project based code assist to a custom component added in JBoss Developer Studio:

1. Create a new xml file in \$JBDS_home\studio/eclipse/plugins/org.jboss.tools.common.kb_***/schemas/tld/. For example call it JeniaFaces.xml. The file should be written according to \$JBDS_home\studio/eclipse/plugins/org.jboss.tools.common.kb/jb.jar/org/jboss/tools/common/kb/kb-schema_1.0.dtd

Follow these steps to set what is available for code assist:

• Adds code assist for JSF pre-defined objects, such as value="#{param}"

```
<AttributeType ...>
  <proposal type="jsfVariables"/>
</AttributeType>
```

• Add bundle resource (property file) code assist:

```
<AttributeType ...>
  <proposal type="bundleProperty"/>
</AttributeType>
```
- Add managed bean property code assist:

```xml
ATTRIBUTE...
  <proposal type="beanProperty"/>
</ATTRIBUTE>
```

- Add managed bean property but of a specified type:

```xml
ATTRIBUTE...
  <proposal type="beanProperty">
    <param name="type" value="java.lang.Boolean"/>
  </proposal>
</ATTRIBUTE>
```

- Add managed bean method with a signature:

```xml
ATTRIBUTE...
  <proposal type="beanMethodBySignature">
    <param name="paramType" value="javax.faces.context.FacesContext"/>
    <param name="paramType" value="javax.faces.component.UIComponent"/>
    <param name="paramType" value="java.lang.Object"/>
    <param name="returnType" value="void"/>
  </proposal>
</ATTRIBUTE>
```

2. Add information on your xml file in `<JBDS_home>/studio/eclipse/plugins/org.jboss.common.kb_***/plugin.xml`

```xml
<tlid
  jsf="true"
  name="Jenia Faces"
  schema-location="schemas/tld/myJSF.xml"
  uri="http://www.jenia.org/jsf/dataTools"/>
```

3. Restart Eclipse. You should now have code assist for the component.
3.1.3. Synchronized Source and Visual Editing

**JBoss Developer Studio** offers the flexibility to edit any files in either source or extra visual modes at the same time.

The project is yours and so is the source. **JBoss Developer Studio** provides you many different graphical editors to speed your application development. At the same time, you always have a full control over all project source files. Any changes you make in the source view immediately appear in the graphical view.

The JSF configuration file editor has three views: **Diagram**, **Tree** and **Source**. All views are synchronized, you can edit the file in any view.

![Three Views are Synchronized](image)

**Figure 3.27. Three Views are Synchronized**

The same is relevant to all other **JBoss Developer Studio** editors.

Web XML editor is shown. Web XML editor has a graphical view (Tree) and source (Source).
Figure 3.28. Two Views are Synchronized

JBoss Developer Studio TLD file editor is shown in Tree view. At any point you can edit the source by switching to Source view.
3.2. Visual Page Editor

**JBoss Developer Studio** comes with a powerful and customizable **Visual Page Editor** (VPE). You can use the Visual Page Editor to develop an application using any technology: JSF, Struts, JSP, HTML and others.

Current VPE version has two tabs: Visual/Source and Preview. To switch between the views you can use tabs at the bottom of the VPE or the shortcuts  Ctrl + PageUp/Ctrl + PageDown.
Figure 3.30. Visual Page Editor

3.2.1. Visual/Source View

Using the Visual/Source view you can edit your pages in the Source and Visual modes simultaneously having an instant synchronization between them:
Figure 3.31. Visual/Source View

The view is designed in the form of a split pane with toggle buttons for quickly moving between Source, Visual or Source/Visual modes as shown on the figure above.

One more way to toggle between the various states of the split pane is using the shortcuts \textit{Shift} + \textit{F6} for maximizing/restoring the Source part and \textit{Shift} + \textit{Alt} + \textit{F6} for maximizing/restoring the Visual part.

\textbf{Tip:}

When editing large documents hiding the Visual part will speed up the editing.

It should be pointed out that, no matter in what mode you are working, you get a full integration with Properties and Outline views:
Figure 3.32. Integration with Properties and Outline Views

It's also possible to use the [JBoss Tools Palette](#) to insert any tag from the list of tag libraries to the page you are editing with just a click or drag-and-drop.
3.2.1.1. JSP Syntax Validation

When working in JBoss Tools JSP editor you are constantly provided with feedback and contextual error checking as you type.

3.2.1.2. Inline Style Editing

In the Visual part of the VPE there is a graphical toolbar, use it to add inline styling to JSF and Struts tags on your page. The toolbar can be hidden by clicking on arrow sign in the upper left corner.
Figure 3.34. Text Formatting

For editing inline styles for DOM elements VPE also provides CSS Dialog. It can be called from style line in the Properties view for a currently selected element.
**Figure 3.35. Call the CSS Dialog**

CSS Dialog has four tabs where css properties for text, background, borders and others can be specified. To see the result use a simple preview which is generated at the bottom of the CSS Dialog.
Figure 3.36. CSS Dialog

3.2.1.3. Advanced Settings

In the left vertical pane of the Visual part there are three buttons: Preferences, Refresh, Page Design Options.
Figure 3.37. Visual Page Editor Buttons

Preferences button provides a quick access to Visual Page Editor preferences.
Figure 3.38. Visual Page Editor Preferences Window

Clicking on Refresh button you refresh the displaying information.

Page Design Options button leads to page design options.
Figure 3.39. Page Design Options

This dialog let's you set resources which are usually only resolved in runtime. To set a stylesheet, click Add (for CSS File Path section) and add your stylesheet. It works when CSS is defined on your page in the following way:

Code:

```
<link rel="stylesheet" type="text/css"
href="#{facesContext.externalContext.requestContextPath}/style.css"/>
```

This will work fine in runtime, but the Visual Page Editor doesn't know what requestContextPath in design time is.

The next section (URI), let's you add URI taglibs if you are using includes so that the editor knows where to find the tag libraries.

The first two sections let you define actual runtime folders. Here is an example.
Let's say you have the following project structure:

```
WebContent/
    pages/
        img/
            a.gif
        header.jsp
    main.jsp
```

header.jsp content:

```
My Header
<img src="img/a.gif"/>
```

main.jsp:

```
<jsp:include page="pages/header.jsp"/>
```

When you open `main.jsp` in Visual Page Editor, it will not be able to resolve the image from the header, however, it will work fine in runtime. To fix this in design time, click the `Page Design Options` button and set `Actual Run-Time Relative Folder` to `<project>WebContent > pages` and you will see the image appear.

At the bottom of VPE there is a Selection bar.

By clicking on the component in Visual view or selecting a code snippet in Source mode you see the tags tree. If you want to hide the selection bar, use the "Hide Selection Bar" button on the lower right side.
3.2.2. Page Preview

VPE comes with design-time preview feature which is available for:

- Struts Pages
- JSF Pages

Preview view is read-only, it shows how the page will look like in a browser.
3.2.3. Setup notes for Linux

Linux users may need to do the following to get the Visual Page Editor to work correctly on their machines.

The Visual Page Editor requires the library libstdc++.so.5. This library is contained in the compat-libstdc++-33.i386 package.

• To install this package on Fedora Core or Red Hat Enterprise Linux run the following command:

```
yum install compat-libstdc++-33.i386
```

• On any other rpm based distributions download libstdc++.so.5 and run the following command:

```
rpm -Uvh compat-libstdc++-33.i386
```

• On Debian based distributives run the following command:

```
apt-get install compat-libstdc++-33.i386
```
In case you have the library installed and you still have issue with starting the visual page editor then close all browser views/editors and leave one visual page editor open and restart eclipse. This should force a load of the right XULRunner viewer.

### 3.3. More Editors

Besides Visual Page Editor JBDS is supplied with a huge range of various editors for different file types: properties, TLD, web.xml, tiles, and so on.

#### 3.3.1. Graphical Properties Editor

The Properties editor allows you to work in two different modes and also supports unicode characters.

To create a new properties file, in the Package Explorer view, select *New > Properties File* from the right-click context menu on the folder where you want to create the file.

![Properties File](image)

*Figure 3.42. Selecting Properties File*

You can edit the file using a table-oriented "Properties" viewer:
Figure 3.43. "Properties" Viewer

You can also use a Source viewer for editing the file:

Figure 3.44. Source Viewer

3.3.2. Graphical TLD Editor

The TLD editor comes with same features you will find in all other JBoss Developer Studio editors:
Graphical TLD Editor

- Graphical and source edit modes
- Validation and error checking

3.3.2.1. Tree view

![Tree View](image)

*Figure 3.45. Tree View*

3.3.2.2. Source view

You can easily switch from Tree to Source by selecting the Source tab at the bottom of the editor.
Figure 3.46. Source View

You can easily add a **new tag**: 

```xml
<html version="1.0" encoding="UTF-8">
<taglib xsi:schemaLocation="http://java.sun.com/xml/ns/javasee web-jsptaglibrary_2_1.1">
<!-- Tag Library Description Elements -->
<description>
This tag library contains JavaServer Faces component tags for all
UIComponent + HTML RenderKit Renderers combinations defined in the
JavaServer Faces Specification.
</description>
<lib-version>
1.2
</lib-version>
<short-name>
h
</short-name>
<uri>
http://java.sun.com/jsf/html
</uri>
<!-- Tag Library Validator -->
<validator>
<validator-class>
com.sun.faces.taglib.html_basic.HtmlBasicValidator
</validator-class>
</validator>
</taglib>
```
Figure 3.47. Adding a New Tag

You can also easily add a new attribute to an existing tag:
Chapter 3. Editors

Figure 3.48. Adding a New Attribute

Content assist is available when editing the file using the Source viewer:

Figure 3.49. Content Assist

In the Source viewer, if at any point a tag is incorrect or incomplete, an error will be indicated next to the line and also in the Problems view below.
3.3.3. Graphical Web Application File (web.xml) Editor

The Web Application File editor comes with the same features you will find in all other JBoss Developer Studio editors:

- Graphical and source edit modes
- Validation and error checking
3.3.3.1. Tree View

You can add any new elements right in the Tree viewer:
Figure 3.52. Adding New Elements

3.3.3.2. Source View

Switch to the Source viewer to edit the web.xml file by hand at any time:
3.3.3.3. Content Assist

Content assist is available in the Source viewer. Simply click `CTRL-Space` anywhere in the file.
3.3.3.4. Errors Checking and Validation

If errors occur anywhere in the file, small red dots will appear next to the lines where the errors occurred. Also, note that the file is marked by a small x in the Package Explorer view.
Chapter 3. Editors

Figure 3.55. Errors Reporting

3.3.4. CSS Editor

The CSS editor comes with the same features you will find in all other JBoss Developer Studio editors.

- Content assist
- Validation and error checking

With the CSS (Cascading Style Sheet) editor, you can take advantage of code prompting:
Figure 3.56. CSS Editor

And you can also use the Properties view next to the editor to edit existing stylesheet declaration properties:
3.3.5. JavaScript Editor

The JavaScript editor includes a Preview viewer and a Source viewer. In the Source viewer, you can use code assist:

Figure 3.57. Properties View
Figure 3.58. JavaScript Editor

You can also use the Source viewer with the Outline view to navigate around the file:
3.3.6. XSD Editor

JBoss Developer Studio comes with an XSD Editor for XML Schema files. This editor comes from the Web Tools Project (WTP) (see \textit{WTP Getting Started}).

To create a new XSD file, right-click a folder in the Package Explorer view, select \textit{New > Other...} from the context menu and then select \textit{XML > XML Schema} in the dialog box.
Figure 3.60. Creating New XSD file

The XSD Editor includes two viewers for working on the file, a Design viewer and a Source viewer:
Figure 3.61. Source Viewer

In the Design viewer, you can drill down on an element by double-clicking on it:
Figure 3.62. Design Viewer

Various edit options are available when you right-click an element in the diagram:
Figure 3.63. Edit Options

You can also use the Properties view to edit a selected element:
Figure 3.64. Properties View

You can also use a Source viewer for the file. In this viewer, along with direct editing of the source code, you can also edit the file by using the Properties view on the right:
3.3.7. Support for XML Schema

JBoss Developer Studio fully supports XML files based on schemas as well as DTDs:
Figure 3.66. XML File
This chapter will introduce you to the functionality provided by JBoss Tools Palette. The Palette allows you to quickly and easily create your JSP or JSF pages. Now you can do it more faster without additional knowledge.

The JBoss Tools Palette allows you to:

- Insert tags into a JSP or JSF page with one click
- Add custom and 3rd party tags

The JBoss Tools Palette contains a developer's project tag libraries and provides possibility to add any tag libraries to it. Also you can choose a necessary one from the list of already existed tag libraries:

- HTML
- JBoss
- JSF
- JSTL
- MyFaces
- Oracle ADF Faces
- Struts
- XHTML

By default the Palette is represented in Web Development Perspective with four groups. If you can't see it, select Window > Show View Other... > JBoss Tools Web > JBoss Tools Palette from the menu bar.
4.1. Palette Options

To facilitate your work, you can configure the Palette in your own way, by selecting the corresponding icon on the Palette toolbar.

There is a possibility to configure the JBoss Tools Palette:

- to edit the palette content by adding, removing or changing the palette elements
- to show/hide groups, subgroups
- to import groups, subgroups

![Figure 4.2. Palette Buttons](image)

4.1.1. Palette Editor

JBoss Tools Palette contains existing libraries of tags, thus the Palette editor is intended to work with them or create your new one, as well.

To open the editor, click on the Palette Editor icon:

![Figure 4.3. Palette Editor Icon](image)
The window has two parts. There is a reflected grouped list of components on the left side of the palette editor. Each group is divided into multiple groups, every of which is a tag library. The right side of the palette editor is an editing window where it's possible to change values of group or tag library attributes that you've chosen on the left part of the window.

It can also be done by right click and using *Edit...* option.

For example, JSF group consists of Core, Facelets, HTML tag libraries and the attributes as name, description and hidden which are available for editing:

![Figure 4.4. Tag Libraries of the JSF Group](image)

The Palette Editor provides the following possibilities when working with existing tags or icons:

- to work with a set of icons

  *Icons* is the root folder for the icon sets. The first step is creating the icon set. Right click on the *Icons* folder and select *Create > Create Set...*

  Set the value of the name in the *Add Icons* window and click *Finish* button. A new element will appear in the list.
Figure 4.5. Creating a Set of Icons

Also you can delete the set. Right click on the set of icons that you wish to remove and chose the Delete Set option from the pop-up menu or click the Delete keyboard button.

• to edit icons in the chosen set

When the set of icons is created, new icons can be imported to it. Choose the required set and select the option Create > Import Icon... from the pop-up menu that appears after you right-click on a folder.
Figure 4.6. Creating Icons

Set the name of the icon and the path and click *Finish* button.

- to work with a group of tag libraries

The first step in work with the editor is creating a group of libraries. It's very easy to do, right mouse button click on the *Palette* folder and select *Create > Create Group*...

Set a name of a group in the *Create Group* window and click *OK* button. A new element will appear at the end of the list.
Chapter 4. JBoss Tools Palette

Figure 4.7. Creating a Group of Tag Libraries

You are allowed to edit or delete a group, as well. If you'd like to change attributes of a group, use the right editing window of the palette editor or the *Edit...* option, like it was mentioned before. In order to remove the group, right click on the group that you wish to remove and chose the *Delete* option or click the *Delete* keyboard button.

**Important:**

The removal option is enabled only for custom folders.

- to work with a tag library

The group maintains a list of tag libraries. If you'd like to create your own library, click right mouse button on the group and choose *Create Group...* option.
Figure 4.8. Creating a tag library

After setting the attribute name and the path of the icon, click **Ok** button.

**Note:**

If you do not choose an icon the default one will be assigned.

You are allowed to edit or delete the tag library, as well. If you’d like to change attributes of the library or choose another icon, use the right editing window of the palette editor or the **Edit...** option. In order to remove the tag library, right click on the library that you wish to remove and chose the **Delete** option or click the **Delete** keyboard button.

**Important:**

The removal option is enabled only for custom tag libraries.

- to work with a tag element

When the library folder is created, new tags can be added to it. Choose the required library and select the option **Create > Create Macro...** from the pop-up menu that appears after you right-click on a folder.
Figure 4.9. Creating a tag element

In the Add Palette Macro window, you can configure the tag element. Attribute Name is mandatory to fill and it will be the name of the tag element. Other settings are optional. You can choose the icon and set the Start Text and the End Text for your tag element. If your tag text is too long, use the Change... button to see it all. For start text and end text there is a possibility to control the cursor position by using "|" symbol.
After all the attributes are set, click the Finish button.

**Note:**
If you do not choose an icon the default one will be assigned.

You are also allowed to edit or delete the tag. If you’d like to change the attributes of the tag or choose another icon for it, use the right editing window of the palette editor or the Edit... option from the pop-up menu. In order to remove the tag, right click on the tag that you wish to remove and chose the Delete option or click the Delete keyboard button.

**Important:**
The removal option is enabled only for custom tags. JBoss Palette tags can not be removed but can be modified.

### 4.1.2. Show/Hide

*Show/Hide* is a very useful feature that allows you to control the number of tag groups that are shown on the palette.

- Click the Show/Hide button, at the top right side of the JBoss Tools Palette.
Figure 4.11. Show/Hide Button

• In the dialog Show/Hide Drawers check the groups the libraries of which you want to be shown on the palette:

Figure 4.12. Show/Hide Drawers

If libraries are not displayed in the palette, check whether they are selected. Click the plus sign to expand the libraries of the group and make sure that a tick is put next to the wanted libraries.

• Click OK. The new groups will now be shown on the palette:
The names of the elements are compound. The first part is the group name and the second is the library name.

4.1.3. Import

The Import button lets you add a custom or 3rd party tag library to JBoss Tools Palette. Find out more information on how to add particular tags see the Adding Custom JSF Tags section.

4.2. Using the Palette

4.2.1. Inserting Tags into a JSP File

A new tag can be added into any text file including jsp, htm, html and xhtml.

Let's do it. Open your JSP file and place the cursor in a place where you'd like to add a tag and then click that tag in the palette. In the Insert Tag window, that appears, you can set the value of general and advanced attributes of the tag that you chose.
Figure 4.14. Inserting Tag

In the example below, the `commandButton` tag has been inserted.
Figure 4.15. Inserting Tag

Tip:

if you place the cursor over any tag, a balloon hint is shown with all the "tag" attributes.

The cursor position after adding a tag into a file is specified by "|" symbol in the tag template on the right in the Palette Editor window.
Figure 4.16. Palette Editor

Above you can see where the cursor position for HTML > Form > input is set. Thus, after adding this tag into your file the cursor will be in the attribute "type". Then, you can straight use the combination of buttons Ctrl + Space to inquire about a prompting.

Figure 4.17. Cursor position

4.2.2. Adding Custom JSF Tags to the JBoss Tools Palette

There are two ways to add any custom or 3rd party tag library to the JBoss Tools Palette:

- Drag-and-drop from the Web Projects view
- The Import button on the JBoss Tools Palette
Before you can add your custom component library, you need to make sure it is included in your project. Either place the ".tld" file or the ".jar" that includes your tag library under the lib folder in your project.

### 4.2.2.1. Drag-and-Drop

Switch to the Web Projects view and expand the Tag Libraries folder. If the view is not active, select **Window > Show View > Web Projects** from the menu bar.

![Web Projects View](image)

**Figure 4.18. Web Projects View**

Also make sure that the JBoss Tools Palette is open. Select the tag library that you want to add and simply drag-and-drop it on to the JBoss Tools Palette.

You will see the following dialog window. As you can see JBoss Developer Studio takes care of all the details. Chosen **TLD file**, **name** and **prefix** of the library and **Library URL** are detected, thus just need to set the **Group** name to which you wish to place this tag library. You can either add this tag library to an existing Group or just create a new one.
Figure 4.19. Import Tags From TLD File Form

Once you are finished, you will see the new tag library added to the JBoss Tools Palette.
Figure 4.20. JBoss Tools Palette with New Tag Library

4.2.2.2. Import Button

The same you can do with *Import* button. You can see this button at the top right side of the JBoss Tools Palette.
Figure 4.21. Import Button

By clicking on the Import button you will see the Import Tag window a similar like in the Drag-and-Drop method. Set the name and prefix of the library and Library URL. Also you need to set the Group name to which you’d like to add your tag library. And like in the previous method you can add it to an existing Group or create a new one. On this Import Tag form you can use Browse... button to locate the tag library that you want to add:
Figure 4.22. Select TLD File

4.3. RichFaces Support

JBoss Developer Studio comes with a tight integration with RichFaces component framework. RichFaces and Ajax4jsf in JBoss Tools Palette always exist, this palette is not dynamic and is not changed from file to file.

Tip:
If you’d like to know the last version of RichFaces component framework see JBoss RichFaces site.

RichFaces components, as well as Ajax4jsf ones are already on the JBoss Tools Palette:
Figure 4.23. RichFaces Components
Web Projects View

Web Projects is a special view that comes with JBoss Developer Studio.

If the Web Projects view's tab is not visible next to the Package Explorer tab, select Window > Show View > Other > JBoss Tools Web > Web Projects from the menu bar.

With the Web Projects view, you can:

• Visualize the project better because the project artifacts for JSF and Struts projects are organized and displayed by function.

• Select these kinds of items to drag and drop into JSP pages:
  • JSF managed bean attributes
  • JSF navigation rules outcomes
  • Property file values
  • Tag library files
  • Tags from tag libraries
  • JSP page links

• Use context menus to develop the application (all create and edit functions are available)

• Use icon shortcuts to create and import JSF and Struts projects

• Expand and inspect tag library files

• Select custom and third-party tag libraries to drag and drop onto the JBoss Tools Palette

5.1. Project Organization

The Web Projects view organizes your project in a different way. The physical structure of course stays the same. The new organization combines common project artifacts together which makes it simpler to locate what you are looking for and develop.

The screen shot below shows a JSF project and a Struts project in Web Projects view.
Chapter 5. Web Projects View

Figure 5.1. Web Projects View

5.2. Drag and Drop

Web Projects View has a drag and drop option that can be used for property, managed bean attributes, navigation rules, tag library file declaration and JSP Pages.

5.2.1. For a Property

Expand the Resources Bundles folder that holds all the Property files in your project. Select the file from which you want to add the property and then select the property.

We will be dragging and dropping a property file value inside the outputText tag for the "value" attribute.
For a Property

```
<html>
<head>
  <title>Input User Name Page</title>
</head>
<body>
  <f:view>
    <h1><f:outputText value=""/></h1>
  </f:view>
</html>
```

**Figure 5.2. OutputText Tag**

Select the property:

![Property selection screenshot]

**Figure 5.3. Selecting Property**

Drag the property and drop it between the quotes for the value attribute in the JSP file. Notice that JBoss Developer Studio added the correctly formatted expression for referring to the property value `#{Message.header}` automatically.

```
<html>
<head>
  <title>Input User Name Page</title>
</head>
<body>
  <f:view>
    <h1><f:outputText value="#{Message.header}"/></h1>
    <f:messages style="color: red"/>
  </f:view>
</html>
```

**Figure 5.4. Inserted Property**
You can actually place the tag anywhere in the page, not just inside an existing tag. In this case, JBoss Developer Studio will place the complete tag `<h:outputText value="#{Message.header}"/>` in the page.

### 5.2.2. For Managed Bean Attributes

Select a "managed bean" attribute and then drag and drop it onto the JSP page. We are going to place it inside the "value" attribute of the inputText tag.

![Figure 5.5. Selecting Managed Bean Attribute](image)

Once again, JBoss Developer Studio adds the correct expression, `#{user.name}`.

```xml
<h:form id="greetingForm">
    <h:outputText value="#{Message.prompt_message}" />
    <h:inputText value="#{user.name}" required="true">
        <f:validateLength maximum="30" minimum="3" />
    </h:inputText>
</h:form>
```

![Figure 5.6. Added Expression](image)

### 5.2.3. Navigation Rules

Select the navigation rule under `Configuration > faces-config.xml > Navigation Rules:`
**Figure 5.7. Selecting Navigation Rule**

Drag and drop it inside the commandButton tag:

```xml
<f:validateLength maximum="30" minimum="3"/>
</f:inputText>

```xml
<h:commandButton action="hello" value="Say Hello!" />

</h:form>
</f:view>

**Figure 5.8. Navigation Rule in CommandButton Tag**

You could do the same if the navigation rule was defined inside an action method:
Chapter 5. Web Projects View

Figure 5.9. Navigation Rule in Action Method

Here is how it would look after drag and drop:

```xml
<br:validateLength maximum="30" minimum="3"/>
</h:inputText>

<h:commandButton action="#{user.name}" value="Say Hello!" />
</h:form>

Figure 5.10. Inserted Navigation Rule

5.2.4. For a Tag Library File Declaration

Select a TLD file:
For JSP Pages

Figure 5.11. Selecting TLD File

Then drag and drop it onto the JSP page to add a declaration at the top of the page:

Figure 5.12. Inserted TLD File

5.2.5. For JSP Pages

You can also drag and drop a JSP page path to a JSP page to create a forward as shown:
5.3. Developing the Application

It is also possible to develop your application right from the Web Projects view. Simply right-click any node in the tree and select an appropriate action from the context menu. For instance, this screen capture shows creating a new navigation rule.
5.4. Expanding Tag Library Files

You can easily expand any TLD file in the project. Browse to the Tag Libraries folder. Right-click a TLD file and select *Expand*. The TLD file will now be expanded.

You can then select any tag and drag it onto a JSP page.
Chapter 5. Web Projects View

5.5. Drag and Drop Tag Libraries on to JBoss Tools Palette

Read Adding Tag Libraries to learn about this.

5.6. Create and Import JSF and Struts Projects

You can also create and import JSF and Struts project from Web Projects view by selecting the buttons below.

From left to right:

1. Create New JSF Project
2. Import JSF Project
3. Create New Struts Project
4. Import Struts Project
Figure 5.16. Web Projects View Buttons
JBoss Tools Preferences

Configuring the various JBoss Developer Studio features is done via the Preferences screen by selecting Window > Preferences > JBoss Tools from the menu bar.

![Preferences dialog]

Figure 6.1. Preferences are included in this dialog.

From this screen, you can select these more specific sets of JBoss Tools preferences:

- **Code Assist**
- **Editors**
- **JBoss Servers**
Chapter 6. JBoss Tools Prefer...

- JSF
- JSF Flow Diagram
- JSF Page
- JSF Project
- Packaging Archives
- Plug-in Insets
- Resource Insets
- Seam
- Seam Validator
- Struts
- Struts Automatic
- Struts Customization
- Struts Flow Diagram
- Struts Pages
- Struts Project
- Struts Support
- Title Diagram
- Verification
- View
- Visual Page Editor
- XDoclet
- XDoclet Templates
- XDoclets Variables

6.1. CodeAssist

Select JBoss Tools > XDoclet > Code Assist to see Code Assist preference page.
Editors

Here is what the Code Assist preference page looks like:

![Code Assist Preference Page]

**Figure 6.2. CodeAssist**

### 6.2. Editors

You can set various preferences for the editors that JBoss Developer Studio adds to the Eclipse environment by selecting **JBoss Tools > Web > Editors.**
Figure 6.3. Editors

In the initial Editors screen, you can decide on some global settings for JBoss Tools editors. You can select whether an available JBoss Tools editor should always be the default editor for a type of file, whether the user should be warned that making a project an Red Hat project will make an JBoss Tools editor fully available for a particular type of file, and whether, for JBoss Tools editors, the Source mode should be the default instead of a visual mode.

6.3. JBoss Servers

The following preferences can be changed on the JBoss Tools > JBoss Servers preference page.

Here is what the JBoss Servers preference page looks like:
Figure 6.4. JBoss Servers

6.4. JSF

Select JBoss Tools > Web > JSF to get to the JSF Project specific preferences.
Figure 6.5. JSF

6.5. JSF Flow Diagram

Selecting *JBoss Tools > Web > Editors > JSF Flow Diagram* allows you to specify some aspects of the Diagram mode of the JSF configuration file editor.
Figure 6.6. JSF Flow Diagram

The first two items control the background grid for the diagram. The next two items allow you to control the appearance of the labels for views (pages) and the transitions between views. For these two items, clicking the Change... button allows you to assign a font with a dialog box.

The first check box determines whether a view in the diagram that doesn't have a transition connecting it to another view yet should be written to the source code as a partial navigation rule. The next check box determines whether the diagram cursor reverts immediately to the standard selection mode after it's used in the transition-drawing mode to draw a transition. Finally, the last two check boxes concern shortcuts. A shortcut is a transition that is there but isn't actually displayed in the diagram as going all the way to the target view it's connected to, in order to make the diagram clearer. With the check boxes, you can decide whether to display a small shortcut icon as part of the shortcut and also whether to display the target view as a label or not.
Figure 6.7. Add View

Selecting the Add Page tab in the JSF Flow Diagram screen allows you to determine the default template and file extension for views (pages) you add directly into the diagram using a context menu or the view-adding mode of the diagram cursor.

6.6. JSF Page

By selecting *JBoss Tools > Web > JSF > > JSF Pages* you can add jsf pages or remove existing ones.
Select JBoss Tools > Web > JSF > Project to see JSF Project preference page.

On Project panel you define a template for a new created project: servlet version, page template and so on.
Figure 6.9. JSF Project

Selecting the Import Project tab in the JSF Project screen allows you to determine the default servlet version and whether to register Web Context in server.xml.
Figure 6.10. Import JSF Project

6.8. Packaging Archives

The following preferences can be changed on the JBoss Tools > Packaging Archives page.

On Packaging Archives panel you determine settings for Project Packages view and core preferences.
6.9. Plug-in Insets

By selecting Web > Struts > Automation > Plug-in Insets on tab Tiles you can define a default text for tiles plugin.
Figure 6.12. Plug-in Insets

The same is done but for validator plugin on the tab Validators.
Figure 6.13. Plug-in Insets of Validators

6.10. Resource Insets

To see Resource Insets preference page select JBoss Tools > Web > Strats > Automation > Resource Insets.

On Resource Insets panel you determine default error messages for error resource files.
6.11. Seam

The following preferences can be changed on the *JBoss Tools > Web > Seam* page.

On *Seam* screen you can add and remove Seam runtimes.

Here is what Seam preference page looks like:
The following preferences can be changed on the JBoss Tools > Web > Seam > Validator page.

In Validator panel you configure seam problems that will be processed by validator.
Figure 6.16. Seam Validator

6.13. Struts

By selecting *JBoss Tools > Web > Struts* you can configure Struts projects specific preferences.
Figure 6.17. Struts


On Automation panel you can modify default text for the Tilel Struts plug-in element, the Validator
Struts plug-in element, and error message resource files.
Figure 6.18. Struts Automatic

6.15. Struts Customization

The following preferences can be changed on the JBoss Tools > Web > Struts > Customization page.

In the Customization screen you configure Link Recognizer for Struts tags.
Similarly to the JSF Flow Diagram screen, selecting JBoss Tools > Web > Editor > Struts Flow Diagram page allows you to specify aspects of the Diagram mode of the Struts configuration file editor. The Struts Flow Diagram screen adds an option to hide the Diagram tab and labeling settings for additional artifacts.
Figure 6.20. Struts Flow Diagram

Selecting the Add Page tab in the Struts Flow Diagram screen allows you to determine the default template and file extension for views (pages) you add directly into the diagram using a context menu or the view-adding mode of the diagram cursor.
Figure 6.21. Adding Page

6.17. Struts Pages

You can change the following preferences on the JBoss Tools > Web > Struts > Struts Pages preference page.

On Struts Pages panel you can add or remove Struts pages.
Figure 6.22. Struts Pages

6.18. Struts Project

You can change the following preferences on the JBoss Tools > Web > Struts > Project preference page:

On Project panel you define a template for a new Struts created project: servlet version, page template and so on.
Figure 6.23. Struts Project

Selecting the Import Project tab in the Struts Project screen allows you to determine the default servlet version and whether to register Web Context in server.xml.
Figure 6.24. Import Struts Pages

6.19. Struts Support

The following preferences can be changed on the JBoss Tools > Web > Struts > Project > Struts Support page.

Select Struts Support screen if you want to configure Struts versions support settings.
Figure 6.25. Struts Support

6.20. Title Diagram

*JBoss Tools > Web > Editors > Title Diagram* screen allows you control some settings for the placement of Tiles definitions in the Diagram mode of the JBoss Tools Tiles editor.
Figure 6.26. Title Diagram

6.21. Verification

The following preferences can be changed on the JBoss Tools > Web > Verification page.

On Rules Configuration tab of Verification panel you can determine JSF and Struts rules.
Figure 6.27. Verification

On Options tab you can define a limit for the reported errors number.
Figure 6.28. Options of Verification

6.22. View

The following preferences can be changed on the JBoss Tools > JBoss Servers > View page.

The View shows you preferences for JBoss Servers view.
6.23. Visual Page Editor

*JBoss Tools > Web > Editors > Visual Page Editor* screen allows you to control some aspects of the behavior of the Visual Page Editor (VPE) for JSP files. Also you can define a default editor tab.
Figure 6.30. Visual Page Editor

On the Templates tab you can edit or remove VPE templates.
6.24. XDoclet

The following preferences can be changed on the JBoss Tools > XDoclet page.

On XDoclet screen you determine XDoclet module versions.
Figure 6.32. XDoclet

6.25. XDoclet Templates

To see what XDoclet tags templates available for completion select JBoss Tools > XDoclet > Code Assist > Templates.
By right clicking on any tree element you can add a new template, remove or rename it and also add a new tree.

Select, for example, *Add* and you'll be prompted by a list of available elements to add.
Figure 6.34. Add New XDoclet Template

By double-clicking some element a new list will be shown: now for available methods.
Figure 6.35. Select New Element

Choose any element from the list, then select an attribute.
Figure 6.36. Select New Element

It will be added to the available templates.
Figure 6.37. Select New Element

6.26. XDoclets Variables

By selecting *JBoss Tools > XDoclet > Variables* you define variables used in templates.
6.27. Changing Default Environment During Project Creation

To change the default environment and project template for either JSF or Struts new project creation:

1. Select **Window > Preferences > JBoss Tools > Web > (JSF or Struts) > Project**

2. For Version set the environment you want to be the default one

3. For Project Template set the template you want to be the default one

---

**Figure 6.38. XDoclets Variables**
6.28. Changing Default Project Template During Project Creation

To change the default project template for either JSF or Struts new project creation:

1. Select \textit{Window} > \textit{Preferences} > \textit{JBoss Tools} > \textit{Web} > \{JSF or Struts\} > \textit{Project}

2. For Project Template set the template you want to be the default one
Changing Default Project Template During Project Creation

Figure 6.40. Changing Project Template