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Visual Web Tools
This guide covers the usage of Visual Web Tools in JBoss Developer Studio and JBoss Tools.

The difference between these products is that JBoss Tools are just a set of Eclipse plugins where

JBoss Developer Studio adds the following functionality:

• an installer

• Eclipse and Web Tools preconfigured

• JBoss EAP with JBoss AS and Seam preconfigured

• 3rd party plugins bundled and configured

• access to RHEL and Red Hat Network

• access to the JBoss/Red Hat supported software

For additional information, please visit the JBoss Developer Studio home page at: http://

www.jboss.com/products/devstudio.

In JBoss Tools there is an extensive collection of specialized wizards, editors and views that can

be used in various scenarios while developing Web applications. The following chapters walk

through these features.

1.1. Key Features of Visual Web Tools

Here is the table of the main features of Visual Web Tools:

Table 1.1. Key Functionality for Visual Web Tools

Feature Benefit Chapter

Visual Page Editor Powerful and customizable visual page editor.

Possibility to develop an application using

any web technology: jsf, seam, struts, jsp,

html and others. Developing using four tabs:

visual/source, visual, source and preview. Fast

and easy switching between these tabs. Split

screen design of visual and source views. Full

and instant synchronization between source

and visual views. Integration with properties

and outline views. Graphical toolbar to add

inline styling to any tag.

visual page editor

JBoss Tools Palette Organizing various tags by groups, inserting

tags into a jsp or xhtml page with one click,

jboss tools palette

http://www.jboss.com/products/devstudio
http://www.jboss.com/products/devstudio
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Feature Benefit Chapter

adding custom or 3rd party tag libraries into

the palette, easy controling the number of tag

groups shown on the palette.

Web Projects View Visualizing and displaying projects by function.

Easy selecting of different kinds of items and

dropping them into jsp pages. Using context

menus to develop the application. Using icon

shortcuts to create and import JSF and Struts

projects. Expanding and inspecting tag library

files. Selecting custom and third-party tag

libraries to drag and drop onto the JBoss Tools

Palette.

web projects view

OpenOn Easy navigation between views and other parts

of your projects.

openOn

Content Assist Code completion proposals while working

with html, java, JavaScript , xml, jsp, xhtml,

xhtml, seam project and jsf configuration

files. Content assist based on project data

(dynamic code assist); with graphical editor.

Code completion for values from property files,

beans attributes and methods, navigation rule

outcomes and jsf variables.

content assist

Drag-and-Drop Possibility of inserting any tag onto the page

you are editing by just drag-and-droping it from

the palette to this page. Adding any properties,

managed bean attributes, navigation rules, tag

library file declarations, jsp files from web

projects view by clicking them and draging to

source code.

visual page editor

drag-and-drop

RichFaces Support Tight integration between JBDS and

RichFaces frameworks. Easy managing

RichFaces components in any web application.

Support for RichFaces and Ajax4jsf libraries

in JBoss Tools Palette. Rendering RichFaces

components in Visual Page Editor.

RichFaces support

1.2. Other relevant resources on the topic

All JBoss Developer Studio/JBoss Tools documentation you can find here.

The latest documentation builds are available here.

http://www.jboss.org/jbossrichfaces
http://www.jboss.com/products/devstudio/docs
http://download.jboss.org/jbosstools/nightly-docs/
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Spring Tools
JBoss Developer Studio is bundled with Spring IDE for Eclipse. Visit Spring IDE site for the latest

versions and documentation.

2.1. Spring IDE guide

Spring IDE is a graphical user interface for the configuration files used by the Spring Framework.

It's built as a set of plugins for the Eclipse platform.

2.1.1. Add Spring Project Nature

2.1.2. Create New Spring Project

2.1.3. Add References To Other Spring Projects

2.1.4. Add Spring Beans Config Files

2.1.5. Create Spring Beans Config Sets

2.1.6. Open Spring Explorer

2.1.7. Validate Spring Beans Config

2.1.8. Open Spring Beans Graph

2.1.9. Search Spring Beans

http://springide.org/project
http://springide.org/project/wiki/SpringideGuide
http://springide.org/project
http://www.springframework.org/
http://springide.org/project/wiki/SpringideGuide#AddProjectNature
http://springide.org/project/wiki/SpringideGuide#CreateNewProject
http://springide.org/project/wiki/SpringideGuide#AddProjectReferences
http://springide.org/project/wiki/SpringideGuide#AddBeansConfigs
http://springide.org/project/wiki/SpringideGuide#CreateBeansConfigSets
http://springide.org/project/wiki/SpringideGuide#OpenSpringExplorer
http://springide.org/project/wiki/SpringideGuide#ValidateBeansConfig
http://springide.org/project/wiki/SpringideGuide#OpenBeansGraph
http://springide.org/project/wiki/SpringideGuide#SearchBeans
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Editors
In the JSF Tools Reference Guide and Struts Tools Reference Guide you had possibility to read

about Graphical Editor for JSF and Struts configuration files, Graphical Editor for Tiles Files,

Graphical Editor for Struts Validation Files. All these editors have  OpenOn  and  Content Assist

features, which are described in more details in this document. In addition you get to know a

Visual Page Editor for combined visual and source editing of Web pages and many other editors

for different types of files.

3.1. Editors Features

JBoss Developer Studio has powerful editor features that help you easily navigate within your

application and make use of content and code assist no matter what project file (jsp, xhtml, xml,

css, etc...) you are working on.

3.1.1. OpenOn

OpenOn lets you easily link directly from one resource to another in your project without using

the Package Explorer view (project tree). With OpenOn, you can simply click on a reference to

another file and the file will be opened.

OpenOn is available for the following files:

• XML files

• JSP/XHTML Pages

• Java files

3.1.1.1. XML Files

Press and hold down the Ctrl key. As you move the mouse cursor over different file references

in the file, they display an underline. When you hover the name of the file you want to open, click

and the file will open in its own editor. In this example the managed bean NameBean will open.

../../jsf_tools_ref_guide/html_single/index.html
../../struts_tools_ref_guide/html_single/index.html
../../jsf_tools_ref_guide/html_single/index.html#jsf_config_file
../../struts_tools_ref_guide/html_single/index.html#struts_config_editor
../../struts_tools_ref_guide/html_single/index.html#GraphicalEditorForTilesFiles132
../../struts_tools_ref_guide/html_single/index.html#GraphicalEditorForStrutsValidationFiles86
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Figure 3.1. NameBean Managed Bean

This is the result of using OpenOn.
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Figure 3.2. NameBean Java Class

You can also use OpenOn with defined attributes.
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Figure 3.3. OpenOn With Defined Attributes

You can also open any JSP pages.

Figure 3.4. JSP Page OpenOn
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3.1.1.2. JSP Pages

OpenOn is also very useful in JSP pages. It will allow you to quickly jump to the reference instead

of having to hunt around in the project structure.

You can easily open the imported property files.

Figure 3.5. OpenOn With Imported Property Files

Use OpenOn to open a CSS file used with a JSP page:
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Figure 3.6. OpenOn With CSS File

Open managed beans:
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Figure 3.7. OpenOn With Managed Beans

For JSP files in a JSF project, you can also easily open the navigation rules by applying OpenOn

to the JSF tag for the navigation outcome:

Figure 3.8. OpenOn With JSF Tag

3.1.2. Content Assist

Content assist is available when working with

• Seam project files

../../seam/html_single/index.html#ContentAssist
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• JSF project files

• Struts project files

• JSP files

• RichFaces components

• ESB XML files

3.1.2.1. JSF Project Files

When working with JSF project in JBoss Developer Studio, you can use various Content Assist

features while developing:

• Content Assist for XML, JSP and JSF configuration files

• Content Assist based on project data

• Content Assist with graphical JSF editor

3.1.2.1.1. Content Assist for XML, JSP and JSF configuration files

At any point when working with any XML, JSP and JSF configuration files Content Assist is

available to help you. Simply type  Ctrl-Space  to see what is available.

Content Assist for JSF configuration file:

Figure 3.9. Content Assist in JSF Configuration File

Content Assist for JSF JSP file:

#ESBContentAssist


Content Assist

13

Figure 3.10. Content Assist in JSP File

Content Assist for other JSF XML project files (web.xml shown):

Figure 3.11. Content Assist in web.xml File
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3.1.2.1.2. Content Assist Based on Project Data

JBoss Developer Studio takes Content Assist to the next level. Studio will constantly scan your

project and you will be able to insert code into the JSP page from your project that includes:

• Values from Property files

• "Managed beans"  attributes and methods

• Navigation Rule Outcomes

• JSF variables (context, request etc...)

The figure below shows how to insert message from a Properties files. You simply put the cursor

inside the  "value"  attribute and press  Ctrl-Space.  JBoss Developer Studio will scan your project

and show a list of possible values to insert.

Figure 3.12. Inserting Message

In the following screenshot we are inserting a  "Managed bean"  attribute value. Again, by simply

clicking Ctrl-Space, JBoss Developer Studio will show a list of all possible values that you can

insert.

Once you select a Managed bean, it will show you a list of all available attributes for the selected

Managed bean (userBean).
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Figure 3.13. Attributes List

Code Assist based on project data will also prompt you for navigation rules that exist in your JSF

configuration file.

Figure 3.14. Code Assist

3.1.2.1.3. Content Assist within Tree JSF Editor

JBoss Developer Studio also provides Content Assist when working within the Tree JSF

configuration editor. Just click  Ctrl-Space.
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Figure 3.15. Content Assist in Tree JSF Configuration Editor

3.1.2.2. Struts Project Files

Content Assist features are available when you work with Struts projects.

3.1.2.2.1. Content Assist for Struts Configuration File

Content Assist helps you in Struts Configuration file.
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Figure 3.16. Struts Content Assist

3.1.2.2.2. Content Assist for Struts JSP File

Using Code Assist in Struts JSP file is shown below.

Figure 3.17. Struts JSP Content Assist
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3.1.2.3. JSP Pages

3.1.2.3.1. Content Assist for JSF Tags

JBDS provides full code completion for JSF tags:

Figure 3.18. JSF Tags Content Assist

When the tag is selected the required attributes, if there any, are already inserted and the cursor

is located to the first attribute. At this point you can ask for attribute proposals.
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Figure 3.19. Attributes Content Assist

3.1.2.3.2. Content Assist for JSTL Tags

Figure 3.20. JSTL Tags Content Assist

3.1.2.3.3. Content Assist for HTML Tags

Content assist for HTML tags has the same mechanism as for JSF tags:
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Figure 3.21. HTML Tags Content Assist

You can use as well attributes proposals for HTML tags:

Figure 3.22. HTML Tags Content Assist

3.1.2.3.4. Content Assist for JavaScript Tags

Figure 3.23. JavaScript Tags Content Assist

3.1.2.4. RichFaces components

JBDS indeed provides code completion for RichFaces framework components. All you have to do

is to install RichFaces libraries into your project. See here how to install it.

http://www.jboss.org/jbossrichfaces
http://labs.jboss.com/file-access/default/members/jbossrichfaces/freezone/docs/devguide/en/html/GettingStarted.html
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Figure 3.24. Content Assist for RichFaces Components

• To insert a RichFaces component on a page expand  JBoss RichFaces  group on the palette

• Click on some component

• Put the needed attributes in the  Insert Tag  dialog and click  Finish  button

Figure 3.25. Insert Tag

The RichFaces tag will be inserted on your page displayed in source and visual modes:
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Figure 3.26. RichFaces Component

3.1.2.5. Adding dynamic code assist to custom components that

were added to JBoss Tools Palette

Here is what you need to do to add project based code assist to a custom component added in

JBoss Developer Studio:

1. Create a new xml file in  <JBDS_home>studio/eclipse/plugins/org.jboss.tools.common.kb_***/

schemas/tld/. For example call it   JeniaFaces.xml . The file should be written

according to  <JBDS_home>/studio/eclipse/plugins/org.jboss.tools.common.kb/kb.jar/org/

jboss/tools/common/kb/kb-schema_1.0.dtd

Follow these steps to set what is available for code assist:

• Adds code assist for JSF pre-defined objects, such as value= "#{param}" :

<AttributeType ...>

       <proposal type="jsfVariables"/>

</AttributeType>

• Add bundle resource (property file) code assist:

<AttributeType ...>

       <proposal type="bundleProperty"/>

</AttributeType>
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• Add managed bean property code assist:

<AttributeType ...>

       <proposal type="beanProperty"/>

</AttributeType>

• Add managed bean property but of a specified type:

<AttributeType ...>

       <proposal type="beanProperty">

          <param name="type" value="java.lang.Boolean"/>

       </proposal>

</AttributeType>

• Add managed bean method with a signature:

<AttributeType ...>

       <proposal type="beanMethodBySignature">

          <param name="paramType" value="javax.faces.context.FacesContext"/>

          <param name="paramType" value="javax.faces.component.UIComponent"/>

          <param name="paramType" value="java.lang.Object"/>

          <param name="returnType" value="void"/>

       </proposal>

</AttributeType>

2. Add information on your xml file in  <JBDS_home>/studio/eclipse/plugins/

org.jboss.common.kb_***/plugin.xml

         <tld

            jsf="true"

            name="Jenia Faces"

            schema-location="schemas/tld/myJSF.xml"

            uri="http://www.jenia.org/jsf/dataTools"/>

                        

3. Restart Eclipse. You should now have code assist for the component.
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3.1.3. Synchronized Source and Visual Editing

JBoss Developer Studio offers the flexibility to edit any files in either source or extra visual modes

at the same time.

The project is yours and so is the source. JBoss Developer Studio provides you many different

graphical editors to speed your application development. At the same time, you always have a

full control over all project source files. Any changes you make in the source view immediately

appear in the graphical view.

The JSF configuration file editor has three views: Diagram, Tree and Source. All views are

synchronized, you can edit the file in any view.

Figure 3.27. Three Views are Synchronized

The same is relevant to all other JBoss Developer Studio editors.

Web XML editor is shown. Web XML editor has a graphical view (Tree) and source (Source).
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Figure 3.28. Two Views are Synchronized

JBoss Developer Studio TLD file editor is shown in Tree view. At any point you can edit the source

by switching to Source view.
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Figure 3.29. Two Views are Synchronized

3.2. Visual Page Editor

JBoss Developer Studio comes with a powerful and customizable Visual Page Editor (VPE). You

can use the Visual Page Editor to develop an application using any technology: JSF, Struts, JSP,

HTML and others.

Current VPE version has three tabs: Visual/Source, Source and Preview. To switch between the

views you can use tabs at the bottom of the VPE or the shortcuts  Ctrl + PageUp/Ctrl + PageDown.
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Figure 3.30. Visual Page Editor

3.2.1. Visual/Source View

Using the Visual/Source view you can edit your pages in the Source and Visual modes

simultaneously having an instant synchronization between them:
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Figure 3.31. Visual/Source View

The view is designed in the form of a split pane with toggle buttons for quickly moving between

Source, Visual or Source/Visual modes as shown on the figure above.

One more way to toggle between the various states of the split pane is using the shortcuts  Shift

+ F6  for maximizing/restoring the Source part and  Shift + Alt + F6  for maximizing/restoring the

Visual part.

Tip:

When editing large documents hiding the Visual part will speed up the editing.

It should be pointed out that, no matter in what mode you are working, you get a full integration

with Properties and Outline views:
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Figure 3.32. Integration with Properties and Outline Views

It's also possible to use the JBoss Tools Palette to insert any tag from the list of tag libraries to

the page you are editing with just a click or drag-and-drop.

Figure 3.33. Inserting Tag From the Palette

3.2.1.1. JSP Syntax Validation

When working in JBoss Tools JSP editor you are constantly provided with feedback and contextual

error checking as you type.
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3.2.2. Pages Styling

Most web pages use the cascading style sheets (CSS) to control the way they look. With Visual

Page Editor you can easily stylise your pages. In this section we are going to introduce you to a

powerful mechanism that VPE provides for a complete control over pages styling.

3.2.2.1. Inline Style Editing

In the Visual part of the VPE there is a graphical toolbar, use it to add inline styling to JSF and

Struts tags on your page. The toolbar can be hidden by clicking on arrow sign in the upper left

corner.

Figure 3.34. Text Formatting

For editing inline styles for DOM elements VPE also provides CSS Dialog. It can be called from

style  line in the Properties view for a currently selected element.



Pages Styling

31

Figure 3.35. Call the CSS Dialog

CSS Dialog has four tabs where css properties for text, background, borders and others can be

specified. A simple preview which is generated at the top of the CSS Dialog allows you to see

the changes before you apply them.

Figure 3.36. CSS Dialog
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3.2.2.2. External Stylesheets

The pages you are working with in VPE can use external stylesheets. VPE allows you to create

new style classes in existing stylesheets and/or edit them as well. For these purposes CSS Style

Class Dialog is provided.

Select the element for which you need to create or edit style class and press button next to

styleClass  field in Properties view.

Figure 3.37. Calling the CSS Style Class Dialog

It'll pick up the CSS Style Class Dialog which looks like on the figure below.
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Figure 3.38. CSS Style Class Dialog

First, you should specify the CSS file where you are going to put your style class. Do this by

pressing button next to the  CSS file  field.
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Figure 3.39. CSS File Selection

To create new CSS class write its name in the  Style class  field and then configure style settings

switching between the tabs:  Text/Font,   Background,   Boxes,   Property Sheet. To add existing

styling to the chosen element expand the list of the existed style classes and point to the necessary

one.
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Figure 3.40. Style Class Selection

Quick Edit  gives a preview of the properties which are set for the existing style class. You can

easily modify them with the help of this wizard.
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Figure 3.41. Quick Edit

Preview at the top of the CSS Style Class Dialog visualizes the result.

The dialog for creating a new CSS class, which is called from  New > Other... > JBoss Tools Web

> CSS Class,  looks the same.
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Figure 3.42. New CSS Class Dialog

3.2.3. Templating

The VPE also makes it possible to create templates for unknown tags.

To call the Template dialog for a tag, right-click on it in Visual mode and select  Template  option.
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Figure 3.43. Calling Template Dialog

Here is what the Template dialog looks like.

Figure 3.44. Template Dialog

Tag for Display  field in the Template dialog requires specifying a type of tag. It can be SPAN,

DIV, TABLE or any other html element. Here it's also possible to mark weather the tag is children
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or not (by checking  Children ), whether it contains an IMG tag (by checking  Icon ) and specify

a value for it.

What comes to the  Style  field, you can fill it out manually or make use of the button next to the

field to bring the CSS Dialog [31] for editing styles.

You can observe all defined templates in the VPE Preferences on the Templates tab which you

can quickly access by pressing Preferences button.

Figure 3.45. Templates Tab of the VPE Preferences Page

Here it's possible to edit or remove any listed in the table template.

3.2.4. Advanced Settings

In the left vertical pane of the Visual part there are three buttons:  Preferences,  Refresh  and

Page Design Options.
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Figure 3.46. Buttons on the Visual Part of VPE

• Preferences  button provides a quick access to Visual Page Editor preferences.
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Figure 3.47. Visual Page Editor Preferences Window

• Clicking on  Refresh  button you refresh the displayed information.

• Page Design Options  button leads to window which helps you to specify necessary references

to resources. Here is what this window looks like.
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Figure 3.48. Page Design Options

This dialog lets you set resources which are usually only resolved in runtime. Let's look at what

functionality it proposes.

The first two sections of the window let you define actual runtime folders. The example below

will help you to clarify how this can be used.

Suppose you have the following project structure:
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WebContent/

  pages/

    img/

       a.gif

    header.jsp

  main.jsp

  

The content of the  header.jsp  is:

My Header

<img src="img/a.gif"/>

and  main.jsp  content is:

<jsp:include page="pages/header.jsp" />

When you open  main.jsp  in Visual Page Editor, it will not be able to resolve the image from the

header, however, it will work fine in runtime. To fix this in design time, click the  Page Design

Options  button and set  Actual Run-Time Relative Folder  to 'projectName > WebContent >

pages' and you will see the image appeared.

In the bottom part of the window you can set a path to included css files, tag libs and substituted

EL expressions.
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Figure 3.49. Bottom Part of the Page Design Options

Let' consider an example. For instance, the definition of your CSS on the page is the next:

<link rel="stylesheet" type="text/css"  

    href="#{facesContext.externalContext.requestContextPath}/style.css"/>

This will work fine in runtime, but the Visual Page Editor doesn't know what requestContextPath

in design time is. In order to see the necessary styles applied in design time your should add

a path to your stylesheet in the CSS File Path section.

The next URI section lets you add URI taglibs so that the editor knows where to find the tag

libraries.

And the last Substituted EL expressions section is provided to specify the values for specific

EL variables. It can be useful for a preview generation.

As an example look at the figure below:
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Figure 3.50. EL Expression

Here bath in Source and Visual modes you see the EL expression #{user.name}. When you

switch to Preview view, you'll also see this expression. Now press  Page Design Options  button

and set the value for the #{user.name} as World.
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Figure 3.51. Setting the Value for the EL Expression

As a result in Visual mode and Preview view the word  World  is displayed.
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Figure 3.52. The EL Expression Value

You can find useful one more functionality provided by VPE. At the bottom of the Visual/Source

view there is a Selection Tag Bar. It allows to see tags tree for a current component selected in

Visual or Source mode.

Figure 3.53. Selection Tag Bar
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If you want to hide the Selection Tag Bar, use the button in the form of a red cross on the lower

right side. To reset it again you should check the proper option in the VPE Preferences.

3.2.5. Page Preview

VPE comes with design-time preview feature which is available for:

• Struts Pages

• JSF Pages

Preview view is read-only, it shows how the page will look like in a browser.

Figure 3.54. Preview View

3.2.6. Setup notes for Linux

Linux users may need to do the following to get the Visual Page Editor to work correctly on their

machines.

The Visual Page Editor requires the library libstdc++.so.5. This library is contained in the compat-

libstdc++-33.i386 package.
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• To install this package on Fedora Core or Red Hat Enterprise Linux run the following command:

yum install compat-libstdc++-33.i386

• On any other rpm based distributions download libstdc++.so.5 and run the following command:

rpm -Uvh compat-libstdc++-33.i386

• On Debian based distributives run the following command:

apt-get install compat-libstdc++-33.i386

In case you have the library installed and you still have issue with starting the visual page editor

then close all browser views/editors and leave one visual page editor open and restart eclipse.

This should force a load of the right XULRunner viewer.

3.3. More Editors

Besides Visual Page Editor JBDS is supplied with a huge range of various editors for different file

types: properties, TLD, web.xml, tiles, and so on.

3.3.1. Graphical Properties Editor

The Properties editor allows you to work in two different modes and also supports unicode

characters.

To create a new properties file, in the Package Explorer view, select  New > Properties File  from

the right-click context menu on the folder where you want to create the file.
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Figure 3.55. Selecting Properties File

You can edit the file using a table-oriented "Properties" viewer:



Graphical TLD Editor

51

Figure 3.56. "Properties" Viewer

You can also use a Source viewer for editing the file:

Figure 3.57. Source Viewer

3.3.2. Graphical TLD Editor

The TLD editor comes with same features you will find in all other JBoss Developer Studio editors:
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• Graphical and source edit modes

• Validation and error checking

3.3.2.1. Tree view

Figure 3.58. Tree View

3.3.2.2. Source view

You can easily switch from Tree to Source by selecting the Source tab at the bottom of the editor.
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Figure 3.59. Source View

You can easily add a new tag:
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Figure 3.60. Adding a New Tag

You can also easily add a new attribute to an existing tag:
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Figure 3.61. Adding a New Attribute

Content assist is available when editing the file using the Source viewer:

Figure 3.62. Content Assist

In the Source viewer, if at any point a tag is incorrect or incomplete, an error will be indicated next

to the line and also in the Problems view below.
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Figure 3.63. Error Reporting

3.3.3. Graphical Web Application File (web.xml) Editor

The Web Application File editor comes with the same features you will find in all other JBoss

Developer Studio editors:

• Graphical and source edit modes

• Validation and error checking
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3.3.3.1. Tree View

Figure 3.64. Tree View

You can add any new elements right in the Tree viewer:
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Figure 3.65. Adding New Elements

3.3.3.2. Source View

Switch to the Source viewer to edit the web.xml file by hand at any time:
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Figure 3.66. Source View

3.3.3.3. Content Assist

Content assist is available in the Source viewer. Simply click  CTRL-Space  anywhere in the file.
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Figure 3.67. Content Assist

3.3.3.4. Errors Checking and Validation

If errors occur anywhere in the file, small red dots will appear next to the lines where the errors

occurred. Also, note that the file is marked by a small x in the Package Explorer view.
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Figure 3.68. Errors Reporting

3.3.4. CSS Editor

The CSS editor comes with the same features you will find in all other JBoss Developer Studio

editors.

• Content assist

• Validation and error checking

With the CSS (Cascading Style Sheet) editor, you can take advantage of code prompting:
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Figure 3.69. CSS Editor

And you can also use the Properties view next to the editor to edit existing stylesheet declaration

properties:
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Figure 3.70. Properties View

3.3.5. JavaScript Editor

The JavaScript editor includes a Preview viewer and a Source viewer. In the Source viewer, you

can use code assist:



Chapter 3. Editors

64

Figure 3.71. JavaScript Editor

You can also use the Source viewer with the Outline view to navigate around the file:
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Figure 3.72. Source Viewer

3.3.6. XSD Editor

JBoss Developer Studio comes with an XSD Editor for XML Schema files. This editor comes from

the Web Tools Project (WTP) (see WTP Getting Started).

To create a new XSD file, right-click a folder in the Package Explorer view, select  New > Other...

from the context menu and then select  XML > XML Schema  in the dialog box.

http://www.eclipse.org/webtools/testtutorials/gettingstarted/GettingStarted.html


Chapter 3. Editors

66

Figure 3.73. Creating New XSD file

The XSD Editor includes two viewers for working on the file, a Design viewer and a Source viewer:
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Figure 3.74. Source Viewer

In the Design viewer, you can drill down on an element by double-clicking on it:
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Figure 3.75. Design Viewer

Various edit options are available when you right-click an element in the diagram:
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Figure 3.76. Edit Options

You can also use the Properties view to edit a selected element:
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Figure 3.77. Properties View

You can also use a Source viewer for the file. In this viewer, along with direct editing of the source

code, you can also edit the file by using the Properties view on the right:
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Figure 3.78. Source Viewer

3.3.7. Support for XML Schema

JBoss Developer Studio fully supports XML files based on schemas as well as DTDs:
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Figure 3.79. XML File
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JBoss Tools Palette
This chapter will introduce you to the functionality provided by JBoss Tools Palette. The Palette

allows you to quickly and easily create your JSP or JSF pages. Now you can do it more faster

without additional knowledge.

The JBoss Tools Palette allows you to:

• Insert tags into a JSP or JSF page with one click

• Add custom and 3rd party tags

The JBoss Tools Palette contains a developer's project tag libraries and provides possibility to

add any tag libraries to it. Also you can choose a necessary one from the list of already existed

tag libraries:

• HTML

• JBoss

• JSF

• JSTL

• MyFaces

• Oracle ADF Faces

• Struts

• XHTML

Figure 4.1. Default View of The JBoss Tools Palette

By default the Palette is represented in Web Development Perspective with four groups. If you

can't see it, select  Window > Show View Other... > JBoss Tools Web > JBoss Tools Palette  from

the menu bar.
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4.1. Palette Options

To facilitate your work, you can configure the Palette in your own way, by selecting the

corresponding icon on the Palette toolbar.

There is a possibility to configure the JBoss Tools Palette:

• to edit the palette content by adding, removing or changing the palette elements

• to show/hide groups, subgroups

• to import groups, subgroups

Figure 4.2. Palette Buttons

4.1.1. Palette Editor

JBoss Tools Palette contains existing libraries of tags, thus the Palette editor is intended to work

with them or create your new one, as well.

To open the editor, click on the  Palette Editor  icon:

Figure 4.3. Palette Editor Icon
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The window has two parts. There is a reflected grouped list of components on the left side of the

palette editor. Each group is divided into multiple groups, every of which is a tag library. The right

side of the palette editor is an editing window where it's possible to change values of group or tag

library attributes that you've chosen on the left part of the window.

It can also be done by right click and using  Edit…  option.

For example, JSF group consists of Core, Facelets, HTML tag libraries and the attributes as name,

description and hidden which are available for editing:

Figure 4.4. Tag Libraries of the JSF Group

The Palette Editor provides the following possibilities when working with existing tags or icons:

• to work with a set of icons

Icons  is the root folder for the icon sets. The first step is creating the icon set. Right click on

the  Icons  folder and select  Create > Create Set...

Set the value of the name in the  Add Icons  window and click  Finish  button. A new element

will appear in the list.
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Figure 4.5. Creating a Set of Icons

Also you can delete the set. Right click on the set of icons that you wish to remove and chose

the  Delete Set  option from the pop-up menu or click the  Delete  keyboard button.

• to edit icons in the chosen set

When the set of icons is created, new icons can be imported to it. Choose the required set

and select the option  Create > Import Icon...   from the pop-up menu that appears after you

right-click on a folder.
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Figure 4.6. Creating Icons

Set the name of the icon and the path and click  Finish  button.

• to work with a group of tag libraries

The first step in work with the editor is creating a group of libraries. It's very easy to do, right

mouse button click on the  Palette  folder and select  Create > Create Group…

Set a name of a group in the Create Group window and click  OK  button. A new element will

appear at the end of the list.
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Figure 4.7. Creating a Group of Tag Libraries

You are allowed to edit or delete a group, as well. If you'd like to change attributes of a group,

use the right editing window of the palette editor or the  Edit...  option, like it was mentioned

before. In order to remove the group, right click on the group that you wish to remove and chose

the  Delete  option or click the  Delete  keyboard button.

Important:

The removal option is enabled only for custom folders.

• to work with a tag library

The group maintains a list of tag libraries. If you'd like to create your own library, click right

mouse button on the group and choose  Create Group…  option.
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Figure 4.8. Creating a tag library

After setting the attribute name and the path of the icon, click  Ok  button.

Note:

If you do not choose an icon the default one will be assigned.

You are allowed to edit or delete the tag library, as well. If you'd like to change attributes of the

library or choose another icon, use the right editing window of the palette editor or the  Edit...

option. In order to remove the tag library, right click on the library that you wish to remove and

chose the  Delete  option or click the  Delete  keyboard button.

Important:

The removal option is enabled only for custom tag libraries.

• to work with a tag element

When the library folder is created, new tags can be added to it. Choose the required library

and select the option  Create > Create Macro…  from the pop-up menu that appears after you

right-click on a folder.
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Figure 4.9. Creating a tag element

In the Add Palette Macro window, you can configure the tag element. Attribute  Name  is

mandatory to fill and it will be the name of the tag element. Other settings are optional. You can

choose the icon and set the  Start Text  and the  End Text  for your tag element. If your tag

text is too long, use the  Change...  button to see it all. For  start text  and  end text  there is a

possibility to control the cursor position by using "|" symbol.
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Figure 4.10. Parameters of the Palette element

After all the attributes are set, click  Finish  button.

Note:

If you do not choose an icon the default one will be assigned.

You are also allowed to edit or delete the tag. If you'd like to change the attributes of the tag or

choose another icon for it, use the right editing window of the palette editor or the  Edit...  option

from the pop-up menu. In order to remove the tag, right click on the tag that you wish to remove

and chose the  Delete  option or click the  Delete  keyboard button.

Important:

The removal option is enabled only for custom tags. JBoss Palette tags can not

be removed but can be modified.

4.1.2. Show/Hide

Show/Hide  is a very useful feature that allows you to control the number of tag groups that are

shown on the palette.

• Click  Show/Hide  button, at the top right side of the JBoss Tools Palette.
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Figure 4.11. Show/Hide Button

• In the dialog Show/Hide Drawers check the groups the libraries of which you want to be shown

on the palette:

Figure 4.12. Show/Hide Drawers

If libraries are not displayed in the palette, check whether they are selected. Click the plus sign to

expand the libraries of the group and make sure that a tick is put next to the wanted libraries.

• Click OK. The new groups will now be shown on the palette:
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Figure 4.13. New Added Groups

The names of the elements are compound. The first part is the group name and the second is

the library name.

4.1.3. Import

The Import button lets you add a custom or 3rd party tag library to JBoss Tools Palette. Find out

more information on how to add particular tags see the Adding Custom JSF Tags section.

4.2. Using the Palette

4.2.1. Inserting Tags into a JSP File

A new tag can be added into any text file including jsp, htm, html and xhtml.

Let's do it. Open your JSP file and place the cursor in a place where you'd like to add a tag and

then click that tag in the palette. In the Insert Tag window, that appears, you can set the value of

general  and  advanced  attributes of the tag that you chose.
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Figure 4.14. Inserting Tag

In the example below, the  commandButton  tag has been inserted.
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Figure 4.15. Inserting Tag

Tip:

if you place the cursor over any tag, a balloon hint is shown with all the  "tag"

attributes.

The cursor position after adding a tag into a file is specified by "|" symbol in the tag template on

the right in the Palette Editor window.
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Figure 4.16. Palette Editor

Above you can see where the cursor position for  HTML > Form > input  is set. Thus, after adding

this tag into your file the cursor will be in the attribute "type". Then, you can straight use the

combination of buttons Ctrl + Space to inquire about a prompting.

Figure 4.17. Cursor position

4.2.2. Adding Custom JSF Tags to the JBoss Tools Palette

There are two ways to add any custom or 3rd party tag library to the JBoss Tools Palette:

• Drag-and-drop from the Web Projects view

• The Import button on the JBoss Tools Palette
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Before you can add your custom component library, you need to make sure it is included in your

project. Either place the  ".tld"  file or the  ".jar"  that includes your tag library under the lib folder

in your project.

4.2.2.1. Drag-and-Drop

Switch to the Web Projects view and expand the Tag Libraries folder. If the view is not active,

select  Window > Show View > Web Projects  from the menu bar.

Figure 4.18. Web Projects View

Also make sure that the JBoss Tools Palette is open. Select the tag library that you want to add

and simply drag-and-drop it on to the JBoss Tools Palette.

You will see the following dialog window. As you can see JBoss Developer Studio takes care of

all the details. Chosen  TLD file ,  name  and  prefix  of the library and  Library URL  are detected,

thus just need to set the  Group  name to which you wish to place this tag library. You can either

add this tag library to an existing Group or just create a new one.
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Figure 4.19. Import Tags From TLD File Form

Once you are finished, you will see the new tag library added to the JBoss Tools Palette.
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Figure 4.20. JBoss Tools Palette with New Tag Library

4.2.2.2. Import Button

The same you can do with  Import  button. You can see this button at the top right side of the

JBoss Tools Palette.
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Figure 4.21. Import Button

By clicking on the  Import button  you will see the Import Tag window a similar like in the  Drag-

and-Drop method. Set the name and prefix of the library and Library URL. Also you need to set the

Group name to which you'd like to add your tag library. And like in the previous method you can

add it to an existing Group or create a new one. On this Import Tag form you can use  Browse...

button to locate the tag library that you want to add:
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Figure 4.22. Select TLD File

4.3. RichFaces Support

JBoss Developer Studio comes with a tight integration with RichFaces component framework.

RichFaces and Ajax4jsf tag libraries in JBoss Tools Palette always exist.

http://labs.jboss.com/jbossrichfaces/
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Figure 4.23. RichFaces Components

To start using RichFaces components as well as Ajax4jsf ones in JBDS you should first put

richfaces-*.jar  files into the  /lib  folder of your project.

Note:

Currant version of JBoss Developer Studio (i. e. 1.1.0GA) includes RichFaces

3.2.2. The JBoss Tools 3.0.0.beta1 comes with RichFaces 3.1.3 and partly support

3.2 version of the component framework. If you need to use the latest version of the

component framework you should import it into the Palette like any other custom

tag library.

4.3.1. Relevant Resources Links

It may be helpful for you to look through the movie which covers a creation of a jsf application with

simple content using the RichFaces components.

http://www.jboss.org/jbossrichfaces/downloads/
http://www.jboss.org/jbossrichfaces/downloads/
http://www.jboss.org/jbossrichfaces/downloads/
http://docs.jboss.org/tools/movies/demos/rich_faces_demo/rich_faces_demo.htm
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Web Projects View
Web Projects is a special view that comes with JBoss Developer Studio.

If the Web Projects view's tab is not visible next to the Package Explorer tab, select Window >

Show View > Other > JBoss Tools Web > Web Projects from the menu bar.

With the Web Projects view, you can:

• Visualize the project better because the project artifacts for JSF and Struts projects are

organized and displayed by function.

• Select these kinds of items to drag and drop into JSP pages:

• JSF managed bean attributes

• JSF navigation rules outcomes

• Property file values

• Tag library files

• Tags from tag libraries

• JSP page links

• Use context menus to develop the application (all create and edit functions are available)

• Use icon shortcuts to create and import JSF and Struts projects

• Expand and inspect tag library files

• Select custom and third-party tag libraries to drag and drop onto the JBoss Tools Palette

5.1. Project Organization

The Web Projects view organizes your project in a different way. The physical structure of course

stays the same. The new organization combines common project artifacts together which makes

it simpler to locate what you are looking for and develop.

The screen shot below shows a JSF project and a Struts project in Web Projects view.
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Figure 5.1. Web Projects View

5.2. Drag and Drop

Web Projects View has a drag and drop option that can be used for property, managed bean

attributes, navigation rules, tag library file declaration and JSP Pages.

5.2.1. For a Property

Expand the Resources Bundles folder that holds all the Property files in your project. Select the

file from which you want to add the property and then select the property.

We will be dragging and dropping a property file value inside the outputText tag for the "value"

attribute.
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Figure 5.2. OutputText Tag

Select the property:

Figure 5.3. Selecting Property

Drag the property and drop it between the quotes for the value attribute in the JSP file. Notice

that JBoss Developer Studio added the correctly formatted expression for referring to the property

value #{Message.header} automatically.

Figure 5.4. Inserted Property
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You can actually place the tag anywhere in the page, not just inside an existing tag. In this case,

JBoss Developer Studio will place the complete tag <h:outputText value="#{Message.header}"/>

in the page.

5.2.2. For Managed Bean Attributes

Select a "managed bean" attribute and then drag and drop it onto the JSP page. We are going to

place it inside the "value" attribute of the inputText tag.

Figure 5.5. Selecting Managed Bean Attribute

Once again, JBoss Developer Studio adds the correct expression, #{user.name}.

Figure 5.6. Added Expression

5.2.3. Navigation Rules

Select the navigation rule under Configuration > faces-config.xml > Navigation Rules:
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Figure 5.7. Selecting Navigation Rule

Drag and drop it inside the commandButton tag:

Figure 5.8. Naviagation Rule in CommandButton Tag

You could do the same if the navigation rule was defined inside an action method:
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Figure 5.9. Navigation Rule in Action Method

Here is how it would look after drag and drop:

Figure 5.10. Inserted Navigation Rule

5.2.4. For a Tag Library File Declaration

Select a TLD file:
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Figure 5.11. Selecting TLD File

Then drag and drop it onto the JSP page to add a declaration at the top of the page:

Figure 5.12. Inserted TLD File

5.2.5. For JSP Pages

You can also drag and drop a JSP page path to a JSP page to create a forward as shown:
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Figure 5.13. Creating JSP Forward

5.3. Developing the Application

It is also possible to develop your application right from the Web Projects view. Simply right-click

any node in the tree and select an appropriate action from the context menu. For instance, this

screen capture shows creating a new navigation rule.



Expanding Tag Library Files

101

Figure 5.14. Creating New Navigation Rule

5.4. Expanding Tag Library Files

You can easily expand any TLD file in the project. Browse to the Tag Libraries folder. Right-click

a TLD file and select Expand. The TLD file will now be expanded.

You can then select any tag and drag it onto a JSP page.
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Figure 5.15. Expanding Tag Library File

5.5. Drag and Drop Tag Libraries on to JBoss Tools

Palette

Read Adding Tag Libraries to learn about this.

5.6. Create and Import JSF and Struts Projects

You can also create and import JSF and Struts project from Web Projects view by selecting the

buttons below.

From left to right:

1. Create New JSF Project

2. Import JSF Project

3. Create New Struts Project

4. Import Struts Project
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Figure 5.16. Web Projects View Buttons
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JBoss Tools Preferences
Configuring the various JBoss Developer Studio features is done via the Preferences screen by

selecting  Window > Preferences > JBoss Tools  from the menu bar.

Figure 6.1. Preferences are included in this dialog.

From this screen, you can select these more specific sets of JBoss Tools preferences:

• Packaging Archives
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• Editors

• Visual Page Editor

• El Variables

• JSF

• JSF Page

• JSF Propject

• JSF Flow Diagram

• Seam

• Seam Validator

• Struts

• Struts Automatic

• Plug-in Insets

• Resource Insets

• Struts Customization

• Struts Project

• Struts Support

• Struts Pages

• Struts Flow Diagram

• Tiles Diagram

• Verification

6.1. Packaging Archives

Fallow to  JBoss Tools > Packaging Archives  to open the page for changing Packaging Archives

preferences.

Here you can determine settings for Project Packages view and core preferences.
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Figure 6.2. Packaging Archives

The next table lists all available preferences for Packaging Archives and their description.

Table 6.1. Packaging Archives Preferences

Option Description Default

Enable incremental

builder

Uncheck this option if you don't want to enable

incremental builder for your resources

On

Show full output path

next to packages

This option allows you to show or hide an

output path next to packages .

On

On
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Option Description Default

Show the full root

directory of filesets

If on, the full root directory is displayed next to

filesets. Otherwise, it's hidden .

Show project at the

root

This option allows you to choose whether to

display a project name at the root of the

packages or not. When checked, 'Show all

projects that contain packages' is enabled .

On

Show all projects that

contain packages

Selecting this setting enables the Projects

Archiving view to show or hide all projects that

contain packages. The option is available when

the previous one is checked.

Off

6.2. Editors

To adjust settings common for all editors supplied with JBoss Developer Studio you should select

JBoss Tools > Web > Editors.
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Figure 6.3. Editors

On the Editors page the following preferences are available:

Table 6.2. Editors Preferences

Option Description Default

Always use JBoss

Tools editors with

Open option

On

On
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Option Description Default

Show warning when

project has no JBoss

Tools capabilities

Check this option to be sure that any JBoss

Tools editor fully available for a particular type

of file. If no, you'll be warned about this.

Use Source tab as a

default for multi-tab

editors

If on, an editor will open the files in the Source

view by default

Off

6.3. Visual Page Editor

JBoss Tools > Web > Editors > Visual Page Editor  screen allows you to control some aspects

of the behavior of the Visual Page Editor (VPE) for JSF/HTML files.
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Figure 6.4. Visual Page Editor

The next table lists the possible settings that you can adjust on the General tab of the VPE

Preferences page.

Table 6.3. VPE Preferences

Option Description Default

On
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Option Description Default

Show Border for

Unknown Tags

The option allows to place the border around

unknown tags or undo this

Show Non-Visual

Tags

Check this box, if you want the editor shows

non-visual elements on the page you're editing

Off

Show Resource

Bundles Usage as EL

Expressions

If the option is checked, the editor will show EL

expressions instead of the resource values

Off

Always Prompts for

Tag Attributes During

Tag Insert

Having this option off, the dialog with possible

attributes for inserting tag won't appear if all its

attributes are optional

On

Show Selection Tag

Bar

This option allows to show or hide the Selection

Bar

On

Always Hide

Selection Bar Without

Prompt

Check this box if you don't want the

confirmation window appears when closing the

Selection Bar

Off

Default Editor Tab The option provides with a possibility to choose

one of the following views - Visual/Source,

Source or Preview, as default when opening

the editor

Visual/Source

Size of Visual Editor

Pane 0 – 100%

With the help of this scroll bar you can adjust

the percentage rating between the Source and

Visual modes of the Visual/Source view

50%

On the Templates tab you can edit or remove VPE templates.
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Figure 6.5. Visual Page Editor Templates

Select a template for editing from the available list and press  Edit  button. It will pick up the

Template dialog [38] where you can adjust new settings.

6.4. El Variables

To specify necessary EL variables globally, i. e. for all projects and resources in your workspace,

you should go to  JBoss Tools > Web > El Variables.
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Figure 6.6. El Variables

Click  Add...  to set value for a new EL variable. In the appeared wizard you should specify the

global values and press  Finish .
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Figure 6.7. Adding a Global El Variable

Tip:

If you specify an equal variable in VPE EL dialog [43] and in Preference EL dialog,

variable from preference dialog will have priority.

6.5. JSF

Select  JBoss Tools > Web > JSF  to get to the JSF Project specific preferences.
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Figure 6.8. JSF

6.6. JSF Pages

By selecting  JBoss Tools > Web > JSF > JSF Pages  you can add jsf pages or remove existing

ones.
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Figure 6.9. JSF Page

6.7. JSF Project

Select  JBoss Tools > Web > JSF > Project  to see JSF Project preferences page.

On the  New Project  tab you can set default values for New JSF Project wizard:

• Version  for setting the default JSF Environment

../../jsf_tools_ref_guide/html_single/index.html#new_jsf_project
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• Project Template  so as New JSF Project wizard shows this template as default for the chosen

JSF Environment

• Project Root  for specifying default location for a new JSF project

If you check  Use Default Path  here, this box will be also checked in the New JSF Project wizard.

• Servlet Version  for setting the default Servlet version of a new JSF project

Here it's also possible to define whether to register Web Context in  server.xml  while organizing

a new project or not. Check the proper box in order to do that.
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Figure 6.10. New JSF Propject Preferences

On the  Import Project  tab in the JSF Project screen you can determine the default Servlet version

for the Import JSF Project wizard and also whether to register Web Context in  server.xml  or not.

../../Exadel-migration/html_single/index.html#import_jsf_screen
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Figure 6.11. Import JSF Propject Preferences

6.8. JSF Flow Diagram

Selecting  JBoss Tools > Web > Editors > JSF Flow Diagram  allows you to specify some aspects

of the Diagram mode of the JSF configuration file editor.
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Figure 6.12. JSF Flow Diagram

The first two items control the background grid for the diagram. The next two items allow you to

control the appearance of the labels for views (pages) and the transitions between views. For

these two items, clicking the  Change...  button allows you to assign a font with a dialog box.

The first check box determines whether a view in the diagram that doesn't have a transition

connecting it to another view yet should be written to the source code as a partial navigation rule.

The next check box determines whether the diagram cursor reverts immediately to the standard

selection mode after it's used in the transition-drawing mode to draw a transition. Finally, the

last two check boxes concern shortcuts. A shortcut is a transition that is there but isn't actually

displayed in the diagram as going all the way to the target view it's connected to, in order to make

the diagram clearer. With the check boxes, you can decide whether to display a small shortcut

icon as part of the shortcut and also whether to display the target view as a label or not.
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Figure 6.13. Add View

Selecting the Add Page tab in the JSF Flow Diagram screen allows you to determine the default

template and file extension for views (pages) you add directly into the diagram using a context

menu or the view-adding mode of the diagram cursor.

6.9. Label Decorations

The Label Decorations page is opened from  JBoss Tools > Web > Label Decorations.
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Figure 6.14. Label Decorations

On this page you can determine the format for a text output near the decoration label for different

Web resources. To change the value for selected element, click  Add Variable...  button next to

Format  field. Appeared wizard will prompt you to select one from the available list.
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Figure 6.15. Label Decoration for Validator

6.10. Seam

The following preferences can be changed on the  JBoss Tools > Web > Seam  page.

On  Seam  screen you can add and remove Seam runtimes.

Here is what Seam preference page looks like:
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Figure 6.16. Seam

6.11. Seam Validator

The following preferences can be changed on the  JBoss Tools > Web > Seam > Validator  page.

In  Validator  panel you configure seam problems that will be processed by validator.
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Figure 6.17. Seam Validator

6.12. Struts

By selecting  JBoss Tools > Web > Struts  you can configure Struts projects specific preferences.
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Figure 6.18. Struts

6.13. Struts Automation

On  Automation  panel you can modify default text for the Tilel Struts plug-in element, the Validator

Struts plug-in element, and error message resource files.
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Figure 6.19. Struts Automatic

6.14. Plug-in Insets

By selecting  Web > Struts > Automation > Plug-in Insets  on tab Tiles you can define a default

text for tiles plugin.
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Figure 6.20. Plug-in Insets

The same is done but for validator plugin on the tab Validators.
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Figure 6.21. Plug-in Insets of Validators

6.15. Resource Insets

To see Resource Insets preference page select  JBoss Tools > Web > Strats > Automation >

Resource Insets .

On  Resource Insets  panel you determine default error messages for error resource files.
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Figure 6.22. Resource Insets

6.16. Struts Customization

The following preferences can be changed on the  JBoss Tools > Web > Struts > Customization

page.

In the Customization  screen you configure Link Recognizer for Struts tags.
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Figure 6.23. Struts Customization

6.17. Struts Project

You can change the following preferences on the  JBoss Tools > Web > Struts > Project

preference page:

On  Project  panel you define a template for a new Struts created project: servlet version, page

template and so on.
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Figure 6.24. Struts Project

Selecting the Import Project tab in the Struts Project screen allows you to determine the default

servlet version and whether to register Web Context in server.xml.
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Figure 6.25. Import Struts Pages

6.18. Struts Support

The following preferences can be changed on the  JBoss Tools > Web > Struts > Project > Struts

Support  page.

Select  Struts Support  screen if you want to configure Struts versions support settings.
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Figure 6.26. Struts Support

6.19. Struts Pages

You can change the following preferences on the JBoss Tools > Web > Struts > Struts Pages

preference page.

On  Struts Pages  panel you can add or remove Struts pages.
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Figure 6.27. Struts Pages

6.20. Struts Flow Diagram

Similarly to the JSF Flow Diagram screen, selecting  JBoss Tools > Web > Editor > Struts Flow

Diagram  page allows you to specify aspects of the Diagram mode of the Struts configuration

file editor. The Struts Flow Diagram screen adds an option to hide the Diagram tab and labeling

settings for additional artifacts.
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Figure 6.28. Struts Flow Diagram

Selecting the Add Page tab in the Struts Flow Diagram screen allows you to determine the default

template and file extension for views (pages) you add directly into the diagram using a context

menu or the view-adding mode of the diagram cursor.
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Figure 6.29. Adding Page

6.21. Tiles Diagram

JBoss Tools > Web > Editors > Title Diagram  screen allows you control some settings for the

placement of Tiles definitions in the Diagram mode of the JBoss Tools Tiles editor.
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Figure 6.30. Title Diagram

6.22. Verification

The following preferences can be changed on the  JBoss Tools > Web > Verification  page.

On Rules Configuration tab of  Verifcation  panel you can determine JSF and Struts rules.
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Figure 6.31. Verification

On Options tab you can define a limit for the reported errors number.
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Figure 6.32. Options of Verification

In summary, this document should guide you to those parts of JBoss Tools which you specifically

need to develop Web Applications. It coves different aspects of visual components such as editors,

views, etc. for browsing, representing and editing web resources you are working with.

If there's anything we didn't cover or you can't figure out, please feel free to visit our JBoss

Developer Studio Forum to ask questions. There we are also looking for your suggestions and

comments.

http://www.jboss.com/index.html?module=bb&op=viewforum&f=258
http://www.jboss.com/index.html?module=bb&op=viewforum&f=258
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