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Introduction

1.1. What is BIRT?

BIRT plugin for JBoss Developer Studio is an Eclipse-based open source reporting system for web

applications based on Java and J2EE. BIRT consists of two main components: a report designer

based on Eclipse, and a runtime component that can be added to your app server. BIRT also

offers a charting engine that lets you add charts to your own Web application.

With the help of BIRT you can generate a great number of reports to be used in your application:

• Lists

• Charts

• Crosstabs, or cross-tabulation, or matrix

• Letters and Documents

• Compound Reports

In this guide we provide you with the information on BIRT Designer which allows you to create a

report much faster and with far fewer errors so sparing your time.

 

You can find detailed information on the BIRT report types and anatomy here: JBoss BIRT [http:/

/www.eclipse.org/birt/phoenix/intro/]

All JBoss Developer Studio/JBoss Tools documentation you can find here [http://docs.jboss.org/

tools/].

The latest documentation builds are available here [http://download.jboss.org/jbosstools/nightly-

docs/].

http://www.eclipse.org/birt/phoenix/intro/
http://www.eclipse.org/birt/phoenix/intro/
http://www.eclipse.org/birt/phoenix/intro/
http://docs.jboss.org/tools/
http://docs.jboss.org/tools/
http://docs.jboss.org/tools/
http://download.jboss.org/jbosstools/nightly-docs/
http://download.jboss.org/jbosstools/nightly-docs/
http://download.jboss.org/jbosstools/nightly-docs/
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BIRT Support
In this section we will focus more on all concepts that JBoss Tools integrates for working with BIRT.

2.1. BIRT Plugin Installation

This chapter will provide you with detailed information on how to install BIRT plugin into JBoss

Developer Studio.

Since BIRT plugin is one of the modules of JBoss Tools project it has a dependence on other

modules and will require their pre-installation.

These are the prerequisites to create a web project including Seam and BIRT capabilities:

• Eclipse Version 3.4 SDK

• DTP Version 1.6 Release

• EMF Version 2.4 Release EMF+XSD

• GEF Version 3.4 Release runtime

• WTP Version 3.0 Release

• BIRT Report Designer SDK 2.3.0 Release [http://repository.jboss.org/eclipse/birt/2.3.0/birt-

report-framework-2_3_0.zip] or BIRT Report Designer 2.3.0 Release

• JBoss Application Server 4.2.2 GA

• JBoss Seam 2.0.1 GA

• BIRT Web Tools Integration [http://repository.jboss.org/eclipse/birt/2.3.0/birt-wtp-integration-

sdk-2_3_0.zip]

• JBoss Tools nightly build

2.2. JBoss BIRT Integration

To understand Hibernate configuration, integration with Seam, and deployment see JBoss BIRT

Integration 1.0.0.alpha1 - New and Noteworthy [http://docs.jboss.org/tools/whatsnew/birt/birt-

news-1.0.0.Alpha1.html].

2.3. Creating a BIRT Report

In this chapter we suggest a step-by-step walk-through of creating your own BIRT report.

http://repository.jboss.org/eclipse/birt/2.3.0/birt-report-framework-2_3_0.zip
http://repository.jboss.org/eclipse/birt/2.3.0/birt-report-framework-2_3_0.zip
http://repository.jboss.org/eclipse/birt/2.3.0/birt-report-framework-2_3_0.zip
http://repository.jboss.org/eclipse/birt/2.3.0/birt-wtp-integration-sdk-2_3_0.zip
http://repository.jboss.org/eclipse/birt/2.3.0/birt-wtp-integration-sdk-2_3_0.zip
http://repository.jboss.org/eclipse/birt/2.3.0/birt-wtp-integration-sdk-2_3_0.zip
http://docs.jboss.org/tools/whatsnew/birt/birt-news-1.0.0.Alpha1.html
http://docs.jboss.org/tools/whatsnew/birt/birt-news-1.0.0.Alpha1.html
http://docs.jboss.org/tools/whatsnew/birt/birt-news-1.0.0.Alpha1.html
http://docs.jboss.org/tools/whatsnew/birt/birt-news-1.0.0.Alpha1.html
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2.3.1. Create a Report Project

First create a Report project. Select File > New > Project...  in the main menu bar or context menu.

The new project dialog appears. Choose Business Intelligence and Reporting Tools > Report

Project:

Figure 2.1. New Report Project Creation

Click on the Next button. Specify a name for the project and change location if necessary:



Create a Report Project
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Figure 2.2. Specify a Name for the Report Project

Click on the Finish button. Click Ok to switch to the Report Design perspective. Your Report Project

is now created:
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Figure 2.3. New Report Project Created

2.3.2. Create a Report

Now you can create a Report. Go to File > New > Report...:



Create a Report
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Figure 2.4. Create a New Report

The new report dialog appears. Select the created project as a parent folder in the tree view:
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Figure 2.5. Select a Parent Folder

Click on the Next button. Then select the type of the template to use for your report. Each template

is shown in the Preview window and is described below. Tick off the "Show Report Creation Cheat

Sheet" checkbox if you don't need the Cheat Sheets view to be displayed. The Cheat Sheets view

can walk you though the process of creating a report based on the template you selected.



Create a Report
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Figure 2.6. Choose a Report Template

Click on the Finish button to open the newly created report in the workspace:
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Figure 2.7. Report Opened in the Workspace

2.3.3. Build a Data Source

Data source is used to connect to the database. In order to create a data source for your report

follow these steps:

Open the Data Explorer View. Select Data Sources, right-click on it and choose New Data Source:



Build a Data Source
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Figure 2.8. Create a Data Source

The New Data Source dialog appears. Choose the "Create from a data source type in the following

list" radiobutton and then "Classic Models Inc. Sample Database". Click on the Next button:
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Figure 2.9. New Data Source

The newly created data source details wll be displayed: Driver Class, Database URL and Database

User:



Build a Data Set
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Figure 2.10. New Data Source Details

Click on the Finish button to add the data source to the data source for your report.

If you need to edit the data source right-click on it and select the corresponding option.

2.3.4. Build a Data Set

Data Set is a query to get and represent necessary column data from the data source specified.

Select Data Sets in the tree view, right-click on it and select New Data Set:
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Figure 2.11. Create a Data Set

The New Data Set dialog will appear. Enter a name for the Data Set Name field and ensure that

the Data Source field shows the data source already created and that the Data Set Type field is

set to "SQL Select Query". Then click on the Next button:



Build a Data Set
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Figure 2.12. New Data Set Details

Enter the following details into the query:

SELECT *

FROM CUSTOMERS

WHERE COUNTRY = 'USA'
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Figure 2.13. Query Details

Click on the Finish button. The Edit Data Set window opens where you can change Data Source,

Settings, Parameters and other details for the Data Set created. If switched to the Query page

you can check the schemas within this database, you can expand them to see the list of tables

with their columns:



Build a Data Set
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Figure 2.14. Edit the Data Set

Switch to the Preview page to test your query and verify whether the list of customers appears:
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Figure 2.15. Test the Query

Click on the Ok button.

2.3.5. Create Report Layout

After the Data source and Data set are specified you can continue with the report layout. Please

see the Birt_Designer chapter to learn more about BIRT Report Designer.
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BIRT Report Designer
BIRT Designer is an intuitive and quite easy Eclipse-based set of plugins to make reports. In this

chapter we will describe its interface and its features to you.

3.1. BIRT User Interface

The central part of the user interface is the Layout Editor. It displays the whole process of building

a report and contains the following tabs:

• Layout - this is an area where you can edit your report design;

• Preview - runs your report created and shows the output;

• Script - on this page you can add JavaScript to your report to customize its behavior;

• XML Source - this is an area where you can view and modify the XML source of your report;

• Master Page - use it to format page data.

The next part of user interface is different Views that can be arranged around the Layout Editor

area the way you like:

• Palette - shows the standard report items you can add to your report using drag and drop.

• Outline - shows the structure of your report as a tree view.

• Navigator - shows your projects and reports within the projects.

• Data Explorer - shows your data sources, data sets and report parameters. You also can use

this view to add data set columns to your report layout.

• Property Editor - displays properties for many report items.

• Properties View - shows all properties for a report item as a simple list.

• Library Explorer View - allows the reuse of report objects, such as tables, data sources and

styles. Objects created for reuse are stored in a library file. The Library Explorer will display

Libraries that exist in the Resource folder. Developed libraries can be added to the resource

folder by selecting File#Publish Library in Resource Folder. The resource folder location can

be configured.

3.2. BIRT Report Designer Features

Here are the main BIRT Report Designer features:

• Palette - contains tables, labels, and charts. It is used in conjunction with the Layout View to

design reports.
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• Data Explorer - organizes your data sources and data sets. The Data Sets editor enables

testing your data set to check whether the report receives the correct data. You can also create

cubes using your data sets (when building any dynamic cross tables) and design necessary

report parameters.

• Resource Explorer - BIRT allows the reuse of report objects, such as tables, data sources

and styles. Objects created for reuse are stored in a library file. To browse the contents of

report libraries BIRT supplies the Resource Explorer view. This view lists all libraries within the

resource folder, in addition to other shared content such as images and JavaScript files.

• Property Editor - shows the most commonly used properties. BIRT also integrates with the

standard Eclipse property view to display a detailed listing of all properties for an item.

• Layout View - WYSIWYG editor. You can select any element from the Palette, drag and drop

it to the report and then edit the way you like.

• Script Editor - scripting adds business logic to reports during data access, report generation,

or viewing. The code editor provides standard features for editing scripts: syntax coloring, auto-

complete etc. You also can debug scripts when the report is running.

• Report Preview - Report Preview is used to test your newly created report with some real data.

• Chart Builder - using the Chart Builder you can add any charts to the design of your report.

Just select a chart type, then data and, finally, format the chart.

• Expression Builder  - expressions are simple scripts that return a value. They are used to

assign data values to report elements, build image locations, hyperlinks, parameter default

values etc.

• Cheat Sheets - Cheat sheets are small pices of useful documentation that lead you through a

report creation process. Just select what you need and then follow the instructions.

• Outline - this view provides a compact overview of the entire report structure.

In this guide we made a simple overview of the BIRT plugin: its installation, support, features etc.

that will help you to make your first steps with it.
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