Visual Web Tools Reference Guide

PDF version
1. Visual Web Tools ................................................................................................. 1
   1.1. Key Features of Visual Web Tools ............................................................. 1
   1.2. Other relevant resources on the topic ...................................................... 2
2. Spring Tools ........................................................................................................ 3
   2.1. Spring IDE guide ..................................................................................... 3
      2.1.1. Add Spring Project Nature ................................................................. 3
      2.1.2. Create New Spring Project ............................................................... 3
      2.1.3. Add References To Other Spring Projects ....................................... 3
      2.1.4. Add Spring Beans Config Files ....................................................... 3
      2.1.5. Create Spring Beans Config Sets ..................................................... 3
      2.1.6. Open Spring Explorer ..................................................................... 3
      2.1.7. Validate Spring Beans Config ......................................................... 3
      2.1.8. Open Spring Beans Graph ................................................................ 3
      2.1.9. Search Spring Beans ....................................................................... 3
3. Editors .................................................................................................................. 5
   3.1. Editors Features ....................................................................................... 5
      3.1.1. OpenOn ............................................................................................. 5
      3.1.2. Content Assist .................................................................................. 10
      3.1.3. Synchronized Source and Visual Editing ........................................ 26
   3.2. Visual Page Editor ..................................................................................... 28
      3.2.1. Visual/Source View .......................................................................... 29
      3.2.2. Pages Styling .................................................................................... 34
      3.2.3. Templating ....................................................................................... 41
      3.2.4. Advanced Settings .......................................................................... 44
      3.2.5. Page Preview ..................................................................................... 53
      3.2.6. Setup notes for Linux ....................................................................... 53
   3.3. More Editors ............................................................................................... 54
      3.3.1. Graphical Properties Editor ............................................................... 54
      3.3.2. Graphical TLD Editor ..................................................................... 56
      3.3.3. Graphical Web Application File (web.xml) Editor ......................... 61
      3.3.4. CSS Editor ....................................................................................... 66
      3.3.5. JavaScript Editor ............................................................................. 68
      3.3.6. XSD Editor ....................................................................................... 70
      3.3.7. Support for XML Schema ............................................................... 76
4. JBoss Tools Palette ............................................................................................. 79
   4.1. Palette Options ........................................................................................... 80
      4.1.1. Palette Editor .................................................................................... 81
      4.1.2. Show/Hide ........................................................................................ 89
      4.1.3. Import ............................................................................................... 90
   4.2. Using the Palette ......................................................................................... 90
      4.2.1. Inserting Tags into a JSP File ............................................................ 90
      4.2.2. Adding Custom JSF Tags to the JBoss Tools Palette ...................... 93
   4.3. RichFaces Support ................................................................................... 98
      4.3.1. Relevant Resources Links ............................................................... 99
Chapter 1.

Visual Web Tools

This guide covers the usage of Visual Web Tools in JBoss Developer Studio and JBoss Tools. The difference between these products is that JBoss Tools are just a set of Eclipse plugins where JBoss Developer Studio adds the following functionality:

- an installer
- Eclipse and Web Tools preconfigured
- JBoss EAP with JBoss AS and Seam preconfigured
- 3rd party plugins bundled and configured
- access to RHEL and Red Hat Network
- access to the JBoss/Red Hat supported software

For additional information, please visit the JBoss Developer Studio home page at: http://www.jboss.com/products/devstudio.

In JBoss Tools there is an extensive collection of specialized wizards, editors and views that can be used in various scenarios while developing Web applications. The following chapters walk through these features.

1.1. Key Features of Visual Web Tools

Here is the table of the main features of Visual Web Tools:

Table 1.1. Key Functionality for Visual Web Tools

<table>
<thead>
<tr>
<th>Feature</th>
<th>Benefit</th>
<th>Chapter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual Page Editor</td>
<td>Powerful and customizable visual page editor. Possibility to develop an application using any web technology: jsf, seam, struts, jsp, html and others. Developing using four tabs: visual/source, visual, source and preview. Fast and easy switching between these tabs. Split screen design of visual and source views. Full and instant synchronization between source and visual views. Integration with properties and outline views. Graphical toolbar to add inline styling to any tag.</td>
<td>visual page editor</td>
</tr>
<tr>
<td>JBoss Tools Palette</td>
<td>Organizing various tags by groups, inserting tags into a jsp or xhtml page with one click,</td>
<td>jboss tools palette</td>
</tr>
</tbody>
</table>
### Feature | Benefit | Chapter
--- | --- | ---
| | adding custom or 3rd party tag libraries into the palette, easy controlling the number of tag groups shown on the palette. | |
| Web Projects View | Visualizing and displaying projects by function. Easy selecting of different kinds of items and dropping them into jsp pages. Using context menus to develop the application. Using icon shortcuts to create and import JSF and Struts projects. Expanding and inspecting tag library files. Selecting custom and third-party tag libraries to drag and drop onto the JBoss Tools Palette. | web projects view |
| OpenOn | Easy navigation between views and other parts of your projects. | openOn |
| Content Assist | Code completion proposals while working with html, java, JavaScript, xml, jsp, xhtml, xml, seam project and jsf configuration files. Content assist based on project data (dynamic code assist); with graphical editor. Code completion for values from property files, beans attributes and methods, navigation rule outcomes and jsf variables. | content assist |
| Drag-and-Drop | Possibility of inserting any tag onto the page you are editing by just drag-and-dropping it from the palette to this page. Adding any properties, managed bean attributes, navigation rules, tag library file declarations, jsp files from web projects view by clicking them and dragging to source code. | visual page editor drag-and-drop |

### 1.2. Other relevant resources on the topic

All JBoss Developer Studio/JBoss Tools documentation you can find here.

The latest documentation builds are available here.
Chapter 2.

Spring Tools

JBoss Developer Studio is bundled with Spring IDE for Eclipse. Visit Spring IDE site for the latest versions and documentation.

2.1. **Spring IDE guide**

*Spring IDE* is a graphical user interface for the configuration files used by the *Spring Framework*. It's built as a set of plugins for the Eclipse platform.

2.1.1. **Add Spring Project Nature**

2.1.2. **Create New Spring Project**

2.1.3. **Add References To Other Spring Projects**

2.1.4. **Add Spring Beans Config Files**

2.1.5. **Create Spring Beans Config Sets**

2.1.6. **Open Spring Explorer**

2.1.7. **Validate Spring Beans Config**

2.1.8. **Open Spring Beans Graph**

2.1.9. **Search Spring Beans**
Editors

In the *JSF Tools Reference Guide* and *Struts Tools Reference Guide* you had possibility to read about Graphical Editor for JSF and Struts configuration files, *Graphical Editor for Tiles Files*, *Graphical Editor for Struts Validation Files*. All these editors have *OpenOn* and *Content Assist* features, which are described in more details in this document. In addition you get to know a *Visual Page Editor* for combined visual and source editing of Web pages and many *other editors* for different types of files.

### 3.1. Editors Features

JBoss Developer Studio has powerful editor features that help you easily navigate within your application and make use of content and code assist no matter what project file (jsp, xhtml, xml, css, etc...) you are working on.

#### 3.1.1. OpenOn

*OpenOn* lets you easily link directly from one resource to another in your project without using the Package Explorer view (project tree). With OpenOn, you can simply use *F3* or *Ctrl+Click* on a reference to another file and the file will be opened.

OpenOn is available for the following files:

- **XML files**
- **JSP/XHTML Pages**
- Java files

#### 3.1.1.1. XML Files

Press and hold down the Ctrl key. As you move the mouse cursor over different file references in the file, they display an underline. When you hover the name of the file you want to open, click and the file will open in its own editor. In this example the managed bean NameBean will open.
Figure 3.1. NameBean Managed Bean

This is the result of using OpenOn.

Figure 3.2. NameBean Java Class

You can also use OpenOn with defined attributes.
Figure 3.3. OpenOn With Defined Attributes

You can also open any JSP pages.

Figure 3.4. JSP Page OpenOn
3.1.1.2. JSP Pages

OpenOn is also very useful in JSP pages. It will allow you to quickly jump to the reference instead of having to hunt around in the project structure.

You can easily open the imported property files.

![Figure 3.5. OpenOn With Imported Property Files](image)

Use OpenOn to open a CSS file used with a JSP page:
OpenOn

**Figure 3.6. OpenOn With CSS File**

Open managed beans:

**Figure 3.7. OpenOn With Managed Beans**

For JSP files in a JSF project, you can also easily open the navigation rules by applying OpenOn to the JSF tag for the navigation outcome:
Figure 3.8. OpenOn With JSF Tag

Richfaces tags `<rich:insert>` and `<a4j:include>` has also OpenOn support.

Figure 3.9. OpenOn With Richfaces Tag

Figure 3.10. OpenOn With A4j Tag

3.1.2. Content Assist

Content assist is available when working with

- Seam project files
- JSF project files
- Struts project files
- JSP files
• *RichFaces components*

• *ESB XML files*

Notice, that code completion for EL variables has icons illustrating what they are from. Currently it's performed for resource bundles, JSF and Seam components.

![Figure 3.11. JSF Content Assist](image)

Also, as you can see, the ranking and sorting are available in EL code completions.

**3.1.2.1. JSF Project Files**

When working with JSF project in JBoss Developer Studio, you can use various Content Assist features while developing:
• Content Assist for XML, JSP and JSF configuration files

• Content Assist based on project data

• Content Assist with graphical JSF editor

3.1.2.1.1. Content Assist for XML, JSP and JSF configuration files

At any point when working with any XML, JSP and JSF configuration files Content Assist is available to help you. Simply type Ctrl-Space to see what is available.

Content Assist for JSF configuration file:

![Figure 3.13. Content Assist in JSF Configuration File](image)

Content Assist for JSF JSP file:
Figure 3.14. Content Assist in JSP File

Content Assist for other JSF XML project files (web.xml shown):

Figure 3.15. Content Assist in web.xml File
3.1.2.1.2. Content Assist Based on Project Data

JBoss Developer Studio takes Content Assist to the next level. Studio will constantly scan your project and you will be able to insert code into the JSP page from your project that includes:

- Values from Property files
- "Managed beans" attributes and methods
- Navigation Rule Outcomes
- JSF variables (context, request etc...)

The figure below shows how to insert message from a Properties files. You simply put the cursor inside the "value" attribute and press Ctrl-Space. JBoss Developer Studio will scan your project and show a list of possible values to insert.

![Figure 3.16. Inserting Message](image)

In the following screenshot we are inserting a "Managed bean" attribute value. Again, by simply clicking Ctrl-Space, JBoss Developer Studio will show a list of all possible values that you can insert.
Once you select a Managed bean, it will show you a list of all available attributes for the selected Managed bean (userBean).

**Figure 3.17. Attributes List**

Code Assist based on project data will also prompt you for navigation rules that exist in your JSF configuration file.
3.1.2.1.3. Content Assist within Tree JSF Editor

JBoss Developer Studio also provides Content Assist when working within the Tree JSF configuration editor. Just click *Ctrl-Space*. 
Figure 3.19. Content Assist in Tree JSF Configuration Editor

3.1.2.2. Struts Project Files

Content Assist features are available when you work with Struts projects.

3.1.2.2.1. Content Assist for Struts Configuration File

Content Assist helps you in Struts Configuration file.
Chapter 3. Editors

Figure 3.20. Struts Content Assist

3.1.2.2.2. Content Assist for Struts JSP File

Using Code Assist in Struts JSP file is shown below.

Figure 3.21. Struts JSP Content Assist
3.1.2.3. JSP Pages

3.1.2.3.1. Content Assist for JSF Tags

JBDS provides full code completion for JSF tags:

Figure 3.22. JSF Tags Content Assist

When the tag is selected the required attributes, if there any, are already inserted and the cursor is located to the first attribute. At this point you can ask for attribute proposals.
Figure 3.23. Attributes Content Assist

3.1.2.3.2. Content Assist for JSTL Tags

Figure 3.24. JSTL Tags Content Assist

3.1.2.3.3. Content Assist for HTML Tags

Content assist for HTML tags has the same mechanism as for JSF tags:
Figure 3.25. HTML Tags Content Assist

You can use as well attributes proposals for HTML tags:

Figure 3.26. HTML Tags Content Assist
3.1.2.3.4. Content Assist for JavaScript Tags

JBDS indeed provides code completion for RichFaces framework components. Tip: RichFaces 3.2 is now fully supported in code completion.

All you have to do is to install RichFaces libraries into your project. See here how to install it.
Figure 3.28. Content Assist for RichFaces Components

- To insert a RichFaces component on a page expand JBoss RichFaces group on the palette
- Click on some component
- Put the needed attributes in the Insert Tag dialog and click Finish button

Figure 3.29. Insert Tag

The RichFaces tag will be inserted on your page displayed in source and visual modes:
3.1.2.5. Adding dynamic code assist to custom components that were added to JBoss Tools Palette

Here is what you need to do to add project based code assist to a custom component added in JBoss Developer Studio:

1. Create a new xml file in `<JBDS_home>studio/eclipse/plugins/org.jboss.tools.common.kb_***/schemas/tld/`. For example call it `JeniaFaces.xml`. The file should be written according to `<JBDS_home>/studio/eclipse/plugins/org.jboss.tools.common.kb/kb.jar/org/jboss/tools/common/kb/kb-schema_1.0.dtd`

Follow these steps to set what is available for code assist:

- Adds code assist for JSF pre-defined objects, such as value= "#{param}" :

  ```xml
  <AttributeType ...
      <proposal type="jsfVariables"/>
  </AttributeType>
  ```

- Add bundle resource (property file) code assist:

  ```xml
  <AttributeType ...
      <proposal type="bundleProperty"/>
  </AttributeType>
  ```
• Add managed bean property code assist:

```xml
<AttributeType ...>
  <proposal type="beanProperty"/>
</AttributeType>
```

• Add managed bean property but of a specified type:

```xml
<AttributeType ...>
  <proposal type="beanProperty">
    <param name="type" value="java.lang.Boolean"/>
  </proposal>
</AttributeType>
```

• Add managed bean method with a signature:

```xml
<AttributeType ...>
  <proposal type="beanMethodBySignature">
    <param name="paramType" value="javax.faces.context.FacesContext"/>
    <param name="paramType" value="javax.faces.component.UIComponent"/>
    <param name="paramType" value="java.lang.Object"/>
    <param name="returnType" value="void"/>
  </proposal>
</AttributeType>
```

1. Add information on your xml file in `<JBDS_home>/studio/eclipse/plugins/org.jboss.common.kb_***/plugin.xml`

```xml
<tld
  jsf="true"
  name="Jenia Faces"
  schema-location="schemas/tld/myJSF.xml"
  uri="http://www.jenia.org/jsf/dataTools"/>
```

2. Restart Eclipse. You should now have code assist for the component.
3.1.3. Synchronized Source and Visual Editing

JBoss Developer Studio offers the flexibility to edit any files in either source or extra visual modes at the same time.

The project is yours and so is the source. JBoss Developer Studio provides you many different graphical editors to speed your application development. At the same time, you always have a full control over all project source files. Any changes you make in the source view immediately appear in the graphical view.

The JSF configuration file editor has three views: Diagram, Tree and Source. All views are synchronized, you can edit the file in any view.

![Figure 3.31. Three Views are Synchronized](image)

The same is relevant to all other JBoss Developer Studio editors.

Web XML editor is shown. Web XML editor has a graphical view (Tree) and source (Source).
Figure 3.32. Two Views are Synchronized

JBoss Developer Studio TLD file editor is shown in Tree view. At any point you can edit the source by switching to Source view.
3.2. Visual Page Editor

JBoss Developer Studio comes with a powerful and customizable Visual Page Editor (VPE). You can use the Visual Page Editor to develop an application using any technology: JSF, Struts, JSP, HTML and others.

Current VPE version has three tabs: Visual/Source, Source and Preview. To switch between the views you can use tabs at the bottom of the VPE or the shortcuts Ctrl + PageUp/Ctrl + PageDown.
3.2.1. Visual/Source View

Using the Visual/Source view you can edit your pages in the Source and Visual modes simultaneously having an instant synchronization between them:
Chapter 3. Editors

Figure 3.35. Visual/Source View

The view is designed in the form of a split pane with toggle buttons for quickly moving between Source, Visual or Source/Visual modes as shown on the figure above.

One more way to toggle between the various states of the split pane is using the shortcuts \textasciitilde Shift + F6 \textasciitilde for maximizing/restoring the Source part and \textasciitilde Shift + Alt + F6 \textasciitilde for maximizing/restoring the Visual part.

**Tip:**

When editing large documents hiding the Visual part will speed up the editing.

It should be pointed out that, no matter in what mode you are working, you get a full integration with Properties and Outline views:
Figure 3.36. Integration with Properties and Outline Views

It’s also possible to use the JBoss Tools Palette to insert any tag from the list of tag libraries to the page you are editing with just a click or drag-and-drop.

Figure 3.37. Inserting Tag From the Palette
Visual Page Editor provides the option for displaying non-visual tags in Visual mode of the editor. To enable this option expand the submenu in the top left corner of the Visual part and select *Show Non-visual tags*.

**Figure 3.38. Enabling the Option for Showing Non-visual Tags**

On the figure you can see non-visual elements with gray dashed borders.

**Figure 3.39. Non-visual Tag in the VPE**
To disable this option again expand the same submenu and select *Hide Non-visual tags.*

![Image of VPE interface with login form]

**Figure 3.40. Non-visual Tag in the VPE**

### 3.2.1.1. Commenting out Code

VPE supports possibility to add comments in files you are working with (JSP, XHTML, etc.):

- HTML comments (`<!-- -->`) which are output to the client
- JSP comments (`<%-- --%>`) which are not output to the client as part of the JSP page output

### 3.2.1.2. JSP Syntax Validation

When working in JBoss Tools JSP editor you are constantly provided with feedback and contextual error checking as you type.

### 3.2.1.3. Support for Taglib versions

VPE templates now support various versions of tag libraries. It means that the VPE takes control under those components which have different parameters or preview according to the framework version (like seam 1.2 and seam 2.0, or JSF 1.1 and JSF 1.2).

For example, `<s:decorate>` element in seam has different parameters in versions 1.2 and 2.0 as well as `<h:outputLink>` JSF element has different preview in versions 1.1 and 1.2.
3.2.2. Pages Styling

Most web pages use the cascading style sheets (CSS) to control the way they look. With Visual Page Editor you can easily style your pages. In this section we are going to introduce you to a powerful mechanism that VPE provides for a complete control over pages styling.

3.2.2.1. Inline Style Editing

In the Visual part of the VPE there is a graphical toolbar, use it to add inline styling to JSF and Struts tags on your page. The toolbar can be hidden by clicking on arrow sign in the upper left corner.

![Figure 3.41. Text Formatting](image)

For editing inline styles for DOM elements VPE also provides CSS Dialog. It can be called from style line in the Properties view for a currently selected element.
Figure 3.42. Call the CSS Dialog

CSS Dialog has four tabs where css properties for text, background, borders and others can be specified. A simple preview which is generated at the top of the CSS Dialog allows you to see the changes before you apply them.

Figure 3.43. CSS Dialog
3.2.2.2. External Stylesheets

The pages you are working with in VPE can use external stylesheets. VPE allows you to create new style classes in existing stylesheets and/or edit them as well. For these purposes CSS Style Class Dialog is provided (hot keys - CTRL+SHIFT+C).

Select the element for which you need to create or edit style class and press button next to styleClass field in Properties view.

Figure 3.44. Calling the CSS Style Class Dialog

It'll pick up the CSS Style Class Dialog which looks like on the figure below.
First, you should specify the CSS file where you are going to put your style class. Do this by pressing button next to the `CSS file` field.
Chapter 3. Editors

Figure 3.46. CSS File Selection

To create new CSS class write its name in the *Style class* field and then configure style settings switching between the tabs: *Text/Font*, *Background*, *Boxes*, *Property Sheet*. To add existing styling to the chosen element expand the list of the existed style classes and point to the necessary one.
Figure 3.47. Style Class Selection

Quick Edit gives a preview of the properties which are set for the existing style class. You can easily modify them with the help of this wizard.
Figure 3.48. Quick Edit

Preview at the top of the CSS Style Class Dialog visualizes the result.

The dialog for creating a new CSS class, which is called from New > Other... > JBoss Tools Web > CSS Class, looks the same.
3.2.3. Templating

The VPE also makes it possible to create templates for unknown tags.

To call the Template dialog for a tag, right-click on it in Visual mode and select Setup Template for <tag name> option.
Figure 3.50. Calling Template Dialog

Here is what the Template dialog looks like.
Figure 3.51. Template Dialog

*Tag for Display* field in the Template dialog requires specifying a type of tag. It can be SPAN, DIV, TABLE or any other html element. Check *Children*, if you want to mark a tag as a child element.

The *Value* field is for setting a tag value.

As for the *Style* field, you can fill it out manually or make use of the button next to the field to bring the CSS Dialog [35] for editing styles.

You can observe all defined templates in the VPE Preferences on the Templates tab which you can quickly access by pressing Preferences button.
Figure 3.52. Templates Tab of the VPE Preferences Page

Here it’s possible to edit or remove any listed in the table template.

3.2.4. Advanced Settings

In the left vertical pane of the Visual part there are three buttons: Preferences, Refresh and Page Design Options.
Figure 3.53. Buttons on the Visual Part of VPE

- **Preferences** button provides a quick access to Visual Page Editor preferences.
Chapter 3. Editors

Figure 3.54. Visual Page Editor Preferences Window

- Clicking on **Refresh** button you refresh the displayed information.

- **Page Design Options** button leads to window which helps you to specify necessary references to resources. Here is what this window looks like.
This dialog lets you set resources which are usually only resolved in runtime. Let's look at what functionality it proposes.

The first two sections of the window let you define actual runtime folders. The example below will help you to clarify how this can be used.

Suppose you have the following project structure:
Chapter 3. Editors

The content of the `header.jsp` is:

```
My Header
<img src="img/a.gif"/>
```

and `main.jsp` content is:

```
<jsp:include page="pages/header.jsp"/>
```

When you open `main.jsp` in Visual Page Editor, it will not be able to resolve the image from the header, however, it will work fine in runtime. To fix this in design time, click the `Page Design Options` button and set `Actual Run-Time Relative Folder` to `projectName > WebContent > pages` and you will see the image appeared.

In the bottom part of the window you can set a path to included css files, tag libs and substituted EL expressions.
Figure 3.56. Bottom Part of the Page Design Options

Let’s consider an example. For instance, the definition of your CSS on the page is the next:

```html
<link rel="stylesheet" type="text/css"
    href="/style.css" />
```

This will work fine in runtime, but the Visual Page Editor doesn't know what `requestContextPath` in design time is. In order to see the necessary styles applied in design time you should add a path to your stylesheet in the CSS File Path section.

The next URI section lets you add URI taglibs so that the editor knows where to find the tag libraries.

And the last Substituted EL expressions section is provided to specify the values for specific EL variables. It can be useful for a preview generation.

As an example look at the figure below:
Figure 3.57. EL Expression

Here both in Source and Visual modes you see the EL expression `#{user.name}`. When you switch to Preview view, you'll also see this expression. Now press Page Design Options button and set the value for the "user.name" as World.
Figure 3.58. Setting the Value for the EL Expression

As a result in Visual mode and Preview view the word *World* is displayed.
Figure 3.59. The EL Expression Value

You can find useful one more functionality provided by VPE. At the bottom of the Visual/Source view there is a Selection Tag Bar. It allows to see tags tree for a current component selected in Visual or Source mode.

Figure 3.60. Selection Tag Bar
If you want to hide the Selection Tag Bar, use the button in the form of a red cross on the lower right side. To reset it again you should check the proper option in the VPE Preferences.

### 3.2.5. Page Preview

VPE comes with design-time preview feature which is available for:

- Struts Pages
- JSF Pages

Preview view is read-only, it shows how the page will look like in a browser.

![Figure 3.61. Preview View](image)

### 3.2.6. Setup notes for Linux

Linux users may need to do the following to get the Visual Page Editor to work correctly on their machines.

The Visual Page Editor requires the library libstdc++.so.5. This library is contained in the compat-libstdc++-33.i386 package.
• To install this package on Fedora Core or Red Hat Enterprise Linux run the following command:

```bash
yum install compat-libstdc++-33.i386
```

• On any other rpm based distributions download libstdc++.so.5 and run the following command:

```bash
rpm -Uvh compat-libstdc++-33.i386
```

• On Debian based distributives run the following command:

```bash
apt-get install compat-libstdc++-33.i386
```

In case you have the library installed and you still have issue with starting the visual page editor then close all browser views/editors and leave one visual page editor open and restart eclipse. This should force a load of the right XULRunner viewer.

### 3.3. More Editors

Besides Visual Page Editor JBDS is supplied with a huge range of various editors for different file types: properties, TLD, web.xml, tiles, and so on.

#### 3.3.1. Graphical Properties Editor

The Properties editor allows you to work in two different modes and also supports unicode characters.

To create a new properties file, in the Package Explorer view, select New > Properties File from the right-click context menu on the folder where you want to create the file.
Figure 3.62. Selecting Properties File

You can edit the file using a table-oriented "Properties" viewer:
Chapter 3. Editors

Figure 3.63. "Properties" Viewer

You can also use a Source viewer for editing the file:

Figure 3.64. Source Viewer

3.3.2. Graphical TLD Editor

The TLD editor comes with same features you will find in all other JBoss Developer Studio editors:
• Graphical and source edit modes

• Validation and error checking

3.3.2.1. Tree view

![Figure 3.65. Tree View](image)

3.3.2.2. Source view

You can easily switch from Tree to Source by selecting the Source tab at the bottom of the editor.
Chapter 3. Editors

Figure 3.66. Source View

You can easily add a new tag:
Figure 3.67. Adding a New Tag

You can also easily add a new attribute to an existing tag:
Figure 3.68. Adding a New Attribute

Content assist is available when editing the file using the Source viewer:

Figure 3.69. Content Assist

In the Source viewer, if at any point a tag is incorrect or incomplete, an error will be indicated next to the line and also in the Problems view below.
3.3.3. Graphical Web Application File (web.xml) Editor

The Web Application File editor comes with the same features you will find in all other JBoss Developer Studio editors:

- Graphical and source edit modes
- Validation and error checking
3.3.3.1. Tree View

Figure 3.71. Tree View

You can add any new elements right in the Tree viewer:
3.3.3.2. Source View

Switch to the Source viewer to edit the web.xml file by hand at any time:
Figure 3.73. Source View

3.3.3.3. Content Assist

Content assist is available in the Source viewer. Simply click  **CTRL-Space** anywhere in the file.
3.3.3.4. Errors Checking and Validation

If errors occur anywhere in the file, small red dots will appear next to the lines where the errors occurred. Also, note that the file is marked by a small x in the Package Explorer view.
Figure 3.75. Errors Reporting

3.3.4. CSS Editor

The CSS editor comes with the same features you will find in all other JBoss Developer Studio editors.

- Content assist
- Validation and error checking

With the CSS (Cascading Style Sheet) editor, you can take advantage of code prompting:
Figure 3.76. CSS Editor

And you can also use the Properties view next to the editor to edit existing stylesheet declaration properties:
3.3.5. JavaScript Editor

The JavaScript editor includes a Preview viewer and a Source viewer. In the Source viewer, you can use code assist:
Figure 3.78. JavaScript Editor

You can also use the Source viewer with the Outline view to navigate around the file:
3.3.6. XSD Editor

JBoss Developer Studio comes with an **XSD Editor** for XML Schema files. This editor comes from the Web Tools Project (WTP) (see [WTP Getting Started](#)).

To create a new XSD file, right-click a folder in the Package Explorer view, select **New > Other...** from the context menu and then select **XML > XML Schema** in the dialog box.
Figure 3.80. Creating New XSD file

The XSD Editor includes two viewers for working on the file, a Design viewer and a Source viewer:
Figure 3.81. Source Viewer

In the Design viewer, you can drill down on an element by double-clicking on it:
Figure 3.82. Design Viewer

Various edit options are available when you right-click an element in the diagram:
Figure 3.83. Edit Options

You can also use the Properties view to edit a selected element:
Figure 3.84. Properties View

You can also use a Source viewer for the file. In this viewer, along with direct editing of the source code, you can also edit the file by using the Properties view on the right:
3.3.7. Support for XML Schema

JBoss Developer Studio fully supports XML files based on schemas as well as DTDs:
Figure 3.86. XML File
Chapter 4.

**JBoss Tools Palette**

This chapter will introduce you to the functionality provided by JBoss Tools Palette. The Palette allows you to quickly and easily create your JSP or JSF pages. Now you can do it more faster without additional knowledge.

The JBoss Tools Palette allows you to:

- Insert tags into a JSP or JSF page with one click
- Add custom and 3rd party tags

The JBoss Tools Palette contains a developer's project tag libraries and provides possibility to add any tag libraries to it. Also you can choose a necessary one from the list of already existed tag libraries:

- HTML
- JBoss
- JSF
- JSTL
- MyFaces
- Oracle ADF Faces
- Struts
- XHTML
Chapter 4. JBoss Tools Palette

Figure 4.1. Default View of The JBoss Tools Palette

By default the Palette is represented in Web Development Perspective with five groups. If you can't see it, select Window > Show View Other... > JBoss Tools Web > JBoss Tools Palette from the menu bar.

4.1. Palette Options

To facilitate your work, you can configure the Palette in your own way, by selecting the corresponding icon on the Palette toolbar.

There is a possibility to configure the JBoss Tools Palette:

- to edit the palette content by adding, removing or changing the palette elements
- to show/hide groups, subgroups
- to import groups, subgroups
4.1.1. Palette Editor

JBoss Tools Palette contains existing libraries of tags, thus the Palette editor is intended to work with them or create your new one, as well.

To open the editor, click on the Palette Editor icon:

Figure 4.2. Palette Buttons

Figure 4.3. Palette Editor Icon

The window has two parts. There is a reflected grouped list of components on the left side of the palette editor. Each group is divided into multiple groups, every of which is a tag library. The right side of the palette editor is an editing window where it's possible to change values of group or tag library attributes that you've chosen on the left part of the window.

It can also be done by right click and using Edit… option.

For example, JSF group consists of Core, Facelets, HTML tag libraries and the attributes as name, description and hidden which are available for editing:
Figure 4.4. Tag Libraries of the JSF Group

The Palette Editor provides the following possibilities when working with existing tags or icons:

- to work with a set of icons

  *Icons* is the root folder for the icon sets. The first step is creating the icon set. Right click on the *Icons* folder and select *Create > Create Set...*

  Set the value of the name in the *Add Icons* window and click *Finish* button. A new element will appear in the list.
Figure 4.5. Creating a Set of Icons

Also you can delete the set. Right click on the set of icons that you wish to remove and chose the  *Delete Set*  option from the pop-up menu or click the  *Delete*  keyboard button.

- to edit icons in the chosen set

When the set of icons is created, new icons can be imported to it. Choose the required set and select the option  *Create > Import Icon...*  from the pop-up menu that appears after you right-click on a folder.
Figure 4.6. Creating Icons

Set the name of the icon and the path and click Finish button.

• to work with a group of tag libraries

The first step in work with the editor is creating a group of libraries. It's very easy to do, right mouse button click on the Palette folder and select Create > Create Group…

Set a name of a group in the Create Group window and click OK button. A new element will appear at the end of the list.
Figure 4.7. Creating a Group of Tag Libraries

You are allowed to edit or delete a group, as well. If you’d like to change attributes of a group, use the right editing window of the palette editor or the Edit... option, like it was mentioned before. In order to remove the group, right click on the group that you wish to remove and choose the Delete option or click the Delete keyboard button.

Important:
The removal option is enabled only for custom folders.

- to work with a tag library

The group maintains a list of tag libraries. If you’d like to create your own library, click right mouse button on the group and choose Create Group... option.
Figure 4.8. Creating a tag library

After setting the attribute name and the path of the icon, click Ok button.

Note:

If you do not choose an icon the default one will be assigned.

You are allowed to edit or delete the tag library, as well. If you’d like to change attributes of the library or choose another icon, use the right editing window of the palette editor or the Edit... option. In order to remove the tag library, right click on the library that you wish to remove and chose the Delete option or click the Delete keyboard button.

Important:

The removal option is enabled only for custom tag libraries.

• to work with a tag element

When the library folder is created, new tags can be added to it. Choose the required library and select the option Create > Create Macro… from the pop-up menu that appears after you right-click on a folder.
Figure 4.9. Creating a tag element

In the Add Palette Macro window, you can configure the tag element. Attribute Name is mandatory to fill and it will be the name of the tag element. Other settings are optional. You can choose the icon and set the Start Text and the End Text for your tag element. If your tag text is too long, use the Change... button to see it all. For start text and end text there is a possibility to control the cursor position by using "|" symbol.
Figure 4.10. Parameters of the Palette element

After all the attributes are set, click Finish button.

Note:
If you do not choose an icon the default one will be assigned.

You are also allowed to edit or delete the tag. If you’d like to change the attributes of the tag or choose another icon for it, use the right editing window of the palette editor or the Edit... option from the pop-up menu. In order to remove the tag, right click on the tag that you wish to remove and chose the Delete option or click the Delete keyboard button.

Important:
The removal option is enabled only for custom tags. JBoss Palette tags can not be removed but can be modified.

If you have changed any object in the tree view and you don’t like the final result you can always use the Restore Defaults button. Click on it will restore defaults for the object selected and for its children elements. Please remember that the button will only restore data for objects defined in the default palette. If selected object is created by you, the button will be disabled. Child objects added by you will not be removed.
When updating JBoss Tools the palette content is not updated.

### 4.1.2. Show/Hide

*Show/Hide* is a very useful feature that allows you to control the number of tag groups that are shown on the palette.

- Click *Show/Hide* button, at the top right side of the JBoss Tools Palette.

![Figure 4.11. Show/Hide Button](image)

- In the dialog Show/Hide Drawers check the groups the libraries of which you want to be shown on the palette:

![Figure 4.12. Show/Hide Drawers](image)
If libraries are not displayed in the palette, check whether they are selected. Click the plus sign to expand the libraries of the group and make sure that a tick is put next to the wanted libraries.

- Click **OK**. The new groups will now be shown on the palette:

![Image of JBoss Tools Palette with added groups]

**Figure 4.13. New Added Groups**

The names of the elements are compound. The first part is the group name and the second is the library name.

### 4.1.3. Import

The Import button lets you add a custom or 3rd party tag library to JBoss Tools Palette. Find out more information on how to add particular tags see the [Adding Custom JSF Tags](#) section.

### 4.2. Using the Palette

#### 4.2.1. Inserting Tags into a JSP File

A new tag can be added into any text file including jsp, htm, html and xhtml.
Let's do it. Open your JSP file and place the cursor in a place where you'd like to add a tag and then click that tag in the palette. In the Insert Tag window, that appears, you can set the value of \textit{general} and \textit{advanced} attributes of the tag that you chose.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{insert-tag.png}
\caption{Inserting Tag}
\end{figure}

In the example below, the \textit{commandButton} tag has been inserted.
Figure 4.15. Inserting Tag

Tip:
if you place the cursor over any tag, a balloon hint is shown with all the "tag" attributes.

The cursor position after adding a tag into a file is specified by "|" symbol in the tag template on the right in the Palette Editor window.
4.2.2. Adding Custom JSF Tags to the JBoss Tools Palette

There are two ways to add any custom or 3rd party tag library to the JBoss Tools Palette:

- Drag-and-drop from the Web Projects view
- The Import button on the JBoss Tools Palette
Before you can add your custom component library, you need to make sure it is included in your project. Either place the ".tld" file or the "jar" that includes your tag library under the lib folder in your project.

4.2.2.1. Drag-and-Drop

Switch to the Web Projects view and expand the Tag Libraries folder. If the view is not active, select Window > Show View > Web Projects from the menu bar.

![Web Projects View](image)

**Figure 4.18. Web Projects View**

Also make sure that the JBoss Tools Palette is open. Select the tag library that you want to add and simply drag-and-drop it on to the JBoss Tools Palette.

You will see the following dialog window. As you can see JBoss Developer Studio takes care of all the details. Chosen TLD file, name and prefix of the library and Library URL are detected, thus just need to set the Group name to which you wish to place this tag library. You can either add this tag library to an existing Group or just create a new one.
Figure 4.19. Import Tags From TLD File Form

Once you are finished, you will see the new tag library added to the JBoss Tools Palette.
4.2.2.2. Import Button

The same you can do with **Import** button. You can see this button at the top right side of the JBoss Tools Palette.
Figure 4.21. Import Button

By clicking on the *Import button* you will see the Import Tag window a similar like in the *Drag-and-Drop* method. Set the name and prefix of the library and Library URL. Also you need to set the Group name to which you’d like to add your tag library. And like in the previous method you can add it to an existing Group or create a new one. On this Import Tag form you can use *Browse...* button to locate the tag library that you want to add:
Figure 4.22. Select TLD File

4.3. RichFaces Support

Figure 4.23. RichFaces Components

To start using RichFaces components as well as Ajax4jsf ones in JBDS you should first put richfaces-*.jar files into the /lib folder of your project.

Note:

Currant version of JBoss Developer Studio (i.e. 1.1.0GA) includes RichFaces 3.2.2. The JBoss Tools 3.0.0.beta1 comes with RichFaces 3.1.3 and partly support 3.2 version of the component framework. If you need to use the latest version of the component framework you should import it into the Palette like any other custom tag library.

4.3.1. Relevant Resources Links

It may be helpful for you to look through the movie which covers a creation of a jsf application with simple content using the RichFaces components.
Web Projects View

Web Projects is a special view that comes with JBoss Developer Studio.

If the Web Projects view's tab is not visible next to the Package Explorer tab, select Window > Show View > Other > JBoss Tools Web > Web Projects from the menu bar.

With the Web Projects view, you can:

- Visualize the project better because the project artifacts for JSF and Struts projects are organized and displayed by function.
- Select these kinds of items to drag and drop into JSP pages:
  - JSF managed bean attributes
  - JSF navigation rules outcomes
  - Property file values
  - Tag library files
  - Tags from tag libraries
  - JSP page links
- Use context menus to develop the application (all create and edit functions are available)
- Use icon shortcuts to create and import JSF and Struts projects
- Expand and inspect tag library files
- Select custom and third-party tag libraries to drag and drop onto the JBoss Tools Palette

5.1. Project Organization

The Web Projects view organizes your project in a different way. The physical structure of course stays the same. The new organization combines common project artifacts together which makes it simpler to locate what you are looking for and develop.

The screen shot below shows a JSF project and a Struts project in Web Projects view.
Figure 5.1. Web Projects View

5.2. Drag and Drop

Web Projects View has a drag and drop option that can be used for property, managed bean attributes, navigation rules, tag library file declaration and JSP Pages.

5.2.1. For a Property

Expand the Resources Bundles folder that holds all the Property files in your project. Select the file from which you want to add the property and then select the property.

We will be dragging and dropping a property file value inside the outputText tag for the "value" attribute.
<html>
  <head>
    <title>Input User Name Page</title>
  </head>
  <body>
    <f:view>
      <h1><f:outputText value=""/></h1>
    </f:view>
  </body>
</html>

**Figure 5.2. OutputText Tag**

Select the property:

![Selecting Property]

**Figure 5.3. Selecting Property**

Drag the property and drop it between the quotes for the value attribute in the JSP file. Notice that JBoss Developer Studio added the correctly formatted expression for referring to the property value `#{Message.header}` automatically.

```html
<html>
  <head>
    <title>Input User Name Page</title>
  </head>
  <body>
    <f:view>
      <h1><f:outputText value="#{Message.header}"/></h1>
      <f:messages style="color: red"/>
    </f:view>
  </body>
</html>
```

**Figure 5.4. Inserted Property**
You can actually place the tag anywhere in the page, not just inside an existing tag. In this case, JBoss Developer Studio will place the complete tag `<h:outputText value="#{Message.header}"/>` in the page.

### 5.2.2. For Managed Bean Attributes

Select a "managed bean" attribute and then drag and drop it onto the JSP page. We are going to place it inside the "value" attribute of the inputText tag.

![Figure 5.5. Selecting Managed Bean Attribute](image)

Figure 5.5. Selecting Managed Bean Attribute

Once again, JBoss Developer Studio adds the correct expression, `#{user.name}`.

```xml
<h:form id="greetingForm">
    <h:outputText value="#{Message.prompt_message}"/>
    <h:inputText value="#{user.name}" required="true">
        <f:validateLength maximum="30" minimum="3"/>
    </h:inputText>
</h:form>
```

Figure 5.6. Added Expression

### 5.2.3. Navigation Rules

Select the navigation rule under `Configuration > faces-config.xml > Navigation Rules:`
Figure 5.7. Selecting Navigation Rule

Drag and drop it inside the commandButton tag:

```xml
<f:validateLength maximum="30" minimum="3"/>
</f:inputText>

<f:commandButton action="hello" value="Say Hello!" />
</f:view>

Figure 5.8. Navigation Rule in CommandButton Tag

You could do the same if the navigation rule was defined inside an action method:
5.2.4. For a Tag Library File Declaration

Select a TLD file:
Figure 5.11. Selecting TLD File

Then drag and drop it onto the JSP page to add a declaration at the top of the page:

Figure 5.12. Inserted TLD File

5.2.5. For JSP Pages

You can also drag and drop a JSP page path to a JSP page to create a forward as shown:
5.3. Developing the Application

It is also possible to develop your application right from the Web Projects view. Simply right-click any node in the tree and select an appropriate action from the context menu. For instance, this screen capture shows creating a new navigation rule.
5.4. Expanding Tag Library Files

You can easily expand any TLD file in the project. Browse to the Tag Libraries folder. Right-click a TLD file and select *Expand*. The TLD file will now be expanded.

You can then select any tag and drag it onto a JSP page.
5.5. Drag and Drop Tag Libraries on to JBoss Tools Palette

Read *Adding Tag Libraries* to learn about this.

5.6. Create and Import JSF and Struts Projects

You can also create and import JSF and Struts project from Web Projects view by selecting the buttons below.

From left to right:

1. Create New JSF Project
2. Import JSF Project
3. Create New Struts Project
4. Import Struts Project
Figure 5.16. Web Projects View Buttons
Chapter 6.

**JBoss Tools Preferences**

Configuring the various **JBoss Developer Studio** features is done via the **Preferences** screen by selecting *Window > Preferences > JBoss Tools* from the menu bar.

![Figure 6.1. Preferences are included in this dialog.](image)

From this screen, you can select these more specific sets of **JBoss Tools preferences**:

- **Packaging Archives**
Chapter 6. JBoss Tools Preferences

- Editors
- Visual Page Editor
- EL Variables
- JSF
- JSF Page
- JSF Project
- JSF Flow Diagram
- Seam
- Seam Validator
- Struts
- Struts Automatic
- Plug-in Insets
- Resource Insets
- Struts Customization
- Struts Project
- Struts Support
- Struts Pages
- Struts Flow Diagram
- Tiles Diagram
- Verification

The Preferences dialog (Window > Preferences) also allows to adjust settings for JBoss Server and XDoclet module.

6.1. Packaging Archives

Follow to JBoss Tools > Packaging Archives to open the page for changing Packaging Archives preferences.

Here you can determine settings for Project Packages view and core preferences.
Figure 6.2. Packaging Archives

The next table lists all available preferences for Packaging Archives and their description.

Table 6.1. Packaging Archives Preferences

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable incremental builder</td>
<td>Uncheck this option if you don’t want to enable incremental builder for your resources</td>
<td>On</td>
</tr>
<tr>
<td>Show full output path next to packages</td>
<td>This option allows you to show or hide an output path next to packages</td>
<td>On</td>
</tr>
</tbody>
</table>
Chapter 6. JBoss Tools Preferences

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the full root directory of filesets</td>
<td>If on, the full root directory is displayed next to filesets. Otherwise, it's hidden.</td>
<td></td>
</tr>
<tr>
<td>Show project at the root</td>
<td>This option allows you to choose whether to display a project name at the root of the packages or not. When checked, 'Show all projects that contain packages' is enabled.</td>
<td>On</td>
</tr>
<tr>
<td>Show all projects that contain packages</td>
<td>Selecting this setting enables the Projects Archiving view to show or hide all projects that contain packages. The option is available when the previous one is checked.</td>
<td>Off</td>
</tr>
</tbody>
</table>

6.2. Editors

To adjust settings common for all editors supplied with JBoss Developer Studio you should select JBoss Tools > Web > Editors.
Figure 6.3. Editors

On the Editors page the following preferences are available:

Table 6.2. Editors Preferences

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Always use JBoss Tools editors with Open option</td>
<td>On</td>
</tr>
<tr>
<td></td>
<td>Show warning when project has no JBoss Tools capabilite</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Use Source tab as a default for multi-tab editors</td>
<td>On</td>
</tr>
</tbody>
</table>
## Option

**Show warning when project has no JBoss Tools capabilities**

Check this option to be sure that any JBoss Tools editor fully available for a particular type of file. If no, you’ll be warned about this.

**Use Source tab as a default for multi-tab editors**

If on, an editor will open the files in the Source view by default

### 6.3. Visual Page Editor

*JBoss Tools > Web > Editors > Visual Page Editor* screen allows you to control some aspects of the behavior of the **Visual Page Editor** (VPE) for JSF/HTML files.
The next table lists the possible settings that you can adjust on the General tab of the VPE Preferences page.

Table 6.3. VPE Preferences

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>On</td>
<td>On</td>
</tr>
</tbody>
</table>
## Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border for Unknown Tags</td>
<td>The option allows to place the border around unknown tags or undo this</td>
<td></td>
</tr>
<tr>
<td>Show Non-Visual Tags</td>
<td>Check this box, if you want the editor shows non-visual elements on the page you’re editing</td>
<td>Off</td>
</tr>
<tr>
<td>Show Resource Bundles Usage as EL Expressions</td>
<td>If the option is checked, the editor will show EL expressions instead of the resource values</td>
<td>Off</td>
</tr>
<tr>
<td>Always Prompts for Tag Attributes During Tag Insert</td>
<td>Having this option off, the dialog with possible attributes for inserting tag won’t appear if all its attributes are optional</td>
<td>On</td>
</tr>
<tr>
<td>Show Selection Tag Bar</td>
<td>This option allows to show or hide the Selection Bar</td>
<td>On</td>
</tr>
<tr>
<td>Always Hide Selection Bar Without Prompt</td>
<td>Check this box if you don’t want the confirmation window appears when closing the Selection Bar</td>
<td>Off</td>
</tr>
<tr>
<td>Default Editor Tab</td>
<td>The option provides with a possibility to choose one of the following views - Visual/Source, Source or Preview, as default when opening the editor</td>
<td>Visual/Source</td>
</tr>
<tr>
<td>Size of Visual Editor Pane 0 – 100%</td>
<td>With the help of this scroll bar you can adjust the percentage rating between the Source and Visual modes of the Visual/Source view</td>
<td>50%</td>
</tr>
</tbody>
</table>

On the **Templates tab** you can edit or remove [VPE templates](#).
Figure 6.5. Visual Page Editor Templates

Select a template for editing from the available list and press the Edit button. It will pick up the Template dialog [42] where you can adjust new settings.

6.4. El Variables

To specify necessary EL variables globally, i.e. for all projects and resources in your workspace, you should go to JBoss Tools > Web > El Variables.
Figure 6.6. EL Variables

Click Add... to set value for a new EL variable. In the appeared wizard you should specify the global values and press Finish.
Figure 6.7. Adding a Global EL Variable

Tip:
If you specify an equal variable in VPE EL dialog and in Preference EL dialog, variable from preference dialog will have priority.

6.5. JSF

Select JBoss Tools > Web > JSF to get to the JSF Project specific preferences.
6.6. JSF Pages

By selecting **JBoss Tools > Web > JSF > JSF Pages** you can add jsf pages or remove existing ones.
Select **JBoss Tools > Web > JSF > Project** to see JSF Project preferences page.

On the **New Project** tab you can set default values for **New JSF Project** wizard:

- **Version** for setting the default JSF Environment
• **Project Template** so as **New JSF Project wizard** shows this template as default for the chosen JSF Environment

• **Project Root** for specifying default location for a new JSF project

  If you check **Use Default Path** here, this box will be also checked in the **New JSF Project wizard**.

• **Servlet Version** for setting the default Servlet version of a new JSF project

  Here it's also possible to define whether to register Web Context in **server.xml** while organizing a new project or not. Check the proper box in order to do that.
Figure 6.10. New JSF Project Preferences

On the Import Project tab in the JSF Project screen you can determine the default Servlet version for the Import JSF Project wizard and also whether to register Web Context in server.xml or not.
6.8. JSF Flow Diagram

Selecting **JBoss Tools > Web > Editors > JSF Flow Diagram** allows you to specify some aspects of the Diagram mode of the JSF configuration file editor.
The first two items control the background grid for the diagram. The next two items allow you to control the appearance of the labels for views (pages) and the transitions between views. For these two items, clicking the Change... button allows you to assign a font with a dialog box.

The first check box determines whether a view in the diagram that doesn't have a transition connecting it to another view yet should be written to the source code as a partial navigation rule. The next check box determines whether the diagram cursor reverts immediately to the standard selection mode after it's used in the transition-drawing mode to draw a transition. Finally, the last two check boxes concern shortcuts. A shortcut is a transition that is there but isn't actually displayed in the diagram as going all the way to the target view it's connected to, in order to make the diagram clearer. With the check boxes, you can decide whether to display a small shortcut icon as part of the shortcut and also whether to display the target view as a label or not.

Figure 6.12. JSF Flow Diagram
6.9. Label Decorations

The Label Decorations page is opened from JBoss Tools > Web > Label Decorations.
Figure 6.14. Label Decorations

On this page you can determine the format for a text output near the decoration label for different Web resources. To change the value for selected element, click Add Variable... button next to Format field. Appeared wizard will prompt you to select one from the available list.
Figure 6.15. Label Decoration for Validator

6.10. Seam

The following preferences can be changed on the *JBoss Tools > Web > Seam* page.

On *Seam* screen you can add and remove Seam runtimes.

Here is what Seam preference page looks like:
Figure 6.16. Seam

6.11. Seam Validator

The following preferences can be changed on the JBoss Tools > Web > Seam > Validator page.

In Validator panel you configure seam problems that will be processed by validator.
Chapter 6. JBoss Tools Preferences...

![Preferences window with Seam Validator settings]

**Figure 6.17. Seam Validator**

### 6.12. Struts

By selecting *JBoss Tools > Web > Struts* you can configure Struts projects specific preferences.
6.13. Struts Automation

On Automation panel you can modify default text for the Tilel Struts plug-in element, the Validator Struts plug-in element, and error message resource files.
Figure 6.19. Struts Automatic


By selecting Web > Struts > Automation > Plug-in Insets on tab Tiles you can define a default text for tiles plugin.
Figure 6.20. Plug-in Insets

The same is done but for validator plugin on the tab Validators.
Figure 6.21. Plug-in Insets of Validators

6.15. Resource Insets

To see Resource Insets preference page select  JBoss Tools > Web > Strats > Automation > Resource Insets  .

On  Resource Insets  panel you determine default error messages for error resource files.
6.16. Struts Customization

The following preferences can be changed on the JBoss Tools > Web > Struts > Customization page.

In the Customization screen you configure Link Recognizer for Struts tags.
Figure 6.23. Struts Customization

6.17. Struts Project

You can change the following preferences on the JBoss Tools > Web > Struts > Project preference page:

On Project panel you define a template for a new Struts created project: servlet version, page template and so on.
Figure 6.24. Struts Project

Selecting the Import Project tab in the Struts Project screen allows you to determine the default servlet version and whether to register Web Context in server.xml.
Figure 6.25. Import Struts Pages

6.18. Struts Support

The following preferences can be changed on the JBoss Tools > Web > Struts > Project > Struts Support page.

Select Struts Support screen if you want to configure Struts versions support settings.
Figure 6.26. Struts Support

6.19. Struts Pages

You can change the following preferences on the JBoss Tools > Web > Struts > Struts Pages preference page.

On **Struts Pages** panel you can add or remove Struts pages.
Figure 6.27. Struts Pages

6.20. Struts Flow Diagram

Similarly to the JSF Flow Diagram screen, selecting JBoss Tools > Web > Editor > Struts Flow Diagram page allows you to specify aspects of the Diagram mode of the Struts configuration file editor. The Struts Flow Diagram screen adds an option to hide the Diagram tab and labeling settings for additional artifacts.
Figure 6.28. Struts Flow Diagram

Selecting the Add Page tab in the Struts Flow Diagram screen allows you to determine the default template and file extension for views (pages) you add directly into the diagram using a context menu or the view-adding mode of the diagram cursor.
Figure 6.29. Adding Page

6.21. Tiles Diagram

JBoss Tools > Web > Editors > Title Diagram screen allows you control some settings for the placement of Tiles definitions in the Diagram mode of the JBoss Tools Tiles editor.
6.22. Verification

The following preferences can be changed on the JBoss Tools > Web > Verification page.

On Rules Configuration tab of Verification panel you can determine JSF and Struts rules.
Figure 6.31. Verification

On Options tab you can define a limit for the reported errors number.
Figure 6.32. Options of Verification

6.23. Server Preferences

Preferences for JBoss Server and other servers can be changed on the Server page.
Figure 6.33. Server Preferences

On the *Server > Runtime Environments* page you can add new or modify already defined Server Runtime.
Figure 6.34. Runtime Environments

Server Launching preferences can be configured on the Server > Launching page.
Figure 6.35. Server Launching Preferences

Going to Server > Audio you can enable/disable the sound notification for different Server states and actions and set the sound volume as well.
6.24. XDoclet

The preferences for XDoclet can be changed if you click XDoclet on the left navigation bar.

On the XDoclet screen it's possible to enable/disable XDoclet builder by checking proper box, specify XDoclet home and determine XDoclet module version as well.
Figure 6.37. XDoclet

Switch to  XDoclet > ejbdoclet  page in order to adjust settings for EJB-specific sub-tasks.
To configure settings for various web-specific XDoclet sub-tasks, follow to XDoclet > webdoclet page.

Figure 6.38. ejbdoclet
Figure 6.39. webdoclet

On the whole, this document should guide you to those parts of JBoss Tools which you specifically need to develop Web Applications. It covers different aspects of visual components such as editors, views, etc. for browsing, representing and editing web resources you are working with.

If there's anything we didn't cover or you can't figure out, please feel free to visit our JBoss Developer Studio Users Forum or JBoss Tools Users Forum to ask questions. There we are also looking for your suggestions and comments.