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Chapter 1. Introduction

Introduction

1.1. What is ESB?

ESB (Enterprise Service Bus) - an abstraction layer on top of implementation of an enterprise
messaging system that provides the features Service Oriented Architectures may be implemented
with.

If you want to develop applications using ESB technology JBoss ESB also meets your needs. The
JBoss Tools provide an ESB editor and all necessary wizards for creating an ESB file.

In this guide we provide you with the information on JBoss ESB support (installation, configuration
and deployment) and usage of ESB Editor which allows you to develop an ESB file much faster
and with far fewer errors so sparing your time.

1.2. Key Features of ESB Tools

For a start, we propose you to look through the table of main features of ESB plugin:

Table 1.1. Key Functionality of ESB Tools

JBoss Tools Project  Some kinds of projects with predefined Creating ESB Project

Examples Wizard structure are available for usage. using JBoss Tools
Project Examples
Wizard

JBoss Enterprise The SOA Platform integrates specific versions using and configuring

SOA Platform of JBoss ESB, jBPM, Drools and the SOA Platform

JBoss Enterprise Application Platform that are
certified to work together in a single supported
enterprise distribution.

ESB Editor JBoss ESB tooling has powerful editor features ESB editor
including syntax validation, support for XML
Schema and other.

1.3. Other relevant resources on the topic

You can find a set of benefits and other extra information on:

» JBoss ESB [http://www.jboss.org/jbossesb]

» JBoss Wiki [http://wiki.jboss.org/wiki/JBoSSESB]

» JBoss ESB Documentation Library [http://www.jboss.org/jbossesb/docs/index.html]
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The latest JBoss Tools/JBoss Developer Studio documentation builds are available JBoss Tools
nightly documentation page [http://download.jboss.org/jbosstools/nightly-docs/].
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ESB Support

In this section we will focus on all concepts that JBoss Tools integrate for working with JBoss ESB.

2.1. ESB Tools Installation

This chapter will provide you with the information on how to install JBoss ESB plugin into Eclipse.

ESB Tools come as one module of JBoss Tools project. Since ESB Tools have a dependence
on other JBoss Tools modules we recommend you to install a bundle of all JBoss Tools plug-ins
[http://labs.jboss.com/tools/download.html]. You can find all necessary installation instructions on
JBoss Wiki in the InstallingJBossTools [http://labs.jboss.com/wiki/InstallingJBossTools] section.

2.2. Creating a ESB Project

In this chapter we suggest a step-by-step walk-through of creating a new ESB project. Let's try
to create a new JBoss ESB project.

We will show you how to use the ESB Project Creation wizard for creating a new ESB project and
setting basic ESB classpath.

Select File >New > Project... in the main menu bar or context menu for selected project and then
ESB > ESB Project in the dialog opened:

Select a wizard E—

Wizards:

Fype riner tex

b =>cvs

b & Drools
I & Eclipse Modeling Framework =
b =EB
= = ESB

H#% ESB File

b = Example EMF Model Creation Wizards

I = Hihemate

® [ cance

Figure 2.1. Select a Wizard dialog
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Clicking Next brings you to the JBoss ESB Project wizard page where a project name, ESB
version and target JBoss Runtime are to be specified. Specify, for example, helloworld as a
Project name and accept the default ESB version.

x|

G Mew ESB Project Wizard
JBoss ESB Project
Create a new |Boss ESE project. @

Project name: |helloworld [

Project contents
] Use default

Target Runtime

|:j_3055 4.2 Runtime : !N:w... |

|Boss ESB version

44 2

|:.i|

< Back H Next = ] Cancel

Figure 2.2. JBoss ESB Project wizard

Clicking Next brings you to the ESB facet installation page where you can specify Java Source
Directory and ESB Content Directory. ESB Content Directory is a folder that contains the most
of artifacts that an ESB archive needs. You also can configure ESB libraries to the project by
selecting a ESB runtime using one of the options:

1. Use Server Supplied ESB Runtime

2. Select a ESB runtime from the JBoss ESB runtime list predefined in the preferences. If you
choose the first option, make sure that the project has the Target JBoss Runtime set and this
runtime has a ESB runtime installed.

3. Choose ESB Config Vertion. From the version 4.5 JBoss ESB supports two different jboss-
esh.xsd versions: jpossesb-1.0.1.xsd and jbossesb-1.1.0.xsd.
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€ New ESB Project Wizard x

Install ESB Facet e

Project Folders
Content Directory

Ieshcuntent ]
Java Source Directory

|5r-c |

JBoss ESB Runtime
(% Server supplied ESB Runtime

O ! :-: N

wer o8

l ESBE Config Versian

Figure 2.3. Install ESB facet step

Click Finish and a ESB project with the default jboss-esb.xml will be created.

= & hellowerld » Jboss-esh ~ |Boss ESB
@src MNa |ilmss-esh
P =\ |RE Systemn IJI::.ra:"_.r I B Providers
b =\ |Boss ESB Runtime BT Parameter Reload Secs: |5
P =4 JBoss 4.2 Runtime [JB = Providers
= build Name
¥ = esbcontent
=i
= (= META-INF
cel jboss-esh.xmi
I 0
* Services
Name
Tree |Source|

Figure 2.4. The generated ESB project structure

[«]
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2.3. Creating ESB Project using JBoss Tools Project
Examples Wizard

JBoss Tools provides a Project Example wizard that is an easy way for users to create some
kinds of projects to be used as examples with some predefined structure. Let's start creating a
ESB project using this wizard.

Before creating a ESB project example create JBoss Runtime with name JBoss 4.2 Runtime, it
will be used by your ESB project example.

Select File >New > Others , in the main menu bar or context menu for selected project and then
JBoss Tools > Project Examples in the New dialog:

Select a wizard —

P &= Java EE

b = Java Emitter Templates

B = JavaScript

b (= |Boss |[BPM

= = |Boss Tools | |

T
I* = MBean Components

b (= |Boss Tools Web

-

Figure 2.5. Select a wizard - Project Examples

Clicking Next brings you to the wizard page where you can select a ESB project example from
the example list. Every ESB example has two projects, one is a ESB project and another is a Java
project used to test the ESB project.

Here is a list of ready examples available:

» JBoss ESB HelloWorld Example - demonstrates the minimal files necessary to make a basic
ESB component execute as well as to prove that the ESB os properly configured.
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« JBoss ESB HelloWorld Action Example - demonstrates the use of multiple action invocations
from a single configuration. You can use a single Action class and make multiple method calls
or use multiple Action classes.

« JBoss ESB HelloWorld File Action Example - demonstrates using the File gateway feature
of the JBoss ESB. Files that are found in a particular directory with a particular extension are
sent to a JMS queue with actions for processing.

« JBoss ESB Web Service consumerl Example - demonstrates how to consume a 181 Web
Service in an ESB action.

« JBoss ESB Web Service producer Example - demonstrates how to deploy a JSR181
Webservice endpoint on JBossESB using the SOAPProcessor action.

« JBoss ESB Smooks CSV -> XML Example - demonstrates how to transform a comma
separated value (CSV) file to an XML.

« JBoss ESB Smooks XML -> POJO Example - demonstrates the use of Smooks performing
a simple transformation by converting an XML file into Java POJOs.

« JBoss ESB Smooks XML -> XML date-manipulation Example - demonstrates how to
manually define and apply a Message Transformation within JBoss ESB.

« JBoss ESB Smooks XML -> XML Example - a very basic example of how to manually define
and apply a Message Transformation within JBoss ESB. It applies a very simple XSLT to a
SampleOrder.xml message and prints the before and after XML to the console.

We will take as our example JBoss ESB HelloWorld Example ESB and Client project:
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£ New Project Example

Project Example
lmpart Project Example

P Portlet
- ESB
|Boss ESB HelloWorld Example - ESB

JBoss ESE HelloWorld Example - Client

|Boss ESB HelloWorld Action Example - ESB £l
-

Description:
Project name: | ]
Project size: | |
URL: | |

N e e |

Figure 2.6. JBoss Tools ESB Project Examples

Choose them using the Ctrl button and then click Finish. As a result you will get two projects

created:
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I:I Package Expl P _ &y Web Projects | . Seam Compo | = O

|
| - & helloworld |
7 [ src

I 84 org jposs soa esb.samples quickstart helloworld
P = JRE System Library [ |25E-1 5]

B |Boss ESE Runtime [JBoss 4.2 Runtime ]
b =i\ |Boss 4.2 Runtime [|Boss 4.2 Runtime]

-

(= build

b ;= esbcontent
= 1= helloworld_testclient

b sre
b =4 JRE System Library [|25E.1 5]
[ =l |Boss ESE Auntime [JBoss 4.2 Runtime]
P =4 |Boss 4.2 Runtime [|Boss 4.2 Runtime]
P =\ Referenced Libraries

= build

Figure 2.7. JBoss ESB Project Examples: helloworld and
helloworld_testclient

Deploy the HelloWorld ESB project and run a test class in the client Java project to see the test
result in the Console view.

2.4. Deploying a ESB Project

In this chapter you will see how to deploy a ESB project using the WTP deployment framework.

Before deploying the project, open the JBoss Server View by selecting Window > Show View >
Other > Server > JBoss Server View, create a JBoss Server in the Server view and start it, and
then right click the created JBoss server, select Add and Remove Projects, and add the ESB
projects you want to deploy from the left side to the right side in the opened dialog.
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Add and Remove Projects
Modify the prajects that are configured on the server
Move projects to the right to configure thern on the server
Awvailable projects: Configured projects:
(% hetloworld
== Remove Al

@ < Back . gsh || cancel J

Figure 2.8. Add and Remove Projects

Click Finish to add the project to the server. You also can drag the ESB project from the Project
View to the server.

T properties |73 |Boss Server View E3

+ 7J |Boss 4.2 Server [Stopped)]

£ helloworld
|3 Rlessts

P+ ¥ ¥ML Configuration

Figure 2.9. JBoss Server View

Thus, you have just added the ESB project to the JBoss server module list. Right click the JBoss
Server and select Publish to publish the project on the server. You can check the deploying result
in the Console view.

10
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The Run and Debug options work on ESB projects causing a (re)deploy for a user designated
server.

You can also use the "Finger touch" for a quick restart of the project without restarting the server:

500 [ EHG & @B |F b K O

Figure 2.10. Finger Touch button

The "Finger" touches descriptors dependent on project (i.e. web.xml for WAR, application.xml for
EAR) and now it is also available for jboss-esb.xml in ESB projects.

You can also deploy your ESB project as an .esb archive. Right-click on the project, choose Export:

11
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Mew >
Go Into

Open in Mew Window

Open Type Hierarchy F4
Show In shift+Alt+w >
1% Copy Ctrl+C
s Copy Qualified Mame
[ Paste Ctr+v
¥ Delete Delete
Build Path >
Source Shift+Alk+S »
Refactor Shift+ak+T »
=3 Import...
< Refresh Fs

Close Project
Clese Unrelated Projects
Assign Working Sets...

%) Convert to Drools Project

Fun As >
Debug As >
Profile As >
Validate

Teamn >
Compare With »
Restore from Local History..,

|Boss Tools >
Wweb Development Tools >
PDE Togls >
Properties alt+Enter

Figure 2.11. Export of ESB project

Choose ESB > ESB File and click Next:
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L; Export X

Select
ESE File

o>

Select an export destination:

|t:.-pe filter text I

B

P = General

P = BPMMN

F =EB

- = ESB

P = Java

b & Java EE

B = JavaScript

I = Plug-in Development
b = FunDebug

Figure 2.12. Choosing ESB File

And finally export the ESB project to the file system: choose the destination, choose the target
runtime if need a specific one and make the appropriate settings for the archive. Then click Finish.
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L; Export
ESB Export J
Export an ESE project to the local file system. @
. |
ESB Project: | ESBtest v

Destination: Lrhumefusarnuurlcspace.lisstastﬁSEtast.e:I 'v [Emwsa...

Target Runtirme

| Optimize for a specific server runtime

| Export source files
[[] Overwrite existing file

\)Boss 4.2 AURtime

|3

Figure 2.13. ESB Export

Your project is deployed as an .esb archive.

An ESB archive can be created for ESB projects only. It is also possible to deploy an .esb archive

to a JBoss AS based server with JBoss ESB installed.

2.5. Creating a ESB File

In this chapter we suggest a step-by-step walk-through of creating your own simple file. Let's try

to organize a new ESB file.

We will show you how to use the Creation wizard for creating a new ESB file.

At first you should open any project. Select File >New > Other... in the main menu bar or context

menu for selected project and then ESB > ESB File in the New dialog:

14
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Select a wizard —
Create a ESE XML File r_

ﬂb;;ilrds:
(type fiter text |

b (= General B
I (= Connection Profiles

b = cvs

I (= Eclipse Modeling Framework
b =ER

= = ESB

I (= Example EMF Model Creation Wizards

T

[a]

@ [ <pack ]! Mext > ” Einish H Cancel

Figure 2.14. Select a wizard - ESB File

Clicking Next brings you to the wizard page where a folder, a name and a version for the file
should be specified. Choose, for example, jboss-esb.xml as the name and accept the selected
projects folder and the default version.

15
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£ New ESBE Flle x
ESB Flie

Lss

Folder:* [MelloWorid || Browse.. |

Marme:* []hﬂﬂﬂ-éﬂh ]

Version:*
1.1.0

® i) (o) (oo

Figure 2.15. Folder, Name and Version for ESB file

Thus, your file will be created in the selected projects folder by default. If you want to change the
folder for your future file click Browse... button to set needed folder or simply type it.

Clicking on Finish results in the file being generated. The wizard creates one xml file.

2.6. Configuring ESB Runtime in Preferences

In this chapter you will know how to predefine a JBoss ESB runtime on the Preferences page.

You may already know, there are two ways to set JBoss ESB runtime when creating a ESB project,
one is to use the project target JBoss runtime, and another is to select a JBoss ESB runtime
predefined in JBoss Tools preferences. Let's configure it.

Select Window >Preferences > JBoss Tools > JBoss ESB Runtime , to open the JBoss ESB
Runtime Preferences page where you can add, remove and Edit a JBoss ESB runtime.

16
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[pe fiter texd |

b Help

HOL editor
B Instanupaate
= Java
I+ Appearance
= Build Path
Classpath Variabh
User Libraries
Code Style
Compiler
Debug
Editor

v T T v v

Installed |REs
JUnit
Properties Files Edito
P JavaScript
I |Boss [BPM
= |Boss Tools
b web
|PA
B Flug-in Development
Preject Archives
P Report Design
I FunDebug

I Server

Freferences

JBoss ESB Runtimes

Name

|bossesb-4 3.G 4.3

Versio: Path

Momefuser/Eclipse/jbossesb-4 3.GA

d
Edit

Remove

1R

] [ Cancel

Figure 2.16. JBoss ESB Runtimes

Select Add to open a dialog where you can specify the JBoss ESB runtime location, name and
version number. You also can customize the libraries of the runtime by checking the Customize
JBoss ESB Runtime jars checkbox.
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L3 New |Boss ESBE Runtime x

JBoss ESB Runtime
Create a |Boss ESB Runtime

Mame: ljhnssesb-se rvar-d 4 GA
Version 44 3
 S——

Home Folder; IIJBD:'-SE SBibossesb-server-4.4.GA

[[] Customize |Boss ESE runtime jars

@ | Finish .| Cancel

Figure 2.17. Configure new JBoss ESB Runtime

The new JBoss ESB Runtime will be configured. Click OK to finish and save the preferences.
You can use the configuration when creating a JBoss ESB project.

When a ESB runtime is configured for your ESB project you are able to change it to any other
using the classpath container page for ESB runtime. To do that, turn to the Package Explorer view
and right-click the "JBoss ESB Runtime" library. Select Properties and a table listing all available
JBoss ESB runtimes will appear:

18
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Properties for |Boss ESB Runtime [jbossesb-serverd. 4.GA]

JBoss ESB Library -
Classpath Container Select a ESB runtime to add to the project classpath
MName Runtime Type
“J jboss-soa-p4.3.0 Server Contained
“d jbossesh-serverd 4.GA Server Contained
@ | Cancel

Figure 2.18. Classpath Container Page to change ESB runtime
Choose one of them to set to the ESB project and click Ok.

ESB container allows Source and JavaDoc locations to be set via the Properties dialog on each
contained .jar: right-click on any .jar file, select Properties. Choose Java Source Attachment and
select location (folder, JAR or zip) containing new source for the chosen .jar using one of the
suggested options (workspace, external folder or file) or enter the path manually:

19
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Properties for fhomefuser/ibdevstudiofjbossesb-4.4.GAflibfjbossesb.esb/management-client.jar
Java Source Attachment o -
Guwnor select the location (folder, JAR or zip) containing the source for 'management- ——————
client jar' Workspace. ..
Javadoe Location Location path: | | External file... |
Mative Library | External Fglder...
[Restare Defaults | | Apply |

Figure 2.19. Classpath Container: Java Source Attachment
Click on Apply and then on Ok.

To change Javadoc Location choose Javadoc Location and specify URL to the documentation
generated by Javadoc. The Javadoc location will contain a file called package-list:

20
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Properties for fhomefuser/ibdevstudiofjbossesb-4.9.GA/libfijbossesb. esb/management-client.jar

type filter text | Javadoc Location o -
Guwnor specify the location (URL) of the documentation generated by Javadoc. The Javadoc location will
Java Source Attachment contain a file called '‘package-ist'.
Javadoe Location ® Javadoc URL (e .g. 'http:fwww.sample-url.ergidocs or ffile e imyworkspacefmyproject/doc')
Mative Library Javadoc location path: [ . Browse...
walidate...

O Javadac in archive

Restore Defaults Apply
@ oK ] Cancel

Figure 2.20. Classpath Container: Javadoc Location

Click on Apply and then on Ok.

2.7. Using and Configuring SOA Platform

In this chapter you will know what is JBoss Enterprise SOA Platform and how you can configure
it to use for your ESB projects.

JBoss Enterprise SOA Platform delivers a flexible, standards-based platform to integrate
applications, SOA services, business events and automate business processes. The SOA
Platform integrates specific versions of JBoss ESB, jBPM, Drools and the JBoss Enterprise
Application Platform that are certified to work together in a single supported enterprise distribution.

Having configured JBoss Enterprise SOA Platform for your ESB project you don't need to install
and configure ESB server and runtime as they are already included.

Check here to find more details on the platform: JBoss Enterprise SOA Platform [http:/
www.jboss.com/products/platforms/soa] and JBoss Enterprise SOA Platform Component Details
[http://www.jboss.com/products/platforms/soa/components].

You can find out what is SOA here: Basics of SOA [http://lwww.jboss.org/jbossesb/resources/
SOABasics.html] and SOA and EOA [http://www.jboss.org/jbossesb/resources/SOAEOA.html].

To configure the JBoss Enterprise SOA platform select Window > Preferences > Server > Runtime
Environments, that will open the Server Runtime Environments Preferences page where you can
add, remove and edit a Server Runtime Environment.

21
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Preferences

[type filter text ] Server Runtime Environments

[ General —{ Add, remove, or edit server runtime environments.

b Ant Server runtime environments:

Mame Type Add...
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x
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7J |Boss 4.2 Runtime |Boss 4.2 Runtime [T
FreeMarker Editor . Edit...

b Data Management

5 “J |Boss 4.2 Server Adapter Rur |Boss 4.2 Runtime
Help

HQL editor
InstalliUpdate Search...
Java
JavaSeript
|Bass jBPM
|Bass Tools
JPa

Bemove

R A~

P Plug-in Development
Praject Archives
P Pun/Debug
¥ Server
Audio ]
Launching
Service Policies
P Spring
P Team

@ | oK | Cancel

[«]

Figure 2.21. Configure new Server Runtime Environment

Select Add, choose JBoss 4.2 Runtime as a type of runtime environment, check the Create a new
local server checkbox and click Next:
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KNew Sernver Runtime Environment

Mew Server Runtime Environment
Define a new server runtimea environment

Select the type of puntime environment:

[ope fiter texd |

= [ |Boss, a dvision of Red Hat (=]
7J |Boss 3.2 Runtime
7J |Bess 4.0 RFuntime

& |Boss 4.2 Runtime

‘¥ |Boss 5.0 Funtime =

7J |Boss Deploy-0nly Runtime

b (= Objectweb .
|Boss Application Server 4.2

1 Create a new local server

(i3] Back Fir Cancel

Figure 2.22. Type of Server Runtime Environment

On the next step you can specify a name of the server runtime environment and browse to its
location. Click Finish to add the server runtime environment.
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New Server Runtime Environment

|Boss Runtime Wizard

L
& @ cy Fed Hat

A |Boss Server runtime references a |[Boss installation directory.

It can be used to set up classpaths for projects which depend on this runtime,
as well as by a "server® which will be able to start and stop instances of |[Boss.

Name

[jl:rnss-sua-p 4.3.0 I

Home Directory

[fh ormefuserjjbdevstudiofjboss-soa-p.4.3.0/jboss-as/

JRE

|jdk1.5.0_12 & @

Configuration

1 minirmal
4 all

=i default
11 production

@ ik Mg Einish ] [ Cancel

Figure 2.23. New Server Runtime Environment Details

Now you have your SOA platform configured. To check the configuration create a ESB Project
using instructions described here. As a result you will have two projects created:

24
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e Exploré

1 helloworld
b @ sre
b =4 |Boss ESE Runtime [jboss-soa-p.4.3.0)
b =i JRE System Library [jdk1.5.0_12]

= build
b = esbcontent

-

& helloworld_testclient

B @8 sre
B =4 |RE Systemn Library [|25E-1.5]
[* =i |Bess ESE Funtime [jboss-saa-p.4.3.0]
P md Referenced Libraries
= build

Figure 2.24. Helloworld Projects Created

Then you will need to add JBoss ESB libraries to your projects to configure the SOA server runtime
exactly for your projects. Right-click on your project, select Build Path > Add Libraries:
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Mew >
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Figure 2.25. Add Libraries

Choose JBoss ESB Libraries and click Next:
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Add Library

Add Library
Select the library type to add,

Connectivity Driver Definition
EAR Libraries

J2EE 1.3 libraries

JZ2EE 1.4 libraries

|Boss EJB3 Libranes

|Boss ESB Libraries
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|RE Systemn Librany
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JUnit

Plug-in Dependencies
Server Funtime

User Library

Web App Libraries

®

Cancel

Figure 2.26. ESB Libraries

Select the necessary runtime to add to the project classpath:
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¢ Add Library
|Boss ESB Library
Select a ESE runtime to add to the project classpath

MName

= jboss-soa-p.4.3.0

Runtime Type

Server Contained

[2]

(] < gack

Finish | Cancel

Figure 2.27. Select a ESB runtime

Click Finish.

Now you can deploy your Helloworld project to the server and run a test class in the client Java

project to see the test result in the Console view.
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ESB Editor

ESB editor has lots of useful features, they are described in details in this chapter. In addition
you'll get to know with how ESB Editor uses combined visual and source editing of esb files.

3.1. ESB File Editor

ESB File Editor is a powerful and customizable tool. ESB File Editor allows developing an
application using ESB technology.

ESB file editor has two tabs: Tree and Source.

You can switch to Tree. The Tree view for the editor displays all ESB artifacts in a tree format. By
selecting any node you can see and edit its properties which will appear in the right-hand area.

For example, a Provider:

(77 jboss-esh.xml 22

JBoss ESB Editor

» jboss-esh

< (@ jboss-esb.xmil

= = Providers

- 3 |BossMQ
= oqp quickstartGwChannel
“F Filter
= o guickstartEsbChannel
7 Filer

= = Services

= &), SimpleListener
= [ Listeners
b @ Ms-Gateway
b @ helloworld
= L Actions
@ actionl
@ action2
‘& testStore

Tree | Source

al |E)

- |[MS Provider

Mame: |JBossMQ

Connection Factony: | ConnectionFactory

- Properties

MName alue

= Channel list

(o]

guickstartGwChannel

quickstartEsbChannel

= Advanced

Add...

Figure 3.1. Tree View

You can easily switch from Tree to Source by selecting the Source tab at the bottom of the editor

and work in Source view.
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|E‘; jposs-esb xmi 2 =0

=7xml version="1.8"7=
<jbossesh
xmlns="http:/s/anensvn.labs. jboss. com/labs/ jbossesb/trunk/product/etc/schemas/»
xmlns:xsi="http:/ www.w3.org/ 2001/ XMLSchema- instance" xsi:schemalocation="httf
=providers>
<jms-provider connection-fTactory="ConnectionFactory” name="JBossM]"
=property name="property® value="0"/=
<jms-bus busid="5StartGwlhannel” />
=jms-bus busid="5tartEsbChannel” >
=property name="time" value="0"/>
=/ ]ms-bu 5=
<jms-bus busid="intakeServiceEsbChannel” /=
<jms-bus busid="discountServiceEsbChannel® /=
=jms-bus busid="shippingServiceEsbChannel® /=
=jms-bus busid="conciergeServiceEsbChannel™ />
=</ ims-providers>
</providers=
<SEryicess
=service category="starter” description="starter® name="StarterService®=
=Listeners>
<jms-Listener busidref="StartEsbChannel® name="ESB-Listener" /=
=flisteners=>
</services
<service category="intake" description="this is intake service® name="Intaket
=listenars>
=jms-Llstener busidref="5tartEsbChannel” name="ESB-Listener" />
=flisteners=>
<actionss
(4] D]

Tree Source

Figure 3.2. Source View

[a]

The Source view for the editor displays a text content of the ESB file. It is always synchronized

with Tree view, so any changes made in one of the views will immediately appear in the other.

No matter what view you select, you get full integration with Outline view. For example, you can
work in the Source view with the help of the Outline view. The Outline view shows a tree structure
of the ESB file. Simply select any element in the Outline view and it will jump to the same place

in the Source editor, so you can navigate through the source code with Outline view.
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| jposs-esb.xmi 2 =08

<?xml version="1.0"7> 2
<jbossesb
xmlns="http://anonsyn. labs. jboss. com/labs/ jbossesh/trunk/product/etc/ schemas/»
®MLlns: xsi="http://www. w3.org/2001/XMLSchema- instance® xs51:schemalocation="http
<providers>
<jms-provider connection-factory="ConnectionFactery” name="JBossM]" =
=property name="property” wvalue="0"/>
<jms-bus busid="StartGwChannel™/>
<jms-bus busid="StartEsbChannel”=
<property name="time" value="0"/>
=fims-bus>
<jms-bus busid="intakeServiceEsbChannel® /=
<jms-bus busid="discountServiceEsbChannel” />
=jms-bus busid="shippingServiceEsbChannel” />
=jms-bus busid="conciergeServiceEsbChannel® /=
</jms-provider>
</providerss
<servicess
=service category="starter” description="starter® name="5tarterervice”>
=<listeners>
=jms-Listener busidref="StartEsbChannel” name="ESB-Listener®/=>
=flisteners>
</services
<service category="intake® description="this is intake service" name
<listeners>
<jms-Listener busidref="StartEsbChannel® name="ESB-Listener®/=
=flisteners>

(4l

<actionss>

i I [»)

feoune -0

= 1 jboss-esb.xml
= & Providers

@ property
b o StartGwChannel
b o StartEsbChannel

B < intakeServiceEsbChannel

w = Services
b & starterService
b &) IntakeService

B o< discountServiceEsbChannel
I o< shippingServiceEsbChannel
B #< conciergeServiceEsbChannel

[
Tree | Source |

Figure 3.3. Outline View

Adding, editing or deleting of some artifacts operations are available right in the Tree view . Right-
click any node and select one of the available actions in the context menu. For example, you can

easily add a new Provider:

JBoss ESB Editor

» jboss-esh « Providers

= @ jboss-esb.xml Mame

o . |BR Provider...
= ogr q o _ ) Schedule Provider...
¥ Kote  ouee
= ol g ) |CA Provider...
Properties )
i : FS Provider...
- B Services FTP Provider...
SOL Provider...

< ), simpleListener
= [& Listeners Hibernate Prouider.._.

b @ MS-Gatewa

b & helloworld

I E@ Actions

a D)

D o rrovder. I | oo ]

Tree] S:nuﬂ:a|

Figure 3.4. Adding New Provider
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Then you can add Channels and Properties for the Providers the same way or using the forms
with Add, Edit and Remove buttons to the right.

You can easily add a new Service too:

JBoss ESB Editor

- _IDGIE-I'IH -~ Services

= L. jboss-esh xmil* name

P = Providers StarterService

b &) StarterService
= &) IntakeService
= [ Listeners ¥ Delete Delete
= ) ESB-Lister
“F Filter
= [ Actions
= & dumpl
o property

Properties. .,

Tree Source

Figure 3.5. Adding New Service

The same way you can create a listener for service and other elements of ESB:

JBoss ESB Editor

~ |boss-esb - Listeners

I = Providers name

- = Services ESB-Listener

= B StarterService

EH

b @ EsB-Lis o ) Scheduled Listener... D
kg Actions ki i+ R ; |
= ) IntakeService X Delete Delete | JMS Listener. . 5
= [= Listeners FS Listener e
b & ESB-Listener o Peres FTP Listener...
= 3 Actions SQL Listener...
B % dumpl Hibernate Listener...
(5] ] D |BR Listener. ..

Groovy Listener...

Tree Source

Figure 3.6. Adding New Listener for Service
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The same actions can be done in the right part of Tree view tab (Form editor) using Add, Edit
and Remove buttons.

In order to add a new generic Action to your ESB XML file you should select the Actions node
under the Services, then right-click and choose New > Generic Action.

JBoss ESB Editor
- jboss-esh = Actions List
= i jboss-eshxmi MEP: [Oneway vl
= & Providers
Acti
b 4 jBossMg v Actions
Mame

= [ Services

[ & Listeners action2 Remove...
o | | testStore
L object Invoke... | ; |
> -
| R Delete Delate Byte Array To String...
% _ Long To Date...
Properties

Object To CSV String...
Object To XStream...
Smooks Action...
Srmooks Transformer...
Message Persister...
xStream To Object...
Command Interprater...

Groovy Action Processar..,

Aggregator...

(=] il 7] Content Based Router...
Static Router...

Static Wiretap...
Motifier...

'I'I'qels-uurcn|

SOAP Processor...
SOAP Client...
System Println...

Figure 3.7. Adding New Action in the Tree View

Or instead make use of Add... button in the Form editor on the left.
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boss-esboml &

]Boss ESB Editor

= jboss-esh
= ] jboss-esbxml
= [ Providers
b 4 jBossMQ
= = Services
< #) simpleListener
I (= Listeners

% actionl
% action2
% testStare

al m B

=8
= Actions List
MEP; |I0nn‘Miy [ W ]l
» Actions
Mame

actionl

action2
testStore

[ Object Invoke...

{ Byte Array To String...

[ Object To CSV String...

Long To Date...

Object To XStream...
Smooks Action...
Smooks Transformer...
Message Persister...
XStream To Object...
Command Interpreter...

Groovy Action Processor...

Aggregator...

Tree | Source|

Content Based Router...

Figure 3.8. Adding New Action in the Form Editor

Static Router...
Static Wiretap...
Motifier...

SOAP Processor...
SOAP Client...
Systern Println...

As you can see on the bath figures above, the context menu will also prompt you to insert one
of the Actions that are supplied out-of-the-box with JBoss ESB. After choosing one an appeared
New Action wizard will ask you to fill out a name field and other fields specific for each Action
property. For example, for Content Based Router Action the wizard looks as follows:
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Add Content Based Router

ESB Content Based Router

Attribute Mame must be set. 0
Mame:* I ]
Process: f | vl
Rule Set:* | |
Fule Language: | |
Rule Reload: |Defaultifalse) | v |

(i) I | Cancel

Figure 3.9. New Action Wizard

After confirming creating the Action you can see itin the Tree under the Actions node and preview
as well as edit its settings in the Form editor on the left.
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= = "o
JBoss ESB Editor

» jboss-esh = Content Based Router Action
= @ jboss-esb.xml Mame: |CuntentEasedﬁnuter |
P = Providers -
) Class: | org jboss.soa.esh.actions.ContentBasedRoutel |
¥ = Servicas
< &, simpleListener Fule Set: |M}rESEIHa!es-XPath.dr| |
P (& Listeners Fule Language: |><PathLanguage.dsI |
= kg Actions | |
Fule Reload: true ~
|
& express Process: [split | -

* Route List

Destination Mame Service Mame Add... |

Exprass ExpressShippingService |P-emvwe |
| Edit...

( [+)
'ITEE-.EBLIrtE
Figure 3.10. Form Editor for Content Based Router

ESB editor can recognize some specific objects. On the figure you can see
org.jboss.soa.esb.actions.ContentBasedRouter in the Class section.

3.2. ESB Editors Features

JBoss ESB tooling has powerful editor features that help you easily make use of content and
code assist.

This last chapter covers capabilities on how you can use ESB editor.

3.2.1. ESB syntax validation

When working in JBoss ESB editor you are constantly provided with feedback and contextual
error checking as you type. In the Source viewer, if at any point a tag is incorrect or incomplete,
an error will be indicated next to the line and also in the Problems view below.

3.2.2. Support for XML Schema

JBoss ESB Framework fully supports XML files based on schemas as well as DTDs.

The schema checks the child elements of any kind of provider element; the ESB generates errors
on startup if you attempt to define an incorrect combination (e.g.: a jms-bus inside an ftp-provider).
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3.2.3. Content Assist for ESB XML file

When you work with any ESB XML file Content Assist is available to help you. It provides pop-
up tip to help you complete your code statements. It allows you to write your code faster and with
more accuracy. Content assist is always available in the Source mode. Simply type Ctrl-Space
to see what is available.

Content Assist for ESB XML file:

m Hboss-esh xml ¥

D/

<7xml version="1.0"7=

=jbossesb
xmlns="http://anonsvn. labs. jboss. com/labs/ jbossesb/trunk/product/etc/schemas/xml/jbossesh-1.90.1, xsd”
XMLns: KS1="http: //www.w3.0rg/2001/XMLSChema- instance™ xsi:schemalocation="http://anonsvn.labs. jboss. com/Lal

I <providers>

-

3 bus-provider fElement : jms-provider
Content Model : ((property*), (bus-))

<> fs-provider

< » ftp-provider

< » hibernate-provider
<> |br-provider

<> [ms-jca-provider
oy spoviger |
< » schedule-provider

]
={ <> sgl-provider

(4l

</listanasres

ﬁ{fmurﬂe]

il I D]

Figure 3.11. Content Assist for ESB XML file

Content Assist for attributes:
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=0

LA BEINGSE FVICEE SOLAaNnEL " /
=jm5-bus busid="conciergeServiceEsbChannel® />
=/ ims-providers
</providerss
<S5EMV1CES>
=service =

bl |}

<jms-Li e service category which will be used to store a reference to

=f1isten|
=/ 5ervice
<service

“® description

“® name

this service in the registry.

Data Type : string

<listene
=jms-1i
</listen
=actiony
<action

<D rope
efactio
<faction
</service
<fservices
=/ bos5es5Dh>

] 0]

Tree Source

Figure 3.12. Content Assist for attributes

3.2.4. OpenOn for ESB XML file

ESB file comes with the OpenOn feature that allows to make use of multiple file references in the
file just with a click and the Ctrl key hold down.

The OpenOn is implemented for different types of files/pages inside the <act i on> tag: .xsd, .xml,
etc.
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dest-name="queuesquickstart_helloworld Request_gw*® dest.type=*QLELE"/=
</ jms-bus=>
<jms-bus busid="quickstartEsbchannel =
=]ms-message-f1lter
dest-name="queve/squickstart_helloworld Request_esh” dest-type="QUELE"/>
</ )ms-bus>
<fms-provider>
</providers>
“servicess
<service category="FirstServiceEss" description="Helle world” name="Simplelistener®
=listeners=>
<jms-Listener busidref="quickstartGwChannel” is-gateway="true” name="JM5S-Gateway"
<)ms- Listener busidref="quickstartEsbchannel” name=*helloworld® /=
=flisteners=>
=actlons meps"Onelay"s
=action
class="org. jboss.soa.esb.samples. quickstart.helloworld. MyJMSLIstenerdction®
name=*actienl® process="displayMessage” /=
<action class="org.jboss.soa.esh.actions.SystemPrintln® name="action2*>
<property name=*message"/>
<property name="printfull® value="true*/>
<factions
<!.. The next actien 1s for Continuous Integration testing --=
<action class="org.jboss.soa.esb.actions. TestMessageStore® name="testStore"/>
=action class="org.jboss.soca.esh.smooks.SmooksAction® name="smooks”=
<property name="smooksConfig® value='ﬂ@£ﬁm@ﬂﬂ_fuﬂ'!”
<factions
=factions=
< SErvice»

[<] I 1]

[}

(=]

Tree Source

Figure 3.13. OpenOn for smooks configuration file

It is also available for classes:
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<jms-bus busid="quickstartEsbChannel "=
<jms-message-filter
dest-name="gueue/quickstart_helloworld Request _esb* dest-type="QUELE*/=
<f1ms-bus>
</]ms-provider=
</providerss
<Servicess
<service category="FirstServiceEss" description="Hello World” name="SimpleListener®
<listeners=>
<jms- Listener busidref="guickstartGwChannel” is-gateway="true” name="JMS- Gateway"
<jms- Listener busidref="quickstartEsbchannel” name=~helloworld" /=
=/listeners>
<actions mep="0OnekWay"=
<action
class="org. .s0a.esbh. . k
name="actionl® process="displayMessage®/>
=action class="org.jboss.soa.esh.actions. SystemPrintln® name=*action2®=
<property name="message” /=
<property name=*printfull® value=*true® /=
=factlion=>
<l-- The next actien 1s for Continuous Integration testing --=
<action class="org.jboss.soa.esb.actions.TestMessageStore® name="testStore”/>
<action class="org. jboss.soa.esh.smoocks. Smooksdction® name="smooks”>
=property name=*smooksConfig® value="META-INF/smooks-config.xml®/=
=factlon=>
<factionss>
=fsErvices
<fServicess
</1bossesb=

[<] [ 1]

E

Al

Tree | Source

Figure 3.14. OpenOn for classes

3.2.5. Synchronized Source and Visual Editing

ESB file can be edited in either source or extra visual modes at the same time.

JBoss Tools provide you two different editors to speed your development: a graphical view (Tree)

and source (Source). At the same time, you always have full control over esb source file.

Any

changes you make in the source view will immediately appear in the tree view. Both views are

synchronized, you can edit the file in any view.
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-

JBoss ESB Editor

- jhoss-ash
- W jboss-esh.xmi*
= = Providers
+ % |BossMQ
@ property
I e StartGwChannel
= onr StartEsbChannel
o time
7 Fitter
b adr intakeServiceEsbC
b oo discountServiceEs
b esr shippingServiceEs

= I Services
b & starterservice
= Bl IntakeService
= = Listeners
= ) ESB-Listener
“F Filter
= lgp Actions

b @ dumpl

Tree | Source|

P e conciergeserviceE —

= |boss Esb

=7xml wversion="1.8%7=
<jbossesh
xmlns="http:/fanonsvn.labs. jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/ jboss
X¥MLNS: XS1="hTTp://www. w3, 0rg/2001/XMLS5chema- instance™ xsi:schemalocation="http://anons
<providers=>
<jms-provider connection-factory="ConnectionFactory” name="J]BossMQ" >
=property name="property” value="0"/>
=jms-bus busid="StartGwChannel” />
<jms-bus busid="StartEsbChannel”=>
<property name="time® value="8"/>
</ jms-bus>
<jms-bus busid="intakeServiceEsbChannel®/>
=jms-bus busid="discountServiceEsbChannel” />
=jms-bus busid="shippingServiceEsbChannel® />
=jms-bus busid="conciergeServiceEsbChannel” />
</jms-providers>
=fproviders>
<servicess
<service category="starter® description="starter® name="StarterService®>
=listeners>
<jms-listener busidref="StartEsbChannel”
</listeners>
</service=
=service categery="intake" description="this is intake service® name="IntakeService":
<listeners=
<jms-listener busidref="StartEsbChannel”
=/listeners>
<actions>
=action class="dumpClass® name="dumpl®>
=property name="property” value="g"/=
<faction=
<factions>
</services

name="ESB- Listener" />

name="ESB-Listener® />

I D]

Tree Source

[4]

Figure 3.15. Two Views are Synchronized

In summary, this reference supplies you with all necessary information on the functionality that
JBoss ESB Editor provides for work with JBoss ESB.

We hope, this guide helped you to get started with the JBoss ESB Tools. Besides, for
additional information you are welcome on JBoss forum [http://www.jboss.com/index.html?
module=bb&op=viewforum&f=201].
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