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Chapter 1. Introduction

Introduction

1.1. What is ESB and JBoss ESB Tools?

ESB (Enterprise Service Bus) is an abstraction layer on top of the implementation of an
enterprise messaging system that provides the features that Service Oriented Architectures may
be implemented with.

If you want to develop applications using ESB technology JBoss ESB also meets your needs.
Read more about Jboss ESB at http://www.jboss.org/jbossesb.

JBoss ESB Tools provide an ESB editor and necessary wizard for creating an ESB file.

In this guide we provide you with the information on JBoss ESB Tools (installation, configuration
and deployment) and usage of ESB Editor which allows you to develop an ESB file much faster
and with far fewer errors so sparing your time.

1.2. Key Features of ESB Tools

For a start, we propose you to look through the table of main features of ESB plugin:

Table 1.1. Key Functionality of ESB Tools

Feature Benefit ‘ Chapter

JBoss Tools Project  Some kinds of projects with predefined Using ESB Project

Examples Wizard structure are available for usage. Examples
JBoss Enterprise The SOA Platform integrates specific versions Using and configuring
SOA Platform of JBoss ESB, jBPM, Drools and the SOA Platform

JBoss Enterprise Application Platform that are
certified to work together in a single supported
enterprise distribution.

ESB Editor JBoss ESB tooling has powerful editor features
including syntax validation, support for XML
Schema and other.

1.3. Requirements and Installation

This section will provide you with the information on how to install JBoss ESB plugin into Eclipse.

ESB Tools come as one module of JBoss Tools project. Since ESB Tools have a dependence
on other JBoss Tools modules we recommend you to install a bundle of all JBoss Tools plug-ins
[http:/Nlabs.jboss.com/tools/download.html]. You can find all necessary installation instructions on
JBoss Wiki in the InstallingJBossTools [http://www.jboss.org/tools/download/installation] section.
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Tasks

In this section we will focus on all concepts that JBoss Tools integrate for working with JBoss ESB.

2.1. Creating a ESB Project

In this chapter we suggest a step-by-step walk-through of creating a new ESB project. Let's try
to create a new JBoss ESB project.

We will show you how to use the ESB Project Creation wizard for creating a new ESB project and
setting basic ESB classpath.

Select File >New > Project... in the main menu bar or context menu for selected project and then
ESB > ESB Project in the dialog opened:

Select a wizard p—

Wizards:

L S =

[2]

I+ = Eclipse Modeling Framewerk
b E=EB
- [=ESB

¥ ESB Action

E% ESE File
"
[= Example EMF Model Creation Wizards
= Java
= Java EE
= Java Ermitter Termplates
[= JavaScript

= |Boss Toals

A A~ A~ A~ A~

= |Bass Toals web -

Figure 2.1. Select a Wizard dialog

Clicking Next brings you to the JBoss ESB Project wizard page where a project name, ESB
version and target JBoss Runtime are to be specified. Specify, for example, helloworld as a
Project name and accept the default ESB version.
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MNew ESE Project Wizard

|Boss ESB Project

Create a new |Boss ESE project, J'H

Project name: [hellowurd

-Project contents

R Use default

Target runtime

UBoss42funtime

|Boss ESE version:

|:4.? 3]

-Configuration

[ Cefault Configuration for |Boss 4.2 Auntime = [Mudify...]

& good starting paint for werking with |Bess 4.2 Runtime runtime. Additienal
facets can later be installed to add new functionality to the project.

@ [ =< Back ] Taxt = Il cancel |

Figure 2.2. JBoss ESB Project wizard

By clicking Modify button you can open Project Facets Wizard page,where you can select facets
that should be enabled for this project. On the Project Facets Wizard page you can also configure
runtime for the application




Chapter 2. Tasks

Froject Facets

Project Facets 3
Select the facets that should be enabled for this project. \V?
Configuration: | Default Configuration for |Boss 4.2 Runtime = | Save As,. [ Delete
Project Facet \ersion |Deta||s| Runtimes
¥ ) Java 5.0 ~ |Boss ESB 4.7

] = JavaScopt Toolkit 1.0
&= |Boss ESE 47 . ]
Requires the following facet:

[J] Java 3.0 or newsr

@ | Cancel (]4

Figure 2.3. Project Facets Wizard
Next step provides you an opportunity to configure your project for building a java application

Clicking Next on this form brings you to the ESB facet installation page where you can specify
Java Source Directory and ESB Content Directory. ESB Content Directory is a folder that contains
the most of artifacts that an ESB archive needs. You also can configure ESB libraries to the project
by selecting a ESB runtime using one of the options:

1. Use Server Supplied ESB Runtime

2. Select a ESB runtime from the JBoss ESB runtime list predefined in the preferences. If you
choose the first option, make sure that the project has the Target JBoss Runtime set and this
runtime has a ESB runtime installed.

3. Choose ESB Config Vertion. From the version 3.1.0 JBoss ESB Tools supports three different
jboss-esb.xsd versions: jbossesb-1.0.1.xsd, jbossesb-1.1.0.xsd and jbossesb-1.2.0.xsd.

@ Note:
If you use ESB 4.7 you should select jbossesb-1.2.0.xsd.
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€ New ESB Project Wizard

Install ESB Facet

Froject Folders
Content Directory

Ieshcuntent

Java Source Directory

ISI’E

JBoss ESB Runtime
(% Server supplied ESB Runtime

) | jbossest A :-!:-

l ESB Config Versian

Figure 2.4. Install ESB facet step

Click Finish and a ESB project with the default jboss-esb.xml will be created.

E‘v,w'g si = 0|7 jposs-esb.xmi 5

| )Boss ESB Editor

= ' hellowortd

= |boss-esh = |Boss ESB
@ src = & |boss-esb.xml
P\ |RE Systemn Library [|c b 2 Slobals
P ®i |Boss ESB Runtime & Providers Parameter Reload Secs
P mi |JBoss 4.2 FAuntime [JB & Sarvices = Providers
(= build Name
¥ = esbcontent
= ]
= = META-INF
24 jboss-esb.xmi
I I
* Services
Name
Tree | Source |

Figure 2.5. The generated ESB project structure

| jposs-esb

B

[«]
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2.2. Using ESB Project Examples

JBoss Tools provides a Project Example wizard that is an easy way for users to create some
kinds of projects to be used as examples with some predefined structure. Let's start creating a
ESB project using this wizard.

Before creating a ESB project example create JBoss Runtime with name JBoss 4.2 Runtime, it
will be used by your ESB project example.

Select File >New > Others , in the main menu bar or context menu for selected project and then
JBoss Tools > Project Examples in the New dialog:

Select a wizard —

Wizards:

[Fpe riertexd

= Java EE
=

Java Emitter Ternplates

= |Boss |BPM

= |Boss Tools
-

I = MBean Components
P (= |Boss Tools Web

b
b
P = JavaScript
b
-

o]

® - =N

Figure 2.6. Select a wizard - Project Examples

Clicking Next brings you to the wizard page where you can select a ESB project example from
the example list.
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Project Example FQ
Import Project Example —r
[ ishow experimental sites !
site: | all g |
Projects:
|type filter text |
I BPEL
Seam

B
b RESTEasy

I ESB for SOA-P 5.0
b

B

Portlet
ESB

Description:

1 Show the Quick Fix dialog

@ T e

Figure 2.7. Project Example Wizard
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It means that if you use a runtime pointed to a SOA-P 5.0, you should download
the examples from the ESB for SOA-P 5.0 category in order to avoid the
incompatibility errors.

Every ESB example has two projects, one is a ESB project and another is a Java project used
to test the ESB project.

Here is a list of ready examples available in both categories (ESB and ESB for SOA-P 5.0):

» JBoss ESB HelloWorld Example - demonstrates the minimal files necessary to make a basic
ESB component execute as well as to prove that the ESB is properly configured.

» JBoss ESB HelloWorld Action Example - demonstrates the use of multiple action invocations
from a single configuration. You can use a single Action class and make multiple method calls
or use multiple Action classes.

« JBoss ESB HelloWorld File Action Example - demonstrates using the File gateway feature
of the JBoss ESB. Files that are found in a particular directory with a particular extension are
sent to a JMS queue with actions for processing.

« JBoss ESB Web Service consumerl Example - demonstrates how to consume a 181 Web
Service in an ESB action.

» JBoss ESB Web Service producer Example - demonstrates how to deploy a JSR181
Webservice endpoint on JBossESB using the SOAPProcessor action.

« JBoss ESB Smooks CSV -> XML Example - demonstrates how to transform a comma
separated value (CSV) file to an XML.

* JBoss ESB Smooks XML -> POJO Example - demonstrates the use of Smooks performing
a simple transformation by converting an XML file into Java POJOs.

« JBoss ESB Smooks XML -> XML date-manipulation Example - demonstrates how to
manually define and apply a Message Transformation within JBoss ESB.

» JBoss ESB Smooks XML -> XML Example - a very basic example of how to manually define
and apply a Message Transformation within JBoss ESB. It applies a very simple XSLT to a
SampleOrder.xml message and prints the before and after XML to the console.

We will take as our example JBoss ESB HelloWorld Example ESB and Client project:
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£ New Project Example

Project Example
lmpart Project Example

b Portlet
= ESB
|Boss ESB HelloWorld Example - ESB

JBoss ESE HelloWorld Example - Client

|Boss ESB HelloWorld Action Example - ESB £l
-

Description:
Project name: | ]
Project size: | |
URL: | |

7 . Next I Finish ” Cancel

Figure 2.8. JBoss Tools ESB Project Examples

Choose them using the Ctrl button and then click Finish. As a result you will get two projects

created:
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! Package Expl X ESEWED Projects| . Seam Compo =5

|
| - & helloworld |
7 [ src

I #4 org jooss soa esb.samples quickstart helloworld
P = JRE System Library [|25E-1 5]

B |Boss ESE Runtime [JBoss 4.2 Runtime]
b =i\ |Boss 4.2 Runtime [|Boss 4.2 Runtime]

-

(= build
b ;= esbcontent

= = helloworld_testclient
b o®sre
b =4 JRE System Library [|25E.1 5]
[ =l |Boss ESE Auntime [JBoss 4.2 Runtime]
P =4 |Boss 4.2 Runtime [|Boss 4.2 Runtime]
b =\ Referenced Libraries

= build

Figure 2.9. JBoss ESB Project Examples: helloworld and
helloworld_testclient

Deploy the HelloWorld ESB project and run a test class in the client Java project to see the test
result in the Console view.

2.3. Deploying a ESB Project

In this chapter you will see how to deploy a ESB project using the WTP deployment framework.

Before deploying the project, open the Servers View by selecting Window > Show View > Other
> Server > Servers, create a JBoss Server in the Server view and start it, and then right click the
created JBoss server, select Add and Remove Projects, and add the ESB projects you want to
deploy from the left side to the right side in the opened dialog.

10
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Add and Remove Projects
Madify the projects that are configured on the server

Move projects to the right to configure therm on the server
Awvailable projects:

[ == Remove All

®

B

Configured projects:

& helloworid

| Bnish ” Cancel J

Figure 2.10. Add and Remove Projects

Click Finish to add the project to the server. You also can drag the ESB project from the Project

View to the server.

D Properties +Th Senvers &3

+ E|Boss 4.2 Server [Stopped)

| 4 Filesets
b (¥ XML Configuration

i healloworld

Figure 2.11. Servers View

11
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Thus, you have just added the ESB project to the JBoss server module list. Right click the JBoss
Server and select Publish to publish the project on the server. You can check the deploying result
in the Console view.

The Run and Debug options work on ESB projects causing a (re)deploy for a user designated
server.

You can also use the "Finger touch" for a quick restart of the project without restarting the server:

50 Qe B EG @ o D b H O

Figure 2.12. Finger Touch button

The "Finger" touches descriptors dependent on project (i.e. web.xml for WAR, application.xml for
EAR) and now it is also available for jboss-esb.xml in ESB projects.

You can also deploy your ESB project as an .esb archive. Right-click on the project, choose Export:

12
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Mew >
Go Into

Open in Mew Window

Open Type Hierarchy F4
Show In shift+Alt+w >
1# Copy Ctrl+C
s Copy Qualified Mame
[ Paste Ctr+v
¥ Delete Delete
Build Path >
Source Shift+Alk+S »
Refactor Shift+ak+T »
=3 Import...
< Refresh Fs

Close Project
Clese Unrelated Projects
Assign Working Sets...

%) Convert to Drools Project

Fun As >
Debug As >
Profile As >
Validate

Team >
Compare With »
Restore from Local History..,

|Boss Tools >
Web Development Tools »
PDE Togls >
Properties alt+Enter

Figure 2.13. Export of ESB project

Choose ESB > ESB File and click Next:

13
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L Export X

Select
ESE File

o>

Select an export destination:

|t:.-pe filter text I

[:]

P = General

P = BPMMN

F =EB

- = ESB

P = Java

b & Java EE

B = JavaScript

I = Plug-in Development
b = FunDebug

(4]

Figure 2.14. Choosing ESB File

And finally export the ESB project to the file system: choose the destination, choose the target
runtime if need a specific one and make the appropriate settings for the archive. Then click Finish.

14
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L Export
ESB Export
Export an ESE project to the local file system.

ESE Project: | ESBtest v

Destination: Lrhumefusarnuurlcspace.lisstastﬁSEtast.e:I 'v [Emwsa...

Target Runtirme

| Optimize for a specific server runtime

| Export source files
[[] Overwrite existing file

|¢»

\)Boss 4.2 AURtime

Figure 2.15. ESB Export

Your project is deployed as an .esb archive.

An ESB archive can be created for ESB projects only. It is also possible to deploy an .esb archive

to a JBoss AS based server with JBoss ESB installed.

2.4. Creating a ESB File

In this chapter we suggest a step-by-step walk-through of creating your own simple file. Let's try

to organize a new ESB file.

We will show you how to use the Creation wizard for creating a new ESB file.

At first you should open any project. Select File >New > Other... in the main menu bar or context

menu for selected project and then ESB > ESB File in the New dialog:

15
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Select a wizard F{}
Create a ESBE XML Fle b
Wizards:

|t}-'pe filter text |

PR e

12]

I* = Eclipse Modeling Framework

b EEE

- [=ESBE £
¥ ESB Action

" ESE File

% ESB Project
= Exarmple EMF Model| Creation Wizards
= Java
[= |ava EE
= Java Ermitter Termplates
[= JavaScript
= |Boss Taals

A A~ A A A A~

= |Bass Tools web

[<]

@ | = Back [ Mext = ] [ cancel Einich

Figure 2.16. Select a wizard - ESB File

Clicking Next brings you to the wizard page where a folder, a name and a version for the file
should be specified. Choose, for example, jboss-esh.xml as the name and accept the selected
projects folder and the default version.

16
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Mew ESB File

ESB File

Folder= [MEIIuwrd.f H Browse...

Marme* [jhngs -esh

Version® 1.0.1
1.1.0

@ [ = Back l  cancel

Figure 2.17. Folder, Name and Version for ESB file

Thus, your file will be created in the selected projects folder by default. If you want to change the
folder for your future file click Browse... button to set needed folder or simply type it.

Clicking on Finish results in the file being generated. The wizard creates one xml file.

2.5. Creating a ESB Action

From this chapter you will find out how to create a ESB Action Java File.

At first you need to open a ESB or simple Java project. Then you should select File > New>Other in
the main menu or from the context project menu. Then click ESB > ESB Action in the New dialog.

17
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Select a wizard p—

Create a ESE Action Java File

Wizards:

EFeva

[2]

[* = Eclipse Modeling Framework
L=
= [=ESB

= ESB Actian

B EsBFile

% ESB Project
[= Example EMF Model| Creation Wizards
= Java 1l
= Java EE

= Java Ermitter Termplates
[= JavaScript

= |Boss Toals

= |Bass Tools web

A A~ A~ A~ A~

(<]

@ [ oo [ ][ oo

Figure 2.18. Select a wizard - ESB Action

After that click Next and you will be brought to the New ESB Action wizard. In this wizard the class
name should be specified, also you can set a package or add a interface as for any Java class.

18
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New ESB Action

ESBE Action 3
Create a new Java class, Q

Source folder: |helloworld/src | [ Browse...
Package: |actions ] Browse...

[ Enclasing type:

Mame: [Action| ]
Maodifiars: @ public 1 default
[] abstract [] final
Superclass: | org.jboss.soa.eshactions AbstractActionPipelineProcessor ] [ Browse. ..
Interfaces: Add...

which method stubs would you like to create?
[] public static veid main{String[] args)
k1 Constructors from superclass
Inherited abstract methods
Do you want te add eornments? (Canfigure templates and default value hera)

] Generate commeants

@ [ < Back | Cancel Einish

Figure 2.19. New ESB Action wizard

As a result, the ESB Action Java File will be created in the selected package and it will have
org.jboss.soa.esb.actions.AbstractActionPipelineProcessor as superclass.

Clicking on Finish will generate the ESB Action class. Also this class will become available in ESB
Editor wizards.

2.6. Configuring ESB Runtime in Preferences

In this chapter you will know how to predefine a JBoss ESB runtime on the Preferences page.

You may already know, there are two ways to set JBoss ESB runtime when creating a ESB project,
one is to use the project target JBoss runtime, and another is to select a JBoss ESB runtime
predefined in JBoss Tools preferences. Let's configure it.

19



Chapter 2. Tasks

Select Window >Preferences > JBoss Tools > JBoss ESB Runtime , to open the JBoss ESB
Runtime Preferences page where you can add, remove and Edit a JBoss ESB runtime.

Eype riter tex) | JBoss ESB Runtimes Lv v
b Help -
HQL editor Mame Versio Path | Add

|bossesb-4.3.C 4.3 Momefuser/Eclipsejbossesh-4 3.GA

P InstalUpdate

= Java
J a Remove |

I Appearance

= Bulld Path
Classpath Variabl
User Libraries
Code Style
Compiler
Debug
Editor

T v T T v

Installed |REs
JUnit
Properties Flies Edito
P JavaScript
P |Boss [BPM
= |Boss Tools
b Web
JPA
I Plug-in Development
Project Archives
I Report Design
P Run/Debug
b

Server

@) ok || cancel

Figure 2.20. JBoss ESB Runtimes

Select Add to open a dialog where you can specify the JBoss ESB runtime location, name and
version number. It's also possible to define configuration if you point the home location to a Jboss
AS or SOA-p, in case you select a standalone ESB runtime location, the configuration combo will
be empty and should be ignored. You can also customize the libraries of the runtime by checking
the Customize JBoss ESB Runtime jars checkbox.

20



Chapter 2. Tasks

Mew |Boss ESB Runtime

|Boss ESB Runtime

Create a |Boss ESE Runtiime

Mame: [jbuss esb-server-4.4,GA

Varsion: |£1.d 2|

Home Folder: [/|BossESB/jbossesb-server-4 4.GA Browse... |

Canfiguration: [ default 2 | only for |Bass AS cantained ESE runtime

] Customize |Boss ESE runtime jars

@l | Cancel | Finish

Figure 2.21. Configure new JBoss ESB Runtime

The new JBoss ESB Runtime will be configured. Click OK to finish and save the preferences.
You can use the configuration when creating a JBoss ESB project.

When a ESB runtime is configured for your ESB project you are able to change it to any other
using the classpath container page for ESB runtime. To do that, turn to the Package Explorer view
and right-click the "JBoss ESB Runtime" library. Select Properties and a table listing all available
JBoss ESB runtimes will appear:

21
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Properties for |Boss ESB Runtime [jbossesh-4.7]

SEEEREEs == [Boss ESB Library P

Select 2 ESE runtime to add to the project classpath

[Jarme Runtime Type
# jbossesh-4.2 ESE Libraries Only
# jbossesh-4.7 ESE Libraries Only

! Manage ESE Runtimeas '

@ | cancel

Figure 2.22. Classpath Container Page to change ESB runtime
Choose one of them to set to the ESB project and click Ok.

ESB container allows Source and JavaDoc locations to be set via the Properties dialog on each
contained .jar: right-click on any .jar file, select Properties. Choose Java Source Attachment and
select location (folder, JAR or zip) containing new source for the chosen .jar using one of the
suggested options (workspace, external folder or file) or enter the path manually:

22
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Properties for fhomejuser/ibdevstudiofjbossesb-4.49.GAflibfjbossesb.esb/management-client.jar
kype filter text] Java Source Attachment o v
Guwnor Select the location (folder, JAR or zip) containing the source for 'management- e
client jar': Workspace...
Javadoe Location Logation path: || External Eile... |
Mative Library | External Fglder...
[Restare Defaults | | Apply |

Figure 2.23. Classpath Container: Java Source Attachment
Click on Apply and then on Ok.

To change Javadoc Location choose Javadoc Location and specify URL to the documentation
generated by Javadoc. The Javadoc location will contain a file called package-list:

23
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Properties for fhomefuser/jbdevstudiofjbossesb-4.9.GA/libfijbossesb.esb/management-client.jar

type filter text | Javadoc Location (o -
Guwnor specify the location (URL) of the documentation generated by Javadoc. The Javadoc location will
Java Source Attachment contain a file called '‘package-ist'.
Javadoc Location @ |avadoc URL (e.g. 'http:ffwww.sarmple-url.ergidocy or file e ymywerkspace/myproject/doc’)
Mative Library Javadoc location path: [ ' Browse...
walidate...

O Javadac in archive

Restore Defaults Apply

@ oK Cancel

Figure 2.24. Classpath Container: Javadoc Location

Click on Apply and then on Ok.

2.7. Using and Configuring SOA Platform

In this chapter you will know what is JBoss Enterprise SOA Platform and how you can configure
it to use for your ESB projects.

JBoss Enterprise SOA Platform delivers a flexible, standards-based platform to integrate
applications, SOA services, business events and automate business processes. The SOA
Platform integrates specific versions of JBoss ESB, jBPM, Drools and the JBoss Enterprise
Application Platform that are certified to work together in a single supported enterprise distribution.

Having configured JBoss Enterprise SOA Platform for your ESB project you don't need to install
and configure ESB server and runtime as they are already included.

Check here to find more details on the platform: JBoss Enterprise SOA Platform [http://
www.jboss.com/products/platforms/soa] and JBoss Enterprise SOA Platform Component Details
[http://www.jboss.com/products/platforms/soa/components].

You can find out what is SOA here: Basics of SOA [http://lwww.jboss.org/jbossesh/resources/
SOABasics.html] and SOA and EOA [http://www.jboss.org/jbossesb/resources/SOAEOA.html].

To configure the JBoss Enterprise SOA platform select Window > Preferences > Server > Runtime
Environments, that will open the Server Runtime Environments Preferences page where you can
add, remove and edit a Server Runtime Environment.

24
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Preferences

[type filter text ] Server Runtime Environments

[ General —{  Add, remove, or edit server runtime environments.

b Ant Server runtime environments:

Mame Type Add...
Droals Preferences [

X
-
“J |Boss 4.2 Runtime |Boss 4.2 Runtime [T
FreeMarker Editor Edit...

b Data Managament

5 “J |Boss 4.2 Server Adapter Rur |Boss 4.2 Runtime
Help

HQL editor
InstalliUpdate Search...
Java
JavaSeript
|Bass jBPM
|Bass Tools
JPa

Bemove

R A~

P Plug-in Development
Praject Archives
I PunfDebug
¥ Server
Audio =
Launching
Service Policies
P Spring
P Team

@ | oK | Cancel

[«]

Figure 2.25. Configure new Server Runtime Environment

Select Add, choose JBoss 4.2 Runtime as a type of runtime environment, check the Create a new
local server checkbox and click Next:
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KNew Sernver Runtime Environment

Mew Server Runtime Environment
Define a new server runtime environment

Select the type of puntime environment:

[ ype filter text I

= [ |Boss, a dvision of Red Hat (=]
7J |Boss 3.2 Runtime
7J |Bess 4.0 Runtime

& |Boss 4.2 Funtime

‘¥ |Boss 5.0 Funtime =

7J |Boss Deploy-0nly Runtime

b (= Objectweb ~
|Boss Application Server 4.2

1 Create a new local server

(i3] Back Fil Cancel

Figure 2.26. Type of Server Runtime Environment

On the next step you can specify a name of the server runtime environment and browse to its
location. Click Finish to add the server runtime environment.

26



Chapter 2. Tasks

New Server Runtime Environment

|Boss Runtime Wizard

L
&P oy Fed Hat

A JBoss Server runtime references a |[Boss installation directory.

It can be used to set up classpaths for projects which depend on this runtime,
as well as by a "server® which will be abla to start and stop instances of |[Boss.

Name

[jl:rnss-sua-p 4.3.0 I

Home Directory

[fh ormefuserjjbdevstudiofjboss-soa-p.4.3.0/jboss-as/

JRE

|jdk1.5.0_12 & @

Configuration

1 minirmal
4 all

=i default
11 production

@ ik e Einish ] [ Cancel

Figure 2.27. New Server Runtime Environment Details

Now you have your SOA platform configured. To check the configuration create a ESB Project
using instructions described here. As a result you will have two projects created:
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= B helloworld
b @ sre
P =i |Boss ESE Runtime [jboss-soa-p.4.3.0]
b =i JRE System Library [jdk1.5.0_12]

= build
b (= esbcontent

& helloworld_testclient

B @8 sre
B =4 |RE Systemn Library [|25E-1.5]
[* =i |Bess ESE Funtime [jboss-saa-p.4.3.0]
P md Referenced Libraries
= build

Figure 2.28. Helloworld Projects Created

Then you will need to add JBoss ESB libraries to your projects to configure the SOA server runtime

exactly for your projects. Right-click on your project, select Build Path > Add Libraries:
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Mew >
Go Into

Open in New Window

Open Type Hierarchy E4
Show In Shift+alt+w >
[ Copy ctr+C
5 Copy Qualified Name
[ paste Ctri+v
¥ Delete Delete
Source shift+Alt+5 » | &9 Mew Source Folder...
Refactor Shift+Alk+T ' '
- ? &® Lse as Source Folder
g2y [mport... s Add External Archives...
i Export... % Add Libraries...
« Refresh FS | &% Configure Build Path...
Cloge Project

Close Unrelated Projects
Assign Working Sets..,

i) Corwvert to Drools Project

Fun As b
Debug As >
Profile As >
validate

Tearmn >
Cormpare With >

Restore from Local History...

|Boss Toals >
Spring Tools >
Web Development Tools >
PDE Togls >
Properties Alt+Enter

Figure 2.29. Add Libraries

Choose JBoss ESB Libraries and click Next:
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Add Library

Add Library
Select the library type to add,

Connectivity Driver Definition
EAR Libraries

J2EE 1.3 libraries

JZ2EE 1.4 libraries

|Boss EJB3 Libranes

|Boss ESB Libraries

|EE 5.0 libraries

|RE Systemn Librany
|5F Libraries

JUnit

Plug-in Dependencies
Server Funtime

User Library

Web App Libraries

®

Cancel

Figure 2.30. ESB Libraries

Select the necessary runtime to add to the project classpath:
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. Add Library
|Boss ESB Library
Select a ESE runtime to add to the project classpath

= jboss-soa-p.4.3.0

Runtime Type

Server Contained

[2]

(] < gack

Finish | Cancel

Figure 2.31. Select a ESB runtime

Click Finish.

Now you can deploy your Helloworld project to the server and run a test class in the client Java

project to see the test result in the Console view.
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Reference

This chapter includes detailed reference information about JBoss ESB Tools.

3.1. JBoss ESB Editor

ESB editor has lots of useful features, they are described in details in this chapter.

ESB File Editor is a powerful and customizable tool which allows developing an application using
ESB technology.

ESB file editor has two tabs: Tree and Source.

3.1.1. Source View

You can easily switch from Tree to Source by selecting the Source tab at the bottom of the editor
and work in Source view.

|5 jposs-esh xrl 22 =0

=7x¥mlL version="1.0"7=
<jbossesh
xmlns="http:s/fanonsvn.labs. jboss. com/labs/ jbossash/trunk/product/etc/schemas/»
*mlns: xsi="http: / fwww. w3, org/ 2001/ XMLSCchema- instance” xs51:schemalocation="htif
zproviders>
<jms-provider connection-Tactory="ConnectionFactory” name="J]BossM(}"
=property name="property® value="@"/=
<jms-bus busid="StartGwChannel” /=
=jms-bus busid="5tartEsbChannel” >
=property name="time" value="0"/=>
=/ jms-bu s>
=jms-bus busid="intakeServiceEsbChannel® /=
<jms-bus busid="discountServiceEsbChannel” /=
=jms-bus busid="shippingServiceEsbChannel” />
=jms-bus busid="conciergeServiceEsbChannel”® /=
</ ims-providers>
</providers=
<services>
=service category="starter” description="starter® name="StarterService®=
=listeners>
<jms-Listener busidref="StartEsbChannel” name="ESB-Listener" />
=flisteners>
</sarvices
=service category="intake® description="this is intake service® name="Intake:
=listenars>
=jms-Llstener busidref="5StartEsbChannel” name="ESB-Listener® /=
=fListeners>
=actionss>
[4] [»]

Tree Source

[a]

Figure 3.1. Source View

The Source view for the editor displays a text content of the ESB file. It is always synchronized
with Tree view, so any changes made in one of the views will immediately appear in the other.
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No matter what view you select, you get full integration with Outline view. For example, you can
work in the Source view with the help of the Outline view. The Outline view shows a tree structure
of the ESB file. Simply select any element in the Outline view and it will jump to the same place
in the Source editor, so you can navigate through the source code with Outline view.

|5 jposs-esbxmi & =0 £ Outline 2 =0
<?xml version="1.0"7= - .-
— ||+ & jposs-esb.xmi
<jbossesb
®mlns="http://anensvn. labs, jboss. com/labs/ jbossesb/trunk/product/ete/ schemas/ > = [= Providers

xmlns: xsi="http://www.w3i.org/2001/¥MLSchema- instance® xsi:schemalocation="httf
=providers>
<jms-provider connection-factory="ConnectionFactory” name="JBossM(" 9 property

<property name="property” value="0"/= b o2 StartGwChannel
<jms-bus busid="StartGwChannel”/=
=jms-bus busid="StartEsbChannel” = b o9 StartEsbChannel
;‘I”"“P:"W name="time" value="0"/> f b +% intakeServiceEsbChannel
=/ 1m5-bu s>

b o9 discountServiceEsbChannel

<jms-bus busid="intakeServiceEsbChannel® />
<jms-bus busid="discountServiceEsbChannel® />
<jms-bus busid="shippingServiceEsbChannel” /=
<jms-bus busid="conciergeServiceEsbChannel® />
</ ims-provider=
:iz ::‘QEZZTJ‘ b & starterService
=service category="starter® description="starter® name="Startergervice"> [ @“makegemce
<listeners>
=]ms- Listener busidref="StartEsbChannel” name="ESB-Listener™/=
=/listeners=>
cfservices
<service category="intake" description="this is intake service" name
<listeners>
<jms-Llistener busidref="StartEsbChannel® name="ESB-Listener®/=>
=flistenerss>
=actioms>
(2] [
Tree Source | N0

b =< shippingServiceEsbChannel
b oo conclergesemiceEsbcnannel

= [ Services

(€1

Figure 3.2. Outline View

3.1.2. Tree View

You can switch to Tree. The Tree view for the editor displays all ESB artifacts in a tree format. By
selecting any node you can see and edit its properties which will appear in the right-hand area.
For example, a Provider:
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= : ==
]Boss ESB Editor
- jboss-esbh - |MS Provider []
= [ jboss-esb.xml Name: |_]Eos~;MQ |
= = Providers
- Connection Factory: |Cunn&ctionFaclu-r)r |
= oo quickstartGwChannel ~ Properties
¥ Filter MName Walue Add
= o5 quickstartEsbChannel |
“F Filter
= = Services | =
< ¥, simpleListener |
= [= Listeners |
b @ JMS-Gateway
b @ helloworld = Channel list
= @ Actions o
% action2 quickstartEsbChannel s
(] i I [>] - Advanced <]
Tree|$ource|
Figure 3.3. Tree View
Some properties are represented as links to the associated editors.
- = o
] jboss-eshxml 33\ =g

]Boss ESE Editor

= jboss-esh " = Action
= i jboss-ash xmil Nafme: |actinn1 |
I = providers
Class: ‘nrg.iboss.soa.asb.samplas.quickstart.hellowurld.My]M:‘ [ Browse... l
- [ Senices e
nj—;
= % SimpleListener Prncgprqdlsplayﬂlessage | l Brawse... I
[P (= Listeners * Properties
= Lg Actions
S MName Value Add...
s
i action2
% testStore Edit.,

EJ snur:e|

Figure 3.4. Property Link to the Associated Editor
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Now when editing ESB actions which refer to other files (Drools, Groovy, Smooks, etc.), the label
for the field turns into a link to launch the editor associated with that type of file.

=5 jboss-asbxml . =g
JBoss ESE Editor

- ihﬂﬁb-eﬁl} ) « Smooks Action
= @ jboss-eshxml Mame: |5imple-transfnrrn |
= 7 Prowiders - -
Class: | org.jboss.sea.esk.smocks. SmooksaAction |
= % |BossM
[ e quickstartGwChannel W@_ fsmooks-res.xml | | Browse. ., |
[ oo quickstartEsbChannsl Process: | |

= [ Services
- ¥ SimpleListener
I [ Listeners
= (G Actions Set Payload Location: | |
iy print-before
W print-after
i testStore

~ Advanced

Get Payload Location: | |

Mapped Context Objects: | |

Exclude Mon-Serializables: || i

Result Type: | b4

|ava Result Bean Id: | |

Report Path: | |

Massage Profile: | |

Trae | Source

Figure 3.5. Property Link to the Associated Editor

Adding, editing or deleting of some artifacts operations are available right in the Tree view . Right-
click any node and select one of the available actions in the context menu. For example, you can
easily add a new Provider:
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JBoss ESB Editor

- jhoss-esh

= @ jboss-ash.xml

Delete

Properties

= = Listaners
bl MS-Gatewsay
bl helowarld
= L Actions
% actionl
& action2
i tastStore

- Providers

Mame

Bus Prawi der

FTP Prowider... [T]

Hibernate Provider..,
|ER Provider... l
JcA Provider... |

der...

M5 Prow
Schedula Provider...
SQL Provider...

Tree Source |

Figure 3.6. Adding New Provider

Then you can add Channels and Properties for the Providers the same way or using the forms
with Add, Edit and Remove buttons to the right.

You can easily add a new Service too:

JBoss ESB Editor

= |boss-esbh
= . jboss-esh xmi*
b & Providers

b &) starterService
= B IntakeService
= [= Listeners
=} ESB-Lister
5? Filter
= [ Actions
= % dumpl
o property

H Delete

Properties. .,

 Services

name

StarterService

Delete

Tree Source |

Figure 3.7. Adding New Service
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The same way you can create a listener for service and other elements of ESB:

JBoss ESB Editor

- |boss-esb
I = Providers
= = Services

= Bl StarterService

e e ]

= Listeners

name

ESB-Listener

Listener...
b & EsB-Lis
(& Actions FS Listensr... |
FTP Listanar...
= & IntakeService 3 Delete Delete _ -
- & U ers Groowvy Listener,.. W |
Properties... Hibernate Listener...
» & ESHLIAS |BR Listener
¥ @ Actions JCA Gateway...
b % dumpl JMS Listener...
(] ' 1) Scheduled Listener..,
Tres 5uur1:a| SOL Listener..,

Figure 3.8. Adding New Listener for Service

The same actions can be done in the right part of Tree view tab (Form editor) using Add, Edit

and Remove buttons.

Filter can be also edited this way

|Bess ESB Editor
= jboss-esh = F5 Message Filter '
< 15 jboss-esbxml Directory: | | Browse... ]
b & Providers
Input Suffi | I
= & Services .
= @ Simplelistener - Advanced
¥ & Listeners work suffe: | |
=} ESB-Listener
. Post Dealeta: l » ||
W Altter . .
= i FS-Listener Post Rename: I ~ ]l
- i
Post Directory: | Browse... ]
ki Actions
Post Suffix: I I
Error Delete: l ~ ]l
Error Directonry: | | Browse... ]
Error Suffix: I I
o I ] B

Tree Source

Figure 3.9. Editing Filter
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In order to add a new custom Action to your ESB XML file you should select the Actions node
under the Services, then right-click and choose New > Custom Action.

ﬁ ! | iil =g

JBoss ESE Editor

- jboss-esh " = Actions List 14

- [ jbass-esh.xml MEP: [Dna'mly | v]

- [& Praviders
« Actions

b |BossMyg

= (= Sarvices Name

action
- #h simpleListener SR E]
. action2
[r (= Listenaers Barmove...

tasiStore

trl 4 Object Invoke...

¥ Delete Delete Byte Array To String...
Long To Date...
Properties

in XS0 Message Persister.. :
8 . 1+ Object Te CSV String... S

Cbject To ¥Stream...

(<]

Tree]'snurce|

Smocks Action...

srmocks Transformer...
¥Stream To Object...
Command Interpreter..,

Groowvy Action Processor...

Aggregator..

Content Based Router (Generic)..,
Static Router...

Static Wiretap...

Motifier...

SOAP Processor,,.

SOAP Client...

System Prontln...
Business Aules Processor

Figure 3.10. Adding New Custom Action in the Tree View

Or instead make use of Add... button in the Form editor on the left.
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Shossatboml i, =)

|Boss ESB Editor

= jhoss-esh = Actions List

- @@ jboss-esh.xml MEP:

{U naiay w

« Actions

= &= Providers

b 4 |BossMO
MName

- & Services | ¢4t
~ & simpleListener

[ = Listeners actionz
testStore Dbject Invoke,..
% actionl Byte Array To String...
i action2 Long To Date...
iy testStare i Message Persister...
Object To CSV String...
~ Advanced Object To XStream...
InXS0: Smocks Acticn,..
] ] LB T smaocks Transformer...
Tree] Suun:e| ®Stream To Ohject...

Comrmmand Intarpreter...
Groowvy Action Processor...

Aggregater...

Content Based Router (Generic)..,
Static Router...

Static Wiretap...

Motifier...

SOAP Processer...

SOAP Client...

System Println..,
Business Aules Processor

Figure 3.11. Adding New Custom Action in the Form Editor

Then you will see Add Action wizard. There is a need to specify Action name and Action Java class.
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Add Action

ESB Action

@ attribute Name must be set. 0

Mame* [

Class* [

Process [

Cancel E

Figure 3.12. Add Action Wizard

To get a help with finding a proper class you can select Browse to open Select class dialog.

Select Class

Select an tem to open (T = any character, * = any string): -

s I

Matching iterms:

{ actinnExamp|E - actians

ActionLifecycle
ActionLifecycleException
ActicnPipelinePracessor
ActionProcessingDetailFaultException
ActionProcessingException
ActionProcessingFaultExceptian

ActicnProcessar

Q0900 @.

ActionUtils

t# actions - helloworldfsre

@ [ cancel | oK

Figure 3.13. Select class dialog

Moreover it's possible to type a Process name or select it with Edit Process dialog which is called
out by clicking Browse.
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Add Action

ESB Action a

Marme* [smpe |

Class* [actiu ns.actionExample | [ Browse... l

Process [prcu CeSs,processsuccess

=] Edit Process x|

Process

W precess

¥l processSuccess

1

Figure 3.14. Edit Process dialog

As you can see on the both figures above, the context menu will also prompt you to insert one
of the Actions that are supplied out-of-the-box with JBoss ESB. After choosing one an appeared
New Pre-Packed Action wizard will ask you to fill out a name field and other fields specific for each

Action property. For example, for Content Based Router Action the wizard looks as follows:
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Add Content Based Router

ESB Content Based Router

Attribute Mame must be set. @
Mame:* I ]
Process: f | vl
Rule Set:* ( |
Fule Language: | |
Rule Reload: | Defaultifalse) | v |

i) I | Cancel

Figure 3.15. Add Pre-Packed Action Wizard

After confirming creating the Action you can see itin the Tree under the Actions node and preview
as well as edit its settings in the Form editor on the left.
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= = "o
JBoss ESB Editor

- jboss-esh = Content Based Router Action
= @ jboss-esb.xml Mame: |CuntentEasedﬁnuter |
P = Providers -
) Class: | org jboss.soa.esh.actions.ContentBasedRoutel |
¥ = Servicas
< &, simpleListener Fule Set: |M}rESEIHa!es-XPath.dr| |
P = Listeners Fule Language: |><PathLanguage.dsI |
= kg Actions | |
Fule Reload: true ~
|
& express Process: [split | -

* Route List

Destination Mame Service Mame Add... |

Exprass ExpressShippingService |P-emvwe |
| Edit...

( [+)
'ITEE-.EBLIrtE
Figure 3.16. Form Editor for Content Based Router

ESB editor can recognize some specific objects. On the figure you can see
org.jboss.soa.esb.actions.ContentBasedRouter in the Class section.

3.2. ESB Editor Features

JBoss ESB tooling has powerful editor features that help you easily make use of content and
code assist.

This last chapter covers capabilities on how you can use ESB editor.

3.2.1. ESB Syntax Validation

When working in JBoss ESB editor you are constantly provided with feedback and contextual
error checking as you type. In the Source viewer, if at any point a tag is incorrect or incomplete,
an error will be indicated next to the line and also in the Problems view below.

3.2.2. Support for XML Schema

JBoss ESB Framework fully supports XML files based on schemas as well as DTDs.

The schema checks the child elements of any kind of provider element; the ESB generates errors
on startup if you attempt to define an incorrect combination (e.g.: a jms-bus inside an ftp-provider).
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3.2.3. Content Assist for ESB XML File

When you work with any ESB XML file Content Assist is available to help you. It provides pop-
up tip to help you complete your code statements. It allows you to write your code faster and with
more accuracy. Content assist is always available in the Source mode. Simply type Ctrl-Space
to see what is available.

Content Assist for ESB XML file:

m Hboss-esh xml ¥

D/

<7xml version="1.0"7=

<jbossesb
xmlns="http://anonsvn. labs. jboss. com/Labs/ jbossesb/trunk/product/etc/schemas/xml/jbossesh-1.90.1. xsd”
XMLNS: KS1="http: //www. w3.0rg/ 2001/ XMLSChema- instance™ xsi:schemalocation="http://anonsvn.labs. jboss. com/Lal

I <providers>

-

3 bus-provider fElement : jms-provider
Content Model : ((property*), (bus-))

<> fs-provider

< » ftp-provider

< » hibernate-provider
<> |br-provider

<> [ms-jca-provider
oy spoviger |
< » schedule-provider

]
=< > sgl-provider

(4l

</listenasras

ﬁ{fmurﬂe]

il I D]

Figure 3.17. Content Assist for ESB XML file

Content Assist for attributes:
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<fprovider

=service

=Listen

<seryice
=listene
<jms-1i
</listen

=action
<P rope

<faction|

<fservices
=/jbossesh

%{HWWWEL 7

=jm5-bus busid="conciergeServiceEsbChannel® />
=/ ims-providers

=actiony

efactio

<fservice

=0

"S5

<58 rMvicess=

=

e e
<jms-Li e service category which will be used to store a reference to

P
</11sten| ® description
</ servicel°g name

bl |}

this service in the registry.

Data Type : string

]

Tree Source

Figure 3.18. Content Assist for attributes

3.2.4. OpenOn for ESB XML File

ESB file comes with the OpenOn feature that allows to make use of multiple file references in the

file just with a click and the Ctrl key hold down.

The OpenOn is implemented for different types of files/pages inside the <act i on> tag: .xsd, .xml,

etc.
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dest-name="queuesquickstart_helloworld Request_gw*® dest.type=*QLELE" /=
</ jms-bus=>
<jms-bus busid="quickstartEsbchannel =
<]ms-message-f1lter
dest-name="queve/squickstart_helloworld Request_esh” dest-type="QUELE"/>
</ )ms-bus>
<f]ms-provider>
</providerss
“seryicess
<service category="FirstServiceEss" description="Hello world” name="Simplelistener®
=listeners=>
<jms-Listener busidref="quickstartGwChannel” is-gateway="true” name="JMS-Gateway"
<jms- Listener busidref="quickstartEsbchannel” name=*helloworld® /=
=flisteners=>
=actlons meps"Onelay"s
=action
class="org. jboss.soa.esb.samples. quickstart.helloworld. MyJMSListenerdction®
name=*actienl® process="displayMessage” /=
<action class="org.jboss.soa.esh.actions. SystemPrintln® name="action2*>
<property name="message"/>
<property name="printfull® value="true*/>
<factions
<!.. The next actien 1s for Continuous Integration testing --=
<action class="org.jboss.soa.esb.actions. TestMessageStore® name="testStore"/>
=action class="org.jboss.soca.esh.smooks.SmooksAction® name="smooks”=
<property name="smooksConfig® value='ﬂ@£ﬁm@ﬂﬂ_fuﬂ'!”
<factions
=factions=
< SErvice»

[<] Il 1]

[]

(=]

Tree Source

Figure 3.19. OpenOn for smooks configuration file

It is also available for classes:
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<jms-bus busid="quickstartEsbChannel "=
<jms-message-filter
dest-name="queue/quickstart_helloworld Request_esb” dest-type="QUELE"/>
<f)ms-bus>
=/]ms-provider=
</providerss
<servicess

<listeners>
<jms- Listener busidref="guickstartGwChannel” is-gateway="true” name="JMS- Gateway"
<jms- Listener busidref="quickstartEsbchannel” name=<helloworld® /=

=/listeners>

<actions mep="0OnekWay"=>
<action
clasﬁfww%wﬂﬂﬂﬂZﬂ'
name="actionl® process="displayMessage®/>
=action class="org.jboss.soa.esh. actions. SystemPrintln® name=*action2®=
<property name="message” /=
<property name=*printfull® value=*true® /=
=faction=>
<!.. The next actien is for Continuous Integraticn testing --=
<action class="org.jboss.soa.esb.actions.TestMessageStore® name="testStore” />
<action class="org. jboss.soa.esh. smoocks. Smooksdction® name="smooks”>
=property name=*smooksConfig® value="META-INF/smooks-config.xml®/=
=factlon=>

<factionss>

=fsErvices

<fServicess
</ibossesb=

[<] | 1]

<service category=*FirstServiceEss" description="Hello World® name=*SimpleListener®| |

[»

Al

Tree | Source

Figure 3.20. OpenOn for classes

3.2.5. Synchronized Source and Visual Editing

ESB file can be edited in either source or extra visual modes at the same time.

JBoss Tools provide you two different editors to speed your development: a graphical view (Tree)

and source (Source). At the same time, you always have full control over esb source file.

Any

changes you make in the source view will immediately appear in the tree view. Both views are

synchronized, you can edit the file in any view.
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Lowossesnamiss

JBoss ESB Editor

~ |boss-esh

+ Jboss Esb

= = Providers
+ % |BossMQ
@ property
B egr StartGwChannel
= oo StartEsbChannel
@ time
7 Fitter
b e intakeServiceEsbC
P e discountServiceEs
P e shippingServiceEs|
b o conciergeServicel
= = Services
b & Starterservice
= & IntakeService
= [ Listeners
+ i ESB-Listener
F Filter
= I Actions
b % dumpl

Tree Source

=7xml
<jbossesh

varsion="1.0" 7>

xmlns="http:/fanonsvn.labs. jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/ jboss
XMLNS: XS1="hTtp:// www.w3.0rg/2001/XMLSchema- instance® xsi:schemalLocation="http://anons
=providers=
<jms-provider connection-factory="ConnectionFactory” name="J]BossMQ">
=property name="property” value="0"/>
<jms-bus busid="StartGwChannel”/>
<jms-bus busid="StartEsbChannel”>
<property name="time® value="0"/>
</ jms-bus=
<jms-bus busid="intakeServiceEsbChannel®/>
<jms-bus busid="discountServiceEsbChannel® />
<jms-bus busid="shippingServiceEsbChannel® />
=jms-bus busid="conciergeServiceEsbChannel” />
<=/]jms-providers
=fproviders>
<servicess
<service category="starter® description="starter” name="StarterService®>
<listenerss
<jms-listener busidref="StartEsbChannel” name="ESB-Listener®/>
</listeners>
=/services>
=seryice category="intake" description="this 1s intake service” name="IntakeService":
<listeners>
<jms-listener busidref="StartEsbChannel” name="ESB-Llistener®/=
=/listeners>
<actions>
=action class="dumpClass® name="dumpl®>
=property name="property” value="0"/=
<faction=
<factions>
</services>

[ Y gy

[ |

<]
Tree | Source

Figure 3.21. Two Views are Synchronized
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Chapter 4. Summary

Summary

On the whole, this reference supplies you with all necessary information on the functionality that
JBoss ESB plugin provides for work with JBoss ESB.

We hope, this guide helped you to get started with the JBoss ESB Tools. For
additional information you are welcome on JBoss forum [http://www.jboss.com/index.html|?
module=bb&op=viewforum&f=201].

4.1. Other Relevant Resources on the Topic

You can find a set of benefits and other extra information on:

» JBoss ESB [http://www.jboss.org/jbossesb]
e JBoss Wiki [http://wiki.jboss.org/wiki/JBoSSESB]

» JBoss ESB Documentation Library [http://www.jboss.org/jbossesb/docs/index.html]

The latest JBoss Tools/JBoss Developer Studio documentation builds are available on the JBoss
Tools nightly documentation page [http://download.jboss.org/jbosstools/nightly-docs/].
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